]> git.pld-linux.org Git - packages/glibc.git/blob - glibc.spec
1d6ac79ceed84a7bd6c25ab924ad7c2511ca1444
[packages/glibc.git] / glibc.spec
1 Summary:        GNU libc
2 Summary(de):    GNU libc
3 Summary(fr):    GNU libc
4 Summary(pl):    GNU libc
5 Summary(tr):    GNU libc
6 name:           glibc
7 Version:        2.1
8 Release:        4
9 Copyright:      LGPL
10 Group:          Libraries
11 Group(pl):      Biblioteki
12 #######         ftp://sourceware.cygnus.com/pub/glibc/
13 Source0:        %{name}-%{version}.tar.gz
14 Source1:        %{name}-linuxthreads-%{version}.tar.gz
15 Source2:        %{name}-crypt-2.0.111.tar.gz
16 Source3:        utmpd.init
17 Source4:        nscd.init
18 Patch0:         glibc-info.patch
19 URL:            http://www.gnu.org/software/libc/
20 Provides:       ld.so.2
21 Obsoletes:      %{name}-profile
22 Obsoletes:      %{name}-debug
23 Autoreq:        false
24 BuildRoot:      /tmp/%{name}-%{version}-root
25
26 %description
27 Contains the standard libraries that are used by multiple programs on
28 the system. In order to save disk space and memory, as well as to
29 ease upgrades, common system code is kept in one place and shared between
30 programs. This package contains the most important sets of shared libraries,
31 the standard C library and the standard math library. Without these, a
32 Linux system will not function. It also contains national language (locale)
33 support and timezone databases.
34
35 %description -l de
36 Enthält die Standard-Libraries, die von verschiedenen Programmen im System
37 benutzt werden. Um Festplatten- und Arbeitsspeicher zu sparen und zur
38 Vereinfachung von Upgrades ist der gemeinsame Systemcode an einer einzigen
39 Stelle gespeichert und wird von den Programmen gemeinsam genutzt. Dieses
40 Paket enthält die wichtigsten Sets der shared Libraries, die
41 Standard-C-Library und die Standard-Math-Library, ohne die das Linux-System
42 nicht funktioniert. Ferner enthält es den Support für die verschiedenen
43 Sprachgregionen (locale) und die Zeitzonen-Datenbank.
44
45 %description -l fr
46 Contient les bibliothèques standards utilisées par de nombreux programmes
47 du système. Afin d'économiser l'espace disque et mémoire, et de faciliter
48 les mises à jour, le code commun au système est mis à un endroit et partagé
49 entre les programmes. Ce paquetage contient les bibliothèques partagées les
50 plus importantes, la bibliothèque standard du C et la bibliothèque
51 mathématique standard. Sans celles-ci, un système Linux ne peut fonctionner.
52 Il contient aussi la gestion des langues nationales (locales) et les bases
53 de données des zones horaires.
54
55 %description -l pl
56 W pakiecie znajduj± siê podstawowe biblioteki, u¿ywane przez ró¿ne programy
57 w Twoim systemie. U¿ywanie przez programy bibliotek z tego pakietu oszczêdza
58 miejsce na dysku i pamiêæ. Wiekszo¶æ kodu systemowego jest usytuowane w
59 jednym miejscu i dzielone miêdzy wieloma programami. Pakiet ten zawiera
60 bardzo wa¿ny zbiór bibliotek standardowych wspó³dzielonych (dynamicznych)
61 bibliotek C i matematycznych. Bez glibc system Linux nie jest w stanie
62 funkcjonowaæ. Znajduj± siê tutaj równie¿ definicje ró¿nych informacji dla
63 wielu jêzyków (locale) oraz definicje stref czasowych.
64
65 %description -l tr
66 Bu paket, birçok programýn kullandýðý standart kitaplýklarý içerir. Disk
67 alaný ve bellek kullanýmýný azaltmak ve ayný zamanda güncelleme iþlemlerini
68 kolaylaþtýrmak için ortak sistem kodlarý tek bir yerde tutulup programlar
69 arasýnda paylaþtýrýlýr. Bu paket en önemli ortak kitaplýklarý, standart
70 C kitaplýðýný ve standart matematik kitaplýðýný içerir. Bu kitaplýklar olmadan
71 Linux sistemi çalýþmayacaktýr. Yerel dil desteði ve zaman dilimi veri tabaný
72 da bu pakette yer alýr.
73
74 %package        devel
75 Summary:        Additional libraries required to compile
76 Summary(de):    Weitere Libraries zum Kompilieren
77 Summary(fr):    Librairies supplémentaires nécessaires à la compilation.
78 Summary(pl):    Dodatkowe biblioteki wymagane podczas kompilacji
79 Summary(tr):    Geliþtirme için gerekli diðer kitaplýklar
80 Group:          Development/Libraries
81 Group(pl):      Programowanie/Biblioteki
82 Prereq:         /sbin/install-info
83 Requires:       %{name} = %{version}
84
85 %description devel
86 To develop programs which use the standard C libraries (which nearly all
87 programs do), the system needs to have these standard header files and object
88 files available for creating the executables.
89
90 %description -l de devel
91 Bei der Entwicklung von Programmen, die die Standard-C-Libraries verwenden
92 (also fast alle), benötigt das System diese Standard-Header- und Objektdateien
93 zum Erstellen der ausführbaren Programme.
94
95 %description -l fr devel
96 Pour développer des programmes utilisant les bibliothèques standard du C
97 (ce que presque tous les programmes font), le système doit posséder ces
98 fichiers en-têtes et objets standards pour créer les exécutables.
99
100 %description -l pl devel
101 Pakiet ten jest niezbêdny przy tworzeniu w³asnych programów korzystaj±cych
102 ze standardowej biblioteki C. Znajduj± siê tutaj pliki nag³ówkowe oraz pliki 
103 objektowe, niezbêdne do kompilacji programów wykonywalnych i innych bibliotek.
104
105 %description -l tr devel
106 C kitaplýðýný kullanan (ki hemen hemen hepsi kullanýyor) programlar
107 geliþtirmek için gereken standart baþlýk dosyalarý ve statik kitaplýklar.
108
109 %prep 
110 %setup -q -a 1 -a 2
111 %patch -p1
112
113 %build
114 install -d sunrpc/cpp; ln -s /lib/cpp sunrpc/cpp/cpp 
115 CFLAGS="$RPM_OPT_FLAGS -pipe" \
116 ./configure \
117         --enable-add-ons=crypt,linuxthreads \
118         --disable-profile \
119         --prefix=/usr \
120         --disable-omitfp
121 make  
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT/{etc/rc.d/init.d,usr/man/man3,var/db}
126
127 make install_root=$RPM_BUILD_ROOT install
128 make install_root=$RPM_BUILD_ROOT install-locales -C localedata
129
130 make -C linuxthreads/man
131 install linuxthreads/man/*.3thr $RPM_BUILD_ROOT/usr/man/man3
132
133 rm -rf $RPM_BUILD_ROOT/usr/share/zoneinfo/{localtime,posixtime,posixrules}
134
135 ln -sf ../../../etc/localtime $RPM_BUILD_ROOT/usr/share/zoneinfo/localtime
136 ln -sf localtime $RPM_BUILD_ROOT/usr/share/zoneinfo/posixtime
137 ln -sf localtime $RPM_BUILD_ROOT/usr/share/zoneinfo/posixrules
138 ln -sf ../../usr/lib/libbsd-compat.a $RPM_BUILD_ROOT/usr/lib/libbsd.a
139
140 rm -f $RPM_BUILD_ROOT/etc/localtime
141
142 install %{SOURCE3} $RPM_BUILD_ROOT/etc/nsswitch.conf
143
144 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
145 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/utmpd
146
147 install nscd/nscd.conf          $RPM_BUILD_ROOT/etc
148 install nss/nsswitch.conf       $RPM_BUILD_ROOT/etc
149
150 install nss/db-Makefile $RPM_BUILD_ROOT/var/db
151
152 cat << EOF > $RPM_BUILD_ROOT/usr/bin/create-db
153 #!/bin/sh
154 /usr/bin/make -f /var/db/db-Makefile
155 EOF
156
157 ln -sf create-db $RPM_BUILD_ROOT/usr/bin/update-db 
158
159 rm -rf documentation
160 install -d documentation
161
162 cp linuxthreads/ChangeLog  documentation/ChangeLog.threads
163 cp linuxthreads/Changes documentation/Changes.threads
164 cp linuxthreads/README documentation/README.threads
165 cp login/README.utmpd documentation/
166 cp crypt/README documentation/README.crypt
167
168 cp ChangeLog ChangeLog.8 documentation
169
170 bzip2 -9 documentation/*
171
172 strip $RPM_BUILD_ROOT/{sbin/*,usr/{bin/*,sbin/*}} || :
173
174 bzip2 -9 README NEWS FAQ BUGS NOTES PROJECTS
175 gzip -9fn $RPM_BUILD_ROOT/usr/{man/man*/*,info/libc*}
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %post devel
181 /sbin/install-info /usr/info/libc.info.gz /etc/info-dir
182
183 %preun devel
184 if [ "$1" = 0 ]; then
185         /sbin/install-info --delete /usr/info/libc.info.gz /etc/info-dir
186 fi
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %files
192 %defattr(644,root,root,755)
193 %doc README.bz2 NEWS.bz2 FAQ.bz2 BUGS.bz2
194
195 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/nscd.*
196 %config(noreplace) %verify(not mtime md5 size) /etc/nsswitch.conf
197 %config /etc/rpc
198
199 %attr(750,root,root) /etc/rc.d/init.d/*
200
201 %attr(755,root,root) /sbin/*
202 %attr(755,root,root) /usr/bin/*
203 %attr(755,root,root) /usr/sbin/*
204
205 %attr(755,root,root) /lib/ld-*
206 %attr(755,root,root) /lib/lib*
207
208 %dir /usr/lib/gconv
209 /usr/lib/gconv/gconv-modules
210
211 /usr/share/i18n
212 /usr/share/locale
213 /usr/share/zoneinfo
214
215 %dir /var/db
216 %config /var/db/db-*
217
218 %files devel
219 %defattr(644,root,root,755)
220 %doc documentation/* NOTES.bz2 PROJECTS.bz2
221
222 /usr/include/*.h
223 /usr/include/arpa
224 /usr/include/bits
225 /usr/include/db1
226 /usr/include/gnu
227 /usr/include/net
228 /usr/include/netash
229 /usr/include/netatalk
230 /usr/include/netax25
231 /usr/include/neteconet
232 /usr/include/netinet
233 /usr/include/netipx
234 /usr/include/netpacket
235 /usr/include/netrom
236 /usr/include/netrose
237 /usr/include/nfs
238 /usr/include/protocols
239 /usr/include/rpc
240 /usr/include/rpcsvc
241 /usr/include/scsi
242 /usr/include/sys
243
244 /usr/info/libc.inf*.gz
245
246 %attr(755,root,root) /usr/lib/lib*.so
247 /usr/lib/*.o
248 /usr/lib/lib*.a
249
250 %attr(755,root,root) /usr/lib/gconv/*.so
251 /usr/man/man3/*
252
253 %changelog
254 * Sat Mar 06 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
255   [2.1-5]
256 - removed striping of shared libraries -- no debug info in this libs,
257 - fixed /etc/rc.d/init.d/* -- Tomek, never again 754 on start scripts... 
258 - fixed permission of /var/db directory -- should be 755...
259
260 * Mon Feb 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
261   [2.1-4]
262 - removed man group from man pages,
263 - standarized {un}registering info pages (added libc-info.patch),
264 - changed base source url to ftp://sourceware.cygnus.com/pub/glibc/,
265 - changed URL,
266 - siplifications in %files devel,
267 - Group in devel changed to Development/Libraries,
268 - removed some %doc (INSTALL and outdated ChangeLog),
269 - removed %config and %verify rules fromn /etc/rc.d/init.d/* files,
270 - changed permission to 754 on /etc/rc.d/init.d/*,
271 - added striping shared libraries.
272
273 * Sun Feb 14 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
274   [2.1-3d]
275 - updated to stable version,
276 - fixed stripping ELF binaries,
277 - removed obsoletes /usr/include/{asm,linux}
278
279 * Fri Jan 29 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
280   [2.0.111-1d]
281 - updated to latest snapshoot,
282 - added utmpd.init, (don't run this piece of ... by default)
283 - added /var/db, (don't generate a data base by default)
284 - removed unused /usr/libexec/pt_ch*
285 - other changes.
286
287 * Sat Nov 07 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
288   [2.0.100-1d]
289 - updated to latest snapshoot,
290 - added install-locales,
291 - minor changes.
292
293 * Tue Oct 13 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
294   [2.0.99-1d]
295 - updated to 2.0.99,
296 - added Obsoletes: glibc-debug, glibc-profile
297
298 * Thu Aug 06 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
299   [2.0.96-1d]
300 - updated to 2.0.96,
301 - translation modified for pl, 
302   (follow the suggestions Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>)
303 - major changes.
304       (rewrote invalid spec file -- follow the PLD policy)
305
306 * Wed Jul 16 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
307   [2.0.94-2d]
308 - added nscd.init and config
309 - fixed permision of pt_chown to 4711 
310 - added %defattr
311 - moved linux include links from kernel-headers to glibc-devel
312
313 * Tue Jun 2 1998 Wojtek Slusarczyk <wojtek@SHADOW.EU.ORG>
314   [2.0.94-1d]
315 - updated to glibc 2.0.94
316
317 * Sun May 24 1998 Marcin Korzonek <mkorz@euler.mat.univ.szczecin.pl>
318   [2.0.93-1d]
319 - updated for glibc 2.0.93
320 - build prepare for PLD-1.1 Tornado
321 - removed glibc-debug and glibc-profile packages generation (it took too
322   long to compile the full featured version on my home linux box ;)
323 - compilation is now performed in compile directory as advised 
324   in Glibc HOWTO,
325 - start at RH spec file.  
326
327   [2.1.1-1]
328 - based on RH spec,
329 - spec rewrited by PLD team,
330   we start at GNU libc 2.0.92 one year ago ...
331 - pl translation by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>.
This page took 0.078759 seconds and 2 git commands to generate.