]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
Update to 3.18.2
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.18.2
10 Release:        1
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/glade/3.18/%{name}-%{version}.tar.xz
14 # Source0-md5:  ecc29cef2c94fa4baa0678c295a897f9
15 URL:            http://glade.gnome.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gnome-common
20 BuildRequires:  gobject-introspection-devel >= 1.32.0
21 BuildRequires:  gtk+3-devel >= 3.12.0
22 BuildRequires:  gtk-doc >= 1.13
23 BuildRequires:  intltool >= 0.41.0
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  libxml2-devel >= 2.4.0
26 BuildRequires:  libxslt-progs
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygobject3-devel >= 3.8.0
29 BuildRequires:  rpmbuild(find_lang) >= 1.23
30 BuildRequires:  rpmbuild(macros) >= 1.311
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  yelp-tools
34 Requires(post,postun):  gtk-update-icon-cache
35 Requires(post,postun):  desktop-file-utils
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires:       hicolor-icon-theme
38 Conflicts:      glade3 < 3.8.2
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Glade is a RAD tool to enable quick & easy development of user
43 interfaces for the GTK+ toolkit and the GNOME desktop environment.
44
45 The user interfaces designed in Glade are saved as XML, and by using
46 the GtkBuilder GTK+ object these can be loaded by applications
47 dynamically as needed.
48
49 By using GtkBuilder, Glade XML files can be used in numerous
50 programming languages including C, C++, C#, Vala, Java, Perl, Python
51 and others.
52
53 %description -l pl.UTF-8
54 Glade jest narzędziem typu RAD (Rapid Application Development) do
55 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
56 bibliotekę GTK+ i środowisko GNOME.
57
58 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
59 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
60 dynamicznie ładowane przez aplikacje.
61
62 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
63 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
64 i inne.
65
66 %package libs
67 Summary:        Glade library
68 Summary(pl.UTF-8):      Biblioteka Glade
69 Group:          X11/Libraries
70 Requires:       gtk+3 >= 3.12.0
71 Requires:       libxml2 >= 2.4.0
72
73 %description libs
74 Glade library.
75
76 %description libs -l pl.UTF-8
77 Biblioteka Glade.
78
79 %package devel
80 Summary:        Header files for Glade library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84 Requires:       gtk+3-devel >= 3.12.0
85 Requires:       libxml2-devel >= 2.4.0
86
87 %description devel
88 Header files for Glade library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki Glade.
92
93 %package static
94 Summary:        Static Glade library
95 Summary(pl.UTF-8):      Statyczna biblioteka Glade
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static Glade library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka Glade.
104
105 %package apidocs
106 Summary:        Glade API documentation
107 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
108 Group:          Documentation
109 Requires:       gtk-doc-common
110 %if "%{_rpmversion}" >= "5"
111 BuildArch:      noarch
112 %endif
113
114 %description apidocs
115 Glade API documentation.
116
117 %description apidocs -l pl.UTF-8
118 Dokumentacja API biblioteki Glade.
119
120 %prep
121 %setup -q
122
123 %build
124 %{__intltoolize}
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --disable-silent-rules \
132         %{__enable_disable apidocs gtk-doc} \
133         %{__enable_disable static_libs static} \
134         --with-html-dir=%{_gtkdocdir}
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.{a,la}
144
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
146
147 %find_lang %{name} --with-gnome
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %update_icon_cache hicolor
154 %update_desktop_database_post
155
156 %postun
157 %update_icon_cache hicolor
158 %update_desktop_database_postun
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
166 %doc AUTHORS COPYING ChangeLog NEWS README TODO
167 %attr(755,root,root) %{_bindir}/glade
168 %attr(755,root,root) %{_bindir}/glade-previewer
169 %dir %{_libdir}/glade
170 %dir %{_libdir}/glade/modules
171 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
172 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
173 %{_datadir}/glade
174 %{_desktopdir}/glade.desktop
175 %{_iconsdir}/hicolor/*/apps/glade.png
176 %{_datadir}/appdata/glade.appdata.xml
177 %{_mandir}/man1/glade-previewer.1*
178 %{_mandir}/man1/glade.1*
179
180 %files libs
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.6
184 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
185
186 %files devel
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libgladeui-2.so
189 %{_datadir}/gir-1.0/Gladeui-2.0.gir
190 %{_includedir}/libgladeui-2.0
191 %{_pkgconfigdir}/gladeui-2.0.pc
192
193 %if %{with static_libs}
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/libgladeui-2.a
197 %endif
198
199 %if %{with apidocs}
200 %files apidocs
201 %defattr(644,root,root,755)
202 %{_gtkdocdir}/gladeui-2
203 %endif
This page took 0.108014 seconds and 3 git commands to generate.