]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
9ecbd4731f23afad76e21cc47413e9f159019d7c
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.16.1
10 Release:        1
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/glade/3.16/%{name}-%{version}.tar.xz
14 # Source0-md5:  1b60003e91a19cc0f1acae24d30269fc
15 URL:            http://glade.gnome.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gnome-common
20 BuildRequires:  gobject-introspection-devel >= 1.32.0
21 BuildRequires:  gtk+3-devel >= 3.6.0
22 BuildRequires:  gtk-doc >= 1.13
23 BuildRequires:  intltool >= 0.41.0
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  libxml2-devel >= 2.4.0
26 BuildRequires:  libxslt-progs
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygobject3-devel >= 3.8.0
29 BuildRequires:  rpmbuild(find_lang) >= 1.23
30 BuildRequires:  rpmbuild(macros) >= 1.311
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  yelp-tools
34 Requires(post,postun):  gtk-update-icon-cache
35 Requires(post,postun):  desktop-file-utils
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires:       hicolor-icon-theme
38 Conflicts:      glade3 < 3.8.2
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Glade is a RAD tool to enable quick & easy development of user
43 interfaces for the GTK+ toolkit and the GNOME desktop environment.
44
45 The user interfaces designed in Glade are saved as XML, and by using
46 the GtkBuilder GTK+ object these can be loaded by applications
47 dynamically as needed.
48
49 By using GtkBuilder, Glade XML files can be used in numerous
50 programming languages including C, C++, C#, Vala, Java, Perl, Python
51 and others.
52
53 %description -l pl.UTF-8
54 Glade jest narzędziem typu RAD (Rapid Application Development) do
55 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
56 bibliotekę GTK+ i środowisko GNOME.
57
58 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
59 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
60 dynamicznie ładowane przez aplikacje.
61
62 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
63 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
64 i inne.
65
66 %package libs
67 Summary:        Glade library
68 Summary(pl.UTF-8):      Biblioteka Glade
69 Group:          X11/Libraries
70 Requires:       gtk+3 >= 3.6.0
71 Requires:       libxml2 >= 2.4.0
72
73 %description libs
74 Glade library.
75
76 %description libs -l pl.UTF-8
77 Biblioteka Glade.
78
79 %package devel
80 Summary:        Header files for Glade library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84 Requires:       gtk+3-devel >= 3.6.0
85 Requires:       libxml2-devel >= 2.4.0
86
87 %description devel
88 Header files for Glade library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki Glade.
92
93 %package static
94 Summary:        Static Glade library
95 Summary(pl.UTF-8):      Statyczna biblioteka Glade
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static Glade library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka Glade.
104
105 %package apidocs
106 Summary:        Glade API documentation
107 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
108 Group:          Documentation
109 Requires:       gtk-doc-common
110
111 %description apidocs
112 Glade API documentation.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API biblioteki Glade.
116
117 %prep
118 %setup -q
119
120 %build
121 %{__intltoolize}
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --disable-silent-rules \
129         %{__enable_disable apidocs gtk-doc} \
130         %{__enable_disable static_libs static} \
131         --with-html-dir=%{_gtkdocdir}
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.{a,la}
141
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
143
144 %find_lang %{name} --with-gnome
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %update_icon_cache hicolor
151 %update_desktop_database_post
152
153 %postun
154 %update_icon_cache hicolor
155 %update_desktop_database_postun
156
157 %post   libs -p /sbin/ldconfig
158 %postun libs -p /sbin/ldconfig
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
163 %doc AUTHORS COPYING ChangeLog NEWS README TODO
164 %attr(755,root,root) %{_bindir}/glade
165 %attr(755,root,root) %{_bindir}/glade-previewer
166 %dir %{_libdir}/glade
167 %dir %{_libdir}/glade/modules
168 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
169 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
170 %{_datadir}/glade
171 %{_desktopdir}/glade.desktop
172 %{_iconsdir}/hicolor/*/apps/glade.png
173 %{_datadir}/appdata/glade.appdata.xml
174 %{_mandir}/man1/glade-previewer.1*
175 %{_mandir}/man1/glade.1*
176
177 %files libs
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.6
181 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
182
183 %files devel
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libgladeui-2.so
186 %{_datadir}/gir-1.0/Gladeui-2.0.gir
187 %{_includedir}/libgladeui-2.0
188 %{_pkgconfigdir}/gladeui-2.0.pc
189
190 %if %{with static_libs}
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/libgladeui-2.a
194 %endif
195
196 %if %{with apidocs}
197 %files apidocs
198 %defattr(644,root,root,755)
199 %{_gtkdocdir}/gladeui-2
200 %endif
This page took 0.060466 seconds and 2 git commands to generate.