]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
- updated to 3.20.0
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.20.0
10 Release:        1
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/glade/3.20/%{name}-%{version}.tar.xz
14 # Source0-md5:  9964a2da14c5f845eae363889586ca43
15 URL:            http://glade.gnome.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gnome-common
20 BuildRequires:  gobject-introspection-devel >= 1.32.0
21 BuildRequires:  gtk+3-devel >= 3.12.0
22 BuildRequires:  gtk-doc >= 1.13
23 BuildRequires:  intltool >= 0.41.0
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  libxml2-devel >= 2.4.0
26 BuildRequires:  libxslt-progs
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-devel >= 2
29 BuildRequires:  python-pygobject3-devel >= 3.8.0
30 BuildRequires:  rpmbuild(find_lang) >= 1.23
31 BuildRequires:  rpmbuild(macros) >= 1.311
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRequires:  yelp-tools
35 Requires(post,postun):  gtk-update-icon-cache
36 Requires(post,postun):  desktop-file-utils
37 Requires:       %{name}-libs = %{version}-%{release}
38 Requires:       hicolor-icon-theme
39 Conflicts:      glade3 < 3.8.2
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Glade is a RAD tool to enable quick & easy development of user
44 interfaces for the GTK+ toolkit and the GNOME desktop environment.
45
46 The user interfaces designed in Glade are saved as XML, and by using
47 the GtkBuilder GTK+ object these can be loaded by applications
48 dynamically as needed.
49
50 By using GtkBuilder, Glade XML files can be used in numerous
51 programming languages including C, C++, C#, Vala, Java, Perl, Python
52 and others.
53
54 %description -l pl.UTF-8
55 Glade jest narzędziem typu RAD (Rapid Application Development) do
56 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
57 bibliotekę GTK+ i środowisko GNOME.
58
59 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
60 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
61 dynamicznie ładowane przez aplikacje.
62
63 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
64 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
65 i inne.
66
67 %package libs
68 Summary:        Glade library
69 Summary(pl.UTF-8):      Biblioteka Glade
70 Group:          X11/Libraries
71 Requires:       gtk+3 >= 3.12.0
72 Requires:       libxml2 >= 2.4.0
73
74 %description libs
75 Glade library.
76
77 %description libs -l pl.UTF-8
78 Biblioteka Glade.
79
80 %package devel
81 Summary:        Header files for Glade library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       gtk+3-devel >= 3.12.0
86 Requires:       libxml2-devel >= 2.4.0
87
88 %description devel
89 Header files for Glade library.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki Glade.
93
94 %package static
95 Summary:        Static Glade library
96 Summary(pl.UTF-8):      Statyczna biblioteka Glade
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 Static Glade library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka Glade.
105
106 %package apidocs
107 Summary:        Glade API documentation
108 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
109 Group:          Documentation
110 Requires:       gtk-doc-common
111 %if "%{_rpmversion}" >= "5"
112 BuildArch:      noarch
113 %endif
114
115 %description apidocs
116 Glade API documentation.
117
118 %description apidocs -l pl.UTF-8
119 Dokumentacja API biblioteki Glade.
120
121 %prep
122 %setup -q
123
124 %build
125 %{__intltoolize}
126 %{__libtoolize}
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         --disable-silent-rules \
133         %{__enable_disable apidocs gtk-doc} \
134         %{__enable_disable static_libs static} \
135         --with-html-dir=%{_gtkdocdir}
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.{a,la}
145
146 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
147
148 %find_lang %{name} --with-gnome
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post
154 %update_icon_cache hicolor
155 %update_desktop_database_post
156
157 %postun
158 %update_icon_cache hicolor
159 %update_desktop_database_postun
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
167 %doc AUTHORS COPYING ChangeLog NEWS README TODO
168 %attr(755,root,root) %{_bindir}/glade
169 %attr(755,root,root) %{_bindir}/glade-previewer
170 %dir %{_libdir}/glade
171 %dir %{_libdir}/glade/modules
172 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
173 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
174 %{_datadir}/glade
175 %{_desktopdir}/glade.desktop
176 %{_iconsdir}/hicolor/*x*/apps/glade.png
177 %{_iconsdir}/hicolor/scalable/apps/glade-symbolic.svg
178 %{_datadir}/appdata/glade.appdata.xml
179 %{_mandir}/man1/glade-previewer.1*
180 %{_mandir}/man1/glade.1*
181
182 %files libs
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.6
186 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libgladeui-2.so
191 %{_datadir}/gir-1.0/Gladeui-2.0.gir
192 %{_includedir}/libgladeui-2.0
193 %{_pkgconfigdir}/gladeui-2.0.pc
194
195 %if %{with static_libs}
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libgladeui-2.a
199 %endif
200
201 %if %{with apidocs}
202 %files apidocs
203 %defattr(644,root,root,755)
204 %{_gtkdocdir}/gladeui-2
205 %endif
This page took 0.07929 seconds and 3 git commands to generate.