]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
487962fd0d6984a56c5cf590235599861e215cb7
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.38.2
10 Release:        1
11 License:        GPL v2+ and LGPL v2.1+
12 Group:          X11/Applications
13 Source0:        https://download.gnome.org/sources/glade/3.38/%{name}-%{version}.tar.xz
14 # Source0-md5:  f1ac9d9b6404308efb74adc548289455
15 URL:            https://glade.gnome.org/
16 BuildRequires:  gettext-devel >= 0.19.8
17 BuildRequires:  gjs-devel >= 1.64.0
18 BuildRequires:  glib2-devel >= 1:2.64.0
19 BuildRequires:  gobject-introspection-devel >= 1.32.0
20 BuildRequires:  gtk+3-devel >= 3.24.0
21 BuildRequires:  gtk-doc >= 1.13
22 BuildRequires:  gtk-webkit4-devel >= 2.28
23 BuildRequires:  libxml2-devel >= 2.4.0
24 BuildRequires:  libxslt-progs
25 BuildRequires:  meson >= 0.49.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-devel >= 2
29 BuildRequires:  python-pygobject3-devel >= 3.8.0
30 BuildRequires:  rpmbuild(find_lang) >= 1.23
31 BuildRequires:  rpmbuild(macros) >= 1.752
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  yelp-tools
36 Requires(post,postun):  gtk-update-icon-cache
37 Requires(post,postun):  desktop-file-utils
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       gjs >= 1.64.0
40 Requires:       gtk-webkit4 >= 2.28
41 Requires:       hicolor-icon-theme
42 Conflicts:      glade3 < 3.8.2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Glade is a RAD tool to enable quick & easy development of user
47 interfaces for the GTK+ toolkit and the GNOME desktop environment.
48
49 The user interfaces designed in Glade are saved as XML, and by using
50 the GtkBuilder GTK+ object these can be loaded by applications
51 dynamically as needed.
52
53 By using GtkBuilder, Glade XML files can be used in numerous
54 programming languages including C, C++, C#, Vala, Java, Perl, Python
55 and others.
56
57 %description -l pl.UTF-8
58 Glade jest narzędziem typu RAD (Rapid Application Development) do
59 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
60 bibliotekę GTK+ i środowisko GNOME.
61
62 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
63 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
64 dynamicznie ładowane przez aplikacje.
65
66 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
67 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
68 i inne.
69
70 %package libs
71 Summary:        Glade library
72 Summary(pl.UTF-8):      Biblioteka Glade
73 Group:          X11/Libraries
74 Requires:       glib2 >= 1:2.64.0
75 Requires:       gtk+3 >= 3.24.0
76 Requires:       libxml2 >= 2.4.0
77
78 %description libs
79 Glade library.
80
81 %description libs -l pl.UTF-8
82 Biblioteka Glade.
83
84 %package devel
85 Summary:        Header files for Glade library
86 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
87 Group:          X11/Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89 Requires:       glib2-devel >= 1:2.64.0
90 Requires:       gtk+3-devel >= 3.24.0
91 Requires:       libxml2-devel >= 2.4.0
92
93 %description devel
94 Header files for Glade library.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe biblioteki Glade.
98
99 %package static
100 Summary:        Static Glade library
101 Summary(pl.UTF-8):      Statyczna biblioteka Glade
102 Group:          X11/Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104
105 %description static
106 Static Glade library.
107
108 %description static -l pl.UTF-8
109 Statyczna biblioteka Glade.
110
111 %package apidocs
112 Summary:        Glade API documentation
113 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
114 Group:          Documentation
115 Requires:       gtk-doc-common
116 %{?noarchpackage}
117
118 %description apidocs
119 Glade API documentation.
120
121 %description apidocs -l pl.UTF-8
122 Dokumentacja API biblioteki Glade.
123
124 %prep
125 %setup -q
126
127 %if %{with static_libs}
128 %{__sed} -i -e '/^libgladeui = / s/shared_library/library/' gladeui/meson.build
129 %endif
130
131 %build
132 %meson build \
133         -Dgladeui=true \
134         %{?with_apidocs:-Dgtk_doc=true}
135
136 %ninja_build -C build
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %ninja_install -C build
142
143 %find_lang %{name} --with-gnome
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 %update_icon_cache hicolor
150 %update_desktop_database_post
151
152 %postun
153 %update_icon_cache hicolor
154 %update_desktop_database_postun
155
156 %post   libs -p /sbin/ldconfig
157 %postun libs -p /sbin/ldconfig
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 # NOTE: COPYING contains general notes; full GPL and LGPL texts are in COPYING.{GPL,LGPL}
162 %doc AUTHORS COPYING MAINTAINERS NEWS TODO
163 %attr(755,root,root) %{_bindir}/glade
164 %attr(755,root,root) %{_bindir}/glade-previewer
165 %dir %{_libdir}/glade
166 %dir %{_libdir}/glade/modules
167 %attr(755,root,root) %{_libdir}/glade/modules/libgladegjs.so
168 %attr(755,root,root) %{_libdir}/glade/modules/libgladeglade.so
169 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
170 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
171 %attr(755,root,root) %{_libdir}/glade/modules/libgladewebkit2gtk.so
172 %{_datadir}/glade
173 %{_datadir}/gettext/its/glade-catalog.its
174 %{_datadir}/gettext/its/glade-catalog.loc
175 %{_desktopdir}/org.gnome.Glade.desktop
176 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Glade.svg
177 %{_iconsdir}/hicolor/symbolic/apps/glade-brand-symbolic.svg
178 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Glade-symbolic.svg
179 %{_datadir}/metainfo/org.gnome.Glade.appdata.xml
180 %{_mandir}/man1/glade-previewer.1*
181 %{_mandir}/man1/glade.1*
182
183 %files libs
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.13
187 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libgladeui-2.so
192 %{_datadir}/gir-1.0/Gladeui-2.0.gir
193 %{_includedir}/libgladeui-2.0
194 %{_pkgconfigdir}/gladeui-2.0.pc
195
196 %if %{with static_libs}
197 %files static
198 %defattr(644,root,root,755)
199 %{_libdir}/libgladeui-2.a
200 %endif
201
202 %if %{with apidocs}
203 %files apidocs
204 %defattr(644,root,root,755)
205 %{_gtkdocdir}/gladeui-2
206 %endif
This page took 0.084443 seconds and 3 git commands to generate.