]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
e16a34b1e8e82a899e9dcaf7e28a76c79283d217
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprof         # sysprof profiling
4 %bcond_without  systemtap       # systemtap/dtrace trace support
5 #
6 Summary:        JavaScript bindings for GNOME
7 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
8 Name:           gjs
9 Version:        1.64.4
10 Release:        2
11 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gjs/1.64/%{name}-%{version}.tar.xz
14 # Source0-md5:  dc0d4a0453484c5a77eb0e2bda091704
15 URL:            https://wiki.gnome.org/Projects/Gjs
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11.1
18 BuildRequires:  cairo-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  glib2-devel >= 1:2.58.0
22 BuildRequires:  gobject-introspection-devel >= 1.61.2
23 BuildRequires:  libffi-devel
24 BuildRequires:  libstdc++-devel >= 6:5.0
25 BuildRequires:  libtool >= 2:2.2.0
26 BuildRequires:  meson >= 0.50.0
27 BuildRequires:  mozjs68-devel >= 68
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pkgconfig
30 BuildRequires:  readline-devel
31 BuildRequires:  rpmbuild(macros) >= 1.736
32 # pkgconfig(sysprof-capture-3)
33 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.34}
34 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires:       glib2 >= 1:2.58.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Gjs allows using GNOME libraries from JavaScript. It is mainly based
42 on Spidermonkey JavaScript engine and the GObject introspection
43 framework.
44
45 %description -l pl.UTF-8
46 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
47 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
48
49 %package devel
50 Summary:        Header files for gjs library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       cairo-devel
55 Requires:       cairo-gobject-devel
56 Requires:       glib2-devel >= 1:2.58.0
57 Requires:       gobject-introspection-devel >= 1.61.2
58 Requires:       libffi-devel
59 Requires:       mozjs68-devel >= 68
60
61 %description devel
62 Header files for gjs library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki gjs.
66
67 %package -n systemtap-gjs
68 Summary:        systemtap/dtrace probes for gjs
69 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
70 Group:          Development/Tools
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       systemtap-client
73
74 %description -n systemtap-gjs
75 systemtap/dtrace probes for gjs.
76
77 %description -n systemtap-gjs -l pl.UTF-8
78 Sondy systemtap/dtrace dla gjs.
79
80 %prep
81 %setup -q
82
83 %build
84 %meson build \
85         -Dprofiler=%{?with_sysprof:enabled}%{!?with_sysprof:disabled} \
86         -Dsystemtap=%{__true_false systemtap} \
87         -Ddtrace=%{__true_false systemtap}
88
89 %ninja_build -C build
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95 %ninja_install -C build
96
97 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
98
99 # belongs to installed-tests
100 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
101 %{__rm} -r $RPM_BUILD_ROOT{%{_datadir},%{_libexecdir}/gjs}/installed-tests
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc COPYING NEWS README.md
112 %attr(755,root,root) %{_bindir}/gjs
113 %attr(755,root,root) %{_bindir}/gjs-console
114 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
116 %dir %{_libdir}/gjs
117 %dir %{_libdir}/gjs/girepository-1.0
118 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
119 %{_datadir}/gjs-1.0
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libgjs.so
124 %{_includedir}/gjs-1.0
125 %{_pkgconfigdir}/gjs-1.0.pc
126 %{_examplesdir}/%{name}-%{version}
127
128 %files -n systemtap-gjs
129 %defattr(644,root,root,755)
130 %{_datadir}/systemtap/tapset/gjs.stp
This page took 0.066253 seconds and 2 git commands to generate.