]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
- updated to 1.72.3 (fixes for libffi 3.4.2+)
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprof         # sysprof profiling
4 %bcond_without  systemtap       # systemtap/dtrace trace support
5 #
6 Summary:        JavaScript bindings for GNOME
7 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
8 Name:           gjs
9 Version:        1.72.3
10 Release:        1
11 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/gjs/1.72/%{name}-%{version}.tar.xz
14 # Source0-md5:  6402feb4fb34803b1f15f0b29aa56f6e
15 URL:            https://wiki.gnome.org/Projects/Gjs
16 BuildRequires:  cairo-devel
17 BuildRequires:  cairo-gobject-devel
18 BuildRequires:  gettext-tools
19 BuildRequires:  glib2-devel >= 1:2.66.0
20 BuildRequires:  gobject-introspection-devel >= 1.66.1
21 BuildRequires:  libffi-devel
22 BuildRequires:  libstdc++-devel >= 6:7.0
23 BuildRequires:  meson >= 0.52.0
24 BuildRequires:  mozjs91-devel >= 91.3.0
25 BuildRequires:  ninja >= 1.5
26 BuildRequires:  pkgconfig
27 BuildRequires:  readline-devel
28 BuildRequires:  rpm-build >= 4.6
29 BuildRequires:  rpmbuild(macros) >= 1.736
30 # pkgconfig(sysprof-capture-4)
31 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.36}
32 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 Requires:       glib2 >= 1:2.66.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Gjs allows using GNOME libraries from JavaScript. It is mainly based
40 on Spidermonkey JavaScript engine and the GObject introspection
41 framework.
42
43 %description -l pl.UTF-8
44 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
45 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
46
47 %package devel
48 Summary:        Header files for gjs library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       cairo-devel
53 Requires:       cairo-gobject-devel
54 Requires:       glib2-devel >= 1:2.66.0
55 Requires:       gobject-introspection-devel >= 1.66.0
56 Requires:       libffi-devel
57 Requires:       mozjs91-devel >= 91.3.0
58
59 %description devel
60 Header files for gjs library.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki gjs.
64
65 %package -n systemtap-gjs
66 Summary:        systemtap/dtrace probes for gjs
67 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
68 Group:          Development/Tools
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       systemtap-client
71 BuildArch:      noarch
72
73 %description -n systemtap-gjs
74 systemtap/dtrace probes for gjs.
75
76 %description -n systemtap-gjs -l pl.UTF-8
77 Sondy systemtap/dtrace dla gjs.
78
79 %prep
80 %setup -q
81
82 %build
83 %meson build \
84         -Dprofiler=%{?with_sysprof:enabled}%{!?with_sysprof:disabled} \
85         -Dsystemtap=%{__true_false systemtap} \
86         -Ddtrace=%{__true_false systemtap}
87
88 %ninja_build -C build
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93
94 %ninja_install -C build
95
96 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
97
98 # belongs to installed-tests
99 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
100 %{__rm} -r $RPM_BUILD_ROOT{%{_datadir},%{_libexecdir}}/installed-tests
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc COPYING NEWS README.md
111 %attr(755,root,root) %{_bindir}/gjs
112 %attr(755,root,root) %{_bindir}/gjs-console
113 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
115 %dir %{_libdir}/gjs
116 %dir %{_libdir}/gjs/girepository-1.0
117 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
118 %{_datadir}/gjs-1.0
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libgjs.so
123 %{_includedir}/gjs-1.0
124 %{_pkgconfigdir}/gjs-1.0.pc
125 %{_examplesdir}/%{name}-%{version}
126
127 %if %{with systemtap}
128 %files -n systemtap-gjs
129 %defattr(644,root,root,755)
130 %{_datadir}/systemtap/tapset/gjs.stp
131 %endif
This page took 0.051462 seconds and 3 git commands to generate.