]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
1290c6f4b911788d5835e934df2c62ca1b65e336
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  systemtap       # systemtap/dtrace trace support
4 #
5 Summary:        JavaScript bindings for GNOME
6 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
7 Name:           gjs
8 Version:        1.50.1
9 Release:        1
10 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gjs/1.50/%{name}-%{version}.tar.xz
13 # Source0-md5:  807c9261e0c3f9f52f2623e55900a58e
14 URL:            http://live.gnome.org/Gjs
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11.1
17 BuildRequires:  cairo-devel
18 BuildRequires:  cairo-gobject-devel
19 BuildRequires:  gettext-tools
20 BuildRequires:  glib2-devel >= 1:2.50.0
21 BuildRequires:  gobject-introspection-devel >= 1.41.4
22 BuildRequires:  gtk+3-devel >= 3.20
23 BuildRequires:  libffi-devel
24 BuildRequires:  libstdc++-devel >= 6:4.7
25 BuildRequires:  libtool >= 2:2.2.0
26 BuildRequires:  mozjs52-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  readline-devel
29 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
30 Requires:       glib2 >= 1:2.50.0
31 Requires:       gtk+3 >= 3.20
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Gjs allows using GNOME libraries from JavaScript. It is mainly based
36 on Spidermonkey JavaScript engine and the GObject introspection
37 framework.
38
39 %description -l pl.UTF-8
40 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
41 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
42
43 %package devel
44 Summary:        Header files for gjs library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       cairo-devel
49 Requires:       cairo-gobject-devel
50 Requires:       glib2-devel >= 1:2.50.0
51 Requires:       gobject-introspection-devel >= 1.41.4
52 Requires:       gtk+3-devel >= 3.20
53 Requires:       libffi-devel
54 Requires:       mozjs52-devel
55
56 %description devel
57 Header files for gjs library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki gjs.
61
62 %package -n systemtap-gjs
63 Summary:        systemtap/dtrace probes for gjs
64 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
65 Group:          Development/Tools
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       systemtap-client
68
69 %description -n systemtap-gjs
70 systemtap/dtrace probes for gjs.
71
72 %description -n systemtap-gjs -l pl.UTF-8
73 Sondy systemtap/dtrace dla gjs.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --disable-silent-rules \
86         %{?with_systemtap:--enable-systemtap}
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
92
93 %{__make} -j1 install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 cp examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
97
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc COPYING NEWS README
109 %attr(755,root,root) %{_bindir}/gjs
110 %attr(755,root,root) %{_bindir}/gjs-console
111 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
113 %dir %{_libdir}/gjs
114 %dir %{_libdir}/gjs/girepository-1.0
115 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libgjs.so
120 %{_includedir}/gjs-1.0
121 %{_pkgconfigdir}/gjs-1.0.pc
122 %{_examplesdir}/%{name}-%{version}
123
124 %files -n systemtap-gjs
125 %defattr(644,root,root,755)
126 %{_datadir}/systemtap/tapset/gjs.stp
This page took 0.259477 seconds and 2 git commands to generate.