]> git.pld-linux.org Git - packages/gitlab-runner.git/commitdiff
Up to 13.12.0
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 6 Sep 2021 14:18:16 +0000 (17:18 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Mon, 6 Sep 2021 14:26:00 +0000 (17:26 +0300)
branch-preserver.patch
gitlab-runner.spec

index e47cbcf86ed390e368fc755ce08baa4f12faf0e9..49175c33891ad2ac666716ca5b1cd1b2405bae49 100644 (file)
@@ -1,9 +1,9 @@
---- gitlab-runner/shells/abstract.go~  2019-10-28 14:11:26.000000000 +0200
-+++ gitlab-runner/shells/abstract.go   2019-11-10 02:47:02.568781451 +0200
-@@ -337,7 +337,11 @@
+--- gitlab-runner-13.12.0/src/gitlab.com/gitlab-org/gitlab-runner/shells/abstract.go~  2021-05-20 18:01:08.000000000 +0300
++++ gitlab-runner-13.12.0/src/gitlab.com/gitlab-org/gitlab-runner/shells/abstract.go   2021-09-06 17:21:01.502430880 +0300
+@@ -386,7 +386,11 @@
  
  func (b *AbstractShell) writeCheckoutCmd(w ShellWriter, build *common.Build) {
  
  func (b *AbstractShell) writeCheckoutCmd(w ShellWriter, build *common.Build) {
-       w.Notice("Checking out %s as %s...", build.GitInfo.Sha[0:8], build.GitInfo.Ref)
+       w.Noticef("Checking out %s as %s...", build.GitInfo.Sha[0:8], build.GitInfo.Ref)
 -      w.Command("git", "checkout", "-f", "-q", build.GitInfo.Sha)
 +      if build.GitInfo.RefType == common.RefTypeTag {
 +              w.Command("git", "checkout", "-f", "-q", build.GitInfo.Sha)
 -      w.Command("git", "checkout", "-f", "-q", build.GitInfo.Sha)
 +      if build.GitInfo.RefType == common.RefTypeTag {
 +              w.Command("git", "checkout", "-f", "-q", build.GitInfo.Sha)
index 7e5bbe6c392f692437ea957277d2b581450e80f9..9970bdcca8681dd44d51180704ebd0ee42fe8ecb 100644 (file)
@@ -5,12 +5,12 @@
 %define                helper_revision 05161b14
 Summary:       The official GitLab CI runner written in Go
 Name:          gitlab-runner
 %define                helper_revision 05161b14
 Summary:       The official GitLab CI runner written in Go
 Name:          gitlab-runner
-Version:       12.7.1
+Version:       13.12.0
 Release:       1
 License:       MIT
 Group:         Development/Building
 Source0:       https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v%{version}/gitlab-runner-v%{version}.tar.bz2
 Release:       1
 License:       MIT
 Group:         Development/Building
 Source0:       https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v%{version}/gitlab-runner-v%{version}.tar.bz2
-# Source0-md5: 20c0e38abbb97ba2c6bc38fd338fc15f
+# Source0-md5: a249bfae11074f3922a6c1f72fa5fa9d
 %if %{with prebuilt}
 Source1:       https://gitlab-runner-downloads.s3.amazonaws.com/v%{version}/binaries/gitlab-runner-linux-amd64
 # Source1-md5: 2fc56f01f932a14a807e37195d08bcf2
 %if %{with prebuilt}
 Source1:       https://gitlab-runner-downloads.s3.amazonaws.com/v%{version}/binaries/gitlab-runner-linux-amd64
 # Source1-md5: 2fc56f01f932a14a807e37195d08bcf2
@@ -66,10 +66,12 @@ mv gitlab-runner-*/*.md .
 # don't you love go?
 install -d src/$(dirname %{import_path})
 mv gitlab-runner-* src/%{import_path}
 # don't you love go?
 install -d src/$(dirname %{import_path})
 mv gitlab-runner-* src/%{import_path}
+
+%patch1 -p1
+
 cd src/%{import_path}
 
 #%patch0 -p5
 cd src/%{import_path}
 
 #%patch0 -p5
-%patch1 -p1
 
 # avoid docker being used even if executable found
 cat <<'EOF' > docker
 
 # avoid docker being used even if executable found
 cat <<'EOF' > docker
This page took 0.059941 seconds and 4 git commands to generate.