]> git.pld-linux.org Git - packages/gitlab-runner.git/commitdiff
up to 12.4.1 auto/th/gitlab-runner-12.4.1-1
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 10 Nov 2019 00:47:46 +0000 (02:47 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 10 Nov 2019 00:47:46 +0000 (02:47 +0200)
branch-preserver.patch
gitlab-runner.spec

index bf6a1209e3635c923fbfb14023e5bdc927d7850f..e47cbcf86ed390e368fc755ce08baa4f12faf0e9 100644 (file)
@@ -1,6 +1,6 @@
---- gitlab-ci-multi-runner/shells/abstract.go~ 2017-05-02 13:12:18.000000000 +0300
-+++ gitlab-ci-multi-runner/shells/abstract.go  2017-05-16 08:10:46.528840805 +0300
-@@ -96,7 +96,11 @@
+--- gitlab-runner/shells/abstract.go~  2019-10-28 14:11:26.000000000 +0200
++++ gitlab-runner/shells/abstract.go   2019-11-10 02:47:02.568781451 +0200
+@@ -337,7 +337,11 @@
  
  func (b *AbstractShell) writeCheckoutCmd(w ShellWriter, build *common.Build) {
        w.Notice("Checking out %s as %s...", build.GitInfo.Sha[0:8], build.GitInfo.Ref)
@@ -10,6 +10,6 @@
 +      } else {
 +              w.Command("git", "checkout", "-fq", "-B", build.GitInfo.Ref, build.GitInfo.Sha)
 +      }
- }
  
- func (b *AbstractShell) writeSubmoduleUpdateCmd(w ShellWriter, build *common.Build, recursive bool) {
+       cleanFlags := build.GetGitCleanFlags()
+       if len(cleanFlags) > 0 {
index 49eb9f6a00651f8a0841c9d92810fe536bccbbeb..14eee8540dfb5a074dba4d0d2aa972259d7b1f1e 100644 (file)
@@ -2,15 +2,15 @@
 # Conditional build:
 %bcond_with    prebuilt                # use prebuilt binary
 
-%define                helper_revision 081978aa
+%define                helper_revision 05161b14
 Summary:       The official GitLab CI runner written in Go
 Name:          gitlab-runner
-Version:       11.1.0
-Release:       0.4
+Version:       12.4.1
+Release:       1
 License:       MIT
 Group:         Development/Building
 Source0:       https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v%{version}/gitlab-runner-v%{version}.tar.bz2
-# Source0-md5: 5d92b8ca3fe5fdfeeb3bc2900c4aecd6
+# Source0-md5: 9b74135f78d5b0f4c1df1f4117ae1eda
 %if %{with prebuilt}
 Source1:       https://gitlab-runner-downloads.s3.amazonaws.com/v%{version}/binaries/gitlab-runner-linux-amd64
 # Source1-md5: 2fc56f01f932a14a807e37195d08bcf2
This page took 0.03266 seconds and 4 git commands to generate.