]> git.pld-linux.org Git - packages/git-core.git/commitdiff
fix t8005-blame-i18n test to work with grep >= 2.22-2 auto/th/git-core-2.7.1-2
authorJan Palus <atler@pld-linux.org>
Sat, 6 Feb 2016 16:59:21 +0000 (17:59 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 6 Feb 2016 16:59:45 +0000 (17:59 +0100)
- rel 2

git-core-test-grep.patch [new file with mode: 0644]
git-core.spec

diff --git a/git-core-test-grep.patch b/git-core-test-grep.patch
new file mode 100644 (file)
index 0000000..20e3b1d
--- /dev/null
@@ -0,0 +1,38 @@
+--- t/t8005-blame-i18n.sh.orig 2016-02-06 17:47:21.108000446 +0100
++++ t/t8005-blame-i18n.sh      2016-02-06 17:48:04.231487635 +0100
+@@ -36,7 +36,7 @@
+ test_expect_success !MINGW \
+       'blame respects i18n.commitencoding' '
+       git blame --incremental file | \
+-              egrep "^(author|summary) " > actual &&
++              egrep -a "^(author|summary) " > actual &&
+       test_cmp actual expected
+ '
+@@ -53,7 +53,7 @@
+       'blame respects i18n.logoutputencoding' '
+       git config i18n.logoutputencoding eucJP &&
+       git blame --incremental file | \
+-              egrep "^(author|summary) " > actual &&
++              egrep -a "^(author|summary) " > actual &&
+       test_cmp actual expected
+ '
+@@ -69,7 +69,7 @@
+ test_expect_success !MINGW \
+       'blame respects --encoding=UTF-8' '
+       git blame --incremental --encoding=UTF-8 file | \
+-              egrep "^(author|summary) " > actual &&
++              egrep -a "^(author|summary) " > actual &&
+       test_cmp actual expected
+ '
+@@ -85,7 +85,7 @@
+ test_expect_success !MINGW \
+       'blame respects --encoding=none' '
+       git blame --incremental --encoding=none file | \
+-              egrep "^(author|summary) " > actual &&
++              egrep -a "^(author|summary) " > actual &&
+       test_cmp actual expected
+ '
index 20fbe9bd8ac12cf82840fe28692a119d9849b88e..105e0b27ec5fa4bb4ad0b31c332d5a1ecc6d2a9f 100644 (file)
@@ -14,7 +14,7 @@ Summary:      Distributed version control system focused on speed, effectivity and us
 Summary(pl.UTF-8):     Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
 Name:          git-core
 Version:       2.7.1
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Development/Tools
 Source0:       http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
@@ -31,6 +31,7 @@ Patch1:               %{name}-key-bindings.patch
 Patch2:                %{name}-sysconfdir.patch
 Patch3:                cherry-picked-commitlog.patch
 Patch4:                %{name}-svn-exit-errors.patch
+Patch5:                %{name}-test-grep.patch
 URL:           http://git-scm.com/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -436,6 +437,7 @@ Moduł trzeba zarejestrować poleceniem:
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p0
 
 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
 
This page took 0.037233 seconds and 4 git commands to generate.