]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- remove unneded files
[packages/git-core.git] / git-core.spec
1
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The stupid content tracker
8 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
9 Name:           git-core
10 Version:        1.5.3.7
11 Release:        1
12 License:        GPL v2
13 Group:          Development/Tools
14 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15 # Source0-md5:  a114cbf532ff627698a031a66d072173
16 Source1:        %{name}-gitweb.conf
17 Source2:        %{name}-gitweb-httpd.conf
18 Source3:        %{name}.sysconfig
19 Source4:        %{name}.inet
20 Source5:        %{name}.init
21 URL:            http://git.or.cz/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  curl-devel
25 BuildRequires:  expat-devel
26 BuildRequires:  openssl-devel
27 BuildRequires:  perl-Error
28 BuildRequires:  perl-base
29 BuildRequires:  python
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 BuildRequires:  rpmbuild(macros) >= 1.264
32 BuildRequires:  zlib-devel
33 %if %{with doc}
34 BuildRequires:  asciidoc >= 7.1.2-3
35 BuildRequires:  xmlto
36 %endif
37 %if %{with tests}
38 BuildRequires:  cvs
39 # tests fail when using this client
40 BuildRequires:  pdksh >= 5.2.14-46
41 BuildConflicts: cvs-nserver-client
42 %endif
43 Requires:       coreutils
44 Requires:       cpio
45 Requires:       curl
46 Requires:       diffutils
47 Requires:       findutils
48 Requires:       grep
49 Requires:       openssh-clients
50 Requires:       perl-Error
51 Requires:       rcs
52 Requires:       sed
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # html docs have links to txt files
56 %define         _noautocompressdoc      *.txt
57
58 %define         webapp          gitweb
59 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
60 %define         appdir          %{_datadir}/%{webapp}
61 %define         cgibindir       %{_prefix}/lib/cgi-bin
62
63 %description
64 "git" can mean anything, depending on your mood.
65
66  - random three-letter combination that is pronounceable, and not
67    actually used by any common UNIX command. The fact that it is a
68    mispronunciation of "get" may or may not be relevant.
69  - stupid. contemptible and despicable. simple. Take your pick from the
70    dictionary of slang.
71  - "global information tracker": you're in a good mood, and it actually
72    works for you. Angels sing, and a light suddenly fills the room.
73  - "goddamn idiotic truckload of sh*t": when it breaks
74
75 This is a stupid (but extremely fast) directory content manager. It
76 doesn't do a whole lot, but what it 'does' do is track directory
77 contents efficiently.
78
79 %description -l pl.UTF-8
80 "git" może oznaczać cokolwiek, w zależności od nastroju.
81
82  - losową kombinację trzech liter, która jest wymawialna i właściwie
83    nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
84    błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
85  - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
86  - "global information tracker" (narzędzie do globalnego śledzenia
87    informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
88    Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
89  - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
90    g*) - kiedy się zepsuje.
91
92 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
93 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
94 katalogu.
95
96 %package daemon-inetd
97 Summary:        Files necessary to run git-daemon as an inetd service
98 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemon w trybie usługi inetd
99 Group:          Networking/Daemons
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       setup >= 2.4.11-1
102 Provides:       git-core-daemon
103 Obsoletes:      git-core-daemon
104 Obsoletes:      git-core-daemon-standalone
105
106 %description daemon-inetd
107 Git-daemon is a really simple TCP git daemon that can serve git
108 repositories. This package provides all necessarry files to run
109 git-daemon as an inetd service.
110
111 %description daemon-inetd -l pl.UTF-8
112 Git-daemon to prosty daemon git korzystający z protokołu TCP do
113 udostępnienia repozytoriów git. Pakiet ten dostarcza potrzebnych
114 plików do uruchomienia git-daemon w trybie usługi inetd.
115
116 %package daemon-standalone
117 Summary:        Files necessary to run git-daemon as a standalone service
118 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemon w trybie usługi standalone
119 Group:          Networking/Daemons
120 Requires:       %{name} = %{version}-%{release}
121 Provides:       git-core-daemon
122 Obsoletes:      git-core-daemon
123 Obsoletes:      git-core-daemon-inetd
124
125 %description daemon-standalone
126 Git-daemon is a really simple TCP git daemon that can serve git
127 repositories. This package provides all necessarry files to run
128 git-daemon as an standalone service.
129
130 %description daemon-standalone -l pl.UTF-8
131 Git-daemon to prosty daemon git korzystający z protokołu TCP do
132 udostępnienia repozytoriów git. Pakiet ten dostarcza potrzebnych
133 plików do uruchomienia git-daemon w trybie usługi standalone.
134
135 %package devel
136 Summary:        Header files for git-core
137 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
138 Group:          Development/Libraries
139
140 %description devel
141 Header files for git-core.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe dla git-core.
145
146 %package gitk
147 Summary:        Tcl/Tk interface to the Git version control system
148 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
149 Group:          Development/Tools
150 Requires:       %{name} = %{version}-%{release}
151 Requires:       tk
152
153 %description gitk
154 Displays changes in a repository or a selected set of commits. This
155 includes visualizing the commit graph, showing information related to
156 each commit, and the files in the trees of each revision.
157
158 Historically, gitk was the first repository browser. It's written in
159 Tcl/Tk and started off in a separate repository but was later merged
160 into the main git repository.
161
162 %description gitk -l pl.UTF-8
163 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
164 to wizualizację grafu commitów, wyświetlanie informacji związanych z
165 każdym z commitów oraz listę plików dla każdej rewizji.
166
167 Z punktu widzenia historii, gitk był pierwszą przeglądarką
168 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
169 osobnym repozytorium, ale z czasem został włączony do głównego
170 repozytorium gita.
171
172 %package gitweb
173 Summary:        Web frontend to git
174 Summary(pl.UTF-8):      Webowy frontend do git
175 Group:          Development/Tools
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       webapps
178
179 %description gitweb
180 This package provides a web interface for browsing git repositories.
181
182 %description gitweb -l pl.UTF-8
183 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
184
185 %package gitview
186 Summary:        A GTK+ based repository browser for git
187 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
188 Group:          Development/Tools
189 Requires:       %{name} = %{version}-%{release}
190 #Requires:      pytongowe mambo dżambo
191
192 %description gitview
193 A GTK+ based repository browser for git.
194
195 %description gitview -l pl.UTF-8
196 Oparta na GTK+ przeglądarka repozytorium gita.
197
198 %package -n bash-completion-git
199 Summary:        bash-completion for git
200 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
201 Group:          Applications/Shells
202 Requires:       bash-completion
203
204 %description -n bash-completion-git
205 This package provides bash-completion for git.
206
207 %description -n bash-completion-git -l pl.UTF-8
208 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
209
210 %package -n perl-Git
211 Summary:        Perl interface to the Git version control system
212 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
213 Group:          Development/Languages/Perl
214 Requires:       %{name} = %{version}-%{release}
215 Obsoletes:      perl-git-core
216
217 %description -n perl-Git
218 This module provides Perl scripts easy way to interface the Git
219 version control system. The modules have an easy and well-tested way
220 to call arbitrary Git commands; in the future, the interface will also
221 provide specialized methods for doing easily operations which are not
222 totally trivial to do over the generic command interface.
223
224 %description -n perl-Git -l pl.UTF-8
225 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
226 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
227 dowolne polecenia Gita; w przyszłości interfejs udostępni także
228 specjalne metody do łatwego wykonywania operacji nietrywialnych do
229 wykonania przy użyciu ogólnego interfejsu poleceń.
230
231 %package -n vim-syntax-gitcommit
232 Summary:        Vim syntax: gitcommit
233 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
234 Group:          Applications/Editors/Vim
235 # for _vimdatadir existence
236 Requires:       vim >= 4:6.3.058-3
237
238 %description -n vim-syntax-gitcommit
239 This plugin provides syntax highlighting for git's commit messages.
240
241 %description -n vim-syntax-gitcommit -l pl.UTF-8
242 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
243
244 %prep
245 %setup -q -n git-%{version}
246
247 %build
248 %{__aclocal}
249 %{__autoconf}
250 %configure \
251         --with-openssl
252
253 %{__make} \
254         INSTALLDIRS=vendor \
255         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
256         GITWEB_PROJECTROOT="/var/lib/git" \
257         GITWEB_CSS="/gitweb/gitweb.css" \
258         GITWEB_LOGO="/gitweb/git-logo.png" \
259         GITWEB_FAVICON="/gitweb/git-favicon.png"
260
261 %{?with_doc:%{__make} -C Documentation}
262
263 %{?with_tests:%{__make} test}
264
265 %install
266 rm -rf $RPM_BUILD_ROOT
267 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
268 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
269 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
270 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
271 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig/rc-inetd,rc.d/init.d}
272
273 %{__make} install \
274         INSTALLDIRS=vendor \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 %if %{with doc}
278 %{__make} -C Documentation install \
279         DESTDIR=$RPM_BUILD_ROOT
280 %endif
281
282 # header files and lib
283 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
284 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
285 install libgit.a $RPM_BUILD_ROOT%{_libdir}
286
287 # bash completion
288 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
289
290 # vim syntax
291 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
292
293 # gitweb
294 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
295 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
296 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
297 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
298 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
299
300 # gitview
301 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
302
303 # git-daemon related files
304 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/git-daemon
305 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rc-inetd/git-daemon
306 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/git-daemon
307
308 # remove unneeded files
309 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
310 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
311 rm $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
312 rm $RPM_BUILD_ROOT%{_mandir}/man3/private-Error.3*
313
314 %clean
315 rm -rf $RPM_BUILD_ROOT
316
317 %post daemon-inetd
318 %service -q rc-inetd reload
319
320 %postun daemon-inetd
321 if [ "$1" = "0" ]; then
322         %service -q rc-inetd reload
323 fi
324
325 %post daemon-standalone
326 /sbin/chkconfig --add git-daemon
327 %service git-daemon restart "git-daemon"
328
329 %preun daemon-standalone
330 if [ "$1" = "0" ]; then
331         %service git-daemon stop
332         /sbin/chkconfig --del git-daemon
333 fi
334
335 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
336 %webapp_register apache %{webapp}
337
338 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
339 %webapp_unregister apache %{webapp}
340
341 %triggerin gitweb -- apache < 2.2.0, apache-base
342 %webapp_register httpd %{webapp}
343
344 %triggerun gitweb -- apache < 2.2.0, apache-base
345 %webapp_unregister httpd %{webapp}
346
347 %files
348 %defattr(644,root,root,755)
349 %doc README contrib
350 %if %{with doc}
351 %doc Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
352 %{_mandir}/man1/git-*.1*
353 %{_mandir}/man5/gitattributes.5*
354 %{_mandir}/man5/gitignore.5*
355 %{_mandir}/man5/gitmodules.5*
356 %{_mandir}/man7/git.7*
357 %endif
358 %attr(755,root,root) %{_bindir}/git
359 %attr(755,root,root) %{_bindir}/git-*
360 %{_datadir}/%{name}
361 %{_datadir}/git-gui
362 %{_sharedstatedir}/git
363
364 %files daemon-inetd
365 %defattr(644,root,root,755)
366 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
367
368 %files daemon-standalone
369 %defattr(644,root,root,755)
370 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
371 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
372
373 %files devel
374 %defattr(644,root,root,755)
375 %{_includedir}/*
376 %{_libdir}/*.a
377
378 %files gitk
379 %defattr(644,root,root,755)
380 %if %{with doc}
381 %doc Documentation/gitk.html
382 %{_mandir}/man1/gitk.1*
383 %endif
384 %attr(755,root,root) %{_bindir}/gitk
385
386 %files gitweb
387 %defattr(644,root,root,755)
388 %doc gitweb/{README,INSTALL}
389 %dir %{webappdir}
390 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
391 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
392 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
393 %attr(755,root,root) %{cgibindir}/gitweb.cgi
394 %{appdir}
395
396 %files gitview
397 %defattr(644,root,root,755)
398 %doc contrib/gitview/gitview.txt
399 %attr(755,root,root) %{_bindir}/gitview
400
401 %files -n bash-completion-git
402 %defattr(644,root,root,755)
403 %{_sysconfdir}/bash_completion.d/*
404
405 %files -n perl-Git
406 %defattr(644,root,root,755)
407 %{perl_vendorlib}/Git.pm
408 %{_mandir}/man3/Git.3pm*
409
410 %files -n vim-syntax-gitcommit
411 %defattr(644,root,root,755)
412 %doc contrib/vim/README
413 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.07524 seconds and 4 git commands to generate.