]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- pl for new subpackages, sorted VCS support subpackages
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.5.3
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  57b966065882f83ef5879620a1e329ca
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-svn-exit-errors.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-bzr
69 Suggests:       git-core-cvs
70 Suggests:       git-core-hg
71 Suggests:       git-core-p4
72 Suggests:       git-core-svn
73 Suggests:       less
74 Suggests:       rsync
75 Obsoletes:      python-Git
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 # html docs have links to txt files
79 %define         _noautocompressdoc      *.txt
80
81 %define         webapp          gitweb
82 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
83 %define         appdir          %{_datadir}/%{webapp}
84 %define         cgibindir       %{_prefix}/lib/cgi-bin
85 %define         bash_compdir    %{_datadir}/bash-completion/completions
86
87 %description
88 "git" can mean anything, depending on your mood.
89
90 - random three-letter combination that is pronounceable, and not
91   actually used by any common UNIX command. The fact that it is a
92   mispronunciation of "get" may or may not be relevant.
93 - stupid. contemptible and despicable. simple. Take your pick from the
94   dictionary of slang.
95 - "global information tracker": you're in a good mood, and it actually
96   works for you. Angels sing, and a light suddenly fills the room.
97 - "goddamn idiotic truckload of sh*t": when it breaks
98
99 This is a stupid (but extremely fast) directory content manager. It
100 doesn't do a whole lot, but what it 'does' do is track directory
101 contents efficiently.
102
103 %description -l pl.UTF-8
104 "git" może oznaczać cokolwiek, w zależności od nastroju.
105
106 - losową kombinację trzech liter, która jest wymawialna i właściwie
107   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
108   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
109 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
110 - "global information tracker" (narzędzie do globalnego śledzenia
111   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
112   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
113 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
114   g*) - kiedy się zepsuje.
115
116 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
117 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
118 katalogu.
119
120 %package doc
121 Summary:        Documentation for git-core
122 Summary(pl.UTF-8):      Dokumentacja do git-core
123 Group:          Documentation
124
125 %description doc
126 Documentation for git-core.
127
128 %description doc -l pl.UTF-8
129 Dokumentacja do git-core.
130
131 %description doc -l fr.UTF-8
132 Javadoc pour git-core.
133
134 %package daemon-inetd
135 Summary:        Files necessary to run git-daemon as an inetd service
136 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
137 Group:          Networking/Daemons
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       setup >= 2.4.11-1
140 Provides:       git-core-daemon
141 Obsoletes:      git-core-daemon
142 Obsoletes:      git-core-daemon-standalone
143
144 %description daemon-inetd
145 Git-daemon is a really simple TCP git daemon that can serve git
146 repositories. This package provides all necessarry files to run
147 git-daemon as an inetd service.
148
149 %description daemon-inetd -l pl.UTF-8
150 Git-daemon to prosty demon git korzystający z protokołu TCP do
151 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
152 do uruchomienia git-demona w trybie usługi inetd.
153
154 %package daemon-standalone
155 Summary:        Files necessary to run git-daemon as a standalone service
156 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
157 Group:          Networking/Daemons
158 Requires:       %{name} = %{version}-%{release}
159 Provides:       git-core-daemon
160 Obsoletes:      git-core-daemon
161 Obsoletes:      git-core-daemon-inetd
162
163 %description daemon-standalone
164 Git-daemon is a really simple TCP git daemon that can serve git
165 repositories. This package provides all necessarry files to run
166 git-daemon as an standalone service.
167
168 %description daemon-standalone -l pl.UTF-8
169 Git-daemon to prosty demon git korzystający z protokołu TCP do
170 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
171 do uruchomienia git-daemona w trybie usługi samodzielnej.
172
173 %package devel
174 Summary:        Git library with header files
175 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
176 Group:          Development/Libraries
177 Requires:       zlib-devel
178
179 %description devel
180 Git library with header files.
181
182 %description devel -l pl.UTF-8
183 Biblioteka Gita oraz pliki nagłówkowe.
184
185 %package gitk
186 Summary:        Tcl/Tk interface to the Git version control system
187 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
188 Group:          Development/Tools
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       tk
191
192 %description gitk
193 gitk displays changes in a repository or a selected set of commits.
194 This includes visualizing the commit graph, showing information
195 related to each commit, and the files in the trees of each revision.
196
197 Historically, gitk was the first repository browser. It's written in
198 Tcl/Tk and started off in a separate repository but was later merged
199 into the main git repository.
200
201 %description gitk -l pl.UTF-8
202 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
203 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
204 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
205
206 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
207 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
208 osobnym repozytorium, ale z czasem został włączony do głównego
209 repozytorium gita.
210
211 %package gitweb
212 Summary:        Web frontend to git
213 Summary(pl.UTF-8):      Frontend WWW do gita
214 Group:          Development/Tools
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       webapps
217 Requires:       webserver(access)
218 Requires:       webserver(alias)
219 Requires:       webserver(cgi)
220 Suggests:       webserver(setenv)
221
222 %description gitweb
223 This package provides a web interface for browsing git repositories.
224
225 %description gitweb -l pl.UTF-8
226 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
227
228 %package gitview
229 Summary:        A GTK+ based repository browser for git
230 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
231 Group:          Development/Tools
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       python >= 1:2.4
234 Requires:       python-pycairo >= 1.0
235 Requires:       python-pygobject
236 Requires:       python-pygtk-gtk >= 2:2.8
237 Suggests:       python-gnome-desktop-gtksourceview
238
239 %description gitview
240 A GTK+ based repository browser for git.
241
242 %description gitview -l pl.UTF-8
243 Oparta na GTK+ przeglądarka repozytorium gita.
244
245 %package gui
246 Summary:        Tcl/Tk interface to the Git version control system
247 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
248 Group:          Development/Tools
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       tk
251 Requires:       xdg-utils
252 Suggests:       meld
253
254 %description gui
255 Displays changes in a repository or a selected set of commits. This
256 includes visualizing the commit graph, showing information related to
257 each commit, and the files in the trees of each revision.
258
259 Historically, gitk was the first repository browser. It's written in
260 Tcl/Tk and started off in a separate repository but was later merged
261 into the main git repository.
262
263 %description gui -l pl.UTF-8
264 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
265 to wizualizację grafu commitów, wyświetlanie informacji związanych z
266 każdym z commitów oraz listę plików dla każdej rewizji.
267
268 Z punktu widzenia historii, gitk był pierwszą przeglądarką
269 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
270 osobnym repozytorium, ale z czasem został włączony do głównego
271 repozytorium gita.
272
273 %package arch
274 Summary:        Git tools for importing Arch repositories
275 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
276 Group:          Development/Tools
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       tla
279
280 %description arch
281 Git tools for importing Arch repositories.
282
283 %description arch -l pl.UTF-8
284 Narzędzia Gita do importowania repozytoriów Archa.
285
286 %package bzr
287 Summary:        Git tools for working with bzr repositories
288 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
289 Group:          Development/Tools
290 Requires:       %{name} = %{version}-%{release}
291 Requires:       bzr
292
293 %description bzr
294 Git tools for working with bzr repositories.
295
296 %description bzr -l pl.UTF-8
297 Narzędzia Gita do pracy z repozytoriami bzr.
298
299 %package cvs
300 Summary:        CVS support for Git
301 Summary(pl.UTF-8):      Obsługa CVS dla Gita
302 Group:          Development/Tools
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       cvsps >= 2.1-2
305 Requires:       rcs
306
307 %description cvs
308 CVS support for Git.
309
310 %description cvs -l pl.UTF-8
311 Obsługa CVS dla Gita.
312
313 %package hg
314 Summary:        Git tools for working with mercurial repositories
315 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
316 Group:          Development/Tools
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       mercurial >= 1.8
319
320 %description hg
321 Git tools for working with mercurial repositories.
322
323 %description hg -l pl.UTF-8
324 Narzędzia Gita do pracy z repozytoriami mercuriala.
325
326 %package p4
327 Summary:        Git tools for working with Perforce depots
328 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
329 Group:          Development/Tools
330 Requires:       %{name} = %{version}-%{release}
331
332 %description p4
333 Git tools for working with Perforce depots.
334
335 %description p4 -l pl.UTF-8
336 Narzędzia Gita do pracy z magazynami Perforce'a.
337
338 %package svn
339 Summary:        Subversion support for Git
340 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
341 Group:          Development/Tools
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       perl-Encode
344 Requires:       perl-Term-ReadKey
345
346 %description svn
347 Subversion support for Git.
348
349 %description svn -l pl.UTF-8
350 Obsługa Subversion dla Gita.
351
352 %package email
353 Summary:        Git tools for sending email
354 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
355 Group:          Development/Tools
356 Requires:       %{name} = %{version}-%{release}
357
358 %description email
359 Git tools for sending email.
360
361 %description email -l pl.UTF-8
362 Narzędzia Gita do wysyłania poczty.
363
364 %package -n bash-completion-git
365 Summary:        bash-completion for git
366 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
367 Group:          Applications/Shells
368 Requires:       %{name} = %{version}-%{release}
369 Requires:       bash-completion >= 2.0
370
371 %description -n bash-completion-git
372 This package provides bash-completion for git.
373
374 %description -n bash-completion-git -l pl.UTF-8
375 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
376
377 %package -n perl-Git
378 Summary:        Perl interface to the Git version control system
379 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
380 Group:          Development/Languages/Perl
381 Obsoletes:      perl-git-core
382
383 %description -n perl-Git
384 This module provides Perl scripts easy way to interface the Git
385 version control system. The modules have an easy and well-tested way
386 to call arbitrary Git commands; in the future, the interface will also
387 provide specialized methods for doing easily operations which are not
388 totally trivial to do over the generic command interface.
389
390 %description -n perl-Git -l pl.UTF-8
391 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
392 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
393 dowolne polecenia Gita; w przyszłości interfejs udostępni także
394 specjalne metody do łatwego wykonywania operacji nietrywialnych do
395 wykonania przy użyciu ogólnego interfejsu poleceń.
396
397 %package -n vim-syntax-gitcommit
398 Summary:        Vim syntax: gitcommit
399 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
400 Group:          Applications/Editors/Vim
401 Requires:       %{name} = %{version}-%{release}
402 # for _vimdatadir existence
403 Requires:       vim-rt >= 4:6.3.058-3
404
405 %description -n vim-syntax-gitcommit
406 This plugin provides syntax highlighting for git's commit messages.
407
408 %description -n vim-syntax-gitcommit -l pl.UTF-8
409 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
410
411 %prep
412 %setup -q -n git-%{version}
413 %patch0 -p1
414 %patch1 -p0
415 %patch2 -p1
416 %patch3 -p1
417 %patch4 -p1
418
419 %build
420 %{__aclocal}
421 %{__autoconf}
422 %configure \
423         --sysconfdir=%{_sysconfdir}/git-core \
424         %{?with_pcre:--with-libpcre} \
425         --with-openssl
426
427 echo "BLK_SHA1=1" >> config.mak
428
429 %{__make} \
430         INSTALLDIRS=vendor \
431         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
432         GITWEB_PROJECTROOT="/var/lib/git" \
433         GITWEB_CSS="/gitweb/gitweb.css" \
434         GITWEB_LOGO="/gitweb/git-logo.png" \
435         GITWEB_FAVICON="/gitweb/git-favicon.png" \
436         V=1
437
438 %if %{with doc}
439 %{__make} -C Documentation \
440         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
441         V=1
442 %endif
443
444 %if %{with tests}
445 %if %{without tests_cvs}
446 %{__rm} t/t*cvs*.sh || :
447 %endif
448 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
449 %endif
450
451 %install
452 rm -rf $RPM_BUILD_ROOT
453 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
454 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
455 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
456 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
457 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
458 [init]
459         templatedir = %{_sysconfdir}/%{name}/templates
460 EOF
461
462 %{__make} install \
463         INSTALLDIRS=vendor \
464         DESTDIR=$RPM_BUILD_ROOT
465
466 %if %{with doc}
467 %{__make} -C Documentation install \
468         DESTDIR=$RPM_BUILD_ROOT
469 %endif
470
471 # copy templates except sample hooks
472 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
473 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
474
475 # header files and lib
476 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
477 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
478 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
479 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
480 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
481 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
482 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
483 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
484
485 # bash completion
486 install -d $RPM_BUILD_ROOT%{bash_compdir}
487 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
488
489 # Install bzr and hg remote helpers from contrib
490 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
491
492 # vim syntax
493 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
494 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
495 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
496 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
497 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
498 autocmd BufNewFile,BufRead .msg.[0-9]*
499         \ if getline(1) =~ '^From.*# This line is ignored.$' |
500         \   setf gitsendemail |
501         \ endif
502 autocmd BufNewFile,BufRead *.git/**
503         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
504         \   setf git |
505         \ endif
506 EOF
507
508 # gitweb
509 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
510 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
511 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
512 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
513 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
514 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
515
516 # gitview
517 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
518
519 # git-daemon related files
520 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
521 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
522 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
523
524 # paths cleanup
525 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
526 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
527
528 # hardlink
529 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
530 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
531 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
532 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
533
534 # remove unneeded files
535 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
536 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
537 %py_postclean
538
539 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
540 %find_lang git
541
542 %clean
543 rm -rf $RPM_BUILD_ROOT
544
545 %post daemon-inetd
546 %service -q rc-inetd reload
547
548 %postun daemon-inetd
549 if [ "$1" = "0" ]; then
550         %service -q rc-inetd reload
551 fi
552
553 %post daemon-standalone
554 /sbin/chkconfig --add git-daemon
555 %service git-daemon restart "git-daemon"
556
557 %preun daemon-standalone
558 if [ "$1" = "0" ]; then
559         %service git-daemon stop
560         /sbin/chkconfig --del git-daemon
561 fi
562
563 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
564 %webapp_register apache %{webapp}
565
566 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
567 %webapp_unregister apache %{webapp}
568
569 %triggerin gitweb -- apache < 2.2.0, apache-base
570 %webapp_register httpd %{webapp}
571
572 %triggerun gitweb -- apache < 2.2.0, apache-base
573 %webapp_unregister httpd %{webapp}
574
575 %triggerin gitweb -- lighttpd
576 %webapp_register lighttpd %{webapp}
577
578 %triggerun gitweb -- lighttpd
579 %webapp_unregister lighttpd %{webapp}
580
581 %files -f git.lang
582 %defattr(644,root,root,755)
583 %doc README contrib
584 %attr(755,root,root) %{_bindir}/git
585 %attr(755,root,root) %{_bindir}/git-receive-pack
586 %attr(755,root,root) %{_bindir}/git-shell
587 %attr(755,root,root) %{_bindir}/git-upload-archive
588 %attr(755,root,root) %{_bindir}/git-upload-pack
589 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
590
591 %if %{with doc}
592 %{_mandir}/man1/git-*.1*
593 %exclude %{_mandir}/man1/git-archimport.1*
594 %exclude %{_mandir}/man1/git-svn.1*
595 %exclude %{_mandir}/man1/git-cvs*.1*
596 %exclude %{_mandir}/man1/git-imap-send*.1*
597 %exclude %{_mandir}/man1/*email*.1*
598 %{_mandir}/man1/git.1*
599 %{_mandir}/man1/gitremote-helpers.1*
600 %{_mandir}/man5/gitattributes.5*
601 %{_mandir}/man5/githooks.5*
602 %{_mandir}/man5/gitignore.5*
603 %{_mandir}/man5/gitmodules.5*
604 %{_mandir}/man5/gitrepository-layout.5*
605 %{_mandir}/man7/gitcli.7*
606 %{_mandir}/man7/gitcore-tutorial.7*
607 %{_mandir}/man7/gitcredentials.7*
608 %{_mandir}/man7/gitdiffcore.7*
609 %{_mandir}/man7/gitglossary.7*
610 %{_mandir}/man7/gitnamespaces.7*
611 %{_mandir}/man7/gitrevisions.7*
612 %{_mandir}/man7/gittutorial-2.7*
613 %{_mandir}/man7/gittutorial.7*
614 %{_mandir}/man7/gitworkflows.7*
615 %endif
616
617 %dir %{_libdir}/%{name}
618 %attr(755,root,root) %{_libdir}/%{name}/*-*
619 %attr(755,root,root) %{_libdir}/%{name}/git
620 %dir %{_libdir}/%{name}/mergetools
621 %{_libdir}/%{name}/mergetools/*
622
623 %{_datadir}/%{name}
624 %{_localstatedir}/lib/git
625
626 # subpackages
627 %exclude %{_libdir}/%{name}/*email*
628 %exclude %{_libdir}/%{name}/*p4*
629 %exclude %{_libdir}/%{name}/git-archimport
630 %exclude %{_libdir}/%{name}/git-cvs*
631 %exclude %{_libdir}/%{name}/git-gui
632 %exclude %{_libdir}/%{name}/git-imap-send
633 %exclude %{_libdir}/%{name}/git-instaweb
634 %exclude %{_libdir}/%{name}/git-remote-bzr
635 %exclude %{_libdir}/%{name}/git-remote-hg
636 %exclude %{_libdir}/%{name}/git-remote-testsvn
637 %exclude %{_libdir}/%{name}/git-svn
638 %exclude %{_libdir}/%{name}/mergetools/p4merge
639
640 %if %{with doc}
641 %files doc
642 %defattr(644,root,root,755)
643 %doc Documentation/RelNotes*
644 %doc Documentation/*.html Documentation/howto Documentation/technical
645 %endif
646
647 %files daemon-inetd
648 %defattr(644,root,root,755)
649 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
650
651 %files daemon-standalone
652 %defattr(644,root,root,755)
653 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
654 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
655
656 %files devel
657 %defattr(644,root,root,755)
658 %{_includedir}/%{name}
659 %{_libdir}/libgit.a
660 %{_libdir}/libgit_xdiff.a
661
662 %files gitk
663 %defattr(644,root,root,755)
664 %if %{with doc}
665 %{_mandir}/man1/gitk.1*
666 %endif
667 %attr(755,root,root) %{_bindir}/gitk
668 %dir %{_datadir}/gitk
669 %dir %{_datadir}/gitk/lib
670 %dir %{_datadir}/gitk/lib/msgs
671 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
672 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
673 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
674 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
675 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
676 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
677 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
678 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
679 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
680
681 %files gitweb
682 %defattr(644,root,root,755)
683 %doc gitweb/{README,INSTALL}
684 %dir %{webappdir}
685 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
686 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
687 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
688 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
689 %attr(755,root,root) %{cgibindir}/gitweb.cgi
690 %{appdir}
691 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
692 %if %{with doc}
693 %{_mandir}/man1/gitweb.1*
694 %{_mandir}/man5/gitweb.conf.5*
695 %endif
696
697 %files gitview
698 %defattr(644,root,root,755)
699 %doc contrib/gitview/gitview.txt
700 %attr(755,root,root) %{_bindir}/gitview
701
702 %files gui
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/%{name}/git-gui
705 %dir %{_datadir}/git-gui
706 %dir %{_datadir}/git-gui/lib
707 %dir %{_datadir}/git-gui/lib/msgs
708 %{_datadir}/git-gui/lib/git-gui.ico
709 %{_datadir}/git-gui/lib/tclIndex
710 %{_datadir}/git-gui/lib/*.js
711 %{_datadir}/git-gui/lib/*.tcl
712 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
713 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
714 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
715 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
716 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
717 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
718 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
719 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
720 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
721 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
722 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
723
724 %files arch
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
727 %if %{with doc}
728 %{_mandir}/man1/git-archimport.1*
729 %endif
730
731 %files bzr
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
734
735 %files cvs
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_bindir}/git-cvsserver
738 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
739 %if %{with doc}
740 %{_mandir}/man1/git-cvs*.1*
741 %{_mandir}/man7/gitcvs-migration.7*
742 %endif
743
744 %files hg
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
747
748 %files p4
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/%{name}/git-p4
751 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
752
753 %files svn
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/%{name}/git-svn
756 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
757 %{perl_vendorlib}/Git/SVN
758 %{perl_vendorlib}/Git/SVN.pm
759 %if %{with doc}
760 %{_mandir}/man1/git-svn.1*
761 %endif
762
763 %files email
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
766 %attr(755,root,root) %{_libdir}/%{name}/*email*
767 %if %{with doc}
768 %{_mandir}/man1/*email*.1*
769 %{_mandir}/man1/*imap-send*.1*
770 %endif
771
772 %files -n bash-completion-git
773 %defattr(644,root,root,755)
774 %{bash_compdir}/git
775
776 %files -n perl-Git
777 %defattr(644,root,root,755)
778 %{perl_vendorlib}/Git.pm
779 %dir %{perl_vendorlib}/Git
780 %{perl_vendorlib}/Git/I18N.pm
781 %{perl_vendorlib}/Git/IndexInfo.pm
782 %{_mandir}/man3/Git*.3pm*
783
784 %files -n vim-syntax-gitcommit
785 %defattr(644,root,root,755)
786 %doc contrib/vim/README
787 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.232219 seconds and 4 git commands to generate.