]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- -arch, -email subpackages
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.6.5.2
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  99708c449b23433136dbdfa38bd16d80
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 URL:            http://git-scm.com/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  curl-devel
26 BuildRequires:  docbook-dtd45-xml
27 BuildRequires:  expat-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  perl-Error
31 BuildRequires:  perl-base
32 BuildRequires:  python
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  rpmbuild(macros) >= 1.264
35 BuildRequires:  zlib-devel
36 %if %{with doc}
37 BuildRequires:  asciidoc >= 7.1.2-3
38 BuildRequires:  xmlto
39 %endif
40 %if %{with tests}
41 %if %{with tests_cvs}
42 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
43 BuildRequires:  cvs-gnu-client < 1.13
44 BuildRequires:  cvs-gnu-client >= 1.12
45 %endif
46 BuildRequires:  pdksh >= 5.2.14-46
47 %endif
48 Requires:       coreutils
49 Requires:       diffutils
50 Requires:       findutils
51 Requires:       grep
52 Requires:       openssh-clients
53 Requires:       perl-Error
54 Requires:       sed
55 Suggests:       git-core-cvs
56 Suggests:       git-core-svn
57 Suggests:       less
58 Suggests:       rsync
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # html docs have links to txt files
62 %define         _noautocompressdoc      *.txt
63
64 %define         webapp          gitweb
65 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
66 %define         appdir          %{_datadir}/%{webapp}
67 %define         cgibindir       %{_prefix}/lib/cgi-bin
68
69 %description
70 "git" can mean anything, depending on your mood.
71
72  - random three-letter combination that is pronounceable, and not
73    actually used by any common UNIX command. The fact that it is a
74    mispronunciation of "get" may or may not be relevant.
75  - stupid. contemptible and despicable. simple. Take your pick from the
76    dictionary of slang.
77  - "global information tracker": you're in a good mood, and it actually
78    works for you. Angels sing, and a light suddenly fills the room.
79  - "goddamn idiotic truckload of sh*t": when it breaks
80
81 This is a stupid (but extremely fast) directory content manager. It
82 doesn't do a whole lot, but what it 'does' do is track directory
83 contents efficiently.
84
85 %description -l pl.UTF-8
86 "git" może oznaczać cokolwiek, w zależności od nastroju.
87
88  - losową kombinację trzech liter, która jest wymawialna i właściwie
89    nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
90    błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
91  - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
92  - "global information tracker" (narzędzie do globalnego śledzenia
93    informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
94    Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
95  - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
96    g*) - kiedy się zepsuje.
97
98 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
99 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
100 katalogu.
101
102 %package daemon-inetd
103 Summary:        Files necessary to run git-daemon as an inetd service
104 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
105 Group:          Networking/Daemons
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       setup >= 2.4.11-1
108 Provides:       git-core-daemon
109 Obsoletes:      git-core-daemon
110 Obsoletes:      git-core-daemon-standalone
111
112 %description daemon-inetd
113 Git-daemon is a really simple TCP git daemon that can serve git
114 repositories. This package provides all necessarry files to run
115 git-daemon as an inetd service.
116
117 %description daemon-inetd -l pl.UTF-8
118 Git-daemon to prosty demon git korzystający z protokołu TCP do
119 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
120 do uruchomienia git-demona w trybie usługi inetd.
121
122 %package daemon-standalone
123 Summary:        Files necessary to run git-daemon as a standalone service
124 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
125 Group:          Networking/Daemons
126 Requires:       %{name} = %{version}-%{release}
127 Provides:       git-core-daemon
128 Obsoletes:      git-core-daemon
129 Obsoletes:      git-core-daemon-inetd
130
131 %description daemon-standalone
132 Git-daemon is a really simple TCP git daemon that can serve git
133 repositories. This package provides all necessarry files to run
134 git-daemon as an standalone service.
135
136 %description daemon-standalone -l pl.UTF-8
137 Git-daemon to prosty demon git korzystający z protokołu TCP do
138 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
139 do uruchomienia git-daemona w trybie usługi samodzielnej.
140
141 %package devel
142 Summary:        Header files for git-core
143 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
144 Group:          Development/Libraries
145
146 %description devel
147 Header files for git-core.
148
149 %description devel -l pl.UTF-8
150 Pliki nagłówkowe dla git-core.
151
152 %package gitk
153 Summary:        Tcl/Tk interface to the Git version control system
154 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
155 Group:          Development/Tools
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       tk
158
159 %description gitk
160 gitk displays changes in a repository or a selected set of commits.
161 This includes visualizing the commit graph, showing information
162 related to each commit, and the files in the trees of each revision.
163
164 Historically, gitk was the first repository browser. It's written in
165 Tcl/Tk and started off in a separate repository but was later merged
166 into the main git repository.
167
168 %description gitk -l pl.UTF-8
169 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
170 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
171 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
172
173 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
174 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
175 osobnym repozytorium, ale z czasem został włączony do głównego
176 repozytorium gita.
177
178 %package gitweb
179 Summary:        Web frontend to git
180 Summary(pl.UTF-8):      Webowy frontend do git
181 Group:          Development/Tools
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       webapps
184
185 %description gitweb
186 This package provides a web interface for browsing git repositories.
187
188 %description gitweb -l pl.UTF-8
189 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
190
191 %package gitview
192 Summary:        A GTK+ based repository browser for git
193 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
194 Group:          Development/Tools
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       python >= 1:2.4
197 Requires:       python-pycairo >= 1.0
198 Requires:       python-pygobject
199 Requires:       python-pygtk-gtk >= 2:2.8
200 Suggests:       python-gnome-desktop-gtksourceview
201
202 %description gitview
203 A GTK+ based repository browser for git.
204
205 %description gitview -l pl.UTF-8
206 Oparta na GTK+ przeglądarka repozytorium gita.
207
208 %package gui
209 Summary:        Tcl/Tk interface to the Git version control system
210 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       tk
214
215 %description gui
216 Displays changes in a repository or a selected set of commits. This
217 includes visualizing the commit graph, showing information related to
218 each commit, and the files in the trees of each revision.
219
220 Historically, gitk was the first repository browser. It's written in
221 Tcl/Tk and started off in a separate repository but was later merged
222 into the main git repository.
223
224 %description gui -l pl.UTF-8
225 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
226 to wizualizację grafu commitów, wyświetlanie informacji związanych z
227 każdym z commitów oraz listę plików dla każdej rewizji.
228
229 Z punktu widzenia historii, gitk był pierwszą przeglądarką
230 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
231 osobnym repozytorium, ale z czasem został włączony do głównego
232 repozytorium gita.
233
234 %package svn
235 Summary:        Subversion support for Git
236 Summary(pl.UTF-8):      Obsługa Subversion dla Git
237 Group:          Development/Tools
238 Requires:       %{name} = %{version}-%{release}
239
240 %description svn
241 Subversion support for Git.
242
243 %description svn -l pl.UTF-8
244 Obsługa Subversion dla Git.
245
246 %package cvs
247 Summary:        CVS support for Git
248 Summary(pl.UTF-8):      Obsługa CVS dla Git
249 Group:          Development/Tools
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       cvsps >= 2.1-2
252 Requires:       rcs
253
254 %description cvs
255 CVS support for Git.
256
257 %description cvs -l pl.UTF-8
258 Obsługa CVS dla Git.
259
260 %package arch
261 Summary:        Git tools for importing Arch repositories
262 Group:          Development/Tools
263 Requires:       %{name} = %{version}-%{release}
264 Requires:       tla
265
266 %description arch
267 Git tools for importing Arch repositories.
268
269 %package email
270 Summary:        Git tools for sending email
271 Group:          Development/Tools
272 Requires:       %{name} = %{version}-%{release}
273
274 %description email
275 Git tools for sending email.
276
277 %package -n bash-completion-git
278 Summary:        bash-completion for git
279 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
280 Group:          Applications/Shells
281 Requires:       bash-completion
282
283 %description -n bash-completion-git
284 This package provides bash-completion for git.
285
286 %description -n bash-completion-git -l pl.UTF-8
287 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
288
289 %package -n perl-Git
290 Summary:        Perl interface to the Git version control system
291 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
292 Group:          Development/Languages/Perl
293 Requires:       %{name} = %{version}-%{release}
294 Obsoletes:      perl-git-core
295
296 %description -n perl-Git
297 This module provides Perl scripts easy way to interface the Git
298 version control system. The modules have an easy and well-tested way
299 to call arbitrary Git commands; in the future, the interface will also
300 provide specialized methods for doing easily operations which are not
301 totally trivial to do over the generic command interface.
302
303 %description -n perl-Git -l pl.UTF-8
304 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
305 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
306 dowolne polecenia Gita; w przyszłości interfejs udostępni także
307 specjalne metody do łatwego wykonywania operacji nietrywialnych do
308 wykonania przy użyciu ogólnego interfejsu poleceń.
309
310 %package -n vim-syntax-gitcommit
311 Summary:        Vim syntax: gitcommit
312 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
313 Group:          Applications/Editors/Vim
314 # for _vimdatadir existence
315 Requires:       vim-rt >= 4:6.3.058-3
316
317 %description -n vim-syntax-gitcommit
318 This plugin provides syntax highlighting for git's commit messages.
319
320 %description -n vim-syntax-gitcommit -l pl.UTF-8
321 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
322
323 %prep
324 %setup -q -n git-%{version}
325
326 %build
327 %{__aclocal}
328 %{__autoconf}
329 %configure \
330         --with-openssl
331
332 %{__make} \
333         BLK_SHA1=1 \
334         INSTALLDIRS=vendor \
335         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
336         GITWEB_PROJECTROOT="/var/lib/git" \
337         GITWEB_CSS="/gitweb/gitweb.css" \
338         GITWEB_LOGO="/gitweb/git-logo.png" \
339         GITWEB_FAVICON="/gitweb/git-favicon.png"
340
341 %{?with_doc:%{__make} -C Documentation}
342
343 %if %{with tests}
344 %if %{without tests_cvs}
345 rm t/t*cvs*.sh
346 %endif
347 %{__make} test
348 %endif
349
350 %install
351 rm -rf $RPM_BUILD_ROOT
352 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
353 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
354 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
355
356 %{__make} install \
357         INSTALLDIRS=vendor \
358         DESTDIR=$RPM_BUILD_ROOT
359
360 %if %{with doc}
361 %{__make} -C Documentation install \
362         DESTDIR=$RPM_BUILD_ROOT
363 %endif
364
365 # header files and lib
366 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
367 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
368 install libgit.a $RPM_BUILD_ROOT%{_libdir}
369 install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
370
371 # bash completion
372 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
373 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
374
375 # vim syntax
376 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
377 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
378 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
379 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
380 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
381 autocmd BufNewFile,BufRead .msg.[0-9]*
382         \ if getline(1) =~ '^From.*# This line is ignored.$' |
383         \   setf gitsendemail |
384         \ endif
385 autocmd BufNewFile,BufRead *.git/**
386         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
387         \   setf git |
388         \ endif
389 EOF
390
391 # gitweb
392 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
393 cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
394 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
395 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
396 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
397
398 # gitview
399 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
400
401 # git-daemon related files
402 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
403 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
404 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
405
406 # paths cleanup
407 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
408 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
409
410 # remove unneeded files
411 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
412 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
413 rm $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
414 rm $RPM_BUILD_ROOT%{_mandir}/man3/private-Error.3*
415
416 %clean
417 rm -rf $RPM_BUILD_ROOT
418
419 %post daemon-inetd
420 %service -q rc-inetd reload
421
422 %postun daemon-inetd
423 if [ "$1" = "0" ]; then
424         %service -q rc-inetd reload
425 fi
426
427 %post daemon-standalone
428 /sbin/chkconfig --add git-daemon
429 %service git-daemon restart "git-daemon"
430
431 %preun daemon-standalone
432 if [ "$1" = "0" ]; then
433         %service git-daemon stop
434         /sbin/chkconfig --del git-daemon
435 fi
436
437 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
438 %webapp_register apache %{webapp}
439
440 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
441 %webapp_unregister apache %{webapp}
442
443 %triggerin gitweb -- apache < 2.2.0, apache-base
444 %webapp_register httpd %{webapp}
445
446 %triggerun gitweb -- apache < 2.2.0, apache-base
447 %webapp_unregister httpd %{webapp}
448
449 %files
450 %defattr(644,root,root,755)
451 %doc README contrib
452 %if %{with doc}
453 %doc Documentation/RelNotes*
454 %doc Documentation/*.html Documentation/howto Documentation/technical
455 %{_mandir}/man1/git-*.1*
456 %if 0
457 # rpm doesn't support exclude for %%doc
458 %exclude Documentation/*svn*.html
459 %exclude Documentation/*git-cvs*.html
460 %exclude Documentation/git-archimport.html
461 %endif
462 %exclude %{_mandir}/man1/git-svn.1*
463 %exclude %{_mandir}/man1/git-cvs*.1*
464 %{_mandir}/man1/git.1*
465 %{_mandir}/man5/gitattributes.5*
466 %{_mandir}/man5/githooks.5*
467 %{_mandir}/man5/gitignore.5*
468 %{_mandir}/man5/gitmodules.5*
469 %{_mandir}/man5/gitrepository-layout.5*
470 %{_mandir}/man7/gitcli.7*
471 %{_mandir}/man7/gitcore-tutorial.7*
472 %{_mandir}/man7/gitdiffcore.7*
473 %{_mandir}/man7/gitglossary.7*
474 %{_mandir}/man7/gittutorial-2.7*
475 %{_mandir}/man7/gittutorial.7*
476 %{_mandir}/man7/gitworkflows.7*
477 %endif
478 %attr(755,root,root) %{_bindir}/git
479 %attr(755,root,root) %{_bindir}/git-*
480 %dir %{_libdir}/%{name}
481 %attr(755,root,root) %{_libdir}/%{name}/*-*
482 %attr(755,root,root) %{_libdir}/%{name}/git
483 %exclude %{_libdir}/%{name}/git-gui
484 %exclude %{_libdir}/%{name}/git-svn
485 %exclude %{_libdir}/%{name}/git-archimport
486 %exclude %{_libdir}/%{name}/git-cvs*
487 %exclude %{_libdir}/%{name}/*email*
488 %{_datadir}/%{name}
489 %{_localstatedir}/lib/git
490
491 %files daemon-inetd
492 %defattr(644,root,root,755)
493 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
494
495 %files daemon-standalone
496 %defattr(644,root,root,755)
497 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
498 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
499
500 %files devel
501 %defattr(644,root,root,755)
502 %{_includedir}/git-core
503 %{_libdir}/libgit.a
504 %{_libdir}/libgit_xdiff.a
505
506 %files gitk
507 %defattr(644,root,root,755)
508 %if %{with doc}
509 %{_mandir}/man1/gitk.1*
510 %endif
511 %attr(755,root,root) %{_bindir}/gitk
512 %dir %{_datadir}/gitk
513 %dir %{_datadir}/gitk/lib
514 %dir %{_datadir}/gitk/lib/msgs
515 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
516 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
517 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
518 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
519 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
520
521 %files gitweb
522 %defattr(644,root,root,755)
523 %doc gitweb/{README,INSTALL}
524 %dir %{webappdir}
525 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
526 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
527 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
528 %attr(755,root,root) %{cgibindir}/gitweb.cgi
529 %{appdir}
530
531 %files gitview
532 %defattr(644,root,root,755)
533 %doc contrib/gitview/gitview.txt
534 %attr(755,root,root) %{_bindir}/gitview
535
536 %files gui
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/%{name}/git-gui
539 %dir %{_datadir}/git-gui
540 %dir %{_datadir}/git-gui/lib
541 %dir %{_datadir}/git-gui/lib/msgs
542 %{_datadir}/git-gui/lib/git-gui.ico
543 %{_datadir}/git-gui/lib/tclIndex
544 %{_datadir}/git-gui/lib/*.js
545 %{_datadir}/git-gui/lib/*.tcl
546 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
547 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
548 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
549 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
550 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
551 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
552 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
553 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
554 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
555
556 %files svn
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/%{name}/git-svn
559 %if %{with doc}
560 %{_mandir}/man1/git-svn.1*
561 %doc Documentation/*svn*.html
562 %endif
563
564 %files cvs
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
567 %if %{with doc}
568 %doc Documentation/*git-cvs*.html
569 %{_mandir}/man1/git-cvs*.1*
570 %{_mandir}/man7/gitcvs-migration.7*
571 %endif
572
573 %files arch
574 %defattr(644,root,root,755)
575 %doc Documentation/git-archimport.txt
576 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
577 %if %{with doc}
578 %doc Documentation/git-archimport.html
579 %{_mandir}/man1/git-archimport.1*
580 %endif
581
582 %files email
583 %defattr(644,root,root,755)
584 %doc Documentation/*email*.txt
585 %attr(755,root,root) %{_libdir}/%{name}/*email*
586 %if %{with doc}
587 %doc Documentation/*email*.html
588 %{_mandir}/man1/*email*.1*
589 %endif
590
591 %files -n bash-completion-git
592 %defattr(644,root,root,755)
593 %{_sysconfdir}/bash_completion.d/*
594
595 %files -n perl-Git
596 %defattr(644,root,root,755)
597 %{perl_vendorlib}/Git.pm
598 %{_mandir}/man3/Git.3pm*
599
600 %files -n vim-syntax-gitcommit
601 %defattr(644,root,root,755)
602 %doc contrib/vim/README
603 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.102331 seconds and 4 git commands to generate.