]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
updated to 1.8.5.rc3
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %define _rc  rc1
10
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        Distributed version control system focused on speed, effectivity and usability
13 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
14 Name:           git-core
15 Version:        1.8.5
16 Release:        0.%{_rc}.3
17 License:        GPL v2
18 Group:          Development/Tools
19 Source0:        http://git-core.googlecode.com/files/git-%{version}.%{_rc}.tar.gz
20 # Source0-md5:  093264675071f17623bc315481fe96fd
21 Source1:        %{name}-gitweb.conf
22 Source2:        %{name}-gitweb-httpd.conf
23 Source3:        %{name}-gitweb-lighttpd.conf
24 Source4:        %{name}.sysconfig
25 Source5:        %{name}.inet
26 Source6:        %{name}.init
27 Patch0:         %{name}-tests.patch
28 Patch1:         %{name}-key-bindings.patch
29 Patch2:         %{name}-sysconfdir.patch
30 Patch3:         cherry-picked-commitlog.patch
31 Patch4:         %{name}-svn-exit-errors.patch
32 URL:            http://git-scm.com/
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake
35 BuildRequires:  curl-devel
36 BuildRequires:  expat-devel
37 BuildRequires:  gettext-devel
38 BuildRequires:  openssl-devel
39 %{?with_pcre:BuildRequires:     pcre-devel}
40 BuildRequires:  perl-Error > 0.15
41 BuildRequires:  perl-base
42 BuildRequires:  python-devel
43 BuildRequires:  rpm-perlprov >= 4.1-13
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.264
46 BuildRequires:  tcl
47 BuildRequires:  zlib-devel
48 %if %{with doc}
49 BuildRequires:  asciidoc >= 7.1.2-3
50 BuildRequires:  docbook-dtd45-xml
51 BuildRequires:  xmlto
52 %endif
53 %if %{with tests}
54 %if %{with tests_cvs}
55 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
56 BuildRequires:  cvs-gnu-client < 1.13
57 BuildRequires:  cvs-gnu-client >= 1.12
58 %endif
59 %{?with_tests_svn:BuildRequires:  subversion}
60 Conflicts:      pdksh < 5.2.14-46
61 %endif
62 Requires:       coreutils
63 Requires:       diffutils
64 Requires:       findutils
65 Requires:       grep
66 Requires:       openssh-clients
67 Requires:       perl-Error
68 Requires:       perl-Git = %{version}-%{release}
69 Requires:       sed
70 Suggests:       git-core-cvs
71 Suggests:       git-core-svn
72 Suggests:       less
73 Suggests:       rsync
74 Obsoletes:      python-Git
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 # html docs have links to txt files
78 %define         _noautocompressdoc      *.txt
79
80 %define         webapp          gitweb
81 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
82 %define         appdir          %{_datadir}/%{webapp}
83 %define         cgibindir       %{_prefix}/lib/cgi-bin
84 %define         bash_compdir    %{_datadir}/bash-completion/completions
85
86 %description
87 "git" can mean anything, depending on your mood.
88
89 - random three-letter combination that is pronounceable, and not
90   actually used by any common UNIX command. The fact that it is a
91   mispronunciation of "get" may or may not be relevant.
92 - stupid. contemptible and despicable. simple. Take your pick from the
93   dictionary of slang.
94 - "global information tracker": you're in a good mood, and it actually
95   works for you. Angels sing, and a light suddenly fills the room.
96 - "goddamn idiotic truckload of sh*t": when it breaks
97
98 This is a stupid (but extremely fast) directory content manager. It
99 doesn't do a whole lot, but what it 'does' do is track directory
100 contents efficiently.
101
102 %description -l pl.UTF-8
103 "git" może oznaczać cokolwiek, w zależności od nastroju.
104
105 - losową kombinację trzech liter, która jest wymawialna i właściwie
106   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
107   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
108 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
109 - "global information tracker" (narzędzie do globalnego śledzenia
110   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
111   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
112 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
113   g*) - kiedy się zepsuje.
114
115 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
116 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
117 katalogu.
118
119 %package doc
120 Summary:        Documentation for git-core
121 Summary(pl.UTF-8):      Dokumentacja do git-core
122 Group:          Documentation
123
124 %description doc
125 Documentation for git-core.
126
127 %description doc -l pl.UTF-8
128 Dokumentacja do git-core.
129
130 %description doc -l fr.UTF-8
131 Javadoc pour git-core.
132
133 %package daemon-inetd
134 Summary:        Files necessary to run git-daemon as an inetd service
135 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
136 Group:          Networking/Daemons
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       setup >= 2.4.11-1
139 Provides:       git-core-daemon
140 Obsoletes:      git-core-daemon
141 Obsoletes:      git-core-daemon-standalone
142
143 %description daemon-inetd
144 Git-daemon is a really simple TCP git daemon that can serve git
145 repositories. This package provides all necessarry files to run
146 git-daemon as an inetd service.
147
148 %description daemon-inetd -l pl.UTF-8
149 Git-daemon to prosty demon git korzystający z protokołu TCP do
150 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
151 do uruchomienia git-demona w trybie usługi inetd.
152
153 %package daemon-standalone
154 Summary:        Files necessary to run git-daemon as a standalone service
155 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
156 Group:          Networking/Daemons
157 Requires:       %{name} = %{version}-%{release}
158 Provides:       git-core-daemon
159 Obsoletes:      git-core-daemon
160 Obsoletes:      git-core-daemon-inetd
161
162 %description daemon-standalone
163 Git-daemon is a really simple TCP git daemon that can serve git
164 repositories. This package provides all necessarry files to run
165 git-daemon as an standalone service.
166
167 %description daemon-standalone -l pl.UTF-8
168 Git-daemon to prosty demon git korzystający z protokołu TCP do
169 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
170 do uruchomienia git-daemona w trybie usługi samodzielnej.
171
172 %package devel
173 Summary:        Git library with header files
174 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
175 Group:          Development/Libraries
176 Requires:       zlib-devel
177
178 %description devel
179 Git library with header files.
180
181 %description devel -l pl.UTF-8
182 Biblioteka Gita oraz pliki nagłówkowe.
183
184 %package gitk
185 Summary:        Tcl/Tk interface to the Git version control system
186 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
187 Group:          Development/Tools
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       tk
190
191 %description gitk
192 gitk displays changes in a repository or a selected set of commits.
193 This includes visualizing the commit graph, showing information
194 related to each commit, and the files in the trees of each revision.
195
196 Historically, gitk was the first repository browser. It's written in
197 Tcl/Tk and started off in a separate repository but was later merged
198 into the main git repository.
199
200 %description gitk -l pl.UTF-8
201 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
202 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
203 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
204
205 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
206 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
207 osobnym repozytorium, ale z czasem został włączony do głównego
208 repozytorium gita.
209
210 %package gitweb
211 Summary:        Web frontend to git
212 Summary(pl.UTF-8):      Frontend WWW do gita
213 Group:          Development/Tools
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       webapps
216 Requires:       webserver(access)
217 Requires:       webserver(alias)
218 Requires:       webserver(cgi)
219 Suggests:       webserver(setenv)
220
221 %description gitweb
222 This package provides a web interface for browsing git repositories.
223
224 %description gitweb -l pl.UTF-8
225 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
226
227 %package gitview
228 Summary:        A GTK+ based repository browser for git
229 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
230 Group:          Development/Tools
231 Requires:       %{name} = %{version}-%{release}
232 Requires:       python >= 1:2.4
233 Requires:       python-pycairo >= 1.0
234 Requires:       python-pygobject
235 Requires:       python-pygtk-gtk >= 2:2.8
236 Suggests:       python-gnome-desktop-gtksourceview
237
238 %description gitview
239 A GTK+ based repository browser for git.
240
241 %description gitview -l pl.UTF-8
242 Oparta na GTK+ przeglądarka repozytorium gita.
243
244 %package gui
245 Summary:        Tcl/Tk interface to the Git version control system
246 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
247 Group:          Development/Tools
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       tk
250 Requires:       xdg-utils
251 Suggests:       meld
252
253 %description gui
254 Displays changes in a repository or a selected set of commits. This
255 includes visualizing the commit graph, showing information related to
256 each commit, and the files in the trees of each revision.
257
258 Historically, gitk was the first repository browser. It's written in
259 Tcl/Tk and started off in a separate repository but was later merged
260 into the main git repository.
261
262 %description gui -l pl.UTF-8
263 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
264 to wizualizację grafu commitów, wyświetlanie informacji związanych z
265 każdym z commitów oraz listę plików dla każdej rewizji.
266
267 Z punktu widzenia historii, gitk był pierwszą przeglądarką
268 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
269 osobnym repozytorium, ale z czasem został włączony do głównego
270 repozytorium gita.
271
272 %package svn
273 Summary:        Subversion support for Git
274 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
275 Group:          Development/Tools
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       perl-Encode
278 Requires:       perl-Term-ReadKey
279
280 %description svn
281 Subversion support for Git.
282
283 %description svn -l pl.UTF-8
284 Obsługa Subversion dla Gita.
285
286 %package cvs
287 Summary:        CVS support for Git
288 Summary(pl.UTF-8):      Obsługa CVS dla Gita
289 Group:          Development/Tools
290 Requires:       %{name} = %{version}-%{release}
291 Requires:       cvsps >= 2.1-2
292 Requires:       rcs
293
294 %description cvs
295 CVS support for Git.
296
297 %description cvs -l pl.UTF-8
298 Obsługa CVS dla Gita.
299
300 %package arch
301 Summary:        Git tools for importing Arch repositories
302 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
303 Group:          Development/Tools
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       tla
306
307 %description arch
308 Git tools for importing Arch repositories.
309
310 %description arch -l pl.UTF-8
311 Narzędzia Gita do importowania repozytoriów Archa.
312
313 %package email
314 Summary:        Git tools for sending email
315 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
316 Group:          Development/Tools
317 Requires:       %{name} = %{version}-%{release}
318
319 %description email
320 Git tools for sending email.
321
322 %description email -l pl.UTF-8
323 Narzędzia Gita do wysyłania poczty.
324
325 %package -n bash-completion-git
326 Summary:        bash-completion for git
327 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
328 Group:          Applications/Shells
329 Requires:       %{name} = %{version}-%{release}
330 Requires:       bash-completion >= 2.0
331
332 %description -n bash-completion-git
333 This package provides bash-completion for git.
334
335 %description -n bash-completion-git -l pl.UTF-8
336 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
337
338 %package -n perl-Git
339 Summary:        Perl interface to the Git version control system
340 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
341 Group:          Development/Languages/Perl
342 Obsoletes:      perl-git-core
343
344 %description -n perl-Git
345 This module provides Perl scripts easy way to interface the Git
346 version control system. The modules have an easy and well-tested way
347 to call arbitrary Git commands; in the future, the interface will also
348 provide specialized methods for doing easily operations which are not
349 totally trivial to do over the generic command interface.
350
351 %description -n perl-Git -l pl.UTF-8
352 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
353 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
354 dowolne polecenia Gita; w przyszłości interfejs udostępni także
355 specjalne metody do łatwego wykonywania operacji nietrywialnych do
356 wykonania przy użyciu ogólnego interfejsu poleceń.
357
358 %package -n vim-syntax-gitcommit
359 Summary:        Vim syntax: gitcommit
360 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
361 Group:          Applications/Editors/Vim
362 Requires:       %{name} = %{version}-%{release}
363 # for _vimdatadir existence
364 Requires:       vim-rt >= 4:6.3.058-3
365
366 %description -n vim-syntax-gitcommit
367 This plugin provides syntax highlighting for git's commit messages.
368
369 %description -n vim-syntax-gitcommit -l pl.UTF-8
370 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
371
372 %prep
373 %setup -q -n git-%{version}.%{_rc}
374 %patch0 -p1
375 %patch1 -p0
376 %patch2 -p1
377 %patch3 -p1
378 %patch4 -p1
379
380 %build
381 %{__aclocal}
382 %{__autoconf}
383 %configure \
384         --sysconfdir=%{_sysconfdir}/git-core \
385         %{?with_pcre:--with-libpcre} \
386         --with-openssl
387
388 echo "BLK_SHA1=1" >> config.mak
389
390 %{__make} \
391         INSTALLDIRS=vendor \
392         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
393         GITWEB_PROJECTROOT="/var/lib/git" \
394         GITWEB_CSS="/gitweb/gitweb.css" \
395         GITWEB_LOGO="/gitweb/git-logo.png" \
396         GITWEB_FAVICON="/gitweb/git-favicon.png" \
397         V=1
398
399 %if %{with doc}
400 %{__make} -C Documentation \
401         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
402         V=1
403 %endif
404
405 %if %{with tests}
406 %if %{without tests_cvs}
407 %{__rm} t/t*cvs*.sh || :
408 %endif
409 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
410 %endif
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
415 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
416 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
417 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
418 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
419 [init]
420         templatedir = %{_sysconfdir}/%{name}/templates
421 EOF
422
423 %{__make} install \
424         INSTALLDIRS=vendor \
425         DESTDIR=$RPM_BUILD_ROOT
426
427 %if %{with doc}
428 %{__make} -C Documentation install \
429         DESTDIR=$RPM_BUILD_ROOT
430 %endif
431
432 # copy templates except sample hooks
433 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
434 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
435
436 # header files and lib
437 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
438 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
439 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
440 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
441 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
442 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
443 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
444 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
445
446 # bash completion
447 install -d $RPM_BUILD_ROOT%{bash_compdir}
448 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
449
450 # vim syntax
451 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
452 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
453 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
454 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
455 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
456 autocmd BufNewFile,BufRead .msg.[0-9]*
457         \ if getline(1) =~ '^From.*# This line is ignored.$' |
458         \   setf gitsendemail |
459         \ endif
460 autocmd BufNewFile,BufRead *.git/**
461         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
462         \   setf git |
463         \ endif
464 EOF
465
466 # gitweb
467 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
468 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
469 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
470 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
471 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
472 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
473
474 # gitview
475 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
476
477 # git-daemon related files
478 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
479 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
480 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
481
482 # paths cleanup
483 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
484 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
485
486 # hardlink
487 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
488 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
489 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
490 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
491
492 # remove unneeded files
493 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
494 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
495 %py_postclean
496
497 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
498 %find_lang git
499
500 %clean
501 rm -rf $RPM_BUILD_ROOT
502
503 %post daemon-inetd
504 %service -q rc-inetd reload
505
506 %postun daemon-inetd
507 if [ "$1" = "0" ]; then
508         %service -q rc-inetd reload
509 fi
510
511 %post daemon-standalone
512 /sbin/chkconfig --add git-daemon
513 %service git-daemon restart "git-daemon"
514
515 %preun daemon-standalone
516 if [ "$1" = "0" ]; then
517         %service git-daemon stop
518         /sbin/chkconfig --del git-daemon
519 fi
520
521 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
522 %webapp_register apache %{webapp}
523
524 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
525 %webapp_unregister apache %{webapp}
526
527 %triggerin gitweb -- apache < 2.2.0, apache-base
528 %webapp_register httpd %{webapp}
529
530 %triggerun gitweb -- apache < 2.2.0, apache-base
531 %webapp_unregister httpd %{webapp}
532
533 %triggerin gitweb -- lighttpd
534 %webapp_register lighttpd %{webapp}
535
536 %triggerun gitweb -- lighttpd
537 %webapp_unregister lighttpd %{webapp}
538
539 %files -f git.lang
540 %defattr(644,root,root,755)
541 %doc README contrib
542 %attr(755,root,root) %{_bindir}/git
543 %attr(755,root,root) %{_bindir}/git-receive-pack
544 %attr(755,root,root) %{_bindir}/git-shell
545 %attr(755,root,root) %{_bindir}/git-upload-archive
546 %attr(755,root,root) %{_bindir}/git-upload-pack
547 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
548
549 %if %{with doc}
550 %{_mandir}/man1/git-*.1*
551 %exclude %{_mandir}/man1/git-archimport.1*
552 %exclude %{_mandir}/man1/git-svn.1*
553 %exclude %{_mandir}/man1/git-cvs*.1*
554 %exclude %{_mandir}/man1/git-imap-send*.1*
555 %exclude %{_mandir}/man1/*email*.1*
556 %{_mandir}/man1/git.1*
557 %{_mandir}/man1/gitremote-helpers.1*
558 %{_mandir}/man5/gitattributes.5*
559 %{_mandir}/man5/githooks.5*
560 %{_mandir}/man5/gitignore.5*
561 %{_mandir}/man5/gitmodules.5*
562 %{_mandir}/man5/gitrepository-layout.5*
563 %{_mandir}/man7/gitcli.7*
564 %{_mandir}/man7/gitcore-tutorial.7*
565 %{_mandir}/man7/gitcredentials.7*
566 %{_mandir}/man7/gitdiffcore.7*
567 %{_mandir}/man7/gitglossary.7*
568 %{_mandir}/man7/gitnamespaces.7*
569 %{_mandir}/man7/gitrevisions.7*
570 %{_mandir}/man7/gittutorial-2.7*
571 %{_mandir}/man7/gittutorial.7*
572 %{_mandir}/man7/gitworkflows.7*
573 %endif
574
575 %dir %{_libdir}/%{name}
576 %attr(755,root,root) %{_libdir}/%{name}/*-*
577 %attr(755,root,root) %{_libdir}/%{name}/git
578 %{_libdir}/%{name}/mergetools
579
580 %exclude %{_libdir}/%{name}/git-gui
581 %exclude %{_libdir}/%{name}/git-svn
582 %exclude %{_libdir}/%{name}/git-archimport
583 %exclude %{_libdir}/%{name}/git-cvs*
584 %exclude %{_libdir}/%{name}/git-imap-send
585 %exclude %{_libdir}/%{name}/git-instaweb
586 %exclude %{_libdir}/%{name}/git-remote-testsvn
587 %exclude %{_libdir}/%{name}/*email*
588
589 %{_datadir}/%{name}
590
591 %{_localstatedir}/lib/git
592
593 %if %{with doc}
594 %files doc
595 %defattr(644,root,root,755)
596 %doc Documentation/RelNotes*
597 %doc Documentation/*.html Documentation/howto Documentation/technical
598 %endif
599
600 %files daemon-inetd
601 %defattr(644,root,root,755)
602 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
603
604 %files daemon-standalone
605 %defattr(644,root,root,755)
606 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
607 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
608
609 %files devel
610 %defattr(644,root,root,755)
611 %{_includedir}/%{name}
612 %{_libdir}/libgit.a
613 %{_libdir}/libgit_xdiff.a
614
615 %files gitk
616 %defattr(644,root,root,755)
617 %if %{with doc}
618 %{_mandir}/man1/gitk.1*
619 %endif
620 %attr(755,root,root) %{_bindir}/gitk
621 %dir %{_datadir}/gitk
622 %dir %{_datadir}/gitk/lib
623 %dir %{_datadir}/gitk/lib/msgs
624 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
625 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
626 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
627 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
628 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
629 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
630 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
631 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
632 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
633
634 %files gitweb
635 %defattr(644,root,root,755)
636 %doc gitweb/{README,INSTALL}
637 %dir %{webappdir}
638 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
639 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
640 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
641 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
642 %attr(755,root,root) %{cgibindir}/gitweb.cgi
643 %{appdir}
644 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
645 %if %{with doc}
646 %{_mandir}/man1/gitweb.1*
647 %{_mandir}/man5/gitweb.conf.5*
648 %endif
649
650 %files gitview
651 %defattr(644,root,root,755)
652 %doc contrib/gitview/gitview.txt
653 %attr(755,root,root) %{_bindir}/gitview
654
655 %files gui
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/%{name}/git-gui
658 %dir %{_datadir}/git-gui
659 %dir %{_datadir}/git-gui/lib
660 %dir %{_datadir}/git-gui/lib/msgs
661 %{_datadir}/git-gui/lib/git-gui.ico
662 %{_datadir}/git-gui/lib/tclIndex
663 %{_datadir}/git-gui/lib/*.js
664 %{_datadir}/git-gui/lib/*.tcl
665 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
666 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
667 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
668 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
669 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
670 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
671 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
672 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
673 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
674 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
675 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
676
677 %files svn
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/%{name}/git-svn
680 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
681 %{perl_vendorlib}/Git/SVN
682 %{perl_vendorlib}/Git/SVN.pm
683 %if %{with doc}
684 %{_mandir}/man1/git-svn.1*
685 %endif
686
687 %files cvs
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_bindir}/git-cvsserver
690 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
691 %if %{with doc}
692 %{_mandir}/man1/git-cvs*.1*
693 %{_mandir}/man7/gitcvs-migration.7*
694 %endif
695
696 %files arch
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
699 %if %{with doc}
700 %{_mandir}/man1/git-archimport.1*
701 %endif
702
703 %files email
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
706 %attr(755,root,root) %{_libdir}/%{name}/*email*
707 %if %{with doc}
708 %{_mandir}/man1/*email*.1*
709 %{_mandir}/man1/*imap-send*.1*
710 %endif
711
712 %files -n bash-completion-git
713 %defattr(644,root,root,755)
714 %{bash_compdir}/git
715
716 %files -n perl-Git
717 %defattr(644,root,root,755)
718 %{perl_vendorlib}/Git.pm
719 %dir %{perl_vendorlib}/Git
720 %{perl_vendorlib}/Git/I18N.pm
721 %{perl_vendorlib}/Git/IndexInfo.pm
722 %{_mandir}/man3/Git*.3pm*
723
724 %files -n vim-syntax-gitcommit
725 %defattr(644,root,root,755)
726 %doc contrib/vim/README
727 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.084353 seconds and 4 git commands to generate.