]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.5.4.4
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The stupid content tracker
8 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
9 Name:           git-core
10 Version:        1.5.4.4
11 Release:        1
12 License:        GPL v2
13 Group:          Development/Tools
14 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15 # Source0-md5:  f754d2ddea7107c5dff5f846f9426d30
16 Source1:        %{name}-gitweb.conf
17 Source2:        %{name}-gitweb-httpd.conf
18 Source3:        %{name}.sysconfig
19 Source4:        %{name}.inet
20 Source5:        %{name}.init
21 URL:            http://git.or.cz/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  curl-devel
25 BuildRequires:  expat-devel
26 BuildRequires:  gettext-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  perl-Error
29 BuildRequires:  perl-base
30 BuildRequires:  python
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  rpmbuild(macros) >= 1.264
33 BuildRequires:  zlib-devel
34 %if %{with doc}
35 BuildRequires:  asciidoc >= 7.1.2-3
36 BuildRequires:  xmlto
37 %endif
38 %if %{with tests}
39 # tests failed sometimes when using nserver client 1.11(?)
40 BuildRequires:  cvs-client >= 1.12
41 BuildRequires:  pdksh >= 5.2.14-46
42 %endif
43 Requires:       coreutils
44 Requires:       cpio
45 Requires:       curl
46 Requires:       cvsps >= 2.1-2
47 Requires:       diffutils
48 Requires:       findutils
49 Requires:       grep
50 Requires:       openssh-clients
51 Requires:       perl-Error
52 Requires:       rcs
53 Requires:       sed
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 # html docs have links to txt files
57 %define         _noautocompressdoc      *.txt
58
59 %define         webapp          gitweb
60 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
61 %define         appdir          %{_datadir}/%{webapp}
62 %define         cgibindir       %{_prefix}/lib/cgi-bin
63
64 %description
65 "git" can mean anything, depending on your mood.
66
67  - random three-letter combination that is pronounceable, and not
68    actually used by any common UNIX command. The fact that it is a
69    mispronunciation of "get" may or may not be relevant.
70  - stupid. contemptible and despicable. simple. Take your pick from the
71    dictionary of slang.
72  - "global information tracker": you're in a good mood, and it actually
73    works for you. Angels sing, and a light suddenly fills the room.
74  - "goddamn idiotic truckload of sh*t": when it breaks
75
76 This is a stupid (but extremely fast) directory content manager. It
77 doesn't do a whole lot, but what it 'does' do is track directory
78 contents efficiently.
79
80 %description -l pl.UTF-8
81 "git" może oznaczać cokolwiek, w zależności od nastroju.
82
83  - losową kombinację trzech liter, która jest wymawialna i właściwie
84    nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
85    błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
86  - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
87  - "global information tracker" (narzędzie do globalnego śledzenia
88    informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
89    Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
90  - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
91    g*) - kiedy się zepsuje.
92
93 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
94 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
95 katalogu.
96
97 %package daemon-inetd
98 Summary:        Files necessary to run git-daemon as an inetd service
99 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
100 Group:          Networking/Daemons
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       setup >= 2.4.11-1
103 Provides:       git-core-daemon
104 Obsoletes:      git-core-daemon
105 Obsoletes:      git-core-daemon-standalone
106
107 %description daemon-inetd
108 Git-daemon is a really simple TCP git daemon that can serve git
109 repositories. This package provides all necessarry files to run
110 git-daemon as an inetd service.
111
112 %description daemon-inetd -l pl.UTF-8
113 Git-daemon to prosty demon git korzystający z protokołu TCP do
114 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
115 do uruchomienia git-demona w trybie usługi inetd.
116
117 %package daemon-standalone
118 Summary:        Files necessary to run git-daemon as a standalone service
119 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
120 Group:          Networking/Daemons
121 Requires:       %{name} = %{version}-%{release}
122 Provides:       git-core-daemon
123 Obsoletes:      git-core-daemon
124 Obsoletes:      git-core-daemon-inetd
125
126 %description daemon-standalone
127 Git-daemon is a really simple TCP git daemon that can serve git
128 repositories. This package provides all necessarry files to run
129 git-daemon as an standalone service.
130
131 %description daemon-standalone -l pl.UTF-8
132 Git-daemon to prosty demon git korzystający z protokołu TCP do
133 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
134 do uruchomienia git-daemona w trybie usługi samodzielnej.
135
136 %package devel
137 Summary:        Header files for git-core
138 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
139 Group:          Development/Libraries
140
141 %description devel
142 Header files for git-core.
143
144 %description devel -l pl.UTF-8
145 Pliki nagłówkowe dla git-core.
146
147 %package gitk
148 Summary:        Tcl/Tk interface to the Git version control system
149 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
150 Group:          Development/Tools
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       tk
153
154 %description gitk
155 Displays changes in a repository or a selected set of commits. This
156 includes visualizing the commit graph, showing information related to
157 each commit, and the files in the trees of each revision.
158
159 Historically, gitk was the first repository browser. It's written in
160 Tcl/Tk and started off in a separate repository but was later merged
161 into the main git repository.
162
163 %description gitk -l pl.UTF-8
164 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
165 to wizualizację grafu commitów, wyświetlanie informacji związanych z
166 każdym z commitów oraz listę plików dla każdej rewizji.
167
168 Z punktu widzenia historii, gitk był pierwszą przeglądarką
169 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
170 osobnym repozytorium, ale z czasem został włączony do głównego
171 repozytorium gita.
172
173 %package gitweb
174 Summary:        Web frontend to git
175 Summary(pl.UTF-8):      Webowy frontend do git
176 Group:          Development/Tools
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       webapps
179
180 %description gitweb
181 This package provides a web interface for browsing git repositories.
182
183 %description gitweb -l pl.UTF-8
184 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
185
186 %package gitview
187 Summary:        A GTK+ based repository browser for git
188 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
189 Group:          Development/Tools
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       python >= 1:2.4
192 Requires:       python-pycairo >= 1.0
193 Requires:       python-pygobject
194 Requires:       python-pygtk-gtk >= 2:2.8
195 Suggests:       python-gnome-desktop-gtksourceview
196
197 %description gitview
198 A GTK+ based repository browser for git.
199
200 %description gitview -l pl.UTF-8
201 Oparta na GTK+ przeglądarka repozytorium gita.
202
203 %package -n bash-completion-git
204 Summary:        bash-completion for git
205 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
206 Group:          Applications/Shells
207 Requires:       bash-completion
208
209 %description -n bash-completion-git
210 This package provides bash-completion for git.
211
212 %description -n bash-completion-git -l pl.UTF-8
213 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
214
215 %package -n perl-Git
216 Summary:        Perl interface to the Git version control system
217 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
218 Group:          Development/Languages/Perl
219 Requires:       %{name} = %{version}-%{release}
220 Obsoletes:      perl-git-core
221
222 %description -n perl-Git
223 This module provides Perl scripts easy way to interface the Git
224 version control system. The modules have an easy and well-tested way
225 to call arbitrary Git commands; in the future, the interface will also
226 provide specialized methods for doing easily operations which are not
227 totally trivial to do over the generic command interface.
228
229 %description -n perl-Git -l pl.UTF-8
230 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
231 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
232 dowolne polecenia Gita; w przyszłości interfejs udostępni także
233 specjalne metody do łatwego wykonywania operacji nietrywialnych do
234 wykonania przy użyciu ogólnego interfejsu poleceń.
235
236 %package -n vim-syntax-gitcommit
237 Summary:        Vim syntax: gitcommit
238 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
239 Group:          Applications/Editors/Vim
240 # for _vimdatadir existence
241 Requires:       vim >= 4:6.3.058-3
242
243 %description -n vim-syntax-gitcommit
244 This plugin provides syntax highlighting for git's commit messages.
245
246 %description -n vim-syntax-gitcommit -l pl.UTF-8
247 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
248
249 %prep
250 %setup -q -n git-%{version}
251
252 %build
253 %{__aclocal}
254 %{__autoconf}
255 %configure \
256         --with-openssl
257
258 %{__make} \
259         INSTALLDIRS=vendor \
260         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
261         GITWEB_PROJECTROOT="/var/lib/git" \
262         GITWEB_CSS="/gitweb/gitweb.css" \
263         GITWEB_LOGO="/gitweb/git-logo.png" \
264         GITWEB_FAVICON="/gitweb/git-favicon.png"
265
266 %{?with_doc:%{__make} -C Documentation}
267
268 %{?with_tests:%{__make} test}
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
273 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
274 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
275 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
276 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
277
278 %{__make} install \
279         INSTALLDIRS=vendor \
280         DESTDIR=$RPM_BUILD_ROOT
281
282 %if %{with doc}
283 %{__make} -C Documentation install \
284         DESTDIR=$RPM_BUILD_ROOT
285 %endif
286
287 # header files and lib
288 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
289 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
290 install libgit.a $RPM_BUILD_ROOT%{_libdir}
291
292 # bash completion
293 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
294
295 # vim syntax
296 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
297
298 # gitweb
299 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
300 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
301 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
302 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
303 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
304
305 # gitview
306 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
307
308 # git-daemon related files
309 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
310 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
311 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
312
313 # remove unneeded files
314 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
315 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
316 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
317 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/private-Error.3*
318
319 %clean
320 rm -rf $RPM_BUILD_ROOT
321
322 %post daemon-inetd
323 %service -q rc-inetd reload
324
325 %postun daemon-inetd
326 if [ "$1" = "0" ]; then
327         %service -q rc-inetd reload
328 fi
329
330 %post daemon-standalone
331 /sbin/chkconfig --add git-daemon
332 %service git-daemon restart "git-daemon"
333
334 %preun daemon-standalone
335 if [ "$1" = "0" ]; then
336         %service git-daemon stop
337         /sbin/chkconfig --del git-daemon
338 fi
339
340 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
341 %webapp_register apache %{webapp}
342
343 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
344 %webapp_unregister apache %{webapp}
345
346 %triggerin gitweb -- apache < 2.2.0, apache-base
347 %webapp_register httpd %{webapp}
348
349 %triggerun gitweb -- apache < 2.2.0, apache-base
350 %webapp_unregister httpd %{webapp}
351
352 %files
353 %defattr(644,root,root,755)
354 %doc README contrib
355 %if %{with doc}
356 %doc Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
357 %{_mandir}/man1/git-*.1*
358 %{_mandir}/man5/gitattributes.5*
359 %{_mandir}/man5/gitcli.5*
360 %{_mandir}/man5/gitignore.5*
361 %{_mandir}/man5/gitmodules.5*
362 %{_mandir}/man7/git.7*
363 %endif
364 %attr(755,root,root) %{_bindir}/git
365 %attr(755,root,root) %{_bindir}/git-*
366 %{_datadir}/%{name}
367 %{_datadir}/git-gui
368 %{_localstatedir}/lib/git
369
370 %files daemon-inetd
371 %defattr(644,root,root,755)
372 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
373
374 %files daemon-standalone
375 %defattr(644,root,root,755)
376 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
377 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
378
379 %files devel
380 %defattr(644,root,root,755)
381 %{_includedir}/git-core
382 %{_libdir}/libgit.a
383
384 %files gitk
385 %defattr(644,root,root,755)
386 %if %{with doc}
387 %doc Documentation/gitk.html
388 %{_mandir}/man1/gitk.1*
389 %endif
390 %attr(755,root,root) %{_bindir}/gitk
391 %dir %{_datadir}/gitk
392 %dir %{_datadir}/gitk/lib
393 %dir %{_datadir}/gitk/lib/msgs
394 %lang(de) %dir %{_datadir}/gitk/lib/msgs/de.msg
395
396 %files gitweb
397 %defattr(644,root,root,755)
398 %doc gitweb/{README,INSTALL}
399 %dir %{webappdir}
400 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
401 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
402 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
403 %attr(755,root,root) %{cgibindir}/gitweb.cgi
404 %{appdir}
405
406 %files gitview
407 %defattr(644,root,root,755)
408 %doc contrib/gitview/gitview.txt
409 %attr(755,root,root) %{_bindir}/gitview
410
411 %files -n bash-completion-git
412 %defattr(644,root,root,755)
413 %{_sysconfdir}/bash_completion.d/*
414
415 %files -n perl-Git
416 %defattr(644,root,root,755)
417 %{perl_vendorlib}/Git.pm
418 %{_mandir}/man3/Git.3pm*
419
420 %files -n vim-syntax-gitcommit
421 %defattr(644,root,root,755)
422 %doc contrib/vim/README
423 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.069077 seconds and 4 git commands to generate.