]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.6.0.5
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The stupid content tracker
8 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
9 Name:           git-core
10 Version:        1.6.0.5
11 Release:        1
12 License:        GPL v2
13 Group:          Development/Tools
14 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15 # Source0-md5:  899172ebeac65f7a09a8e204d4f87d8c
16 Source1:        %{name}-gitweb.conf
17 Source2:        %{name}-gitweb-httpd.conf
18 Source3:        %{name}.sysconfig
19 Source4:        %{name}.inet
20 Source5:        %{name}.init
21 URL:            http://git.or.cz/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  curl-devel
25 BuildRequires:  expat-devel
26 BuildRequires:  gettext-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  perl-Error
29 BuildRequires:  perl-base
30 BuildRequires:  python
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  rpmbuild(macros) >= 1.264
33 BuildRequires:  zlib-devel
34 %if %{with doc}
35 BuildRequires:  asciidoc >= 7.1.2-3
36 BuildRequires:  xmlto
37 %endif
38 %if %{with tests}
39 # tests failed sometimes when using nserver client 1.11(?)
40 BuildRequires:  cvs-client >= 1.12
41 BuildRequires:  pdksh >= 5.2.14-46
42 %endif
43 Requires:       coreutils
44 Requires:       cvsps >= 2.1-2
45 Requires:       diffutils
46 Requires:       findutils
47 Requires:       grep
48 Requires:       openssh-clients
49 Requires:       perl-Error
50 Requires:       rcs
51 Requires:       sed
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 # html docs have links to txt files
55 %define         _noautocompressdoc      *.txt
56
57 %define         webapp          gitweb
58 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
59 %define         appdir          %{_datadir}/%{webapp}
60 %define         cgibindir       %{_prefix}/lib/cgi-bin
61
62 %description
63 "git" can mean anything, depending on your mood.
64
65  - random three-letter combination that is pronounceable, and not
66    actually used by any common UNIX command. The fact that it is a
67    mispronunciation of "get" may or may not be relevant.
68  - stupid. contemptible and despicable. simple. Take your pick from the
69    dictionary of slang.
70  - "global information tracker": you're in a good mood, and it actually
71    works for you. Angels sing, and a light suddenly fills the room.
72  - "goddamn idiotic truckload of sh*t": when it breaks
73
74 This is a stupid (but extremely fast) directory content manager. It
75 doesn't do a whole lot, but what it 'does' do is track directory
76 contents efficiently.
77
78 %description -l pl.UTF-8
79 "git" może oznaczać cokolwiek, w zależności od nastroju.
80
81  - losową kombinację trzech liter, która jest wymawialna i właściwie
82    nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
83    błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
84  - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
85  - "global information tracker" (narzędzie do globalnego śledzenia
86    informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
87    Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
88  - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
89    g*) - kiedy się zepsuje.
90
91 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
92 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
93 katalogu.
94
95 %package daemon-inetd
96 Summary:        Files necessary to run git-daemon as an inetd service
97 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
98 Group:          Networking/Daemons
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       setup >= 2.4.11-1
101 Provides:       git-core-daemon
102 Obsoletes:      git-core-daemon
103 Obsoletes:      git-core-daemon-standalone
104
105 %description daemon-inetd
106 Git-daemon is a really simple TCP git daemon that can serve git
107 repositories. This package provides all necessarry files to run
108 git-daemon as an inetd service.
109
110 %description daemon-inetd -l pl.UTF-8
111 Git-daemon to prosty demon git korzystający z protokołu TCP do
112 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
113 do uruchomienia git-demona w trybie usługi inetd.
114
115 %package daemon-standalone
116 Summary:        Files necessary to run git-daemon as a standalone service
117 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
118 Group:          Networking/Daemons
119 Requires:       %{name} = %{version}-%{release}
120 Provides:       git-core-daemon
121 Obsoletes:      git-core-daemon
122 Obsoletes:      git-core-daemon-inetd
123
124 %description daemon-standalone
125 Git-daemon is a really simple TCP git daemon that can serve git
126 repositories. This package provides all necessarry files to run
127 git-daemon as an standalone service.
128
129 %description daemon-standalone -l pl.UTF-8
130 Git-daemon to prosty demon git korzystający z protokołu TCP do
131 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
132 do uruchomienia git-daemona w trybie usługi samodzielnej.
133
134 %package devel
135 Summary:        Header files for git-core
136 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
137 Group:          Development/Libraries
138
139 %description devel
140 Header files for git-core.
141
142 %description devel -l pl.UTF-8
143 Pliki nagłówkowe dla git-core.
144
145 %package gitk
146 Summary:        Tcl/Tk interface to the Git version control system
147 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
148 Group:          Development/Tools
149 Requires:       %{name} = %{version}-%{release}
150 Requires:       tk
151
152 %description gitk
153 gitk displays changes in a repository or a selected set of commits.
154 This includes visualizing the commit graph, showing information
155 related to each commit, and the files in the trees of each revision.
156
157 Historically, gitk was the first repository browser. It's written in
158 Tcl/Tk and started off in a separate repository but was later merged
159 into the main git repository.
160
161 %description gitk -l pl.UTF-8
162 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
163 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
164 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
165
166 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
167 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
168 osobnym repozytorium, ale z czasem został włączony do głównego
169 repozytorium gita.
170
171 %package gitweb
172 Summary:        Web frontend to git
173 Summary(pl.UTF-8):      Webowy frontend do git
174 Group:          Development/Tools
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       webapps
177
178 %description gitweb
179 This package provides a web interface for browsing git repositories.
180
181 %description gitweb -l pl.UTF-8
182 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
183
184 %package gitview
185 Summary:        A GTK+ based repository browser for git
186 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
187 Group:          Development/Tools
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       python >= 1:2.4
190 Requires:       python-pycairo >= 1.0
191 Requires:       python-pygobject
192 Requires:       python-pygtk-gtk >= 2:2.8
193 Suggests:       python-gnome-desktop-gtksourceview
194
195 %description gitview
196 A GTK+ based repository browser for git.
197
198 %description gitview -l pl.UTF-8
199 Oparta na GTK+ przeglądarka repozytorium gita.
200
201 %package gui
202 Summary:        Tcl/Tk interface to the Git version control system
203 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
204 Group:          Development/Tools
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       tk
207
208 %description gui
209 Displays changes in a repository or a selected set of commits. This
210 includes visualizing the commit graph, showing information related to
211 each commit, and the files in the trees of each revision.
212
213 Historically, gitk was the first repository browser. It's written in
214 Tcl/Tk and started off in a separate repository but was later merged
215 into the main git repository.
216
217 %description gui -l pl.UTF-8
218 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
219 to wizualizację grafu commitów, wyświetlanie informacji związanych z
220 każdym z commitów oraz listę plików dla każdej rewizji.
221
222 Z punktu widzenia historii, gitk był pierwszą przeglądarką
223 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
224 osobnym repozytorium, ale z czasem został włączony do głównego
225 repozytorium gita.
226
227 %package -n bash-completion-git
228 Summary:        bash-completion for git
229 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
230 Group:          Applications/Shells
231 Requires:       bash-completion
232
233 %description -n bash-completion-git
234 This package provides bash-completion for git.
235
236 %description -n bash-completion-git -l pl.UTF-8
237 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
238
239 %package -n perl-Git
240 Summary:        Perl interface to the Git version control system
241 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
242 Group:          Development/Languages/Perl
243 Requires:       %{name} = %{version}-%{release}
244 Obsoletes:      perl-git-core
245
246 %description -n perl-Git
247 This module provides Perl scripts easy way to interface the Git
248 version control system. The modules have an easy and well-tested way
249 to call arbitrary Git commands; in the future, the interface will also
250 provide specialized methods for doing easily operations which are not
251 totally trivial to do over the generic command interface.
252
253 %description -n perl-Git -l pl.UTF-8
254 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
255 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
256 dowolne polecenia Gita; w przyszłości interfejs udostępni także
257 specjalne metody do łatwego wykonywania operacji nietrywialnych do
258 wykonania przy użyciu ogólnego interfejsu poleceń.
259
260 %package -n vim-syntax-gitcommit
261 Summary:        Vim syntax: gitcommit
262 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
263 Group:          Applications/Editors/Vim
264 # for _vimdatadir existence
265 Requires:       vim-rt >= 4:6.3.058-3
266
267 %description -n vim-syntax-gitcommit
268 This plugin provides syntax highlighting for git's commit messages.
269
270 %description -n vim-syntax-gitcommit -l pl.UTF-8
271 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
272
273 %prep
274 %setup -q -n git-%{version}
275
276 %build
277 %{__aclocal}
278 %{__autoconf}
279 %configure \
280         --with-openssl
281
282 %{__make} \
283         INSTALLDIRS=vendor \
284         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
285         GITWEB_PROJECTROOT="/var/lib/git" \
286         GITWEB_CSS="/gitweb/gitweb.css" \
287         GITWEB_LOGO="/gitweb/git-logo.png" \
288         GITWEB_FAVICON="/gitweb/git-favicon.png"
289
290 %{?with_doc:%{__make} -C Documentation}
291
292 %{?with_tests:%{__make} test}
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
297 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
298 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
299 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
300 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
301
302 %{__make} install \
303         INSTALLDIRS=vendor \
304         DESTDIR=$RPM_BUILD_ROOT
305
306 %if %{with doc}
307 %{__make} -C Documentation install \
308         DESTDIR=$RPM_BUILD_ROOT
309 %endif
310
311 # header files and lib
312 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
313 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
314 install libgit.a $RPM_BUILD_ROOT%{_libdir}
315
316 # bash completion
317 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
318
319 # vim syntax
320 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
321
322 # gitweb
323 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
324 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
325 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
326 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
327 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
328
329 # gitview
330 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
331
332 # git-daemon related files
333 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
334 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
335 install %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
336
337 # paths cleanup
338 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon 
339 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
340
341 # remove unneeded files
342 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
343 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
344 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
345 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/private-Error.3*
346
347 %clean
348 rm -rf $RPM_BUILD_ROOT
349
350 %post daemon-inetd
351 %service -q rc-inetd reload
352
353 %postun daemon-inetd
354 if [ "$1" = "0" ]; then
355         %service -q rc-inetd reload
356 fi
357
358 %post daemon-standalone
359 /sbin/chkconfig --add git-daemon
360 %service git-daemon restart "git-daemon"
361
362 %preun daemon-standalone
363 if [ "$1" = "0" ]; then
364         %service git-daemon stop
365         /sbin/chkconfig --del git-daemon
366 fi
367
368 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
369 %webapp_register apache %{webapp}
370
371 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
372 %webapp_unregister apache %{webapp}
373
374 %triggerin gitweb -- apache < 2.2.0, apache-base
375 %webapp_register httpd %{webapp}
376
377 %triggerun gitweb -- apache < 2.2.0, apache-base
378 %webapp_unregister httpd %{webapp}
379
380 %files
381 %defattr(644,root,root,755)
382 %doc README contrib
383 %if %{with doc}
384 %doc Documentation/RelNotes*
385 %doc Documentation/*.html Documentation/howto Documentation/technical
386 %{_mandir}/man1/git-*.1*
387 %{_mandir}/man1/git.1*
388 %{_mandir}/man5/gitattributes.5*
389 %{_mandir}/man5/githooks.5*
390 %{_mandir}/man5/gitignore.5*
391 %{_mandir}/man5/gitmodules.5*
392 %{_mandir}/man5/gitrepository-layout.5*
393 %{_mandir}/man7/gitcli.7*
394 %{_mandir}/man7/gitcore-tutorial.7*
395 %{_mandir}/man7/gitcvs-migration.7*
396 %{_mandir}/man7/gitdiffcore.7*
397 %{_mandir}/man7/gitglossary.7*
398 %{_mandir}/man7/gittutorial-2.7*
399 %{_mandir}/man7/gittutorial.7*
400 %endif
401 %attr(755,root,root) %{_bindir}/git
402 %attr(755,root,root) %{_bindir}/git-*
403 %dir %{_libdir}/%{name}
404 %attr(755,root,root) %{_libdir}/%{name}/*-*
405 %exclude %{_libdir}/%{name}/git-gui
406 %{_datadir}/%{name}
407 %{_localstatedir}/lib/git
408
409 %files daemon-inetd
410 %defattr(644,root,root,755)
411 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
412
413 %files daemon-standalone
414 %defattr(644,root,root,755)
415 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
416 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
417
418 %files devel
419 %defattr(644,root,root,755)
420 %{_includedir}/git-core
421 %{_libdir}/libgit.a
422
423 %files gitk
424 %defattr(644,root,root,755)
425 %if %{with doc}
426 %{_mandir}/man1/gitk.1*
427 %endif
428 %attr(755,root,root) %{_bindir}/gitk
429 %dir %{_datadir}/gitk
430 %dir %{_datadir}/gitk/lib
431 %dir %{_datadir}/gitk/lib/msgs
432 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
433 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
434 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
435 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
436
437 %files gitweb
438 %defattr(644,root,root,755)
439 %doc gitweb/{README,INSTALL}
440 %dir %{webappdir}
441 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
442 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
443 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
444 %attr(755,root,root) %{cgibindir}/gitweb.cgi
445 %{appdir}
446
447 %files gitview
448 %defattr(644,root,root,755)
449 %doc contrib/gitview/gitview.txt
450 %attr(755,root,root) %{_bindir}/gitview
451
452 %files gui
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_libdir}/%{name}/git-gui
455 %dir %{_datadir}/git-gui
456 %dir %{_datadir}/git-gui/lib
457 %dir %{_datadir}/git-gui/lib/msgs
458 %{_datadir}/git-gui/lib/git-gui.ico
459 %{_datadir}/git-gui/lib/tclIndex
460 %{_datadir}/git-gui/lib/*.js
461 %{_datadir}/git-gui/lib/*.tcl
462 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
463 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
464 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
465 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
466 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
467 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
468 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
469 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
470
471 %files -n bash-completion-git
472 %defattr(644,root,root,755)
473 %{_sysconfdir}/bash_completion.d/*
474
475 %files -n perl-Git
476 %defattr(644,root,root,755)
477 %{perl_vendorlib}/Git.pm
478 %{_mandir}/man3/Git.3pm*
479
480 %files -n vim-syntax-gitcommit
481 %defattr(644,root,root,755)
482 %doc contrib/vim/README
483 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.076101 seconds and 4 git commands to generate.