]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- unified GTK+ naming
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.3.4
10 Release:        1
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  b35fd5abba0e8655733c8e8c470f39cf
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc >= 7.1.2-3
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 %{?with_tests:BuildRequires:    pdksh >= 5.2.14-46}
27 BuildRequires:  python
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRequires:  rpmbuild(macros) >= 1.264
30 BuildRequires:  xmlto
31 BuildRequires:  zlib-devel
32 Requires:       coreutils
33 Requires:       curl
34 Requires:       diffutils
35 Requires:       findutils
36 Requires:       grep
37 Requires:       openssh-clients
38 Requires:       perl-Error
39 Requires:       rcs
40 Requires:       sed
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         webapp          gitweb
44 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
45 %define         appdir          %{_datadir}/%{webapp}
46 %define         cgibindir       %{_prefix}/lib/cgi-bin
47
48 %description
49 "git" can mean anything, depending on your mood.
50
51  - random three-letter combination that is pronounceable, and not
52    actually used by any common UNIX command. The fact that it is a
53    mispronunciation of "get" may or may not be relevant.
54  - stupid. contemptible and despicable. simple. Take your pick from the
55    dictionary of slang.
56  - "global information tracker": you're in a good mood, and it actually
57    works for you. Angels sing, and a light suddenly fills the room.
58  - "goddamn idiotic truckload of sh*t": when it breaks
59
60 This is a stupid (but extremely fast) directory content manager. It
61 doesn't do a whole lot, but what it 'does' do is track directory
62 contents efficiently.
63
64 %description -l pl.UTF-8
65 "git" może oznaczać cokolwiek, w zależności od nastroju.
66
67 - losową kombinację trzech liter, która jest wymawialna i
68   właściwie nie używana przez żadne popularne polecenie uniksowe.
69   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
70   mieć znaczenia.
71 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
72 - "global information tracker" (narzędzie do globalnego śledzenia
73   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
74   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
75 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
76   g*) - kiedy się zepsuje.
77
78 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
79 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
80 katalogu.
81
82 %package devel
83 Summary:        Header files for git-core
84 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
85 Group:          Development/Libraries
86
87 %description devel
88 Header files for git-core.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe dla git-core.
92
93 %package gitk
94 Summary:        Tcl/Tk interface to the Git version control system
95 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
96 Group:          Development/Tools
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       tk
99
100 %description gitk
101 Displays changes in a repository or a selected set of commits. This
102 includes visualizing the commit graph, showing information related to
103 each commit, and the files in the trees of each revision.
104
105 Historically, gitk was the first repository browser. It's written in
106 Tcl/Tk and started off in a separate repository but was later merged
107 into the main git repository.
108
109 %description gitk -l pl.UTF-8
110 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
111 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
112 związanych z każdym z commitów oraz listę plików dla każdej
113 rewizji.
114
115 Z punktu widzenia historii, gitk był pierwszą przeglądarką
116 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
117 w osobnym repozytorium, ale z czasem został włączony do głównego
118 repozytorium gita.
119
120 %package gitweb
121 Summary:        Web frontend to git
122 Summary(pl.UTF-8):      Webowy frontend do git
123 Group:          Development/Tools
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       webapps
126
127 %description gitweb
128 This package provides a web interface for browsing git repositories.
129
130 %description gitweb -l pl.UTF-8
131 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
132
133 %package gitview
134 Summary:        A GTK+ based repository browser for git
135 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
136 Group:          Development/Tools
137 Requires:       %{name} = %{version}-%{release}
138 #Requires:      pytongowe mambo dżambo
139
140 %description gitview
141 A GTK+ based repository browser for git.
142
143 %description gitview -l pl.UTF-8
144 Oparta na GTK+ przeglądarka repozytorium gita.
145
146 %package -n bash-completion-git
147 Summary:        bash-completion for git
148 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
149 Group:          Applications/Shell
150 Requires:       bash-completion
151
152 %description -n bash-completion-git
153 This package provides bash-completion for git.
154
155 %description -n bash-completion-git -l pl.UTF-8
156 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
157
158 %package -n perl-Git
159 Summary:        Perl interface to the Git version control system
160 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
161 Group:          Development/Languages/Perl
162 Requires:       %{name} = %{version}-%{release}
163 Obsoletes:      perl-git-core
164
165 %description -n perl-Git
166 This module provides Perl scripts easy way to interface the Git
167 version control system. The modules have an easy and well-tested way
168 to call arbitrary Git commands; in the future, the interface will also
169 provide specialized methods for doing easily operations which are not
170 totally trivial to do over the generic command interface.
171
172 %description -n perl-Git -l pl.UTF-8
173 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
174 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
175 wywoływać dowolne polecenia Gita; w przyszłości interfejs
176 udostępni także specjalne metody do łatwego wykonywania operacji
177 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
178 poleceń.
179
180 %package -n vim-syntax-gitcommit
181 Summary:        Vim syntax: gitcommit
182 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
183 Group:          Applications/Editors/Vim
184 # for _vimdatadir existence
185 Requires:       vim >= 4:6.3.058-3
186
187 %description -n vim-syntax-gitcommit
188 This plugin provides syntax highlighting for git's commit messages.
189
190 %description -n vim-syntax-gitcommit -l pl.UTF-8
191 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
192
193 %prep
194 %setup -q -n git-%{version}
195
196 %build
197 %{__aclocal}
198 %{__autoconf}
199 %configure \
200         --with-openssl
201
202 %{__make} \
203         INSTALLDIRS=vendor \
204         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
205         GITWEB_PROJECTROOT="/var/lib/git" \
206         GITWEB_CSS="/gitweb/gitweb.css" \
207         GITWEB_LOGO="/gitweb/git-logo.png" \
208         GITWEB_FAVICON="/gitweb/git-favicon.png"
209
210 %{__make} -C Documentation
211
212 %{?with_tests:%{__make} test}
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
217 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
218 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
219 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
220
221 %{__make} install \
222         INSTALLDIRS=vendor \
223         DESTDIR=$RPM_BUILD_ROOT
224
225 %{__make} -C Documentation install \
226         DESTDIR=$RPM_BUILD_ROOT
227
228 # header files and lib
229 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
230 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
231 install libgit.a $RPM_BUILD_ROOT%{_libdir}
232
233 # bash completion
234 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
235
236 # vim syntax
237 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
238
239 # gitweb
240 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
241 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
242 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
243 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
244 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
245
246 # gitview
247 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
248
249 # remove unneeded files
250 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
251 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
252
253 %clean
254 rm -rf $RPM_BUILD_ROOT
255
256 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
257 %webapp_register apache %{webapp}
258
259 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
260 %webapp_unregister apache %{webapp}
261
262 %triggerin gitweb -- apache < 2.2.0, apache-base
263 %webapp_register httpd %{webapp}
264
265 %triggerun gitweb -- apache < 2.2.0, apache-base
266 %webapp_unregister httpd %{webapp}
267
268 %files
269 %defattr(644,root,root,755)
270 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
271 %attr(755,root,root) %{_bindir}/git
272 %attr(755,root,root) %{_bindir}/git-*
273 %{_mandir}/man1/git-*.1*
274 %{_mandir}/man5/gitattributes.5*
275 %{_mandir}/man5/gitignore.5*
276 %{_mandir}/man5/gitmodules.5*
277 %{_mandir}/man7/git.7*
278 %{_datadir}/%{name}
279 %{_datadir}/git-gui
280 %{_sharedstatedir}/git
281
282 %files devel
283 %defattr(644,root,root,755)
284 %{_includedir}/*
285 %{_libdir}/*.a
286
287 %files gitk
288 %defattr(644,root,root,755)
289 %doc Documentation/gitk.html
290 %attr(755,root,root) %{_bindir}/gitk
291 %{_mandir}/man1/gitk.1*
292
293 %files gitweb
294 %defattr(644,root,root,755)
295 %doc gitweb/{README,INSTALL}
296 %dir %{webappdir}
297 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
298 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
299 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
300 %attr(755,root,root) %{cgibindir}/gitweb.cgi
301 %{appdir}
302
303 %files gitview
304 %defattr(644,root,root,755)
305 %doc contrib/gitview/gitview.txt
306 %attr(755,root,root) %{_bindir}/gitview
307
308 %files -n bash-completion-git
309 %defattr(644,root,root,755)
310 %{_sysconfdir}/bash_completion.d/*
311
312 %files -n perl-Git
313 %defattr(644,root,root,755)
314 %{perl_vendorlib}/Git.pm
315 %{_mandir}/man3/Git.3pm*
316
317 %files -n vim-syntax-gitcommit
318 %defattr(644,root,root,755)
319 %doc contrib/vim/README
320 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.069122 seconds and 4 git commands to generate.