]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- tests require cvs tool
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.3.5
10 Release:        1
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  3fdff0bdb3638fce1c4bc6795ed81fb3
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc >= 7.1.2-3
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.264
29 BuildRequires:  xmlto
30 BuildRequires:  zlib-devel
31 %if %{with tests}
32 BuildRequires   pdksh >= 5.2.14-46
33 BuildRequires:  cvs
34 %endif
35 Requires:       coreutils
36 Requires:       curl
37 Requires:       diffutils
38 Requires:       findutils
39 Requires:       grep
40 Requires:       openssh-clients
41 Requires:       perl-Error
42 Requires:       rcs
43 Requires:       sed
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # html docs have links to txt files
47 %define         _noautocompressdoc      *.txt
48
49 %define         webapp          gitweb
50 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
51 %define         appdir          %{_datadir}/%{webapp}
52 %define         cgibindir       %{_prefix}/lib/cgi-bin
53
54 %description
55 "git" can mean anything, depending on your mood.
56
57  - random three-letter combination that is pronounceable, and not
58    actually used by any common UNIX command. The fact that it is a
59    mispronunciation of "get" may or may not be relevant.
60  - stupid. contemptible and despicable. simple. Take your pick from the
61    dictionary of slang.
62  - "global information tracker": you're in a good mood, and it actually
63    works for you. Angels sing, and a light suddenly fills the room.
64  - "goddamn idiotic truckload of sh*t": when it breaks
65
66 This is a stupid (but extremely fast) directory content manager. It
67 doesn't do a whole lot, but what it 'does' do is track directory
68 contents efficiently.
69
70 %description -l pl.UTF-8
71 "git" może oznaczać cokolwiek, w zależności od nastroju.
72
73 - losową kombinację trzech liter, która jest wymawialna i
74   właściwie nie używana przez żadne popularne polecenie uniksowe.
75   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
76   mieć znaczenia.
77 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
78 - "global information tracker" (narzędzie do globalnego śledzenia
79   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
80   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
81 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
82   g*) - kiedy się zepsuje.
83
84 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
85 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
86 katalogu.
87
88 %package devel
89 Summary:        Header files for git-core
90 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
91 Group:          Development/Libraries
92
93 %description devel
94 Header files for git-core.
95
96 %description devel -l pl.UTF-8
97 Pliki nagłówkowe dla git-core.
98
99 %package gitk
100 Summary:        Tcl/Tk interface to the Git version control system
101 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
102 Group:          Development/Tools
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       tk
105
106 %description gitk
107 Displays changes in a repository or a selected set of commits. This
108 includes visualizing the commit graph, showing information related to
109 each commit, and the files in the trees of each revision.
110
111 Historically, gitk was the first repository browser. It's written in
112 Tcl/Tk and started off in a separate repository but was later merged
113 into the main git repository.
114
115 %description gitk -l pl.UTF-8
116 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
117 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
118 związanych z każdym z commitów oraz listę plików dla każdej
119 rewizji.
120
121 Z punktu widzenia historii, gitk był pierwszą przeglądarką
122 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
123 w osobnym repozytorium, ale z czasem został włączony do głównego
124 repozytorium gita.
125
126 %package gitweb
127 Summary:        Web frontend to git
128 Summary(pl.UTF-8):      Webowy frontend do git
129 Group:          Development/Tools
130 Requires:       %{name} = %{version}-%{release}
131 Requires:       webapps
132
133 %description gitweb
134 This package provides a web interface for browsing git repositories.
135
136 %description gitweb -l pl.UTF-8
137 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
138
139 %package gitview
140 Summary:        A GTK+ based repository browser for git
141 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
142 Group:          Development/Tools
143 Requires:       %{name} = %{version}-%{release}
144 #Requires:      pytongowe mambo dżambo
145
146 %description gitview
147 A GTK+ based repository browser for git.
148
149 %description gitview -l pl.UTF-8
150 Oparta na GTK+ przeglądarka repozytorium gita.
151
152 %package -n bash-completion-git
153 Summary:        bash-completion for git
154 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
155 Group:          Applications/Shell
156 Requires:       bash-completion
157
158 %description -n bash-completion-git
159 This package provides bash-completion for git.
160
161 %description -n bash-completion-git -l pl.UTF-8
162 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
163
164 %package -n perl-Git
165 Summary:        Perl interface to the Git version control system
166 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
167 Group:          Development/Languages/Perl
168 Requires:       %{name} = %{version}-%{release}
169 Obsoletes:      perl-git-core
170
171 %description -n perl-Git
172 This module provides Perl scripts easy way to interface the Git
173 version control system. The modules have an easy and well-tested way
174 to call arbitrary Git commands; in the future, the interface will also
175 provide specialized methods for doing easily operations which are not
176 totally trivial to do over the generic command interface.
177
178 %description -n perl-Git -l pl.UTF-8
179 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
180 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
181 wywoływać dowolne polecenia Gita; w przyszłości interfejs
182 udostępni także specjalne metody do łatwego wykonywania operacji
183 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
184 poleceń.
185
186 %package -n vim-syntax-gitcommit
187 Summary:        Vim syntax: gitcommit
188 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
189 Group:          Applications/Editors/Vim
190 # for _vimdatadir existence
191 Requires:       vim >= 4:6.3.058-3
192
193 %description -n vim-syntax-gitcommit
194 This plugin provides syntax highlighting for git's commit messages.
195
196 %description -n vim-syntax-gitcommit -l pl.UTF-8
197 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
198
199 %prep
200 %setup -q -n git-%{version}
201
202 %build
203 %{__aclocal}
204 %{__autoconf}
205 %configure \
206         --with-openssl
207
208 %{__make} \
209         INSTALLDIRS=vendor \
210         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
211         GITWEB_PROJECTROOT="/var/lib/git" \
212         GITWEB_CSS="/gitweb/gitweb.css" \
213         GITWEB_LOGO="/gitweb/git-logo.png" \
214         GITWEB_FAVICON="/gitweb/git-favicon.png"
215
216 %{__make} -C Documentation
217
218 %{?with_tests:%{__make} test}
219
220 %install
221 rm -rf $RPM_BUILD_ROOT
222 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
223 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
224 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
225 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
226
227 %{__make} install \
228         INSTALLDIRS=vendor \
229         DESTDIR=$RPM_BUILD_ROOT
230
231 %{__make} -C Documentation install \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 # header files and lib
235 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
236 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
237 install libgit.a $RPM_BUILD_ROOT%{_libdir}
238
239 # bash completion
240 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
241
242 # vim syntax
243 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
244
245 # gitweb
246 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
247 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
248 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
249 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
250 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
251
252 # gitview
253 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
254
255 # remove unneeded files
256 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
257 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
263 %webapp_register apache %{webapp}
264
265 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
266 %webapp_unregister apache %{webapp}
267
268 %triggerin gitweb -- apache < 2.2.0, apache-base
269 %webapp_register httpd %{webapp}
270
271 %triggerun gitweb -- apache < 2.2.0, apache-base
272 %webapp_unregister httpd %{webapp}
273
274 %files
275 %defattr(644,root,root,755)
276 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
277 %attr(755,root,root) %{_bindir}/git
278 %attr(755,root,root) %{_bindir}/git-*
279 %{_mandir}/man1/git-*.1*
280 %{_mandir}/man5/gitattributes.5*
281 %{_mandir}/man5/gitignore.5*
282 %{_mandir}/man5/gitmodules.5*
283 %{_mandir}/man7/git.7*
284 %{_datadir}/%{name}
285 %{_datadir}/git-gui
286 %{_sharedstatedir}/git
287
288 %files devel
289 %defattr(644,root,root,755)
290 %{_includedir}/*
291 %{_libdir}/*.a
292
293 %files gitk
294 %defattr(644,root,root,755)
295 %doc Documentation/gitk.html
296 %attr(755,root,root) %{_bindir}/gitk
297 %{_mandir}/man1/gitk.1*
298
299 %files gitweb
300 %defattr(644,root,root,755)
301 %doc gitweb/{README,INSTALL}
302 %dir %{webappdir}
303 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
304 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
305 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
306 %attr(755,root,root) %{cgibindir}/gitweb.cgi
307 %{appdir}
308
309 %files gitview
310 %defattr(644,root,root,755)
311 %doc contrib/gitview/gitview.txt
312 %attr(755,root,root) %{_bindir}/gitview
313
314 %files -n bash-completion-git
315 %defattr(644,root,root,755)
316 %{_sysconfdir}/bash_completion.d/*
317
318 %files -n perl-Git
319 %defattr(644,root,root,755)
320 %{perl_vendorlib}/Git.pm
321 %{_mandir}/man3/Git.3pm*
322
323 %files -n vim-syntax-gitcommit
324 %defattr(644,root,root,755)
325 %doc contrib/vim/README
326 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.107955 seconds and 4 git commands to generate.