]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.5.3.5
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.3.5
10 Release:        1
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  3fdff0bdb3638fce1c4bc6795ed81fb3
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc >= 7.1.2-3
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 %{?with_tests:BuildRequires:    pdksh >= 5.2.14-46}
27 BuildRequires:  python
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildRequires:  rpmbuild(macros) >= 1.264
30 BuildRequires:  xmlto
31 BuildRequires:  zlib-devel
32 Requires:       coreutils
33 Requires:       curl
34 Requires:       diffutils
35 Requires:       findutils
36 Requires:       grep
37 Requires:       openssh-clients
38 Requires:       perl-Error
39 Requires:       rcs
40 Requires:       sed
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 # html docs have links to txt files
44 %define         _noautocompressdoc      *.txt
45
46 %define         webapp          gitweb
47 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
48 %define         appdir          %{_datadir}/%{webapp}
49 %define         cgibindir       %{_prefix}/lib/cgi-bin
50
51 %description
52 "git" can mean anything, depending on your mood.
53
54  - random three-letter combination that is pronounceable, and not
55    actually used by any common UNIX command. The fact that it is a
56    mispronunciation of "get" may or may not be relevant.
57  - stupid. contemptible and despicable. simple. Take your pick from the
58    dictionary of slang.
59  - "global information tracker": you're in a good mood, and it actually
60    works for you. Angels sing, and a light suddenly fills the room.
61  - "goddamn idiotic truckload of sh*t": when it breaks
62
63 This is a stupid (but extremely fast) directory content manager. It
64 doesn't do a whole lot, but what it 'does' do is track directory
65 contents efficiently.
66
67 %description -l pl.UTF-8
68 "git" może oznaczać cokolwiek, w zależności od nastroju.
69
70 - losową kombinację trzech liter, która jest wymawialna i
71   właściwie nie używana przez żadne popularne polecenie uniksowe.
72   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
73   mieć znaczenia.
74 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
75 - "global information tracker" (narzędzie do globalnego śledzenia
76   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
77   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
78 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
79   g*) - kiedy się zepsuje.
80
81 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
82 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
83 katalogu.
84
85 %package devel
86 Summary:        Header files for git-core
87 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
88 Group:          Development/Libraries
89
90 %description devel
91 Header files for git-core.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe dla git-core.
95
96 %package gitk
97 Summary:        Tcl/Tk interface to the Git version control system
98 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
99 Group:          Development/Tools
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       tk
102
103 %description gitk
104 Displays changes in a repository or a selected set of commits. This
105 includes visualizing the commit graph, showing information related to
106 each commit, and the files in the trees of each revision.
107
108 Historically, gitk was the first repository browser. It's written in
109 Tcl/Tk and started off in a separate repository but was later merged
110 into the main git repository.
111
112 %description gitk -l pl.UTF-8
113 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
114 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
115 związanych z każdym z commitów oraz listę plików dla każdej
116 rewizji.
117
118 Z punktu widzenia historii, gitk był pierwszą przeglądarką
119 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
120 w osobnym repozytorium, ale z czasem został włączony do głównego
121 repozytorium gita.
122
123 %package gitweb
124 Summary:        Web frontend to git
125 Summary(pl.UTF-8):      Webowy frontend do git
126 Group:          Development/Tools
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       webapps
129
130 %description gitweb
131 This package provides a web interface for browsing git repositories.
132
133 %description gitweb -l pl.UTF-8
134 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
135
136 %package gitview
137 Summary:        A GTK+ based repository browser for git
138 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
139 Group:          Development/Tools
140 Requires:       %{name} = %{version}-%{release}
141 #Requires:      pytongowe mambo dżambo
142
143 %description gitview
144 A GTK+ based repository browser for git.
145
146 %description gitview -l pl.UTF-8
147 Oparta na GTK+ przeglądarka repozytorium gita.
148
149 %package -n bash-completion-git
150 Summary:        bash-completion for git
151 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
152 Group:          Applications/Shell
153 Requires:       bash-completion
154
155 %description -n bash-completion-git
156 This package provides bash-completion for git.
157
158 %description -n bash-completion-git -l pl.UTF-8
159 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
160
161 %package -n perl-Git
162 Summary:        Perl interface to the Git version control system
163 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
164 Group:          Development/Languages/Perl
165 Requires:       %{name} = %{version}-%{release}
166 Obsoletes:      perl-git-core
167
168 %description -n perl-Git
169 This module provides Perl scripts easy way to interface the Git
170 version control system. The modules have an easy and well-tested way
171 to call arbitrary Git commands; in the future, the interface will also
172 provide specialized methods for doing easily operations which are not
173 totally trivial to do over the generic command interface.
174
175 %description -n perl-Git -l pl.UTF-8
176 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
177 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
178 wywoływać dowolne polecenia Gita; w przyszłości interfejs
179 udostępni także specjalne metody do łatwego wykonywania operacji
180 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
181 poleceń.
182
183 %package -n vim-syntax-gitcommit
184 Summary:        Vim syntax: gitcommit
185 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
186 Group:          Applications/Editors/Vim
187 # for _vimdatadir existence
188 Requires:       vim >= 4:6.3.058-3
189
190 %description -n vim-syntax-gitcommit
191 This plugin provides syntax highlighting for git's commit messages.
192
193 %description -n vim-syntax-gitcommit -l pl.UTF-8
194 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
195
196 %prep
197 %setup -q -n git-%{version}
198
199 %build
200 %{__aclocal}
201 %{__autoconf}
202 %configure \
203         --with-openssl
204
205 %{__make} \
206         INSTALLDIRS=vendor \
207         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
208         GITWEB_PROJECTROOT="/var/lib/git" \
209         GITWEB_CSS="/gitweb/gitweb.css" \
210         GITWEB_LOGO="/gitweb/git-logo.png" \
211         GITWEB_FAVICON="/gitweb/git-favicon.png"
212
213 %{__make} -C Documentation
214
215 %{?with_tests:%{__make} test}
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
220 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
221 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
222 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
223
224 %{__make} install \
225         INSTALLDIRS=vendor \
226         DESTDIR=$RPM_BUILD_ROOT
227
228 %{__make} -C Documentation install \
229         DESTDIR=$RPM_BUILD_ROOT
230
231 # header files and lib
232 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
233 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
234 install libgit.a $RPM_BUILD_ROOT%{_libdir}
235
236 # bash completion
237 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
238
239 # vim syntax
240 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
241
242 # gitweb
243 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
244 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
245 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
246 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
247 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
248
249 # gitview
250 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
251
252 # remove unneeded files
253 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
254 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
255
256 %clean
257 rm -rf $RPM_BUILD_ROOT
258
259 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
260 %webapp_register apache %{webapp}
261
262 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
263 %webapp_unregister apache %{webapp}
264
265 %triggerin gitweb -- apache < 2.2.0, apache-base
266 %webapp_register httpd %{webapp}
267
268 %triggerun gitweb -- apache < 2.2.0, apache-base
269 %webapp_unregister httpd %{webapp}
270
271 %files
272 %defattr(644,root,root,755)
273 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
274 %attr(755,root,root) %{_bindir}/git
275 %attr(755,root,root) %{_bindir}/git-*
276 %{_mandir}/man1/git-*.1*
277 %{_mandir}/man5/gitattributes.5*
278 %{_mandir}/man5/gitignore.5*
279 %{_mandir}/man5/gitmodules.5*
280 %{_mandir}/man7/git.7*
281 %{_datadir}/%{name}
282 %{_datadir}/git-gui
283 %{_sharedstatedir}/git
284
285 %files devel
286 %defattr(644,root,root,755)
287 %{_includedir}/*
288 %{_libdir}/*.a
289
290 %files gitk
291 %defattr(644,root,root,755)
292 %doc Documentation/gitk.html
293 %attr(755,root,root) %{_bindir}/gitk
294 %{_mandir}/man1/gitk.1*
295
296 %files gitweb
297 %defattr(644,root,root,755)
298 %doc gitweb/{README,INSTALL}
299 %dir %{webappdir}
300 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
301 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
302 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
303 %attr(755,root,root) %{cgibindir}/gitweb.cgi
304 %{appdir}
305
306 %files gitview
307 %defattr(644,root,root,755)
308 %doc contrib/gitview/gitview.txt
309 %attr(755,root,root) %{_bindir}/gitview
310
311 %files -n bash-completion-git
312 %defattr(644,root,root,755)
313 %{_sysconfdir}/bash_completion.d/*
314
315 %files -n perl-Git
316 %defattr(644,root,root,755)
317 %{perl_vendorlib}/Git.pm
318 %{_mandir}/man3/Git.3pm*
319
320 %files -n vim-syntax-gitcommit
321 %defattr(644,root,root,755)
322 %doc contrib/vim/README
323 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.091985 seconds and 4 git commands to generate.