]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- fix group for bash-completion; adapter back
[packages/git-core.git] / git-core.spec
1
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The stupid content tracker
8 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
9 Name:           git-core
10 Version:        1.5.3.5
11 Release:        1
12 License:        GPL v2
13 Group:          Development/Tools
14 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
15 # Source0-md5:  3fdff0bdb3638fce1c4bc6795ed81fb3
16 Source1:        %{name}-gitweb.conf
17 Source2:        %{name}-gitweb-httpd.conf
18 URL:            http://git.or.cz/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.264
29 BuildRequires:  zlib-devel
30 %if %{with doc}
31 BuildRequires:  asciidoc >= 7.1.2-3
32 BuildRequires:  xmlto
33 %endif
34 %if %{with tests}
35 BuildRequires:  cvs
36 BuildRequires:  pdksh >= 5.2.14-46
37 %endif
38 Requires:       coreutils
39 Requires:       cpio
40 Requires:       curl
41 Requires:       diffutils
42 Requires:       findutils
43 Requires:       grep
44 Requires:       openssh-clients
45 Requires:       perl-Error
46 Requires:       rcs
47 Requires:       sed
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 # html docs have links to txt files
51 %define         _noautocompressdoc      *.txt
52
53 %define         webapp          gitweb
54 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
55 %define         appdir          %{_datadir}/%{webapp}
56 %define         cgibindir       %{_prefix}/lib/cgi-bin
57
58 %description
59 "git" can mean anything, depending on your mood.
60
61  - random three-letter combination that is pronounceable, and not
62    actually used by any common UNIX command. The fact that it is a
63    mispronunciation of "get" may or may not be relevant.
64  - stupid. contemptible and despicable. simple. Take your pick from the
65    dictionary of slang.
66  - "global information tracker": you're in a good mood, and it actually
67    works for you. Angels sing, and a light suddenly fills the room.
68  - "goddamn idiotic truckload of sh*t": when it breaks
69
70 This is a stupid (but extremely fast) directory content manager. It
71 doesn't do a whole lot, but what it 'does' do is track directory
72 contents efficiently.
73
74 %description -l pl.UTF-8
75 "git" może oznaczać cokolwiek, w zależności od nastroju.
76
77 - losową kombinację trzech liter, która jest wymawialna i
78   właściwie nie używana przez żadne popularne polecenie uniksowe.
79   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
80   mieć znaczenia.
81 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
82 - "global information tracker" (narzędzie do globalnego śledzenia
83   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
84   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
85 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
86   g*) - kiedy się zepsuje.
87
88 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
89 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
90 katalogu.
91
92 %package devel
93 Summary:        Header files for git-core
94 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
95 Group:          Development/Libraries
96
97 %description devel
98 Header files for git-core.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe dla git-core.
102
103 %package gitk
104 Summary:        Tcl/Tk interface to the Git version control system
105 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
106 Group:          Development/Tools
107 Requires:       %{name} = %{version}-%{release}
108 Requires:       tk
109
110 %description gitk
111 Displays changes in a repository or a selected set of commits. This
112 includes visualizing the commit graph, showing information related to
113 each commit, and the files in the trees of each revision.
114
115 Historically, gitk was the first repository browser. It's written in
116 Tcl/Tk and started off in a separate repository but was later merged
117 into the main git repository.
118
119 %description gitk -l pl.UTF-8
120 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
121 to wizualizację grafu commitów, wyświetlanie informacji związanych z
122 każdym z commitów oraz listę plików dla każdej rewizji.
123
124 Z punktu widzenia historii, gitk był pierwszą przeglądarką
125 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
126 osobnym repozytorium, ale z czasem został włączony do głównego
127 repozytorium gita.
128
129 %package gitweb
130 Summary:        Web frontend to git
131 Summary(pl.UTF-8):      Webowy frontend do git
132 Group:          Development/Tools
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       webapps
135
136 %description gitweb
137 This package provides a web interface for browsing git repositories.
138
139 %description gitweb -l pl.UTF-8
140 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
141
142 %package gitview
143 Summary:        A GTK+ based repository browser for git
144 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
145 Group:          Development/Tools
146 Requires:       %{name} = %{version}-%{release}
147 #Requires:      pytongowe mambo dżambo
148
149 %description gitview
150 A GTK+ based repository browser for git.
151
152 %description gitview -l pl.UTF-8
153 Oparta na GTK+ przeglądarka repozytorium gita.
154
155 %package -n bash-completion-git
156 Summary:        bash-completion for git
157 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
158 Group:          Applications/Shells
159 Requires:       bash-completion
160
161 %description -n bash-completion-git
162 This package provides bash-completion for git.
163
164 %description -n bash-completion-git -l pl.UTF-8
165 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
166
167 %package -n perl-Git
168 Summary:        Perl interface to the Git version control system
169 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
170 Group:          Development/Languages/Perl
171 Requires:       %{name} = %{version}-%{release}
172 Obsoletes:      perl-git-core
173
174 %description -n perl-Git
175 This module provides Perl scripts easy way to interface the Git
176 version control system. The modules have an easy and well-tested way
177 to call arbitrary Git commands; in the future, the interface will also
178 provide specialized methods for doing easily operations which are not
179 totally trivial to do over the generic command interface.
180
181 %description -n perl-Git -l pl.UTF-8
182 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
183 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
184 dowolne polecenia Gita; w przyszłości interfejs udostępni także
185 specjalne metody do łatwego wykonywania operacji nietrywialnych do
186 wykonania przy użyciu ogólnego interfejsu poleceń.
187
188 %package -n vim-syntax-gitcommit
189 Summary:        Vim syntax: gitcommit
190 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
191 Group:          Applications/Editors/Vim
192 # for _vimdatadir existence
193 Requires:       vim >= 4:6.3.058-3
194
195 %description -n vim-syntax-gitcommit
196 This plugin provides syntax highlighting for git's commit messages.
197
198 %description -n vim-syntax-gitcommit -l pl.UTF-8
199 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
200
201 %prep
202 %setup -q -n git-%{version}
203
204 %build
205 %{__aclocal}
206 %{__autoconf}
207 %configure \
208         --with-openssl
209
210 %{__make} \
211         INSTALLDIRS=vendor \
212         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
213         GITWEB_PROJECTROOT="/var/lib/git" \
214         GITWEB_CSS="/gitweb/gitweb.css" \
215         GITWEB_LOGO="/gitweb/git-logo.png" \
216         GITWEB_FAVICON="/gitweb/git-favicon.png"
217
218 %{?with_doc:%{__make} -C Documentation}
219
220 %{?with_tests:%{__make} test}
221
222 %install
223 rm -rf $RPM_BUILD_ROOT
224 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
225 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
226 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
227 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
228
229 %{__make} install \
230         INSTALLDIRS=vendor \
231         DESTDIR=$RPM_BUILD_ROOT
232
233 %if %{with doc}
234 %{__make} -C Documentation install \
235         DESTDIR=$RPM_BUILD_ROOT
236 %endif
237
238 # header files and lib
239 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
240 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
241 install libgit.a $RPM_BUILD_ROOT%{_libdir}
242
243 # bash completion
244 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
245
246 # vim syntax
247 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
248
249 # gitweb
250 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
251 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
252 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
253 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
254 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
255
256 # gitview
257 install contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
258
259 # remove unneeded files
260 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
261 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
267 %webapp_register apache %{webapp}
268
269 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
270 %webapp_unregister apache %{webapp}
271
272 %triggerin gitweb -- apache < 2.2.0, apache-base
273 %webapp_register httpd %{webapp}
274
275 %triggerun gitweb -- apache < 2.2.0, apache-base
276 %webapp_unregister httpd %{webapp}
277
278 %files
279 %defattr(644,root,root,755)
280 %doc README contrib
281 %if %{with doc}
282 %doc Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical
283 %{_mandir}/man1/git-*.1*
284 %{_mandir}/man5/gitattributes.5*
285 %{_mandir}/man5/gitignore.5*
286 %{_mandir}/man5/gitmodules.5*
287 %{_mandir}/man7/git.7*
288 %endif
289 %attr(755,root,root) %{_bindir}/git
290 %attr(755,root,root) %{_bindir}/git-*
291 %{_datadir}/%{name}
292 %{_datadir}/git-gui
293 %{_sharedstatedir}/git
294
295 %files devel
296 %defattr(644,root,root,755)
297 %{_includedir}/*
298 %{_libdir}/*.a
299
300 %files gitk
301 %defattr(644,root,root,755)
302 %if %{with doc}
303 %doc Documentation/gitk.html
304 %{_mandir}/man1/gitk.1*
305 %endif
306 %attr(755,root,root) %{_bindir}/gitk
307
308 %files gitweb
309 %defattr(644,root,root,755)
310 %doc gitweb/{README,INSTALL}
311 %dir %{webappdir}
312 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
313 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
314 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
315 %attr(755,root,root) %{cgibindir}/gitweb.cgi
316 %{appdir}
317
318 %files gitview
319 %defattr(644,root,root,755)
320 %doc contrib/gitview/gitview.txt
321 %attr(755,root,root) %{_bindir}/gitview
322
323 %files -n bash-completion-git
324 %defattr(644,root,root,755)
325 %{_sysconfdir}/bash_completion.d/*
326
327 %files -n perl-Git
328 %defattr(644,root,root,755)
329 %{perl_vendorlib}/Git.pm
330 %{_mandir}/man3/Git.3pm*
331
332 %files -n vim-syntax-gitcommit
333 %defattr(644,root,root,755)
334 %doc contrib/vim/README
335 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.080354 seconds and 4 git commands to generate.