]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.7.5.3
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Distributed version control system focused on speed, effectivity and usability
9 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
10 Name:           git-core
11 Release:        1
12 Version:        1.7.5.3
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  5b5a5e6c1c5c05db6b8dd33e6f3acea4
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}-gitweb-lighttpd.conf
20 Source4:        %{name}.sysconfig
21 Source5:        %{name}.inet
22 Source6:        %{name}.init
23 Patch0:         %{name}-tests.patch
24 Patch1:         %{name}-key-bindings.patch
25 Patch2:         %{name}-sysconfdir.patch
26 URL:            http://git-scm.com/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  curl-devel
30 BuildRequires:  expat-devel
31 BuildRequires:  gettext-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  perl-Error > 0.15
34 BuildRequires:  perl-base
35 BuildRequires:  python-devel
36 BuildRequires:  rpm-perlprov >= 4.1-13
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.264
39 BuildRequires:  tcl
40 BuildRequires:  zlib-devel
41 %if %{with doc}
42 BuildRequires:  asciidoc >= 7.1.2-3
43 BuildRequires:  docbook-dtd45-xml
44 BuildRequires:  xmlto
45 %endif
46 %if %{with tests}
47 %if %{with tests_cvs}
48 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
49 BuildRequires:  cvs-gnu-client < 1.13
50 BuildRequires:  cvs-gnu-client >= 1.12
51 %endif
52 BuildRequires:  pdksh >= 5.2.14-46
53 %endif
54 Requires:       coreutils
55 Requires:       diffutils
56 Requires:       findutils
57 Requires:       grep
58 Requires:       openssh-clients
59 Requires:       perl-Error
60 Requires:       perl-Git = %{version}-%{release}
61 Requires:       sed
62 Suggests:       git-core-cvs
63 Suggests:       git-core-svn
64 Suggests:       less
65 Suggests:       rsync
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 # html docs have links to txt files
69 %define         _noautocompressdoc      *.txt
70
71 %define         webapp          gitweb
72 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
73 %define         appdir          %{_datadir}/%{webapp}
74 %define         cgibindir       %{_prefix}/lib/cgi-bin
75
76 %description
77 "git" can mean anything, depending on your mood.
78
79 - random three-letter combination that is pronounceable, and not
80   actually used by any common UNIX command. The fact that it is a
81   mispronunciation of "get" may or may not be relevant.
82 - stupid. contemptible and despicable. simple. Take your pick from the
83   dictionary of slang.
84 - "global information tracker": you're in a good mood, and it actually
85   works for you. Angels sing, and a light suddenly fills the room.
86 - "goddamn idiotic truckload of sh*t": when it breaks
87
88 This is a stupid (but extremely fast) directory content manager. It
89 doesn't do a whole lot, but what it 'does' do is track directory
90 contents efficiently.
91
92 %description -l pl.UTF-8
93 "git" może oznaczać cokolwiek, w zależności od nastroju.
94
95 - losową kombinację trzech liter, która jest wymawialna i właściwie
96   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
97   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
98 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
99 - "global information tracker" (narzędzie do globalnego śledzenia
100   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
101   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
102 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
103   g*) - kiedy się zepsuje.
104
105 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
106 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
107 katalogu.
108
109 %package doc
110 Summary:        Documentation for git-core
111 Summary(pl.UTF-8):      Dokumentacja do git-core
112 Group:          Documentation
113
114 %description doc
115 Documentation for git-core.
116
117 %description doc -l pl.UTF-8
118 Dokumentacja do git-core.
119
120 %description doc -l fr.UTF-8
121 Javadoc pour git-core.
122
123 %package daemon-inetd
124 Summary:        Files necessary to run git-daemon as an inetd service
125 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
126 Group:          Networking/Daemons
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       setup >= 2.4.11-1
129 Provides:       git-core-daemon
130 Obsoletes:      git-core-daemon
131 Obsoletes:      git-core-daemon-standalone
132
133 %description daemon-inetd
134 Git-daemon is a really simple TCP git daemon that can serve git
135 repositories. This package provides all necessarry files to run
136 git-daemon as an inetd service.
137
138 %description daemon-inetd -l pl.UTF-8
139 Git-daemon to prosty demon git korzystający z protokołu TCP do
140 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
141 do uruchomienia git-demona w trybie usługi inetd.
142
143 %package daemon-standalone
144 Summary:        Files necessary to run git-daemon as a standalone service
145 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
146 Group:          Networking/Daemons
147 Requires:       %{name} = %{version}-%{release}
148 Provides:       git-core-daemon
149 Obsoletes:      git-core-daemon
150 Obsoletes:      git-core-daemon-inetd
151
152 %description daemon-standalone
153 Git-daemon is a really simple TCP git daemon that can serve git
154 repositories. This package provides all necessarry files to run
155 git-daemon as an standalone service.
156
157 %description daemon-standalone -l pl.UTF-8
158 Git-daemon to prosty demon git korzystający z protokołu TCP do
159 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
160 do uruchomienia git-daemona w trybie usługi samodzielnej.
161
162 %package devel
163 Summary:        Header files for git-core
164 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
165 Group:          Development/Libraries
166 Requires:       zlib-devel
167
168 %description devel
169 Header files for git-core.
170
171 %description devel -l pl.UTF-8
172 Pliki nagłówkowe dla git-core.
173
174 %package gitk
175 Summary:        Tcl/Tk interface to the Git version control system
176 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
177 Group:          Development/Tools
178 Requires:       %{name} = %{version}-%{release}
179 Requires:       tk
180
181 %description gitk
182 gitk displays changes in a repository or a selected set of commits.
183 This includes visualizing the commit graph, showing information
184 related to each commit, and the files in the trees of each revision.
185
186 Historically, gitk was the first repository browser. It's written in
187 Tcl/Tk and started off in a separate repository but was later merged
188 into the main git repository.
189
190 %description gitk -l pl.UTF-8
191 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
192 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
193 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
194
195 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
196 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
197 osobnym repozytorium, ale z czasem został włączony do głównego
198 repozytorium gita.
199
200 %package gitweb
201 Summary:        Web frontend to git
202 Summary(pl.UTF-8):      Frontend WWW do gita
203 Group:          Development/Tools
204 Requires:       %{name} = %{version}-%{release}
205 Requires:       webapps
206 Requires:       webserver(alias)
207 Requires:       webserver(cgi)
208
209 %description gitweb
210 This package provides a web interface for browsing git repositories.
211
212 %description gitweb -l pl.UTF-8
213 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
214
215 %package gitview
216 Summary:        A GTK+ based repository browser for git
217 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
218 Group:          Development/Tools
219 Requires:       %{name} = %{version}-%{release}
220 Requires:       python >= 1:2.4
221 Requires:       python-pycairo >= 1.0
222 Requires:       python-pygobject
223 Requires:       python-pygtk-gtk >= 2:2.8
224 Suggests:       python-gnome-desktop-gtksourceview
225
226 %description gitview
227 A GTK+ based repository browser for git.
228
229 %description gitview -l pl.UTF-8
230 Oparta na GTK+ przeglądarka repozytorium gita.
231
232 %package gui
233 Summary:        Tcl/Tk interface to the Git version control system
234 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
235 Group:          Development/Tools
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       tk
238 Requires:       xdg-utils
239 Suggests:       meld
240
241 %description gui
242 Displays changes in a repository or a selected set of commits. This
243 includes visualizing the commit graph, showing information related to
244 each commit, and the files in the trees of each revision.
245
246 Historically, gitk was the first repository browser. It's written in
247 Tcl/Tk and started off in a separate repository but was later merged
248 into the main git repository.
249
250 %description gui -l pl.UTF-8
251 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
252 to wizualizację grafu commitów, wyświetlanie informacji związanych z
253 każdym z commitów oraz listę plików dla każdej rewizji.
254
255 Z punktu widzenia historii, gitk był pierwszą przeglądarką
256 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
257 osobnym repozytorium, ale z czasem został włączony do głównego
258 repozytorium gita.
259
260 %package svn
261 Summary:        Subversion support for Git
262 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
263 Group:          Development/Tools
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       perl-Term-ReadKey
266
267 %description svn
268 Subversion support for Git.
269
270 %description svn -l pl.UTF-8
271 Obsługa Subversion dla Gita.
272
273 %package cvs
274 Summary:        CVS support for Git
275 Summary(pl.UTF-8):      Obsługa CVS dla Gita
276 Group:          Development/Tools
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       cvsps >= 2.1-2
279 Requires:       rcs
280
281 %description cvs
282 CVS support for Git.
283
284 %description cvs -l pl.UTF-8
285 Obsługa CVS dla Gita.
286
287 %package arch
288 Summary:        Git tools for importing Arch repositories
289 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
290 Group:          Development/Tools
291 Requires:       %{name} = %{version}-%{release}
292 Requires:       tla
293
294 %description arch
295 Git tools for importing Arch repositories.
296
297 %description arch -l pl.UTF-8
298 Narzędzia Gita do importowania repozytoriów Archa.
299
300 %package email
301 Summary:        Git tools for sending email
302 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
303 Group:          Development/Tools
304 Requires:       %{name} = %{version}-%{release}
305
306 %description email
307 Git tools for sending email.
308
309 %description email -l pl.UTF-8
310 Narzędzia Gita do wysyłania poczty.
311
312 %package -n bash-completion-git
313 Summary:        bash-completion for git
314 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
315 Group:          Applications/Shells
316 Requires:       bash-completion
317
318 %description -n bash-completion-git
319 This package provides bash-completion for git.
320
321 %description -n bash-completion-git -l pl.UTF-8
322 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
323
324 %package -n perl-Git
325 Summary:        Perl interface to the Git version control system
326 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
327 Group:          Development/Languages/Perl
328 Obsoletes:      perl-git-core
329
330 %description -n perl-Git
331 This module provides Perl scripts easy way to interface the Git
332 version control system. The modules have an easy and well-tested way
333 to call arbitrary Git commands; in the future, the interface will also
334 provide specialized methods for doing easily operations which are not
335 totally trivial to do over the generic command interface.
336
337 %description -n perl-Git -l pl.UTF-8
338 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
339 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
340 dowolne polecenia Gita; w przyszłości interfejs udostępni także
341 specjalne metody do łatwego wykonywania operacji nietrywialnych do
342 wykonania przy użyciu ogólnego interfejsu poleceń.
343
344 %package -n python-Git
345 Summary:        Python interface to the Git version control system
346 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
347 Group:          Development/Languages/Python
348
349 %description -n python-Git
350 This module provides Python scripts easy way to interface the Git
351 version control system.
352
353 %description -n python-Git -l pl.UTF-8
354 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
355 wersji Git.
356
357 %package -n vim-syntax-gitcommit
358 Summary:        Vim syntax: gitcommit
359 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
360 Group:          Applications/Editors/Vim
361 # for _vimdatadir existence
362 Requires:       vim-rt >= 4:6.3.058-3
363
364 %description -n vim-syntax-gitcommit
365 This plugin provides syntax highlighting for git's commit messages.
366
367 %description -n vim-syntax-gitcommit -l pl.UTF-8
368 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
369
370 %prep
371 %setup -q -n git-%{version}
372 %patch0 -p1
373 %patch1 -p0
374 %patch2 -p1
375
376 %build
377 %{__aclocal}
378 %{__autoconf}
379 %configure \
380         --sysconfdir=%{_sysconfdir}/git-core \
381         --with-openssl
382
383 echo "BLK_SHA1=1" >> config.mak
384
385 %{__make} \
386         INSTALLDIRS=vendor \
387         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
388         GITWEB_PROJECTROOT="/var/lib/git" \
389         GITWEB_CSS="/gitweb/gitweb.css" \
390         GITWEB_LOGO="/gitweb/git-logo.png" \
391         GITWEB_FAVICON="/gitweb/git-favicon.png" \
392         V=1
393
394 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
395 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
396
397 %if %{with tests}
398 %if %{without tests_cvs}
399 rm t/t*cvs*.sh || :
400 %endif
401 %{__make} test
402 %endif
403
404 %install
405 rm -rf $RPM_BUILD_ROOT
406 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
407 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
408 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
409 install -d $RPM_BUILD_ROOT%{_sysconfdir}/git-core
410 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
411 [init]
412         templatedir = /etc/git-core/templates
413 EOF
414
415 %{__make} install \
416         INSTALLDIRS=vendor \
417         DESTDIR=$RPM_BUILD_ROOT
418
419 %if %{with doc}
420 %{__make} -C Documentation install \
421         DESTDIR=$RPM_BUILD_ROOT
422 %endif
423
424 # copy templates except sample hooks
425 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
426 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
427
428 # header files and lib
429 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
430 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
431 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
432 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
433 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
434
435 # bash completion
436 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
437 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
438
439 # vim syntax
440 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
441 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
442 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
443 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
444 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
445 autocmd BufNewFile,BufRead .msg.[0-9]*
446         \ if getline(1) =~ '^From.*# This line is ignored.$' |
447         \   setf gitsendemail |
448         \ endif
449 autocmd BufNewFile,BufRead *.git/**
450         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
451         \   setf git |
452         \ endif
453 EOF
454
455 # gitweb
456 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
457 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
458 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
459 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
460 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
461
462 # gitview
463 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
464
465 # git-daemon related files
466 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
467 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
468 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
469
470 # paths cleanup
471 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
472 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
473
474 # hardlink
475 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
476 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
477 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
478 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
479
480 # remove unneeded files
481 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
482 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
483 %py_postclean
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %post daemon-inetd
489 %service -q rc-inetd reload
490
491 %postun daemon-inetd
492 if [ "$1" = "0" ]; then
493         %service -q rc-inetd reload
494 fi
495
496 %post daemon-standalone
497 /sbin/chkconfig --add git-daemon
498 %service git-daemon restart "git-daemon"
499
500 %preun daemon-standalone
501 if [ "$1" = "0" ]; then
502         %service git-daemon stop
503         /sbin/chkconfig --del git-daemon
504 fi
505
506 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
507 %webapp_register apache %{webapp}
508
509 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
510 %webapp_unregister apache %{webapp}
511
512 %triggerin gitweb -- apache < 2.2.0, apache-base
513 %webapp_register httpd %{webapp}
514
515 %triggerun gitweb -- apache < 2.2.0, apache-base
516 %webapp_unregister httpd %{webapp}
517
518 %triggerin gitweb -- lighttpd
519 %webapp_register lighttpd %{webapp}
520
521 %triggerun gitweb -- lighttpd
522 %webapp_unregister lighttpd %{webapp}
523
524 %files
525 %defattr(644,root,root,755)
526 %doc README contrib
527 %attr(755,root,root) %{_bindir}/git
528 %attr(755,root,root) %{_bindir}/git-receive-pack
529 %attr(755,root,root) %{_bindir}/git-shell
530 %attr(755,root,root) %{_bindir}/git-upload-archive
531 %attr(755,root,root) %{_bindir}/git-upload-pack
532 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/git-core
533
534 %if %{with doc}
535 %{_mandir}/man1/git-*.1*
536 %exclude %{_mandir}/man1/git-svn.1*
537 %exclude %{_mandir}/man1/git-cvs*.1*
538 %{_mandir}/man1/git.1*
539 %{_mandir}/man5/gitattributes.5*
540 %{_mandir}/man5/githooks.5*
541 %{_mandir}/man5/gitignore.5*
542 %{_mandir}/man5/gitmodules.5*
543 %{_mandir}/man5/gitrepository-layout.5*
544 %{_mandir}/man7/gitcli.7*
545 %{_mandir}/man7/gitcore-tutorial.7*
546 %{_mandir}/man7/gitdiffcore.7*
547 %{_mandir}/man7/gitglossary.7*
548 %{_mandir}/man7/gitrevisions.7*
549 %{_mandir}/man7/gittutorial-2.7*
550 %{_mandir}/man7/gittutorial.7*
551 %{_mandir}/man7/gitworkflows.7*
552 %endif
553
554 %dir %{_libdir}/%{name}
555 %attr(755,root,root) %{_libdir}/%{name}/*-*
556 %attr(755,root,root) %{_libdir}/%{name}/git
557
558 %exclude %{_libdir}/%{name}/git-gui
559 %exclude %{_libdir}/%{name}/git-svn
560 %exclude %{_libdir}/%{name}/git-archimport
561 %exclude %{_libdir}/%{name}/git-cvs*
562 %exclude %{_libdir}/%{name}/*email*
563
564 %{_datadir}/%{name}
565
566 %{_localstatedir}/lib/git
567
568 %if %{with doc}
569 %files doc
570 %defattr(644,root,root,755)
571 %doc Documentation/RelNotes*
572 %doc Documentation/*.html Documentation/howto Documentation/technical
573 %endif
574
575 %files daemon-inetd
576 %defattr(644,root,root,755)
577 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
578
579 %files daemon-standalone
580 %defattr(644,root,root,755)
581 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
582 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
583
584 %files devel
585 %defattr(644,root,root,755)
586 %{_includedir}/git-core
587 %{_libdir}/libgit.a
588 %{_libdir}/libgit_xdiff.a
589
590 %files gitk
591 %defattr(644,root,root,755)
592 %if %{with doc}
593 %{_mandir}/man1/gitk.1*
594 %endif
595 %attr(755,root,root) %{_bindir}/gitk
596 %dir %{_datadir}/gitk
597 %dir %{_datadir}/gitk/lib
598 %dir %{_datadir}/gitk/lib/msgs
599 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
600 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
601 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
602 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
603 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
604 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
605 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
606 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
607 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
608
609 %files gitweb
610 %defattr(644,root,root,755)
611 %doc gitweb/{README,INSTALL}
612 %dir %{webappdir}
613 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
614 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
615 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
616 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
617 %attr(755,root,root) %{cgibindir}/gitweb.cgi
618 %{appdir}
619
620 %files gitview
621 %defattr(644,root,root,755)
622 %doc contrib/gitview/gitview.txt
623 %attr(755,root,root) %{_bindir}/gitview
624
625 %files gui
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/%{name}/git-gui
628 %dir %{_datadir}/git-gui
629 %dir %{_datadir}/git-gui/lib
630 %dir %{_datadir}/git-gui/lib/msgs
631 %{_datadir}/git-gui/lib/git-gui.ico
632 %{_datadir}/git-gui/lib/tclIndex
633 %{_datadir}/git-gui/lib/*.js
634 %{_datadir}/git-gui/lib/*.tcl
635 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
636 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
637 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
638 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
639 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
640 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
641 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
642 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
643 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
644 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
645 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
646
647 %files svn
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/%{name}/git-svn
650 %if %{with doc}
651 %{_mandir}/man1/git-svn.1*
652 %endif
653
654 %files cvs
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/git-cvsserver
657 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
658 %if %{with doc}
659 %{_mandir}/man1/git-cvs*.1*
660 %{_mandir}/man7/gitcvs-migration.7*
661 %endif
662
663 %files arch
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
666 %if %{with doc}
667 %{_mandir}/man1/git-archimport.1*
668 %endif
669
670 %files email
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/%{name}/*email*
673 %if %{with doc}
674 %{_mandir}/man1/*email*.1*
675 %endif
676
677 %files -n bash-completion-git
678 %defattr(644,root,root,755)
679 %{_sysconfdir}/bash_completion.d/*
680
681 %files -n perl-Git
682 %defattr(644,root,root,755)
683 %{perl_vendorlib}/Git.pm
684 %{_mandir}/man3/Git.3pm*
685
686 %files -n python-Git
687 %defattr(644,root,root,755)
688 %dir %{py_sitescriptdir}/git_remote_helpers
689 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
690 %dir %{py_sitescriptdir}/git_remote_helpers/git
691 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
692 %if "%{py_ver}" > "2.4"
693 %{py_sitescriptdir}/git_remote_helpers*.egg-info
694 %endif
695
696 %files -n vim-syntax-gitcommit
697 %defattr(644,root,root,755)
698 %doc contrib/vim/README
699 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.130616 seconds and 3 git commands to generate.