]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
c438151888483a0d0ddf3e72351c6ec4de3efb98
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 # - gitk subpackage?
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The stupid content tracker
6 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
7 Name:           git-core
8 Version:        1.5.2.1
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Tools
12 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
13 # Source0-md5:  0a39e786a12974cbe7b14f2fe92dc163
14 URL:            http://git.or.cz/
15 BuildRequires:  asciidoc
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  curl-devel
19 BuildRequires:  expat-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  perl-Error
22 BuildRequires:  perl-base
23 BuildRequires:  python
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  xmlto
26 BuildRequires:  zlib-devel
27 Requires:       coreutils
28 Requires:       curl
29 Requires:       diffutils
30 Requires:       findutils
31 Requires:       grep
32 Requires:       openssh-clients
33 Requires:       perl-Error
34 Requires:       rcs
35 Requires:       sed
36 Requires:       tk
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 "git" can mean anything, depending on your mood.
41
42  - random three-letter combination that is pronounceable, and not
43    actually used by any common UNIX command. The fact that it is a
44    mispronunciation of "get" may or may not be relevant.
45  - stupid. contemptible and despicable. simple. Take your pick from the
46    dictionary of slang.
47  - "global information tracker": you're in a good mood, and it actually
48    works for you. Angels sing, and a light suddenly fills the room.
49  - "goddamn idiotic truckload of sh*t": when it breaks
50
51 This is a stupid (but extremely fast) directory content manager. It
52 doesn't do a whole lot, but what it 'does' do is track directory
53 contents efficiently.
54
55 %description -l pl.UTF-8
56 "git" może oznaczać cokolwiek, w zależności od nastroju.
57
58 - losową kombinację trzech liter, która jest wymawialna i właściwie
59   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
60   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
61 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
62 - "global information tracker" (narzędzie do globalnego śledzenia
63   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
64   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
65 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
66   g*) - kiedy się zepsuje.
67
68 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
69 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
70 katalogu.
71
72 %package devel
73 Summary:        Header files for git-core
74 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
75 Group:          Development/Libraries
76
77 %description devel
78 Header files for git-core.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe dla git-core.
82
83 %package -n perl-Git
84 Summary:        Perl interface to the Git version control system
85 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
86 Group:          Development/Languages/Perl
87 Requires:       %{name} = %{version}-%{release}
88 Obsoletes:      perl-git-core
89
90 %description -n perl-Git
91 This module provides Perl scripts easy way to interface the Git
92 version control system. The modules have an easy and well-tested way
93 to call arbitrary Git commands; in the future, the interface will also
94 provide specialized methods for doing easily operations which are not
95 totally trivial to do over the generic command interface.
96
97 %description -n perl-Git -l pl.UTF-8
98 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
99 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
100 dowolne polecenia Gita; w przyszłości interfejs udostępni także
101 specjalne metody do łatwego wykonywania operacji nietrywialnych do
102 wykonania przy użyciu ogólnego interfejsu poleceń.
103
104 %prep
105 %setup -q -n git-%{version}
106
107 %build
108 %{__aclocal}
109 %{__autoconf}
110 %configure \
111         --with-openssl
112
113 %{__make} \
114         INSTALLDIRS=vendor
115
116 %{__make} -C Documentation
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
121
122 %{__make} install \
123         INSTALLDIRS=vendor \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %{__make} -C Documentation install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
130 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
131
132 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
133 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc README Documentation/*.html Documentation/howto Documentation/technical
141 %attr(755,root,root) %{_bindir}/*
142 %{_mandir}/man*/*
143 %{_datadir}/%{name}
144 %{_datadir}/git-gui
145
146 %files devel
147 %defattr(644,root,root,755)
148 %{_includedir}/*
149
150 %files -n perl-Git
151 %defattr(644,root,root,755)
152 %{perl_vendorlib}/Git.pm
153 %{_mandir}/man3/*
This page took 0.030382 seconds and 2 git commands to generate.