]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
bzr, hg, p4 subpackages
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        Distributed version control system focused on speed, effectivity and usability
11 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
12 Name:           git-core
13 Version:        1.8.5.3
14 Release:        2
15 License:        GPL v2
16 Group:          Development/Tools
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  57b966065882f83ef5879620a1e329ca
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 Patch3:         cherry-picked-commitlog.patch
29 Patch4:         %{name}-svn-exit-errors.patch
30 URL:            http://git-scm.com/
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 BuildRequires:  curl-devel
34 BuildRequires:  expat-devel
35 BuildRequires:  gettext-devel
36 BuildRequires:  openssl-devel
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  perl-Error > 0.15
39 BuildRequires:  perl-base
40 BuildRequires:  python-devel
41 BuildRequires:  rpm-perlprov >= 4.1-13
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  rpmbuild(macros) >= 1.264
44 BuildRequires:  tcl
45 BuildRequires:  zlib-devel
46 %if %{with doc}
47 BuildRequires:  asciidoc >= 7.1.2-3
48 BuildRequires:  docbook-dtd45-xml
49 BuildRequires:  xmlto
50 %endif
51 %if %{with tests}
52 %if %{with tests_cvs}
53 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
54 BuildRequires:  cvs-gnu-client < 1.13
55 BuildRequires:  cvs-gnu-client >= 1.12
56 %endif
57 %{?with_tests_svn:BuildRequires:  subversion}
58 Conflicts:      pdksh < 5.2.14-46
59 %endif
60 Requires:       coreutils
61 Requires:       diffutils
62 Requires:       findutils
63 Requires:       grep
64 Requires:       openssh-clients
65 Requires:       perl-Error
66 Requires:       perl-Git = %{version}-%{release}
67 Requires:       sed
68 Suggests:       git-core-bzr
69 Suggests:       git-core-cvs
70 Suggests:       git-core-hg
71 Suggests:       git-core-p4
72 Suggests:       git-core-svn
73 Suggests:       less
74 Suggests:       rsync
75 Obsoletes:      python-Git
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 # html docs have links to txt files
79 %define         _noautocompressdoc      *.txt
80
81 %define         webapp          gitweb
82 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
83 %define         appdir          %{_datadir}/%{webapp}
84 %define         cgibindir       %{_prefix}/lib/cgi-bin
85 %define         bash_compdir    %{_datadir}/bash-completion/completions
86
87 %description
88 "git" can mean anything, depending on your mood.
89
90 - random three-letter combination that is pronounceable, and not
91   actually used by any common UNIX command. The fact that it is a
92   mispronunciation of "get" may or may not be relevant.
93 - stupid. contemptible and despicable. simple. Take your pick from the
94   dictionary of slang.
95 - "global information tracker": you're in a good mood, and it actually
96   works for you. Angels sing, and a light suddenly fills the room.
97 - "goddamn idiotic truckload of sh*t": when it breaks
98
99 This is a stupid (but extremely fast) directory content manager. It
100 doesn't do a whole lot, but what it 'does' do is track directory
101 contents efficiently.
102
103 %description -l pl.UTF-8
104 "git" może oznaczać cokolwiek, w zależności od nastroju.
105
106 - losową kombinację trzech liter, która jest wymawialna i właściwie
107   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
108   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
109 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
110 - "global information tracker" (narzędzie do globalnego śledzenia
111   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
112   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
113 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
114   g*) - kiedy się zepsuje.
115
116 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
117 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
118 katalogu.
119
120 %package doc
121 Summary:        Documentation for git-core
122 Summary(pl.UTF-8):      Dokumentacja do git-core
123 Group:          Documentation
124
125 %description doc
126 Documentation for git-core.
127
128 %description doc -l pl.UTF-8
129 Dokumentacja do git-core.
130
131 %description doc -l fr.UTF-8
132 Javadoc pour git-core.
133
134 %package daemon-inetd
135 Summary:        Files necessary to run git-daemon as an inetd service
136 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
137 Group:          Networking/Daemons
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       setup >= 2.4.11-1
140 Provides:       git-core-daemon
141 Obsoletes:      git-core-daemon
142 Obsoletes:      git-core-daemon-standalone
143
144 %description daemon-inetd
145 Git-daemon is a really simple TCP git daemon that can serve git
146 repositories. This package provides all necessarry files to run
147 git-daemon as an inetd service.
148
149 %description daemon-inetd -l pl.UTF-8
150 Git-daemon to prosty demon git korzystający z protokołu TCP do
151 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
152 do uruchomienia git-demona w trybie usługi inetd.
153
154 %package daemon-standalone
155 Summary:        Files necessary to run git-daemon as a standalone service
156 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
157 Group:          Networking/Daemons
158 Requires:       %{name} = %{version}-%{release}
159 Provides:       git-core-daemon
160 Obsoletes:      git-core-daemon
161 Obsoletes:      git-core-daemon-inetd
162
163 %description daemon-standalone
164 Git-daemon is a really simple TCP git daemon that can serve git
165 repositories. This package provides all necessarry files to run
166 git-daemon as an standalone service.
167
168 %description daemon-standalone -l pl.UTF-8
169 Git-daemon to prosty demon git korzystający z protokołu TCP do
170 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
171 do uruchomienia git-daemona w trybie usługi samodzielnej.
172
173 %package devel
174 Summary:        Git library with header files
175 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
176 Group:          Development/Libraries
177 Requires:       zlib-devel
178
179 %description devel
180 Git library with header files.
181
182 %description devel -l pl.UTF-8
183 Biblioteka Gita oraz pliki nagłówkowe.
184
185 %package gitk
186 Summary:        Tcl/Tk interface to the Git version control system
187 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
188 Group:          Development/Tools
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       tk
191
192 %description gitk
193 gitk displays changes in a repository or a selected set of commits.
194 This includes visualizing the commit graph, showing information
195 related to each commit, and the files in the trees of each revision.
196
197 Historically, gitk was the first repository browser. It's written in
198 Tcl/Tk and started off in a separate repository but was later merged
199 into the main git repository.
200
201 %description gitk -l pl.UTF-8
202 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
203 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
204 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
205
206 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
207 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
208 osobnym repozytorium, ale z czasem został włączony do głównego
209 repozytorium gita.
210
211 %package gitweb
212 Summary:        Web frontend to git
213 Summary(pl.UTF-8):      Frontend WWW do gita
214 Group:          Development/Tools
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       webapps
217 Requires:       webserver(access)
218 Requires:       webserver(alias)
219 Requires:       webserver(cgi)
220 Suggests:       webserver(setenv)
221
222 %description gitweb
223 This package provides a web interface for browsing git repositories.
224
225 %description gitweb -l pl.UTF-8
226 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
227
228 %package gitview
229 Summary:        A GTK+ based repository browser for git
230 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
231 Group:          Development/Tools
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       python >= 1:2.4
234 Requires:       python-pycairo >= 1.0
235 Requires:       python-pygobject
236 Requires:       python-pygtk-gtk >= 2:2.8
237 Suggests:       python-gnome-desktop-gtksourceview
238
239 %description gitview
240 A GTK+ based repository browser for git.
241
242 %description gitview -l pl.UTF-8
243 Oparta na GTK+ przeglądarka repozytorium gita.
244
245 %package gui
246 Summary:        Tcl/Tk interface to the Git version control system
247 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
248 Group:          Development/Tools
249 Requires:       %{name} = %{version}-%{release}
250 Requires:       tk
251 Requires:       xdg-utils
252 Suggests:       meld
253
254 %description gui
255 Displays changes in a repository or a selected set of commits. This
256 includes visualizing the commit graph, showing information related to
257 each commit, and the files in the trees of each revision.
258
259 Historically, gitk was the first repository browser. It's written in
260 Tcl/Tk and started off in a separate repository but was later merged
261 into the main git repository.
262
263 %description gui -l pl.UTF-8
264 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
265 to wizualizację grafu commitów, wyświetlanie informacji związanych z
266 każdym z commitów oraz listę plików dla każdej rewizji.
267
268 Z punktu widzenia historii, gitk był pierwszą przeglądarką
269 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
270 osobnym repozytorium, ale z czasem został włączony do głównego
271 repozytorium gita.
272
273 %package bzr
274 Summary:        Git tools for working with bzr repositories
275 Group:          Development/Tools
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       bzr
278
279 %description bzr
280 Git tools for working with bzr repositories.
281
282 %package hg
283 Summary:        Git tools for working with mercurial repositories
284 Group:          Development/Tools
285 Requires:       %{name} = %{version}-%{release}
286 Requires:       mercurial >= 1.8
287
288 %description hg
289 Git tools for working with mercurial repositories.
290
291 %package p4
292 Summary:        Git tools for working with Perforce depots
293 Group:          Development/Tools
294 Requires:       %{name} = %{version}-%{release}
295
296 %description p4
297 Git tools for working with Perforce depots.
298
299 %package svn
300 Summary:        Subversion support for Git
301 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
302 Group:          Development/Tools
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       perl-Encode
305 Requires:       perl-Term-ReadKey
306
307 %description svn
308 Subversion support for Git.
309
310 %description svn -l pl.UTF-8
311 Obsługa Subversion dla Gita.
312
313 %package cvs
314 Summary:        CVS support for Git
315 Summary(pl.UTF-8):      Obsługa CVS dla Gita
316 Group:          Development/Tools
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       cvsps >= 2.1-2
319 Requires:       rcs
320
321 %description cvs
322 CVS support for Git.
323
324 %description cvs -l pl.UTF-8
325 Obsługa CVS dla Gita.
326
327 %package arch
328 Summary:        Git tools for importing Arch repositories
329 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
330 Group:          Development/Tools
331 Requires:       %{name} = %{version}-%{release}
332 Requires:       tla
333
334 %description arch
335 Git tools for importing Arch repositories.
336
337 %description arch -l pl.UTF-8
338 Narzędzia Gita do importowania repozytoriów Archa.
339
340 %package email
341 Summary:        Git tools for sending email
342 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
343 Group:          Development/Tools
344 Requires:       %{name} = %{version}-%{release}
345
346 %description email
347 Git tools for sending email.
348
349 %description email -l pl.UTF-8
350 Narzędzia Gita do wysyłania poczty.
351
352 %package -n bash-completion-git
353 Summary:        bash-completion for git
354 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
355 Group:          Applications/Shells
356 Requires:       %{name} = %{version}-%{release}
357 Requires:       bash-completion >= 2.0
358
359 %description -n bash-completion-git
360 This package provides bash-completion for git.
361
362 %description -n bash-completion-git -l pl.UTF-8
363 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
364
365 %package -n perl-Git
366 Summary:        Perl interface to the Git version control system
367 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
368 Group:          Development/Languages/Perl
369 Obsoletes:      perl-git-core
370
371 %description -n perl-Git
372 This module provides Perl scripts easy way to interface the Git
373 version control system. The modules have an easy and well-tested way
374 to call arbitrary Git commands; in the future, the interface will also
375 provide specialized methods for doing easily operations which are not
376 totally trivial to do over the generic command interface.
377
378 %description -n perl-Git -l pl.UTF-8
379 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
380 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
381 dowolne polecenia Gita; w przyszłości interfejs udostępni także
382 specjalne metody do łatwego wykonywania operacji nietrywialnych do
383 wykonania przy użyciu ogólnego interfejsu poleceń.
384
385 %package -n vim-syntax-gitcommit
386 Summary:        Vim syntax: gitcommit
387 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
388 Group:          Applications/Editors/Vim
389 Requires:       %{name} = %{version}-%{release}
390 # for _vimdatadir existence
391 Requires:       vim-rt >= 4:6.3.058-3
392
393 %description -n vim-syntax-gitcommit
394 This plugin provides syntax highlighting for git's commit messages.
395
396 %description -n vim-syntax-gitcommit -l pl.UTF-8
397 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
398
399 %prep
400 %setup -q -n git-%{version}
401 %patch0 -p1
402 %patch1 -p0
403 %patch2 -p1
404 %patch3 -p1
405 %patch4 -p1
406
407 %build
408 %{__aclocal}
409 %{__autoconf}
410 %configure \
411         --sysconfdir=%{_sysconfdir}/git-core \
412         %{?with_pcre:--with-libpcre} \
413         --with-openssl
414
415 echo "BLK_SHA1=1" >> config.mak
416
417 %{__make} \
418         INSTALLDIRS=vendor \
419         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
420         GITWEB_PROJECTROOT="/var/lib/git" \
421         GITWEB_CSS="/gitweb/gitweb.css" \
422         GITWEB_LOGO="/gitweb/git-logo.png" \
423         GITWEB_FAVICON="/gitweb/git-favicon.png" \
424         V=1
425
426 %if %{with doc}
427 %{__make} -C Documentation \
428         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
429         V=1
430 %endif
431
432 %if %{with tests}
433 %if %{without tests_cvs}
434 %{__rm} t/t*cvs*.sh || :
435 %endif
436 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
437 %endif
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
442 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
443 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
444 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
445 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
446 [init]
447         templatedir = %{_sysconfdir}/%{name}/templates
448 EOF
449
450 %{__make} install \
451         INSTALLDIRS=vendor \
452         DESTDIR=$RPM_BUILD_ROOT
453
454 %if %{with doc}
455 %{__make} -C Documentation install \
456         DESTDIR=$RPM_BUILD_ROOT
457 %endif
458
459 # copy templates except sample hooks
460 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
461 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
462
463 # header files and lib
464 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
465 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
466 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
467 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
468 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
469 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
470 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
471 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
472
473 # bash completion
474 install -d $RPM_BUILD_ROOT%{bash_compdir}
475 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
476
477 # Install bzr and hg remote helpers from contrib
478 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
479
480 # vim syntax
481 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
482 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
483 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
484 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
485 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
486 autocmd BufNewFile,BufRead .msg.[0-9]*
487         \ if getline(1) =~ '^From.*# This line is ignored.$' |
488         \   setf gitsendemail |
489         \ endif
490 autocmd BufNewFile,BufRead *.git/**
491         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
492         \   setf git |
493         \ endif
494 EOF
495
496 # gitweb
497 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
498 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
499 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
500 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
501 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
502 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
503
504 # gitview
505 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
506
507 # git-daemon related files
508 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
509 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
510 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
511
512 # paths cleanup
513 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
514 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
515
516 # hardlink
517 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
518 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
519 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
520 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
521
522 # remove unneeded files
523 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
524 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
525 %py_postclean
526
527 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
528 %find_lang git
529
530 %clean
531 rm -rf $RPM_BUILD_ROOT
532
533 %post daemon-inetd
534 %service -q rc-inetd reload
535
536 %postun daemon-inetd
537 if [ "$1" = "0" ]; then
538         %service -q rc-inetd reload
539 fi
540
541 %post daemon-standalone
542 /sbin/chkconfig --add git-daemon
543 %service git-daemon restart "git-daemon"
544
545 %preun daemon-standalone
546 if [ "$1" = "0" ]; then
547         %service git-daemon stop
548         /sbin/chkconfig --del git-daemon
549 fi
550
551 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
552 %webapp_register apache %{webapp}
553
554 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
555 %webapp_unregister apache %{webapp}
556
557 %triggerin gitweb -- apache < 2.2.0, apache-base
558 %webapp_register httpd %{webapp}
559
560 %triggerun gitweb -- apache < 2.2.0, apache-base
561 %webapp_unregister httpd %{webapp}
562
563 %triggerin gitweb -- lighttpd
564 %webapp_register lighttpd %{webapp}
565
566 %triggerun gitweb -- lighttpd
567 %webapp_unregister lighttpd %{webapp}
568
569 %files -f git.lang
570 %defattr(644,root,root,755)
571 %doc README contrib
572 %attr(755,root,root) %{_bindir}/git
573 %attr(755,root,root) %{_bindir}/git-receive-pack
574 %attr(755,root,root) %{_bindir}/git-shell
575 %attr(755,root,root) %{_bindir}/git-upload-archive
576 %attr(755,root,root) %{_bindir}/git-upload-pack
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
578
579 %if %{with doc}
580 %{_mandir}/man1/git-*.1*
581 %exclude %{_mandir}/man1/git-archimport.1*
582 %exclude %{_mandir}/man1/git-svn.1*
583 %exclude %{_mandir}/man1/git-cvs*.1*
584 %exclude %{_mandir}/man1/git-imap-send*.1*
585 %exclude %{_mandir}/man1/*email*.1*
586 %{_mandir}/man1/git.1*
587 %{_mandir}/man1/gitremote-helpers.1*
588 %{_mandir}/man5/gitattributes.5*
589 %{_mandir}/man5/githooks.5*
590 %{_mandir}/man5/gitignore.5*
591 %{_mandir}/man5/gitmodules.5*
592 %{_mandir}/man5/gitrepository-layout.5*
593 %{_mandir}/man7/gitcli.7*
594 %{_mandir}/man7/gitcore-tutorial.7*
595 %{_mandir}/man7/gitcredentials.7*
596 %{_mandir}/man7/gitdiffcore.7*
597 %{_mandir}/man7/gitglossary.7*
598 %{_mandir}/man7/gitnamespaces.7*
599 %{_mandir}/man7/gitrevisions.7*
600 %{_mandir}/man7/gittutorial-2.7*
601 %{_mandir}/man7/gittutorial.7*
602 %{_mandir}/man7/gitworkflows.7*
603 %endif
604
605 %dir %{_libdir}/%{name}
606 %attr(755,root,root) %{_libdir}/%{name}/*-*
607 %attr(755,root,root) %{_libdir}/%{name}/git
608 %dir %{_libdir}/%{name}/mergetools
609 %{_libdir}/%{name}/mergetools/*
610
611 %{_datadir}/%{name}
612 %{_localstatedir}/lib/git
613
614 # subpackages
615 %exclude %{_libdir}/%{name}/*email*
616 %exclude %{_libdir}/%{name}/*p4*
617 %exclude %{_libdir}/%{name}/git-archimport
618 %exclude %{_libdir}/%{name}/git-cvs*
619 %exclude %{_libdir}/%{name}/git-gui
620 %exclude %{_libdir}/%{name}/git-imap-send
621 %exclude %{_libdir}/%{name}/git-instaweb
622 %exclude %{_libdir}/%{name}/git-remote-bzr
623 %exclude %{_libdir}/%{name}/git-remote-hg
624 %exclude %{_libdir}/%{name}/git-remote-testsvn
625 %exclude %{_libdir}/%{name}/git-svn
626 %exclude %{_libdir}/%{name}/mergetools/p4merge
627
628 %if %{with doc}
629 %files doc
630 %defattr(644,root,root,755)
631 %doc Documentation/RelNotes*
632 %doc Documentation/*.html Documentation/howto Documentation/technical
633 %endif
634
635 %files daemon-inetd
636 %defattr(644,root,root,755)
637 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
638
639 %files daemon-standalone
640 %defattr(644,root,root,755)
641 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
642 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
643
644 %files devel
645 %defattr(644,root,root,755)
646 %{_includedir}/%{name}
647 %{_libdir}/libgit.a
648 %{_libdir}/libgit_xdiff.a
649
650 %files gitk
651 %defattr(644,root,root,755)
652 %if %{with doc}
653 %{_mandir}/man1/gitk.1*
654 %endif
655 %attr(755,root,root) %{_bindir}/gitk
656 %dir %{_datadir}/gitk
657 %dir %{_datadir}/gitk/lib
658 %dir %{_datadir}/gitk/lib/msgs
659 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
660 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
661 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
662 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
663 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
664 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
665 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
666 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
667 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
668
669 %files gitweb
670 %defattr(644,root,root,755)
671 %doc gitweb/{README,INSTALL}
672 %dir %{webappdir}
673 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
674 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
675 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
676 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
677 %attr(755,root,root) %{cgibindir}/gitweb.cgi
678 %{appdir}
679 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
680 %if %{with doc}
681 %{_mandir}/man1/gitweb.1*
682 %{_mandir}/man5/gitweb.conf.5*
683 %endif
684
685 %files gitview
686 %defattr(644,root,root,755)
687 %doc contrib/gitview/gitview.txt
688 %attr(755,root,root) %{_bindir}/gitview
689
690 %files gui
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/%{name}/git-gui
693 %dir %{_datadir}/git-gui
694 %dir %{_datadir}/git-gui/lib
695 %dir %{_datadir}/git-gui/lib/msgs
696 %{_datadir}/git-gui/lib/git-gui.ico
697 %{_datadir}/git-gui/lib/tclIndex
698 %{_datadir}/git-gui/lib/*.js
699 %{_datadir}/git-gui/lib/*.tcl
700 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
701 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
702 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
703 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
704 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
705 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
706 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
707 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
708 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
709 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
710 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
711
712 %files bzr
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
715
716 %files hg
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
719
720 %files p4
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_libdir}/%{name}/git-p4
723 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
724
725 %files svn
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/%{name}/git-svn
728 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
729 %{perl_vendorlib}/Git/SVN
730 %{perl_vendorlib}/Git/SVN.pm
731 %if %{with doc}
732 %{_mandir}/man1/git-svn.1*
733 %endif
734
735 %files cvs
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_bindir}/git-cvsserver
738 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
739 %if %{with doc}
740 %{_mandir}/man1/git-cvs*.1*
741 %{_mandir}/man7/gitcvs-migration.7*
742 %endif
743
744 %files arch
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
747 %if %{with doc}
748 %{_mandir}/man1/git-archimport.1*
749 %endif
750
751 %files email
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
754 %attr(755,root,root) %{_libdir}/%{name}/*email*
755 %if %{with doc}
756 %{_mandir}/man1/*email*.1*
757 %{_mandir}/man1/*imap-send*.1*
758 %endif
759
760 %files -n bash-completion-git
761 %defattr(644,root,root,755)
762 %{bash_compdir}/git
763
764 %files -n perl-Git
765 %defattr(644,root,root,755)
766 %{perl_vendorlib}/Git.pm
767 %dir %{perl_vendorlib}/Git
768 %{perl_vendorlib}/Git/I18N.pm
769 %{perl_vendorlib}/Git/IndexInfo.pm
770 %{_mandir}/man3/Git*.3pm*
771
772 %files -n vim-syntax-gitcommit
773 %defattr(644,root,root,755)
774 %doc contrib/vim/README
775 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.215971 seconds and 3 git commands to generate.