]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
a61c46ba26861e89340e129743da828ff1946c3e
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Distributed version control system focused on speed, effectivity and usability
9 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
10 Name:           git-core
11 Version:        1.7.7.1
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 # Source0:      http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
17 # Source0-md5:  7cfb3e7ea585037272a7ad8e35f4ac0a
18 Source1:        %{name}-gitweb.conf
19 Source2:        %{name}-gitweb-httpd.conf
20 Source3:        %{name}-gitweb-lighttpd.conf
21 Source4:        %{name}.sysconfig
22 Source5:        %{name}.inet
23 Source6:        %{name}.init
24 Patch0:         %{name}-tests.patch
25 Patch1:         %{name}-key-bindings.patch
26 Patch2:         %{name}-sysconfdir.patch
27 URL:            http://git-scm.com/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  curl-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  gettext-devel
33 BuildRequires:  openssl-devel
34 BuildRequires:  perl-Error > 0.15
35 BuildRequires:  perl-base
36 BuildRequires:  python-devel
37 BuildRequires:  rpm-perlprov >= 4.1-13
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.264
40 BuildRequires:  tcl
41 BuildRequires:  zlib-devel
42 %if %{with doc}
43 BuildRequires:  asciidoc >= 7.1.2-3
44 BuildRequires:  docbook-dtd45-xml
45 BuildRequires:  xmlto
46 %endif
47 %if %{with tests}
48 %if %{with tests_cvs}
49 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
50 BuildRequires:  cvs-gnu-client < 1.13
51 BuildRequires:  cvs-gnu-client >= 1.12
52 %endif
53 Conflicts:      pdksh < 5.2.14-46
54 %endif
55 Requires:       coreutils
56 Requires:       diffutils
57 Requires:       findutils
58 Requires:       grep
59 Requires:       openssh-clients
60 Requires:       perl-Error
61 Requires:       perl-Git = %{version}-%{release}
62 Requires:       sed
63 Suggests:       git-core-cvs
64 Suggests:       git-core-svn
65 Suggests:       less
66 Suggests:       rsync
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 # html docs have links to txt files
70 %define         _noautocompressdoc      *.txt
71
72 %define         webapp          gitweb
73 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
74 %define         appdir          %{_datadir}/%{webapp}
75 %define         cgibindir       %{_prefix}/lib/cgi-bin
76
77 %description
78 "git" can mean anything, depending on your mood.
79
80 - random three-letter combination that is pronounceable, and not
81   actually used by any common UNIX command. The fact that it is a
82   mispronunciation of "get" may or may not be relevant.
83 - stupid. contemptible and despicable. simple. Take your pick from the
84   dictionary of slang.
85 - "global information tracker": you're in a good mood, and it actually
86   works for you. Angels sing, and a light suddenly fills the room.
87 - "goddamn idiotic truckload of sh*t": when it breaks
88
89 This is a stupid (but extremely fast) directory content manager. It
90 doesn't do a whole lot, but what it 'does' do is track directory
91 contents efficiently.
92
93 %description -l pl.UTF-8
94 "git" może oznaczać cokolwiek, w zależności od nastroju.
95
96 - losową kombinację trzech liter, która jest wymawialna i właściwie
97   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
98   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
99 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
100 - "global information tracker" (narzędzie do globalnego śledzenia
101   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
102   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
103 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
104   g*) - kiedy się zepsuje.
105
106 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
107 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
108 katalogu.
109
110 %package doc
111 Summary:        Documentation for git-core
112 Summary(pl.UTF-8):      Dokumentacja do git-core
113 Group:          Documentation
114
115 %description doc
116 Documentation for git-core.
117
118 %description doc -l pl.UTF-8
119 Dokumentacja do git-core.
120
121 %description doc -l fr.UTF-8
122 Javadoc pour git-core.
123
124 %package daemon-inetd
125 Summary:        Files necessary to run git-daemon as an inetd service
126 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
127 Group:          Networking/Daemons
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       setup >= 2.4.11-1
130 Provides:       git-core-daemon
131 Obsoletes:      git-core-daemon
132 Obsoletes:      git-core-daemon-standalone
133
134 %description daemon-inetd
135 Git-daemon is a really simple TCP git daemon that can serve git
136 repositories. This package provides all necessarry files to run
137 git-daemon as an inetd service.
138
139 %description daemon-inetd -l pl.UTF-8
140 Git-daemon to prosty demon git korzystający z protokołu TCP do
141 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
142 do uruchomienia git-demona w trybie usługi inetd.
143
144 %package daemon-standalone
145 Summary:        Files necessary to run git-daemon as a standalone service
146 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
147 Group:          Networking/Daemons
148 Requires:       %{name} = %{version}-%{release}
149 Provides:       git-core-daemon
150 Obsoletes:      git-core-daemon
151 Obsoletes:      git-core-daemon-inetd
152
153 %description daemon-standalone
154 Git-daemon is a really simple TCP git daemon that can serve git
155 repositories. This package provides all necessarry files to run
156 git-daemon as an standalone service.
157
158 %description daemon-standalone -l pl.UTF-8
159 Git-daemon to prosty demon git korzystający z protokołu TCP do
160 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
161 do uruchomienia git-daemona w trybie usługi samodzielnej.
162
163 %package devel
164 Summary:        Header files for git-core
165 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
166 Group:          Development/Libraries
167 Requires:       zlib-devel
168
169 %description devel
170 Header files for git-core.
171
172 %description devel -l pl.UTF-8
173 Pliki nagłówkowe dla git-core.
174
175 %package gitk
176 Summary:        Tcl/Tk interface to the Git version control system
177 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
178 Group:          Development/Tools
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       tk
181
182 %description gitk
183 gitk displays changes in a repository or a selected set of commits.
184 This includes visualizing the commit graph, showing information
185 related to each commit, and the files in the trees of each revision.
186
187 Historically, gitk was the first repository browser. It's written in
188 Tcl/Tk and started off in a separate repository but was later merged
189 into the main git repository.
190
191 %description gitk -l pl.UTF-8
192 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
193 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
194 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
195
196 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
197 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
198 osobnym repozytorium, ale z czasem został włączony do głównego
199 repozytorium gita.
200
201 %package gitweb
202 Summary:        Web frontend to git
203 Summary(pl.UTF-8):      Frontend WWW do gita
204 Group:          Development/Tools
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       webapps
207 Requires:       webserver(alias)
208 Requires:       webserver(cgi)
209
210 %description gitweb
211 This package provides a web interface for browsing git repositories.
212
213 %description gitweb -l pl.UTF-8
214 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
215
216 %package gitview
217 Summary:        A GTK+ based repository browser for git
218 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
219 Group:          Development/Tools
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       python >= 1:2.4
222 Requires:       python-pycairo >= 1.0
223 Requires:       python-pygobject
224 Requires:       python-pygtk-gtk >= 2:2.8
225 Suggests:       python-gnome-desktop-gtksourceview
226
227 %description gitview
228 A GTK+ based repository browser for git.
229
230 %description gitview -l pl.UTF-8
231 Oparta na GTK+ przeglądarka repozytorium gita.
232
233 %package gui
234 Summary:        Tcl/Tk interface to the Git version control system
235 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
236 Group:          Development/Tools
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       tk
239 Requires:       xdg-utils
240 Suggests:       meld
241
242 %description gui
243 Displays changes in a repository or a selected set of commits. This
244 includes visualizing the commit graph, showing information related to
245 each commit, and the files in the trees of each revision.
246
247 Historically, gitk was the first repository browser. It's written in
248 Tcl/Tk and started off in a separate repository but was later merged
249 into the main git repository.
250
251 %description gui -l pl.UTF-8
252 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
253 to wizualizację grafu commitów, wyświetlanie informacji związanych z
254 każdym z commitów oraz listę plików dla każdej rewizji.
255
256 Z punktu widzenia historii, gitk był pierwszą przeglądarką
257 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
258 osobnym repozytorium, ale z czasem został włączony do głównego
259 repozytorium gita.
260
261 %package svn
262 Summary:        Subversion support for Git
263 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
264 Group:          Development/Tools
265 Requires:       %{name} = %{version}-%{release}
266 Requires:       perl-Term-ReadKey
267
268 %description svn
269 Subversion support for Git.
270
271 %description svn -l pl.UTF-8
272 Obsługa Subversion dla Gita.
273
274 %package cvs
275 Summary:        CVS support for Git
276 Summary(pl.UTF-8):      Obsługa CVS dla Gita
277 Group:          Development/Tools
278 Requires:       %{name} = %{version}-%{release}
279 Requires:       cvsps >= 2.1-2
280 Requires:       rcs
281
282 %description cvs
283 CVS support for Git.
284
285 %description cvs -l pl.UTF-8
286 Obsługa CVS dla Gita.
287
288 %package arch
289 Summary:        Git tools for importing Arch repositories
290 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
291 Group:          Development/Tools
292 Requires:       %{name} = %{version}-%{release}
293 Requires:       tla
294
295 %description arch
296 Git tools for importing Arch repositories.
297
298 %description arch -l pl.UTF-8
299 Narzędzia Gita do importowania repozytoriów Archa.
300
301 %package email
302 Summary:        Git tools for sending email
303 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
304 Group:          Development/Tools
305 Requires:       %{name} = %{version}-%{release}
306
307 %description email
308 Git tools for sending email.
309
310 %description email -l pl.UTF-8
311 Narzędzia Gita do wysyłania poczty.
312
313 %package -n bash-completion-git
314 Summary:        bash-completion for git
315 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
316 Group:          Applications/Shells
317 Requires:       bash-completion
318
319 %description -n bash-completion-git
320 This package provides bash-completion for git.
321
322 %description -n bash-completion-git -l pl.UTF-8
323 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
324
325 %package -n perl-Git
326 Summary:        Perl interface to the Git version control system
327 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
328 Group:          Development/Languages/Perl
329 Obsoletes:      perl-git-core
330
331 %description -n perl-Git
332 This module provides Perl scripts easy way to interface the Git
333 version control system. The modules have an easy and well-tested way
334 to call arbitrary Git commands; in the future, the interface will also
335 provide specialized methods for doing easily operations which are not
336 totally trivial to do over the generic command interface.
337
338 %description -n perl-Git -l pl.UTF-8
339 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
340 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
341 dowolne polecenia Gita; w przyszłości interfejs udostępni także
342 specjalne metody do łatwego wykonywania operacji nietrywialnych do
343 wykonania przy użyciu ogólnego interfejsu poleceń.
344
345 %package -n python-Git
346 Summary:        Python interface to the Git version control system
347 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
348 Group:          Development/Languages/Python
349
350 %description -n python-Git
351 This module provides Python scripts easy way to interface the Git
352 version control system.
353
354 %description -n python-Git -l pl.UTF-8
355 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
356 wersji Git.
357
358 %package -n vim-syntax-gitcommit
359 Summary:        Vim syntax: gitcommit
360 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
361 Group:          Applications/Editors/Vim
362 # for _vimdatadir existence
363 Requires:       vim-rt >= 4:6.3.058-3
364
365 %description -n vim-syntax-gitcommit
366 This plugin provides syntax highlighting for git's commit messages.
367
368 %description -n vim-syntax-gitcommit -l pl.UTF-8
369 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
370
371 %prep
372 %setup -q -n git-%{version}
373 %patch0 -p1
374 %patch1 -p0
375 %patch2 -p1
376
377 %build
378 %{__aclocal}
379 %{__autoconf}
380 %configure \
381         --sysconfdir=%{_sysconfdir}/git-core \
382         --with-openssl
383
384 echo "BLK_SHA1=1" >> config.mak
385
386 %{__make} \
387         INSTALLDIRS=vendor \
388         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
389         GITWEB_PROJECTROOT="/var/lib/git" \
390         GITWEB_CSS="/gitweb/gitweb.css" \
391         GITWEB_LOGO="/gitweb/git-logo.png" \
392         GITWEB_FAVICON="/gitweb/git-favicon.png" \
393         V=1
394
395 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
396 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
397
398 %if %{with tests}
399 %if %{without tests_cvs}
400 rm t/t*cvs*.sh || :
401 %endif
402 %{__make} test
403 %endif
404
405 %install
406 rm -rf $RPM_BUILD_ROOT
407 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
408 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
409 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
410 install -d $RPM_BUILD_ROOT%{_sysconfdir}/git-core
411 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
412 [init]
413         templatedir = /etc/git-core/templates
414 EOF
415
416 %{__make} install \
417         INSTALLDIRS=vendor \
418         DESTDIR=$RPM_BUILD_ROOT
419
420 %if %{with doc}
421 %{__make} -C Documentation install \
422         DESTDIR=$RPM_BUILD_ROOT
423 %endif
424
425 # copy templates except sample hooks
426 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
427 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
428
429 # header files and lib
430 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
431 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
432 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
433 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
434 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
435
436 # bash completion
437 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
438 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
439
440 # vim syntax
441 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
442 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
443 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
444 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
445 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
446 autocmd BufNewFile,BufRead .msg.[0-9]*
447         \ if getline(1) =~ '^From.*# This line is ignored.$' |
448         \   setf gitsendemail |
449         \ endif
450 autocmd BufNewFile,BufRead *.git/**
451         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
452         \   setf git |
453         \ endif
454 EOF
455
456 # gitweb
457 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
458 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
459 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
460 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
461 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
462
463 # gitview
464 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
465
466 # git-daemon related files
467 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
468 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
469 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
470
471 # paths cleanup
472 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
473 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
474
475 # hardlink
476 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
477 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
478 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
479 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
480
481 # remove unneeded files
482 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
483 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
484 %py_postclean
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 %post daemon-inetd
490 %service -q rc-inetd reload
491
492 %postun daemon-inetd
493 if [ "$1" = "0" ]; then
494         %service -q rc-inetd reload
495 fi
496
497 %post daemon-standalone
498 /sbin/chkconfig --add git-daemon
499 %service git-daemon restart "git-daemon"
500
501 %preun daemon-standalone
502 if [ "$1" = "0" ]; then
503         %service git-daemon stop
504         /sbin/chkconfig --del git-daemon
505 fi
506
507 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
508 %webapp_register apache %{webapp}
509
510 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
511 %webapp_unregister apache %{webapp}
512
513 %triggerin gitweb -- apache < 2.2.0, apache-base
514 %webapp_register httpd %{webapp}
515
516 %triggerun gitweb -- apache < 2.2.0, apache-base
517 %webapp_unregister httpd %{webapp}
518
519 %triggerin gitweb -- lighttpd
520 %webapp_register lighttpd %{webapp}
521
522 %triggerun gitweb -- lighttpd
523 %webapp_unregister lighttpd %{webapp}
524
525 %files
526 %defattr(644,root,root,755)
527 %doc README contrib
528 %attr(755,root,root) %{_bindir}/git
529 %attr(755,root,root) %{_bindir}/git-receive-pack
530 %attr(755,root,root) %{_bindir}/git-shell
531 %attr(755,root,root) %{_bindir}/git-upload-archive
532 %attr(755,root,root) %{_bindir}/git-upload-pack
533 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/git-core
534
535 %if %{with doc}
536 %{_mandir}/man1/git-*.1*
537 %exclude %{_mandir}/man1/git-svn.1*
538 %exclude %{_mandir}/man1/git-cvs*.1*
539 %{_mandir}/man1/git.1*
540 %{_mandir}/man5/gitattributes.5*
541 %{_mandir}/man5/githooks.5*
542 %{_mandir}/man5/gitignore.5*
543 %{_mandir}/man5/gitmodules.5*
544 %{_mandir}/man5/gitrepository-layout.5*
545 %{_mandir}/man7/gitcli.7*
546 %{_mandir}/man7/gitcore-tutorial.7*
547 %{_mandir}/man7/gitdiffcore.7*
548 %{_mandir}/man7/gitglossary.7*
549 %{_mandir}/man7/gitnamespaces.7*
550 %{_mandir}/man7/gitrevisions.7*
551 %{_mandir}/man7/gittutorial-2.7*
552 %{_mandir}/man7/gittutorial.7*
553 %{_mandir}/man7/gitworkflows.7*
554 %endif
555
556 %dir %{_libdir}/%{name}
557 %attr(755,root,root) %{_libdir}/%{name}/*-*
558 %attr(755,root,root) %{_libdir}/%{name}/git
559 %{_libdir}/%{name}/mergetools
560
561 %exclude %{_libdir}/%{name}/git-gui
562 %exclude %{_libdir}/%{name}/git-svn
563 %exclude %{_libdir}/%{name}/git-archimport
564 %exclude %{_libdir}/%{name}/git-cvs*
565 %exclude %{_libdir}/%{name}/*email*
566
567 %{_datadir}/%{name}
568
569 %{_localstatedir}/lib/git
570
571 %if %{with doc}
572 %files doc
573 %defattr(644,root,root,755)
574 %doc Documentation/RelNotes*
575 %doc Documentation/*.html Documentation/howto Documentation/technical
576 %endif
577
578 %files daemon-inetd
579 %defattr(644,root,root,755)
580 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
581
582 %files daemon-standalone
583 %defattr(644,root,root,755)
584 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
585 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
586
587 %files devel
588 %defattr(644,root,root,755)
589 %{_includedir}/git-core
590 %{_libdir}/libgit.a
591 %{_libdir}/libgit_xdiff.a
592
593 %files gitk
594 %defattr(644,root,root,755)
595 %if %{with doc}
596 %{_mandir}/man1/gitk.1*
597 %endif
598 %attr(755,root,root) %{_bindir}/gitk
599 %dir %{_datadir}/gitk
600 %dir %{_datadir}/gitk/lib
601 %dir %{_datadir}/gitk/lib/msgs
602 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
603 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
604 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
605 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
606 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
607 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
608 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
609 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
610 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
611
612 %files gitweb
613 %defattr(644,root,root,755)
614 %doc gitweb/{README,INSTALL}
615 %dir %{webappdir}
616 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
617 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
618 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
619 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
620 %attr(755,root,root) %{cgibindir}/gitweb.cgi
621 %{appdir}
622
623 %files gitview
624 %defattr(644,root,root,755)
625 %doc contrib/gitview/gitview.txt
626 %attr(755,root,root) %{_bindir}/gitview
627
628 %files gui
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/%{name}/git-gui
631 %dir %{_datadir}/git-gui
632 %dir %{_datadir}/git-gui/lib
633 %dir %{_datadir}/git-gui/lib/msgs
634 %{_datadir}/git-gui/lib/git-gui.ico
635 %{_datadir}/git-gui/lib/tclIndex
636 %{_datadir}/git-gui/lib/*.js
637 %{_datadir}/git-gui/lib/*.tcl
638 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
639 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
640 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
641 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
642 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
643 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
644 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
645 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
646 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
647 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
648 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
649
650 %files svn
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/%{name}/git-svn
653 %if %{with doc}
654 %{_mandir}/man1/git-svn.1*
655 %endif
656
657 %files cvs
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_bindir}/git-cvsserver
660 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
661 %if %{with doc}
662 %{_mandir}/man1/git-cvs*.1*
663 %{_mandir}/man7/gitcvs-migration.7*
664 %endif
665
666 %files arch
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
669 %if %{with doc}
670 %{_mandir}/man1/git-archimport.1*
671 %endif
672
673 %files email
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/%{name}/*email*
676 %if %{with doc}
677 %{_mandir}/man1/*email*.1*
678 %endif
679
680 %files -n bash-completion-git
681 %defattr(644,root,root,755)
682 %{_sysconfdir}/bash_completion.d/*
683
684 %files -n perl-Git
685 %defattr(644,root,root,755)
686 %{perl_vendorlib}/Git.pm
687 %{_mandir}/man3/Git.3pm*
688
689 %files -n python-Git
690 %defattr(644,root,root,755)
691 %dir %{py_sitescriptdir}/git_remote_helpers
692 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
693 %dir %{py_sitescriptdir}/git_remote_helpers/git
694 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
695 %if "%{py_ver}" > "2.4"
696 %{py_sitescriptdir}/git_remote_helpers*.egg-info
697 %endif
698
699 %files -n vim-syntax-gitcommit
700 %defattr(644,root,root,755)
701 %doc contrib/vim/README
702 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.086199 seconds and 2 git commands to generate.