]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
drop now unccessary coreutils,diffutils,findutils requires
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        1.9.1
17 Release:        1
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  a71a1ee1418bd61d73182fba62b05fd3
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  gettext-devel
40 %if %{with gnome_keyring}
41 BuildRequires:  libgnome-keyring-devel
42 BuildRequires:  pkgconfig
43 %endif
44 BuildRequires:  openssl-devel
45 %{?with_pcre:BuildRequires:     pcre-devel}
46 BuildRequires:  perl-Error > 0.15
47 BuildRequires:  perl-base
48 BuildRequires:  python-devel
49 BuildRequires:  rpm-perlprov >= 4.1-13
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.673
52 BuildRequires:  tcl
53 BuildRequires:  zlib-devel
54 %if %{with doc}
55 BuildRequires:  asciidoc >= 7.1.2-3
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  xmlto
58 %endif
59 %if %{with tests}
60 %if %{with tests_cvs}
61 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62 BuildRequires:  cvs-gnu-client < 1.13
63 BuildRequires:  cvs-gnu-client >= 1.12
64 %endif
65 %{?with_tests_svn:BuildRequires:  subversion}
66 Conflicts:      pdksh < 5.2.14-46
67 %endif
68 Requires:       grep
69 Requires:       openssh-clients
70 Requires:       perl-Error
71 Requires:       perl-Git = %{version}-%{release}
72 Requires:       sed
73 Suggests:       git-core-bzr
74 Suggests:       git-core-cvs
75 Suggests:       git-core-hg
76 Suggests:       git-core-p4
77 Suggests:       git-core-svn
78 Suggests:       less
79 Suggests:       rsync
80 Obsoletes:      python-Git
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 # html docs have links to txt files
84 %define         _noautocompressdoc      *.txt
85
86 %define         webapp          gitweb
87 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
88 %define         appdir          %{_datadir}/%{webapp}
89 %define         cgibindir       %{_prefix}/lib/cgi-bin
90
91 %description
92 "git" can mean anything, depending on your mood.
93
94 - random three-letter combination that is pronounceable, and not
95   actually used by any common UNIX command. The fact that it is a
96   mispronunciation of "get" may or may not be relevant.
97 - stupid. contemptible and despicable. simple. Take your pick from the
98   dictionary of slang.
99 - "global information tracker": you're in a good mood, and it actually
100   works for you. Angels sing, and a light suddenly fills the room.
101 - "goddamn idiotic truckload of sh*t": when it breaks
102
103 This is a stupid (but extremely fast) directory content manager. It
104 doesn't do a whole lot, but what it 'does' do is track directory
105 contents efficiently.
106
107 %description -l pl.UTF-8
108 "git" może oznaczać cokolwiek, w zależności od nastroju.
109
110 - losową kombinację trzech liter, która jest wymawialna i właściwie
111   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
112   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
113 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
114 - "global information tracker" (narzędzie do globalnego śledzenia
115   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
116   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
117 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
118   g*) - kiedy się zepsuje.
119
120 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
121 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
122 katalogu.
123
124 %package doc
125 Summary:        Documentation for git-core
126 Summary(pl.UTF-8):      Dokumentacja do git-core
127 Group:          Documentation
128
129 %description doc
130 Documentation for git-core.
131
132 %description doc -l pl.UTF-8
133 Dokumentacja do git-core.
134
135 %description doc -l fr.UTF-8
136 Javadoc pour git-core.
137
138 %package daemon-inetd
139 Summary:        Files necessary to run git-daemon as an inetd service
140 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
141 Group:          Networking/Daemons
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       setup >= 2.4.11-1
144 Provides:       git-core-daemon
145 Obsoletes:      git-core-daemon
146 Obsoletes:      git-core-daemon-standalone
147
148 %description daemon-inetd
149 Git-daemon is a really simple TCP git daemon that can serve git
150 repositories. This package provides all necessarry files to run
151 git-daemon as an inetd service.
152
153 %description daemon-inetd -l pl.UTF-8
154 Git-daemon to prosty demon git korzystający z protokołu TCP do
155 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
156 do uruchomienia git-demona w trybie usługi inetd.
157
158 %package daemon-standalone
159 Summary:        Files necessary to run git-daemon as a standalone service
160 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
161 Group:          Networking/Daemons
162 Requires:       %{name} = %{version}-%{release}
163 Provides:       git-core-daemon
164 Obsoletes:      git-core-daemon
165 Obsoletes:      git-core-daemon-inetd
166
167 %description daemon-standalone
168 Git-daemon is a really simple TCP git daemon that can serve git
169 repositories. This package provides all necessarry files to run
170 git-daemon as an standalone service.
171
172 %description daemon-standalone -l pl.UTF-8
173 Git-daemon to prosty demon git korzystający z protokołu TCP do
174 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
175 do uruchomienia git-daemona w trybie usługi samodzielnej.
176
177 %package devel
178 Summary:        Git library with header files
179 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
180 Group:          Development/Libraries
181 Requires:       zlib-devel
182
183 %description devel
184 Git library with header files.
185
186 %description devel -l pl.UTF-8
187 Biblioteka Gita oraz pliki nagłówkowe.
188
189 %package gitk
190 Summary:        Tcl/Tk interface to the Git version control system
191 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
192 Group:          Development/Tools
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       tk
195
196 %description gitk
197 gitk displays changes in a repository or a selected set of commits.
198 This includes visualizing the commit graph, showing information
199 related to each commit, and the files in the trees of each revision.
200
201 Historically, gitk was the first repository browser. It's written in
202 Tcl/Tk and started off in a separate repository but was later merged
203 into the main git repository.
204
205 %description gitk -l pl.UTF-8
206 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
207 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
208 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
209
210 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
211 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
212 osobnym repozytorium, ale z czasem został włączony do głównego
213 repozytorium gita.
214
215 %package gitweb
216 Summary:        Web frontend to git
217 Summary(pl.UTF-8):      Frontend WWW do gita
218 Group:          Development/Tools
219 Requires:       %{name} = %{version}-%{release}
220 Requires:       webapps
221 Requires:       webserver(access)
222 Requires:       webserver(alias)
223 Requires:       webserver(cgi)
224 Suggests:       webserver(setenv)
225
226 %description gitweb
227 This package provides a web interface for browsing git repositories.
228
229 %description gitweb -l pl.UTF-8
230 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
231
232 %package gitview
233 Summary:        A GTK+ based repository browser for git
234 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
235 Group:          Development/Tools
236 Requires:       %{name} = %{version}-%{release}
237 Requires:       python >= 1:2.4
238 Requires:       python-pycairo >= 1.0
239 Requires:       python-pygobject
240 Requires:       python-pygtk-gtk >= 2:2.8
241 Suggests:       python-gnome-desktop-gtksourceview
242
243 %description gitview
244 A GTK+ based repository browser for git.
245
246 %description gitview -l pl.UTF-8
247 Oparta na GTK+ przeglądarka repozytorium gita.
248
249 %package gui
250 Summary:        Tcl/Tk interface to the Git version control system
251 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
252 Group:          Development/Tools
253 Requires:       %{name} = %{version}-%{release}
254 Requires:       tk
255 Requires:       xdg-utils
256 Suggests:       meld
257
258 %description gui
259 Displays changes in a repository or a selected set of commits. This
260 includes visualizing the commit graph, showing information related to
261 each commit, and the files in the trees of each revision.
262
263 Historically, gitk was the first repository browser. It's written in
264 Tcl/Tk and started off in a separate repository but was later merged
265 into the main git repository.
266
267 %description gui -l pl.UTF-8
268 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
269 to wizualizację grafu commitów, wyświetlanie informacji związanych z
270 każdym z commitów oraz listę plików dla każdej rewizji.
271
272 Z punktu widzenia historii, gitk był pierwszą przeglądarką
273 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
274 osobnym repozytorium, ale z czasem został włączony do głównego
275 repozytorium gita.
276
277 %package arch
278 Summary:        Git tools for importing Arch repositories
279 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
280 Group:          Development/Tools
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       tla
283
284 %description arch
285 Git tools for importing Arch repositories.
286
287 %description arch -l pl.UTF-8
288 Narzędzia Gita do importowania repozytoriów Archa.
289
290 %package bzr
291 Summary:        Git tools for working with bzr repositories
292 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
293 Group:          Development/Tools
294 Requires:       %{name} = %{version}-%{release}
295 Requires:       bzr
296
297 %description bzr
298 Git tools for working with bzr repositories.
299
300 %description bzr -l pl.UTF-8
301 Narzędzia Gita do pracy z repozytoriami bzr.
302
303 %package cvs
304 Summary:        CVS support for Git
305 Summary(pl.UTF-8):      Obsługa CVS dla Gita
306 Group:          Development/Tools
307 Requires:       %{name} = %{version}-%{release}
308 Requires:       cvsps >= 2.1-2
309 Requires:       rcs
310
311 %description cvs
312 CVS support for Git.
313
314 %description cvs -l pl.UTF-8
315 Obsługa CVS dla Gita.
316
317 %package hg
318 Summary:        Git tools for working with mercurial repositories
319 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
320 Group:          Development/Tools
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       mercurial >= 1.8
323
324 %description hg
325 Git tools for working with mercurial repositories.
326
327 %description hg -l pl.UTF-8
328 Narzędzia Gita do pracy z repozytoriami mercuriala.
329
330 %package p4
331 Summary:        Git tools for working with Perforce depots
332 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
333 Group:          Development/Tools
334 Requires:       %{name} = %{version}-%{release}
335
336 %description p4
337 Git tools for working with Perforce depots.
338
339 %description p4 -l pl.UTF-8
340 Narzędzia Gita do pracy z magazynami Perforce'a.
341
342 %package svn
343 Summary:        Subversion support for Git
344 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
345 Group:          Development/Tools
346 Requires:       %{name} = %{version}-%{release}
347 Requires:       perl-Encode
348 Requires:       perl-Term-ReadKey
349
350 %description svn
351 Subversion support for Git.
352
353 %description svn -l pl.UTF-8
354 Obsługa Subversion dla Gita.
355
356 %package email
357 Summary:        Git tools for sending email
358 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
359 Group:          Development/Tools
360 Requires:       %{name} = %{version}-%{release}
361
362 %description email
363 Git tools for sending email.
364
365 %description email -l pl.UTF-8
366 Narzędzia Gita do wysyłania poczty.
367
368 %package -n bash-completion-git
369 Summary:        bash-completion for git
370 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
371 Group:          Applications/Shells
372 Requires:       %{name} = %{version}-%{release}
373 Requires:       bash-completion >= 2.0
374 %if "%{_rpmversion}" >= "5"
375 BuildArch:      noarch
376 %endif
377
378 %description -n bash-completion-git
379 This package provides bash-completion for git.
380
381 %description -n bash-completion-git -l pl.UTF-8
382 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
383
384 %package -n perl-Git
385 Summary:        Perl interface to the Git version control system
386 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
387 Group:          Development/Languages/Perl
388 Obsoletes:      perl-git-core
389
390 %description -n perl-Git
391 This module provides Perl scripts easy way to interface the Git
392 version control system. The modules have an easy and well-tested way
393 to call arbitrary Git commands; in the future, the interface will also
394 provide specialized methods for doing easily operations which are not
395 totally trivial to do over the generic command interface.
396
397 %description -n perl-Git -l pl.UTF-8
398 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
399 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
400 dowolne polecenia Gita; w przyszłości interfejs udostępni także
401 specjalne metody do łatwego wykonywania operacji nietrywialnych do
402 wykonania przy użyciu ogólnego interfejsu poleceń.
403
404 %package -n gnome-keyring-git-core
405 Summary:        GNOME Keyring authentication provider for Git
406 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
407 Group:          X11/Applications
408 Requires:       %{name} = %{version}-%{release}
409
410 %description -n gnome-keyring-git-core
411 Authentication provider module for Git which allows git client to
412 authenticate using GNOME Keyring.
413
414 %description -n gnome-keyring-git-core -l pl.UTF-8
415 Moduł uwierzytelniający dla Subversion pozwalający klientom git
416 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
417
418 %prep
419 %setup -q -n git-%{version}
420 %patch0 -p1
421 %patch1 -p0
422 %patch2 -p1
423 %patch3 -p1
424 %patch4 -p1
425
426 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
427
428 %build
429 %{__aclocal}
430 %{__autoconf}
431 %configure \
432         --sysconfdir=%{_sysconfdir}/git-core \
433         %{?with_pcre:--with-libpcre} \
434         --with-openssl
435
436 echo "BLK_SHA1=1" >> config.mak
437
438 %{__make} \
439         INSTALLDIRS=vendor \
440         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
441         GITWEB_PROJECTROOT="/var/lib/git" \
442         GITWEB_CSS="/gitweb/gitweb.css" \
443         GITWEB_LOGO="/gitweb/git-logo.png" \
444         GITWEB_FAVICON="/gitweb/git-favicon.png" \
445         V=1
446
447 %{__make} -C contrib/subtree
448
449 %if %{with gnome_keyring}
450 %{__make} -C contrib/credential/gnome-keyring
451 %endif
452
453 %if %{with doc}
454 %{__make} -C Documentation \
455         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
456         V=1
457 %endif
458
459 %if %{with tests}
460 %if %{without tests_cvs}
461 %{__rm} t/t*cvs*.sh || :
462 %endif
463 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
464 %endif
465
466 %install
467 rm -rf $RPM_BUILD_ROOT
468 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
469 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
470 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
471 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
472 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
473 [init]
474         templatedir = %{_sysconfdir}/%{name}/templates
475 EOF
476
477 %{__make} install \
478         INSTALLDIRS=vendor \
479         DESTDIR=$RPM_BUILD_ROOT
480
481 %if %{with doc}
482 %{__make} -C Documentation install \
483         DESTDIR=$RPM_BUILD_ROOT
484 %endif
485
486 # copy templates except sample hooks
487 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
488 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
489
490 # header files and lib
491 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
492 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
493 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
494 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
495 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
496 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
497 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
498 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
499
500 %{__make} -C contrib/subtree install \
501         libexecdir=%{_libdir}/%{name} \
502         DESTDIR=$RPM_BUILD_ROOT
503
504 %if %{with doc}
505 %{__make} -C contrib/subtree install-doc \
506         DESTDIR=$RPM_BUILD_ROOT
507 %endif
508
509 %if %{with gnome_keyring}
510 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libdir}/%{name}
511 # Remove built binary files, otherwise they will be installed in doc
512 %{__make} -C contrib/credential/gnome-keyring clean
513 %endif
514
515 # bash completion
516 install -d $RPM_BUILD_ROOT%{bash_compdir}
517 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
518
519 # Install git-prompt.sh
520 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
521 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
522
523 # Install bzr and hg remote helpers from contrib
524 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
525
526 # gitweb
527 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
528 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
529 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
530 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
531 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
532 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
533 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
534
535 # gitview
536 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
537
538 # git-daemon related files
539 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
540 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
541 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
542
543 # paths cleanup
544 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
545 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
546
547 # hardlink
548 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
549 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
550 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
551 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
552
553 # remove unneeded files
554 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
555 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
556 %py_postclean
557
558 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
559 %find_lang git
560
561 %clean
562 rm -rf $RPM_BUILD_ROOT
563
564 %post daemon-inetd
565 %service -q rc-inetd reload
566
567 %postun daemon-inetd
568 if [ "$1" = "0" ]; then
569         %service -q rc-inetd reload
570 fi
571
572 %post daemon-standalone
573 /sbin/chkconfig --add git-daemon
574 %service git-daemon restart "git-daemon"
575
576 %preun daemon-standalone
577 if [ "$1" = "0" ]; then
578         %service git-daemon stop
579         /sbin/chkconfig --del git-daemon
580 fi
581
582 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
583 %webapp_register apache %{webapp}
584
585 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
586 %webapp_unregister apache %{webapp}
587
588 %triggerin gitweb -- apache < 2.2.0, apache-base
589 %webapp_register httpd %{webapp}
590
591 %triggerun gitweb -- apache < 2.2.0, apache-base
592 %webapp_unregister httpd %{webapp}
593
594 %triggerin gitweb -- lighttpd
595 %webapp_register lighttpd %{webapp}
596
597 %triggerun gitweb -- lighttpd
598 %webapp_unregister lighttpd %{webapp}
599
600 %files -f git.lang
601 %defattr(644,root,root,755)
602 %doc README contrib
603 %attr(755,root,root) %{_bindir}/git
604 %attr(755,root,root) %{_bindir}/git-receive-pack
605 %attr(755,root,root) %{_bindir}/git-shell
606 %attr(755,root,root) %{_bindir}/git-upload-archive
607 %attr(755,root,root) %{_bindir}/git-upload-pack
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
609
610 %if %{with doc}
611 %{_mandir}/man1/git-*.1*
612 %exclude %{_mandir}/man1/git-archimport.1*
613 %exclude %{_mandir}/man1/git-svn.1*
614 %exclude %{_mandir}/man1/git-cvs*.1*
615 %exclude %{_mandir}/man1/git-imap-send*.1*
616 %exclude %{_mandir}/man1/*email*.1*
617 %{_mandir}/man1/git.1*
618 %{_mandir}/man1/gitremote-helpers.1*
619 %{_mandir}/man5/gitattributes.5*
620 %{_mandir}/man5/githooks.5*
621 %{_mandir}/man5/gitignore.5*
622 %{_mandir}/man5/gitmodules.5*
623 %{_mandir}/man5/gitrepository-layout.5*
624 %{_mandir}/man7/gitcli.7*
625 %{_mandir}/man7/gitcore-tutorial.7*
626 %{_mandir}/man7/gitcredentials.7*
627 %{_mandir}/man7/gitdiffcore.7*
628 %{_mandir}/man7/gitglossary.7*
629 %{_mandir}/man7/gitnamespaces.7*
630 %{_mandir}/man7/gitrevisions.7*
631 %{_mandir}/man7/gittutorial-2.7*
632 %{_mandir}/man7/gittutorial.7*
633 %{_mandir}/man7/gitworkflows.7*
634 %endif
635
636 %dir %{_libdir}/%{name}
637 %attr(755,root,root) %{_libdir}/%{name}/*-*
638 %attr(755,root,root) %{_libdir}/%{name}/git
639 %dir %{_libdir}/%{name}/mergetools
640 %{_libdir}/%{name}/mergetools/*
641
642 %{_datadir}/%{name}
643 %{_localstatedir}/lib/git
644
645 # subpackages
646 %exclude %{_libdir}/%{name}/*email*
647 %exclude %{_libdir}/%{name}/*p4*
648 %exclude %{_libdir}/%{name}/git-archimport
649 %exclude %{_libdir}/%{name}/git-cvs*
650 %exclude %{_libdir}/%{name}/git-gui
651 %exclude %{_libdir}/%{name}/git-imap-send
652 %exclude %{_libdir}/%{name}/git-instaweb
653 %exclude %{_libdir}/%{name}/git-remote-bzr
654 %exclude %{_libdir}/%{name}/git-remote-hg
655 %exclude %{_libdir}/%{name}/git-remote-testsvn
656 %exclude %{_libdir}/%{name}/git-svn
657 %exclude %{_libdir}/%{name}/mergetools/p4merge
658 %if %{with gnome_keyring}
659 %exclude %{_libdir}/%{name}/git-credential-gnome-keyring
660 %endif
661
662 %if %{with doc}
663 %files doc
664 %defattr(644,root,root,755)
665 %doc Documentation/RelNotes*
666 %doc Documentation/*.html Documentation/howto Documentation/technical
667 %endif
668
669 %files daemon-inetd
670 %defattr(644,root,root,755)
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
672
673 %files daemon-standalone
674 %defattr(644,root,root,755)
675 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
676 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
677
678 %files devel
679 %defattr(644,root,root,755)
680 %{_includedir}/%{name}
681 %{_libdir}/libgit.a
682 %{_libdir}/libgit_xdiff.a
683
684 %files gitk
685 %defattr(644,root,root,755)
686 %if %{with doc}
687 %{_mandir}/man1/gitk.1*
688 %endif
689 %attr(755,root,root) %{_bindir}/gitk
690 %dir %{_datadir}/gitk
691 %dir %{_datadir}/gitk/lib
692 %dir %{_datadir}/gitk/lib/msgs
693 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
694 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
695 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
696 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
697 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
698 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
699 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
700 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
701 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
702 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
703
704 %files gitweb
705 %defattr(644,root,root,755)
706 %doc gitweb/{README,INSTALL}
707 %dir %{webappdir}
708 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
709 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
710 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
711 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
712 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
713 %attr(755,root,root) %{cgibindir}/gitweb.cgi
714 %{appdir}
715 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
716 %if %{with doc}
717 %{_mandir}/man1/gitweb.1*
718 %{_mandir}/man5/gitweb.conf.5*
719 %endif
720
721 %files gitview
722 %defattr(644,root,root,755)
723 %doc contrib/gitview/gitview.txt
724 %attr(755,root,root) %{_bindir}/gitview
725
726 %files gui
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/%{name}/git-gui
729 %dir %{_datadir}/git-gui
730 %dir %{_datadir}/git-gui/lib
731 %dir %{_datadir}/git-gui/lib/msgs
732 %{_datadir}/git-gui/lib/git-gui.ico
733 %{_datadir}/git-gui/lib/tclIndex
734 %{_datadir}/git-gui/lib/*.js
735 %{_datadir}/git-gui/lib/*.tcl
736 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
737 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
738 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
739 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
740 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
741 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
742 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
743 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
744 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
745 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
746 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
747 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
748
749 %files arch
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
752 %if %{with doc}
753 %{_mandir}/man1/git-archimport.1*
754 %endif
755
756 %files bzr
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
759
760 %files cvs
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_bindir}/git-cvsserver
763 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
764 %if %{with doc}
765 %{_mandir}/man1/git-cvs*.1*
766 %{_mandir}/man7/gitcvs-migration.7*
767 %endif
768
769 %files hg
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
772
773 %files p4
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/%{name}/git-p4
776 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
777
778 %files svn
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{_libdir}/%{name}/git-svn
781 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
782 %{perl_vendorlib}/Git/SVN
783 %{perl_vendorlib}/Git/SVN.pm
784 %if %{with doc}
785 %{_mandir}/man1/git-svn.1*
786 %endif
787
788 %files email
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
791 %attr(755,root,root) %{_libdir}/%{name}/*email*
792 %if %{with doc}
793 %{_mandir}/man1/*email*.1*
794 %{_mandir}/man1/*imap-send*.1*
795 %endif
796
797 %files -n bash-completion-git
798 %defattr(644,root,root,755)
799 %{bash_compdir}/git
800
801 %files -n perl-Git
802 %defattr(644,root,root,755)
803 %{perl_vendorlib}/Git.pm
804 %dir %{perl_vendorlib}/Git
805 %{perl_vendorlib}/Git/I18N.pm
806 %{perl_vendorlib}/Git/IndexInfo.pm
807 %{_mandir}/man3/Git*.3pm*
808
809 %if %{with gnome_keyring}
810 %files -n gnome-keyring-git-core
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/%{name}/git-credential-gnome-keyring
813 %endif
This page took 0.133429 seconds and 3 git commands to generate.