]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
999508ddad9491234cab0c0c7c62261dad80d126
[packages/git-core.git] / git-core.spec
1 # ToDo:
2 # - git-gui subpackage (depends on tk)
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform make test
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.5.2.2
12 Release:        4
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  846940654b703ec5c8de4ee388cb4d08
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 URL:            http://git.or.cz/
20 BuildRequires:  asciidoc
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  curl-devel
24 BuildRequires:  expat-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  perl-Error
27 BuildRequires:  perl-base
28 BuildRequires:  python
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 BuildRequires:  rpmbuild(macros) >= 1.264
31 BuildRequires:  xmlto
32 BuildRequires:  zlib-devel
33 Requires:       coreutils
34 Requires:       curl
35 Requires:       diffutils
36 Requires:       findutils
37 Requires:       grep
38 Requires:       openssh-clients
39 Requires:       perl-Error
40 Requires:       rcs
41 Requires:       sed
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         webapp          gitweb
45 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
46 %define         appdir          %{_datadir}/%{webapp}
47 %define         cgibindir       %{_prefix}/lib/cgi-bin
48
49 %description
50 "git" can mean anything, depending on your mood.
51
52  - random three-letter combination that is pronounceable, and not
53    actually used by any common UNIX command. The fact that it is a
54    mispronunciation of "get" may or may not be relevant.
55  - stupid. contemptible and despicable. simple. Take your pick from the
56    dictionary of slang.
57  - "global information tracker": you're in a good mood, and it actually
58    works for you. Angels sing, and a light suddenly fills the room.
59  - "goddamn idiotic truckload of sh*t": when it breaks
60
61 This is a stupid (but extremely fast) directory content manager. It
62 doesn't do a whole lot, but what it 'does' do is track directory
63 contents efficiently.
64
65 %description -l pl.UTF-8
66 "git" może oznaczać cokolwiek, w zależności od nastroju.
67
68 - losową kombinację trzech liter, która jest wymawialna i
69   właściwie nie używana przez żadne popularne polecenie uniksowe.
70   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
71   mieć znaczenia.
72 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
73 - "global information tracker" (narzędzie do globalnego śledzenia
74   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
75   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
76 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
77   g*) - kiedy się zepsuje.
78
79 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
80 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
81 katalogu.
82
83 %package devel
84 Summary:        Header files for git-core
85 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
86 Group:          Development/Libraries
87
88 %description devel
89 Header files for git-core.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe dla git-core.
93
94 %package gitk
95 Summary:        Tcl/Tk interface to the Git version control system
96 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
97 Group:          Development/Tools
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       tk
100
101 %description gitk
102 Displays changes in a repository or a selected set of commits. This
103 includes visualizing the commit graph, showing information related to
104 each commit, and the files in the trees of each revision.
105
106 Historically, gitk was the first repository browser. It's written in
107 Tcl/Tk and started off in a separate repository but was later merged
108 into the main git repository.
109
110 %description gitk -l pl.UTF-8
111 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
112 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
113 związanych z każdym z commitów oraz listę plików dla każdej
114 rewizji.
115
116 Z punktu widzenia historii, gitk był pierwszą przeglądarką
117 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
118 w osobnym repozytorium, ale z czasem został włączony do głównego
119 repozytorium gita.
120
121 %package gitweb
122 Summary:        Web frontend to git
123 Summary(pl.UTF-8):      Webowy frontend do git
124 Group:          Development/Tools
125 Requires:       %{name} = %{version}-%{release}
126 Requires:       webapps
127
128 %description gitweb
129 This package provides a web interface for browsing git repositories.
130
131 %description gitweb -l pl.UTF-8
132 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
133
134 %package -n bash-completion-git
135 Summary:        bash-completion for git
136 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
137 Group:          Applications/Shell
138 Requires:       bash-completion
139
140 %description -n bash-completion-git
141 This package provides bash-completion for git.
142
143 %description -n bash-completion-git -l pl.UTF-8
144 Pakiet ten dostarcza bashowego uzupełniania nazw dla gita.
145
146 %package -n perl-Git
147 Summary:        Perl interface to the Git version control system
148 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
149 Group:          Development/Languages/Perl
150 Requires:       %{name} = %{version}-%{release}
151 Obsoletes:      perl-git-core
152
153 %description -n perl-Git
154 This module provides Perl scripts easy way to interface the Git
155 version control system. The modules have an easy and well-tested way
156 to call arbitrary Git commands; in the future, the interface will also
157 provide specialized methods for doing easily operations which are not
158 totally trivial to do over the generic command interface.
159
160 %description -n perl-Git -l pl.UTF-8
161 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
162 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
163 wywoływać dowolne polecenia Gita; w przyszłości interfejs
164 udostępni także specjalne metody do łatwego wykonywania operacji
165 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
166 poleceń.
167
168 %package -n vim-syntax-gitcommit
169 Summary:        Vim syntax: gitcommit
170 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
171 Group:          Applications/Editors/Vim
172 # for _vimdatadir existence
173 Requires:       vim >= 4:6.3.058-3
174
175 %description -n vim-syntax-gitcommit
176 This plugin provides syntax highlighting for git's commit messages.
177
178 %description -n vim-syntax-gitcommit -l pl.UTF-8
179 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
180
181 %prep
182 %setup -q -n git-%{version}
183
184 %build
185 %{__aclocal}
186 %{__autoconf}
187 %configure \
188         --with-openssl
189
190 %{__make} \
191         INSTALLDIRS=vendor \
192         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
193         GITWEB_PROJECTROOT="/var/lib/git" \
194         GITWEB_CSS="/gitweb/gitweb.css" \
195         GITWEB_LOGO="/gitweb/git-logo.png" \
196         GITWEB_FAVICON="/gitweb/git-favicon.png"
197
198 %{__make} -C Documentation
199
200 %{?with_tests:%{__make} test}
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
205 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
206 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
207 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
208
209 %{__make} install \
210         INSTALLDIRS=vendor \
211         DESTDIR=$RPM_BUILD_ROOT
212
213 %{__make} -C Documentation install \
214         DESTDIR=$RPM_BUILD_ROOT
215
216 # header files and lib
217 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
218 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
219 install libgit.a $RPM_BUILD_ROOT%{_libdir}
220
221 # bash completion
222 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
223
224 # vim syntax
225 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
226
227 # gitweb
228 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
229 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
230 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
231 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
232 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
233
234 # remove unneeded files
235 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
236 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
237
238 %clean
239 rm -rf $RPM_BUILD_ROOT
240
241 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
242 %webapp_register apache %{webapp}
243
244 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
245 %webapp_unregister apache %{webapp}
246
247 %triggerin gitweb -- apache < 2.2.0, apache-base
248 %webapp_register httpd %{webapp}
249
250 %triggerun gitweb -- apache < 2.2.0, apache-base
251 %webapp_unregister httpd %{webapp}
252
253 %files
254 %defattr(644,root,root,755)
255 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
256 %attr(755,root,root) %{_bindir}/git
257 %attr(755,root,root) %{_bindir}/git-*
258 %{_mandir}/man1/git-*.1*
259 %{_mandir}/man5/gitattributes.5*
260 %{_mandir}/man5/gitignore.5*
261 %{_mandir}/man7/git.7*
262 %{_datadir}/%{name}
263 %{_datadir}/git-gui
264 %{_sharedstatedir}/git
265
266 %files devel
267 %defattr(644,root,root,755)
268 %{_includedir}/*
269 %{_libdir}/*.a
270
271 %files gitk
272 %defattr(644,root,root,755)
273 %doc Documentation/gitk.html
274 %attr(755,root,root) %{_bindir}/gitk
275 %{_mandir}/man1/gitk.1*
276
277 %files gitweb
278 %defattr(644,root,root,755)
279 %doc gitweb/{README,INSTALL}
280 %dir %{webappdir}
281 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
282 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
283 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
284 %attr(755,root,root) %{cgibindir}/gitweb.cgi
285 %{appdir}
286
287 %files -n bash-completion-git
288 %defattr(644,root,root,755)
289 %{_sysconfdir}/bash_completion.d/*
290
291 %files -n perl-Git
292 %defattr(644,root,root,755)
293 %{perl_vendorlib}/Git.pm
294 %{_mandir}/man3/Git.3pm*
295
296 %files -n vim-syntax-gitcommit
297 %defattr(644,root,root,755)
298 %doc contrib/vim/README
299 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.061559 seconds and 2 git commands to generate.