]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.5.3.1
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        The stupid content tracker
7 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
8 Name:           git-core
9 Version:        1.5.3.1
10 Release:        1
11 License:        GPL v2
12 Group:          Development/Tools
13 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
14 # Source0-md5:  3213bc24c86e3741bae3607192f3ee7d
15 Source1:        %{name}-gitweb.conf
16 Source2:        %{name}-gitweb-httpd.conf
17 URL:            http://git.or.cz/
18 BuildRequires:  asciidoc
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  curl-devel
22 BuildRequires:  expat-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-Error
25 BuildRequires:  perl-base
26 BuildRequires:  python
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.264
29 BuildRequires:  xmlto
30 BuildRequires:  zlib-devel
31 Requires:       coreutils
32 Requires:       curl
33 Requires:       diffutils
34 Requires:       findutils
35 Requires:       grep
36 Requires:       openssh-clients
37 Requires:       perl-Error
38 Requires:       rcs
39 Requires:       sed
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         webapp          gitweb
43 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
44 %define         appdir          %{_datadir}/%{webapp}
45 %define         cgibindir       %{_prefix}/lib/cgi-bin
46
47 %description
48 "git" can mean anything, depending on your mood.
49
50  - random three-letter combination that is pronounceable, and not
51    actually used by any common UNIX command. The fact that it is a
52    mispronunciation of "get" may or may not be relevant.
53  - stupid. contemptible and despicable. simple. Take your pick from the
54    dictionary of slang.
55  - "global information tracker": you're in a good mood, and it actually
56    works for you. Angels sing, and a light suddenly fills the room.
57  - "goddamn idiotic truckload of sh*t": when it breaks
58
59 This is a stupid (but extremely fast) directory content manager. It
60 doesn't do a whole lot, but what it 'does' do is track directory
61 contents efficiently.
62
63 %description -l pl.UTF-8
64 "git" może oznaczać cokolwiek, w zależności od nastroju.
65
66 - losową kombinację trzech liter, która jest wymawialna i
67   właściwie nie używana przez żadne popularne polecenie uniksowe.
68   Fakt, że jest to błędna pisownia słowa "get" może mieć lub nie
69   mieć znaczenia.
70 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
71 - "global information tracker" (narzędzie do globalnego śledzenia
72   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
73   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
74 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
75   g*) - kiedy się zepsuje.
76
77 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
78 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
79 katalogu.
80
81 %package devel
82 Summary:        Header files for git-core
83 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
84 Group:          Development/Libraries
85
86 %description devel
87 Header files for git-core.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe dla git-core.
91
92 %package gitk
93 Summary:        Tcl/Tk interface to the Git version control system
94 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
95 Group:          Development/Tools
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       tk
98
99 %description gitk
100 Displays changes in a repository or a selected set of commits. This
101 includes visualizing the commit graph, showing information related to
102 each commit, and the files in the trees of each revision.
103
104 Historically, gitk was the first repository browser. It's written in
105 Tcl/Tk and started off in a separate repository but was later merged
106 into the main git repository.
107
108 %description gitk -l pl.UTF-8
109 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
110 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
111 związanych z każdym z commitów oraz listę plików dla każdej
112 rewizji.
113
114 Z punktu widzenia historii, gitk był pierwszą przeglądarką
115 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany
116 w osobnym repozytorium, ale z czasem został włączony do głównego
117 repozytorium gita.
118
119 %package gitweb
120 Summary:        Web frontend to git
121 Summary(pl.UTF-8):      Webowy frontend do git
122 Group:          Development/Tools
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       webapps
125
126 %description gitweb
127 This package provides a web interface for browsing git repositories.
128
129 %description gitweb -l pl.UTF-8
130 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
131
132 %package -n bash-completion-git
133 Summary:        bash-completion for git
134 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
135 Group:          Applications/Shell
136 Requires:       bash-completion
137
138 %description -n bash-completion-git
139 This package provides bash-completion for git.
140
141 %description -n bash-completion-git -l pl.UTF-8
142 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
143
144 %package -n perl-Git
145 Summary:        Perl interface to the Git version control system
146 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
147 Group:          Development/Languages/Perl
148 Requires:       %{name} = %{version}-%{release}
149 Obsoletes:      perl-git-core
150
151 %description -n perl-Git
152 This module provides Perl scripts easy way to interface the Git
153 version control system. The modules have an easy and well-tested way
154 to call arbitrary Git commands; in the future, the interface will also
155 provide specialized methods for doing easily operations which are not
156 totally trivial to do over the generic command interface.
157
158 %description -n perl-Git -l pl.UTF-8
159 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
160 wersji Git. W łatwy i dobrze przetestowany sposób pozwala
161 wywoływać dowolne polecenia Gita; w przyszłości interfejs
162 udostępni także specjalne metody do łatwego wykonywania operacji
163 nietrywialnych do wykonania przy użyciu ogólnego interfejsu
164 poleceń.
165
166 %package -n vim-syntax-gitcommit
167 Summary:        Vim syntax: gitcommit
168 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
169 Group:          Applications/Editors/Vim
170 # for _vimdatadir existence
171 Requires:       vim >= 4:6.3.058-3
172
173 %description -n vim-syntax-gitcommit
174 This plugin provides syntax highlighting for git's commit messages.
175
176 %description -n vim-syntax-gitcommit -l pl.UTF-8
177 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
178
179 %prep
180 %setup -q -n git-%{version}
181
182 %build
183 %{__aclocal}
184 %{__autoconf}
185 %configure \
186         --with-openssl
187
188 %{__make} \
189         INSTALLDIRS=vendor \
190         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
191         GITWEB_PROJECTROOT="/var/lib/git" \
192         GITWEB_CSS="/gitweb/gitweb.css" \
193         GITWEB_LOGO="/gitweb/git-logo.png" \
194         GITWEB_FAVICON="/gitweb/git-favicon.png"
195
196 %{__make} -C Documentation
197
198 %{?with_tests:%{__make} test}
199
200 %install
201 rm -rf $RPM_BUILD_ROOT
202 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_sharedstatedir}/git}
203 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
204 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
205 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
206
207 %{__make} install \
208         INSTALLDIRS=vendor \
209         DESTDIR=$RPM_BUILD_ROOT
210
211 %{__make} -C Documentation install \
212         DESTDIR=$RPM_BUILD_ROOT
213
214 # header files and lib
215 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
216 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
217 install libgit.a $RPM_BUILD_ROOT%{_libdir}
218
219 # bash completion
220 install contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
221
222 # vim syntax
223 install contrib/vim/syntax/gitcommit.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
224
225 # gitweb
226 install gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
227 install gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
228 install %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
229 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
230 install %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
231
232 # remove unneeded files
233 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
234 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
235
236 %clean
237 rm -rf $RPM_BUILD_ROOT
238
239 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
240 %webapp_register apache %{webapp}
241
242 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
243 %webapp_unregister apache %{webapp}
244
245 %triggerin gitweb -- apache < 2.2.0, apache-base
246 %webapp_register httpd %{webapp}
247
248 %triggerun gitweb -- apache < 2.2.0, apache-base
249 %webapp_unregister httpd %{webapp}
250
251 %files
252 %defattr(644,root,root,755)
253 %doc README Documentation/{[!g]*,g[!i]*,git,git[!k]*}.html Documentation/howto Documentation/technical contrib
254 %attr(755,root,root) %{_bindir}/git
255 %attr(755,root,root) %{_bindir}/git-*
256 %{_mandir}/man1/git-*.1*
257 %{_mandir}/man5/gitattributes.5*
258 %{_mandir}/man5/gitignore.5*
259 %{_mandir}/man5/gitmodules.5*
260 %{_mandir}/man7/git.7*
261 %{_datadir}/%{name}
262 %{_datadir}/git-gui
263 %{_sharedstatedir}/git
264
265 %files devel
266 %defattr(644,root,root,755)
267 %{_includedir}/*
268 %{_libdir}/*.a
269
270 %files gitk
271 %defattr(644,root,root,755)
272 %doc Documentation/gitk.html
273 %attr(755,root,root) %{_bindir}/gitk
274 %{_mandir}/man1/gitk.1*
275
276 %files gitweb
277 %defattr(644,root,root,755)
278 %doc gitweb/{README,INSTALL}
279 %dir %{webappdir}
280 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
281 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
282 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
283 %attr(755,root,root) %{cgibindir}/gitweb.cgi
284 %{appdir}
285
286 %files -n bash-completion-git
287 %defattr(644,root,root,755)
288 %{_sysconfdir}/bash_completion.d/*
289
290 %files -n perl-Git
291 %defattr(644,root,root,755)
292 %{perl_vendorlib}/Git.pm
293 %{_mandir}/man3/Git.3pm*
294
295 %files -n vim-syntax-gitcommit
296 %defattr(644,root,root,755)
297 %doc contrib/vim/README
298 %{_datadir}/vim/vimfiles/syntax/*
This page took 0.073954 seconds and 3 git commands to generate.