]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
33e6822c51748f32c9fd4e7d7568f39798eef5a9
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 # - gitk subpackage?
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The stupid content tracker
6 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
7 Name:           git-core
8 Version:        1.5.0.6
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Tools
12 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
13 # Source0-md5:  25a20a1c305e7791e5101424a048b6d2
14 Patch0:         %{name}-build.patch
15 URL:            http://git.or.cz/
16 BuildRequires:  asciidoc
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  curl-devel
20 BuildRequires:  expat-devel
21 BuildRequires:  openssl-devel
22 BuildRequires:  perl-Error
23 BuildRequires:  perl-base
24 BuildRequires:  python
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRequires:  xmlto
27 BuildRequires:  zlib-devel
28 Requires:       coreutils
29 Requires:       curl
30 Requires:       diffutils
31 Requires:       findutils
32 Requires:       grep
33 Requires:       openssh-clients
34 Requires:       rcs
35 Requires:       sed
36 Requires:       tk
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 "git" can mean anything, depending on your mood.
41
42  - random three-letter combination that is pronounceable, and not
43    actually used by any common UNIX command. The fact that it is a
44    mispronunciation of "get" may or may not be relevant.
45  - stupid. contemptible and despicable. simple. Take your pick from the
46    dictionary of slang.
47  - "global information tracker": you're in a good mood, and it actually
48    works for you. Angels sing, and a light suddenly fills the room.
49  - "goddamn idiotic truckload of sh*t": when it breaks
50
51 This is a stupid (but extremely fast) directory content manager. It
52 doesn't do a whole lot, but what it 'does' do is track directory
53 contents efficiently.
54
55 %description -l pl.UTF-8
56 "git" może oznaczać cokolwiek, w zależności od nastroju.
57
58 - losową kombinację trzech liter, która jest wymawialna i właściwie
59   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
60   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
61 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
62 - "global information tracker" (narzędzie do globalnego śledzenia
63   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
64   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
65 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
66   g*) - kiedy się zepsuje.
67
68 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
69 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
70 katalogu.
71
72 %package devel
73 Summary:        Header files for git-core
74 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
75 Group:          Development/Libraries
76
77 %description devel
78 Header files for git-core.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe dla git-core.
82
83 %package -n perl-Git
84 Summary:        Perl interface to the Git version control system
85 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
86 Group:          Development/Languages/Perl
87 Requires:       %{name} = %{version}-%{release}
88 Obsoletes:      perl-git-core
89
90 %description -n perl-Git
91 This module provides Perl scripts easy way to interface the Git
92 version control system. The modules have an easy and well-tested way
93 to call arbitrary Git commands; in the future, the interface will also
94 provide specialized methods for doing easily operations which are not
95 totally trivial to do over the generic command interface.
96
97 %description -n perl-Git -l pl.UTF-8
98 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
99 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
100 dowolne polecenia Gita; w przyszłości interfejs udostępni także
101 specjalne metody do łatwego wykonywania operacji nietrywialnych do
102 wykonania przy użyciu ogólnego interfejsu poleceń.
103
104 %prep
105 %setup -q -n git-%{version}
106 %patch0 -p1
107
108 %build
109 %{__aclocal}
110 %{__autoconf}
111 %configure \
112         --with-openssl
113
114 %{__make} \
115         INSTALLDIRS=vendor
116
117 %{__make} -C Documentation
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
122
123 %{__make} install \
124         INSTALLDIRS=vendor \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__make} -C Documentation install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
131 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
132
133 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
134 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %doc README Documentation/*.html Documentation/howto Documentation/technical
142 %attr(755,root,root) %{_bindir}/*
143 %{_mandir}/man*/*
144 %dir %{_datadir}/%{name}
145 %{_datadir}/%{name}/*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %{_includedir}/*
150
151 %files -n perl-Git
152 %defattr(644,root,root,755)
153 %{perl_vendorlib}/Git.pm
154 %{_mandir}/man3/*
This page took 0.04946 seconds and 2 git commands to generate.