]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.7.8.3
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_with     tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Distributed version control system focused on speed, effectivity and usability
10 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
11 Name:           git-core
12 Version:        1.7.8.3
13 Release:        1
14 License:        GPL v2
15 Group:          Development/Tools
16 # Source0:      http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
17 Source0:        http://git-core.googlecode.com/files/git-%{version}.tar.gz
18 # Source0-md5:  7a4bc5160166537d4da5eb48a7670dff
19 Source1:        %{name}-gitweb.conf
20 Source2:        %{name}-gitweb-httpd.conf
21 Source3:        %{name}-gitweb-lighttpd.conf
22 Source4:        %{name}.sysconfig
23 Source5:        %{name}.inet
24 Source6:        %{name}.init
25 Patch0:         %{name}-tests.patch
26 Patch1:         %{name}-key-bindings.patch
27 Patch2:         %{name}-sysconfdir.patch
28 URL:            http://git-scm.com/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  curl-devel
32 BuildRequires:  expat-devel
33 BuildRequires:  gettext-devel
34 BuildRequires:  openssl-devel
35 BuildRequires:  perl-Error > 0.15
36 BuildRequires:  perl-base
37 BuildRequires:  python-devel
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 BuildRequires:  rpm-pythonprov
40 BuildRequires:  rpmbuild(macros) >= 1.264
41 BuildRequires:  tcl
42 BuildRequires:  zlib-devel
43 %if %{with doc}
44 BuildRequires:  asciidoc >= 7.1.2-3
45 BuildRequires:  docbook-dtd45-xml
46 BuildRequires:  xmlto
47 %endif
48 %if %{with tests}
49 %if %{with tests_cvs}
50 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
51 BuildRequires:  cvs-gnu-client < 1.13
52 BuildRequires:  cvs-gnu-client >= 1.12
53 %endif
54 Conflicts:      pdksh < 5.2.14-46
55 %endif
56 Requires:       coreutils
57 Requires:       diffutils
58 Requires:       findutils
59 Requires:       grep
60 Requires:       openssh-clients
61 Requires:       perl-Error
62 Requires:       perl-Git = %{version}-%{release}
63 Requires:       sed
64 Suggests:       git-core-cvs
65 Suggests:       git-core-svn
66 Suggests:       less
67 Suggests:       rsync
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 # html docs have links to txt files
71 %define         _noautocompressdoc      *.txt
72
73 %define         webapp          gitweb
74 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
75 %define         appdir          %{_datadir}/%{webapp}
76 %define         cgibindir       %{_prefix}/lib/cgi-bin
77
78 %description
79 "git" can mean anything, depending on your mood.
80
81 - random three-letter combination that is pronounceable, and not
82   actually used by any common UNIX command. The fact that it is a
83   mispronunciation of "get" may or may not be relevant.
84 - stupid. contemptible and despicable. simple. Take your pick from the
85   dictionary of slang.
86 - "global information tracker": you're in a good mood, and it actually
87   works for you. Angels sing, and a light suddenly fills the room.
88 - "goddamn idiotic truckload of sh*t": when it breaks
89
90 This is a stupid (but extremely fast) directory content manager. It
91 doesn't do a whole lot, but what it 'does' do is track directory
92 contents efficiently.
93
94 %description -l pl.UTF-8
95 "git" może oznaczać cokolwiek, w zależności od nastroju.
96
97 - losową kombinację trzech liter, która jest wymawialna i właściwie
98   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
99   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
100 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
101 - "global information tracker" (narzędzie do globalnego śledzenia
102   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
103   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
104 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
105   g*) - kiedy się zepsuje.
106
107 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
108 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
109 katalogu.
110
111 %package doc
112 Summary:        Documentation for git-core
113 Summary(pl.UTF-8):      Dokumentacja do git-core
114 Group:          Documentation
115
116 %description doc
117 Documentation for git-core.
118
119 %description doc -l pl.UTF-8
120 Dokumentacja do git-core.
121
122 %description doc -l fr.UTF-8
123 Javadoc pour git-core.
124
125 %package daemon-inetd
126 Summary:        Files necessary to run git-daemon as an inetd service
127 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
128 Group:          Networking/Daemons
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       setup >= 2.4.11-1
131 Provides:       git-core-daemon
132 Obsoletes:      git-core-daemon
133 Obsoletes:      git-core-daemon-standalone
134
135 %description daemon-inetd
136 Git-daemon is a really simple TCP git daemon that can serve git
137 repositories. This package provides all necessarry files to run
138 git-daemon as an inetd service.
139
140 %description daemon-inetd -l pl.UTF-8
141 Git-daemon to prosty demon git korzystający z protokołu TCP do
142 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
143 do uruchomienia git-demona w trybie usługi inetd.
144
145 %package daemon-standalone
146 Summary:        Files necessary to run git-daemon as a standalone service
147 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
148 Group:          Networking/Daemons
149 Requires:       %{name} = %{version}-%{release}
150 Provides:       git-core-daemon
151 Obsoletes:      git-core-daemon
152 Obsoletes:      git-core-daemon-inetd
153
154 %description daemon-standalone
155 Git-daemon is a really simple TCP git daemon that can serve git
156 repositories. This package provides all necessarry files to run
157 git-daemon as an standalone service.
158
159 %description daemon-standalone -l pl.UTF-8
160 Git-daemon to prosty demon git korzystający z protokołu TCP do
161 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
162 do uruchomienia git-daemona w trybie usługi samodzielnej.
163
164 %package devel
165 Summary:        Header files for git-core
166 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
167 Group:          Development/Libraries
168 Requires:       zlib-devel
169
170 %description devel
171 Header files for git-core.
172
173 %description devel -l pl.UTF-8
174 Pliki nagłówkowe dla git-core.
175
176 %package gitk
177 Summary:        Tcl/Tk interface to the Git version control system
178 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
179 Group:          Development/Tools
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       tk
182
183 %description gitk
184 gitk displays changes in a repository or a selected set of commits.
185 This includes visualizing the commit graph, showing information
186 related to each commit, and the files in the trees of each revision.
187
188 Historically, gitk was the first repository browser. It's written in
189 Tcl/Tk and started off in a separate repository but was later merged
190 into the main git repository.
191
192 %description gitk -l pl.UTF-8
193 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
194 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
195 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
196
197 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
198 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
199 osobnym repozytorium, ale z czasem został włączony do głównego
200 repozytorium gita.
201
202 %package gitweb
203 Summary:        Web frontend to git
204 Summary(pl.UTF-8):      Frontend WWW do gita
205 Group:          Development/Tools
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       webapps
208 Requires:       webserver(alias)
209 Requires:       webserver(cgi)
210
211 %description gitweb
212 This package provides a web interface for browsing git repositories.
213
214 %description gitweb -l pl.UTF-8
215 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
216
217 %package gitview
218 Summary:        A GTK+ based repository browser for git
219 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
220 Group:          Development/Tools
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       python >= 1:2.4
223 Requires:       python-pycairo >= 1.0
224 Requires:       python-pygobject
225 Requires:       python-pygtk-gtk >= 2:2.8
226 Suggests:       python-gnome-desktop-gtksourceview
227
228 %description gitview
229 A GTK+ based repository browser for git.
230
231 %description gitview -l pl.UTF-8
232 Oparta na GTK+ przeglądarka repozytorium gita.
233
234 %package gui
235 Summary:        Tcl/Tk interface to the Git version control system
236 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
237 Group:          Development/Tools
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       tk
240 Requires:       xdg-utils
241 Suggests:       meld
242
243 %description gui
244 Displays changes in a repository or a selected set of commits. This
245 includes visualizing the commit graph, showing information related to
246 each commit, and the files in the trees of each revision.
247
248 Historically, gitk was the first repository browser. It's written in
249 Tcl/Tk and started off in a separate repository but was later merged
250 into the main git repository.
251
252 %description gui -l pl.UTF-8
253 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
254 to wizualizację grafu commitów, wyświetlanie informacji związanych z
255 każdym z commitów oraz listę plików dla każdej rewizji.
256
257 Z punktu widzenia historii, gitk był pierwszą przeglądarką
258 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
259 osobnym repozytorium, ale z czasem został włączony do głównego
260 repozytorium gita.
261
262 %package svn
263 Summary:        Subversion support for Git
264 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
265 Group:          Development/Tools
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       perl-Term-ReadKey
268
269 %description svn
270 Subversion support for Git.
271
272 %description svn -l pl.UTF-8
273 Obsługa Subversion dla Gita.
274
275 %package cvs
276 Summary:        CVS support for Git
277 Summary(pl.UTF-8):      Obsługa CVS dla Gita
278 Group:          Development/Tools
279 Requires:       %{name} = %{version}-%{release}
280 Requires:       cvsps >= 2.1-2
281 Requires:       rcs
282
283 %description cvs
284 CVS support for Git.
285
286 %description cvs -l pl.UTF-8
287 Obsługa CVS dla Gita.
288
289 %package arch
290 Summary:        Git tools for importing Arch repositories
291 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
292 Group:          Development/Tools
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       tla
295
296 %description arch
297 Git tools for importing Arch repositories.
298
299 %description arch -l pl.UTF-8
300 Narzędzia Gita do importowania repozytoriów Archa.
301
302 %package email
303 Summary:        Git tools for sending email
304 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
305 Group:          Development/Tools
306 Requires:       %{name} = %{version}-%{release}
307
308 %description email
309 Git tools for sending email.
310
311 %description email -l pl.UTF-8
312 Narzędzia Gita do wysyłania poczty.
313
314 %package -n bash-completion-git
315 Summary:        bash-completion for git
316 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
317 Group:          Applications/Shells
318 Requires:       %{name} = %{version}-%{release}
319 Requires:       bash-completion
320
321 %description -n bash-completion-git
322 This package provides bash-completion for git.
323
324 %description -n bash-completion-git -l pl.UTF-8
325 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
326
327 %package -n perl-Git
328 Summary:        Perl interface to the Git version control system
329 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
330 Group:          Development/Languages/Perl
331 Obsoletes:      perl-git-core
332
333 %description -n perl-Git
334 This module provides Perl scripts easy way to interface the Git
335 version control system. The modules have an easy and well-tested way
336 to call arbitrary Git commands; in the future, the interface will also
337 provide specialized methods for doing easily operations which are not
338 totally trivial to do over the generic command interface.
339
340 %description -n perl-Git -l pl.UTF-8
341 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
342 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
343 dowolne polecenia Gita; w przyszłości interfejs udostępni także
344 specjalne metody do łatwego wykonywania operacji nietrywialnych do
345 wykonania przy użyciu ogólnego interfejsu poleceń.
346
347 %package -n python-Git
348 Summary:        Python Git remote helpers for non-git repositories
349 Summary(pl.UTF-8):      Pythonowe zdalne moduły pomocnicze dla repozytoriów niegitowych
350 Group:          Development/Languages/Python
351 Requires:       %{name} = %{version}-%{release}
352
353 %description -n python-Git
354 This package contains Python git_repote_helpers package - Git remote
355 helpers for non-git repositories.
356
357 %description -n python-Git -l pl.UTF-8
358 Ten pakiet zawiera pakiet Pythona git_remote_helpers - zdalne moduły
359 pomocnicze Gita dla repozytoriów niegitowych.
360
361 %package -n vim-syntax-gitcommit
362 Summary:        Vim syntax: gitcommit
363 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
364 Group:          Applications/Editors/Vim
365 Requires:       %{name} = %{version}-%{release}
366 # for _vimdatadir existence
367 Requires:       vim-rt >= 4:6.3.058-3
368
369 %description -n vim-syntax-gitcommit
370 This plugin provides syntax highlighting for git's commit messages.
371
372 %description -n vim-syntax-gitcommit -l pl.UTF-8
373 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
374
375 %prep
376 %setup -q -n git-%{version}
377 %patch0 -p1
378 %patch1 -p0
379 %patch2 -p1
380
381 %build
382 %{__aclocal}
383 %{__autoconf}
384 %configure \
385         --sysconfdir=%{_sysconfdir}/git-core \
386         --with-openssl
387
388 echo "BLK_SHA1=1" >> config.mak
389
390 %{__make} \
391         INSTALLDIRS=vendor \
392         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
393         GITWEB_PROJECTROOT="/var/lib/git" \
394         GITWEB_CSS="/gitweb/gitweb.css" \
395         GITWEB_LOGO="/gitweb/git-logo.png" \
396         GITWEB_FAVICON="/gitweb/git-favicon.png" \
397         V=1
398
399 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
400 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
401
402 %if %{with tests}
403 %if %{without tests_cvs}
404 rm t/t*cvs*.sh || :
405 %endif
406 %{!?with_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
407 %endif
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
412 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
413 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
414 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
415 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
416 [init]
417         templatedir = %{_sysconfdir}/%{name}/templates
418 EOF
419
420 %{__make} install \
421         INSTALLDIRS=vendor \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 %if %{with doc}
425 %{__make} -C Documentation install \
426         DESTDIR=$RPM_BUILD_ROOT
427 %endif
428
429 # copy templates except sample hooks
430 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
431 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
432
433 # header files and lib
434 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
435 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
436 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
437 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
438 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
439
440 # bash completion
441 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
442 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT/etc/bash_completion.d
443
444 # vim syntax
445 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
446 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
447 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
448 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
449 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
450 autocmd BufNewFile,BufRead .msg.[0-9]*
451         \ if getline(1) =~ '^From.*# This line is ignored.$' |
452         \   setf gitsendemail |
453         \ endif
454 autocmd BufNewFile,BufRead *.git/**
455         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
456         \   setf git |
457         \ endif
458 EOF
459
460 # gitweb
461 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
462 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
463 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
464 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
465 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
466
467 # gitview
468 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
469
470 # git-daemon related files
471 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
472 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
473 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
474
475 # paths cleanup
476 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
477 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
478
479 # hardlink
480 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
481 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
482 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
483 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
484
485 # remove unneeded files
486 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
487 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
488 %py_postclean
489
490 %clean
491 rm -rf $RPM_BUILD_ROOT
492
493 %post daemon-inetd
494 %service -q rc-inetd reload
495
496 %postun daemon-inetd
497 if [ "$1" = "0" ]; then
498         %service -q rc-inetd reload
499 fi
500
501 %post daemon-standalone
502 /sbin/chkconfig --add git-daemon
503 %service git-daemon restart "git-daemon"
504
505 %preun daemon-standalone
506 if [ "$1" = "0" ]; then
507         %service git-daemon stop
508         /sbin/chkconfig --del git-daemon
509 fi
510
511 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
512 %webapp_register apache %{webapp}
513
514 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
515 %webapp_unregister apache %{webapp}
516
517 %triggerin gitweb -- apache < 2.2.0, apache-base
518 %webapp_register httpd %{webapp}
519
520 %triggerun gitweb -- apache < 2.2.0, apache-base
521 %webapp_unregister httpd %{webapp}
522
523 %triggerin gitweb -- lighttpd
524 %webapp_register lighttpd %{webapp}
525
526 %triggerun gitweb -- lighttpd
527 %webapp_unregister lighttpd %{webapp}
528
529 %files
530 %defattr(644,root,root,755)
531 %doc README contrib
532 %attr(755,root,root) %{_bindir}/git
533 %attr(755,root,root) %{_bindir}/git-receive-pack
534 %attr(755,root,root) %{_bindir}/git-shell
535 %attr(755,root,root) %{_bindir}/git-upload-archive
536 %attr(755,root,root) %{_bindir}/git-upload-pack
537 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
538
539 %if %{with doc}
540 %{_mandir}/man1/git-*.1*
541 %exclude %{_mandir}/man1/git-svn.1*
542 %exclude %{_mandir}/man1/git-cvs*.1*
543 %exclude %{_mandir}/man1/git-remote-helpers.1*
544 %{_mandir}/man1/git.1*
545 %{_mandir}/man5/gitattributes.5*
546 %{_mandir}/man5/githooks.5*
547 %{_mandir}/man5/gitignore.5*
548 %{_mandir}/man5/gitmodules.5*
549 %{_mandir}/man5/gitrepository-layout.5*
550 %{_mandir}/man7/gitcli.7*
551 %{_mandir}/man7/gitcore-tutorial.7*
552 %{_mandir}/man7/gitdiffcore.7*
553 %{_mandir}/man7/gitglossary.7*
554 %{_mandir}/man7/gitnamespaces.7*
555 %{_mandir}/man7/gitrevisions.7*
556 %{_mandir}/man7/gittutorial-2.7*
557 %{_mandir}/man7/gittutorial.7*
558 %{_mandir}/man7/gitworkflows.7*
559 %endif
560
561 %dir %{_libdir}/%{name}
562 %attr(755,root,root) %{_libdir}/%{name}/*-*
563 %attr(755,root,root) %{_libdir}/%{name}/git
564 %{_libdir}/%{name}/mergetools
565
566 %exclude %{_libdir}/%{name}/git-gui
567 %exclude %{_libdir}/%{name}/git-svn
568 %exclude %{_libdir}/%{name}/git-archimport
569 %exclude %{_libdir}/%{name}/git-cvs*
570 %exclude %{_libdir}/%{name}/git-remote-testgit
571 %exclude %{_libdir}/%{name}/*email*
572
573 %{_datadir}/%{name}
574
575 %{_localstatedir}/lib/git
576
577 %if %{with doc}
578 %files doc
579 %defattr(644,root,root,755)
580 %doc Documentation/RelNotes*
581 %doc Documentation/*.html Documentation/howto Documentation/technical
582 %endif
583
584 %files daemon-inetd
585 %defattr(644,root,root,755)
586 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
587
588 %files daemon-standalone
589 %defattr(644,root,root,755)
590 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
591 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
592
593 %files devel
594 %defattr(644,root,root,755)
595 %{_includedir}/%{name}
596 %{_libdir}/libgit.a
597 %{_libdir}/libgit_xdiff.a
598
599 %files gitk
600 %defattr(644,root,root,755)
601 %if %{with doc}
602 %{_mandir}/man1/gitk.1*
603 %endif
604 %attr(755,root,root) %{_bindir}/gitk
605 %dir %{_datadir}/gitk
606 %dir %{_datadir}/gitk/lib
607 %dir %{_datadir}/gitk/lib/msgs
608 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
609 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
610 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
611 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
612 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
613 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
614 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
615 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
616 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
617
618 %files gitweb
619 %defattr(644,root,root,755)
620 %doc gitweb/{README,INSTALL}
621 %dir %{webappdir}
622 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
623 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
624 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
625 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
626 %attr(755,root,root) %{cgibindir}/gitweb.cgi
627 %{appdir}
628 %{_mandir}/man1/gitweb.1*
629 %{_mandir}/man5/gitweb.conf.5*
630
631 %files gitview
632 %defattr(644,root,root,755)
633 %doc contrib/gitview/gitview.txt
634 %attr(755,root,root) %{_bindir}/gitview
635
636 %files gui
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/%{name}/git-gui
639 %dir %{_datadir}/git-gui
640 %dir %{_datadir}/git-gui/lib
641 %dir %{_datadir}/git-gui/lib/msgs
642 %{_datadir}/git-gui/lib/git-gui.ico
643 %{_datadir}/git-gui/lib/tclIndex
644 %{_datadir}/git-gui/lib/*.js
645 %{_datadir}/git-gui/lib/*.tcl
646 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
647 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
648 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
649 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
650 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
651 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
652 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
653 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
654 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
655 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
656 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
657
658 %files svn
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/%{name}/git-svn
661 %if %{with doc}
662 %{_mandir}/man1/git-svn.1*
663 %endif
664
665 %files cvs
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/git-cvsserver
668 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
669 %if %{with doc}
670 %{_mandir}/man1/git-cvs*.1*
671 %{_mandir}/man7/gitcvs-migration.7*
672 %endif
673
674 %files arch
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
677 %if %{with doc}
678 %{_mandir}/man1/git-archimport.1*
679 %endif
680
681 %files email
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_libdir}/%{name}/*email*
684 %if %{with doc}
685 %{_mandir}/man1/*email*.1*
686 %endif
687
688 %files -n bash-completion-git
689 %defattr(644,root,root,755)
690 /etc/bash_completion.d/git-completion.bash
691
692 %files -n perl-Git
693 %defattr(644,root,root,755)
694 %{perl_vendorlib}/Git.pm
695 %{_mandir}/man3/Git.3pm*
696
697 %files -n python-Git
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testgit
700 %dir %{py_sitescriptdir}/git_remote_helpers
701 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
702 %dir %{py_sitescriptdir}/git_remote_helpers/git
703 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
704 %if "%{py_ver}" > "2.4"
705 %{py_sitescriptdir}/git_remote_helpers*.egg-info
706 %endif
707 %if %{with doc}
708 %{_mandir}/man1/git-remote-helpers.1*
709 %endif
710
711 %files -n vim-syntax-gitcommit
712 %defattr(644,root,root,755)
713 %doc contrib/vim/README
714 %{_datadir}/vim/vimfiles/syntax/gitcommit.vim
This page took 0.102791 seconds and 3 git commands to generate.