]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.7.0.4
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.0.4
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  1cc8b2aea57e5e999ccac18ae355f760
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 Patch0:         %{name}-tests.patch
23 URL:            http://git-scm.com/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  curl-devel
27 BuildRequires:  expat-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  perl-Error > 0.15
31 BuildRequires:  perl-base
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.264
36 BuildRequires:  zlib-devel
37 %if %{with doc}
38 BuildRequires:  asciidoc >= 7.1.2-3
39 BuildRequires:  docbook-dtd45-xml
40 BuildRequires:  xmlto
41 %endif
42 %if %{with tests}
43 %if %{with tests_cvs}
44 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
45 BuildRequires:  cvs-gnu-client < 1.13
46 BuildRequires:  cvs-gnu-client >= 1.12
47 %endif
48 BuildRequires:  pdksh >= 5.2.14-46
49 %endif
50 Requires:       coreutils
51 Requires:       diffutils
52 Requires:       findutils
53 Requires:       grep
54 Requires:       openssh-clients
55 Requires:       perl-Error
56 Requires:       sed
57 Suggests:       git-core-cvs
58 Suggests:       git-core-svn
59 Suggests:       less
60 Suggests:       rsync
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # html docs have links to txt files
64 %define         _noautocompressdoc      *.txt
65
66 %define         webapp          gitweb
67 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
68 %define         appdir          %{_datadir}/%{webapp}
69 %define         cgibindir       %{_prefix}/lib/cgi-bin
70
71 %description
72 "git" can mean anything, depending on your mood.
73
74  - random three-letter combination that is pronounceable, and not
75    actually used by any common UNIX command. The fact that it is a
76    mispronunciation of "get" may or may not be relevant.
77  - stupid. contemptible and despicable. simple. Take your pick from the
78    dictionary of slang.
79  - "global information tracker": you're in a good mood, and it actually
80    works for you. Angels sing, and a light suddenly fills the room.
81  - "goddamn idiotic truckload of sh*t": when it breaks
82
83 This is a stupid (but extremely fast) directory content manager. It
84 doesn't do a whole lot, but what it 'does' do is track directory
85 contents efficiently.
86
87 %description -l pl.UTF-8
88 "git" może oznaczać cokolwiek, w zależności od nastroju.
89
90  - losową kombinację trzech liter, która jest wymawialna i właściwie
91    nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
92    błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
93  - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
94  - "global information tracker" (narzędzie do globalnego śledzenia
95    informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
96    Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
97  - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
98    g*) - kiedy się zepsuje.
99
100 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
101 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
102 katalogu.
103
104 %package doc
105 Summary:        Documentation for git-core
106 Summary(pl.UTF-8):      Dokumentacja do git-core
107 Group:          Documentation
108
109 %description doc
110 Documentation for git-core.
111
112 %description doc -l pl.UTF-8
113 Dokumentacja do git-core.
114
115 %description doc -l fr.UTF-8
116 Javadoc pour git-core.
117
118 %package daemon-inetd
119 Summary:        Files necessary to run git-daemon as an inetd service
120 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
121 Group:          Networking/Daemons
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       setup >= 2.4.11-1
124 Provides:       git-core-daemon
125 Obsoletes:      git-core-daemon
126 Obsoletes:      git-core-daemon-standalone
127
128 %description daemon-inetd
129 Git-daemon is a really simple TCP git daemon that can serve git
130 repositories. This package provides all necessarry files to run
131 git-daemon as an inetd service.
132
133 %description daemon-inetd -l pl.UTF-8
134 Git-daemon to prosty demon git korzystający z protokołu TCP do
135 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
136 do uruchomienia git-demona w trybie usługi inetd.
137
138 %package daemon-standalone
139 Summary:        Files necessary to run git-daemon as a standalone service
140 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
141 Group:          Networking/Daemons
142 Requires:       %{name} = %{version}-%{release}
143 Provides:       git-core-daemon
144 Obsoletes:      git-core-daemon
145 Obsoletes:      git-core-daemon-inetd
146
147 %description daemon-standalone
148 Git-daemon is a really simple TCP git daemon that can serve git
149 repositories. This package provides all necessarry files to run
150 git-daemon as an standalone service.
151
152 %description daemon-standalone -l pl.UTF-8
153 Git-daemon to prosty demon git korzystający z protokołu TCP do
154 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
155 do uruchomienia git-daemona w trybie usługi samodzielnej.
156
157 %package devel
158 Summary:        Header files for git-core
159 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
160 Group:          Development/Libraries
161
162 %description devel
163 Header files for git-core.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe dla git-core.
167
168 %package gitk
169 Summary:        Tcl/Tk interface to the Git version control system
170 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
171 Group:          Development/Tools
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       tk
174
175 %description gitk
176 gitk displays changes in a repository or a selected set of commits.
177 This includes visualizing the commit graph, showing information
178 related to each commit, and the files in the trees of each revision.
179
180 Historically, gitk was the first repository browser. It's written in
181 Tcl/Tk and started off in a separate repository but was later merged
182 into the main git repository.
183
184 %description gitk -l pl.UTF-8
185 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
186 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
187 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
188
189 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
190 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
191 osobnym repozytorium, ale z czasem został włączony do głównego
192 repozytorium gita.
193
194 %package gitweb
195 Summary:        Web frontend to git
196 Summary(pl.UTF-8):      Webowy frontend do git
197 Group:          Development/Tools
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       webapps
200
201 %description gitweb
202 This package provides a web interface for browsing git repositories.
203
204 %description gitweb -l pl.UTF-8
205 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
206
207 %package gitview
208 Summary:        A GTK+ based repository browser for git
209 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
210 Group:          Development/Tools
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       python >= 1:2.4
213 Requires:       python-pycairo >= 1.0
214 Requires:       python-pygobject
215 Requires:       python-pygtk-gtk >= 2:2.8
216 Suggests:       python-gnome-desktop-gtksourceview
217
218 %description gitview
219 A GTK+ based repository browser for git.
220
221 %description gitview -l pl.UTF-8
222 Oparta na GTK+ przeglądarka repozytorium gita.
223
224 %package gui
225 Summary:        Tcl/Tk interface to the Git version control system
226 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
227 Group:          Development/Tools
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       tk
230
231 %description gui
232 Displays changes in a repository or a selected set of commits. This
233 includes visualizing the commit graph, showing information related to
234 each commit, and the files in the trees of each revision.
235
236 Historically, gitk was the first repository browser. It's written in
237 Tcl/Tk and started off in a separate repository but was later merged
238 into the main git repository.
239
240 %description gui -l pl.UTF-8
241 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
242 to wizualizację grafu commitów, wyświetlanie informacji związanych z
243 każdym z commitów oraz listę plików dla każdej rewizji.
244
245 Z punktu widzenia historii, gitk był pierwszą przeglądarką
246 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
247 osobnym repozytorium, ale z czasem został włączony do głównego
248 repozytorium gita.
249
250 %package svn
251 Summary:        Subversion support for Git
252 Summary(pl.UTF-8):      Obsługa Subversion dla Git
253 Group:          Development/Tools
254 Requires:       %{name} = %{version}-%{release}
255
256 %description svn
257 Subversion support for Git.
258
259 %description svn -l pl.UTF-8
260 Obsługa Subversion dla Git.
261
262 %package cvs
263 Summary:        CVS support for Git
264 Summary(pl.UTF-8):      Obsługa CVS dla Git
265 Group:          Development/Tools
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       cvsps >= 2.1-2
268 Requires:       rcs
269
270 %description cvs
271 CVS support for Git.
272
273 %description cvs -l pl.UTF-8
274 Obsługa CVS dla Git.
275
276 %package arch
277 Summary:        Git tools for importing Arch repositories
278 Group:          Development/Tools
279 Requires:       %{name} = %{version}-%{release}
280 Requires:       tla
281
282 %description arch
283 Git tools for importing Arch repositories.
284
285 %package email
286 Summary:        Git tools for sending email
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289
290 %description email
291 Git tools for sending email.
292
293 %package -n bash-completion-git
294 Summary:        bash-completion for git
295 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
296 Group:          Applications/Shells
297 Requires:       bash-completion
298
299 %description -n bash-completion-git
300 This package provides bash-completion for git.
301
302 %description -n bash-completion-git -l pl.UTF-8
303 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
304
305 %package -n perl-Git
306 Summary:        Perl interface to the Git version control system
307 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
308 Group:          Development/Languages/Perl
309 Obsoletes:      perl-git-core
310
311 %description -n perl-Git
312 This module provides Perl scripts easy way to interface the Git
313 version control system. The modules have an easy and well-tested way
314 to call arbitrary Git commands; in the future, the interface will also
315 provide specialized methods for doing easily operations which are not
316 totally trivial to do over the generic command interface.
317
318 %description -n perl-Git -l pl.UTF-8
319 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
320 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
321 dowolne polecenia Gita; w przyszłości interfejs udostępni także
322 specjalne metody do łatwego wykonywania operacji nietrywialnych do
323 wykonania przy użyciu ogólnego interfejsu poleceń.
324
325 %package -n python-Git
326 Summary:        Python interface to the Git version control system
327 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
328 Group:          Development/Languages/Python
329
330 %description -n python-Git
331 This module provides Python scripts easy way to interface the Git
332 version control system.
333
334 %description -n python-Git -l pl.UTF-8
335 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
336 wersji Git.
337
338 %package -n vim-syntax-gitcommit
339 Summary:        Vim syntax: gitcommit
340 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
341 Group:          Applications/Editors/Vim
342 # for _vimdatadir existence
343 Requires:       vim-rt >= 4:6.3.058-3
344
345 %description -n vim-syntax-gitcommit
346 This plugin provides syntax highlighting for git's commit messages.
347
348 %description -n vim-syntax-gitcommit -l pl.UTF-8
349 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
350
351 %prep
352 %setup -q -n git-%{version}
353 %patch0 -p1
354
355 %build
356 %{__aclocal}
357 %{__autoconf}
358 %configure \
359         --with-openssl
360
361 echo "BLK_SHA1=1" >> config.mak
362
363 %{__make} \
364         INSTALLDIRS=vendor \
365         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
366         GITWEB_PROJECTROOT="/var/lib/git" \
367         GITWEB_CSS="/gitweb/gitweb.css" \
368         GITWEB_LOGO="/gitweb/git-logo.png" \
369         GITWEB_FAVICON="/gitweb/git-favicon.png"
370
371 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
372 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
373
374 %if %{with tests}
375 %if %{without tests_cvs}
376 rm t/t*cvs*.sh || :
377 %endif
378 %{__make} test
379 %endif
380
381 %install
382 rm -rf $RPM_BUILD_ROOT
383 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
384 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
385 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
386
387 %{__make} install \
388         INSTALLDIRS=vendor \
389         DESTDIR=$RPM_BUILD_ROOT
390
391 %if %{with doc}
392 %{__make} -C Documentation install \
393         DESTDIR=$RPM_BUILD_ROOT
394 %endif
395
396 # header files and lib
397 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
398 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
399 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
400 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
401
402 # bash completion
403 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
404 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
405
406 # vim syntax
407 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
408 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
409 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
410 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
411 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
412 autocmd BufNewFile,BufRead .msg.[0-9]*
413         \ if getline(1) =~ '^From.*# This line is ignored.$' |
414         \   setf gitsendemail |
415         \ endif
416 autocmd BufNewFile,BufRead *.git/**
417         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
418         \   setf git |
419         \ endif
420 EOF
421
422 # gitweb
423 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
424 cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
425 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
426 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
427 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
428
429 # gitview
430 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
431
432 # git-daemon related files
433 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
434 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
435 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
436
437 # paths cleanup
438 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
439 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
440
441 # hardlink
442 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
443 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
444 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
445 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
446
447 # remove unneeded files
448 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
449 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
450 %py_postclean
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post daemon-inetd
456 %service -q rc-inetd reload
457
458 %postun daemon-inetd
459 if [ "$1" = "0" ]; then
460         %service -q rc-inetd reload
461 fi
462
463 %post daemon-standalone
464 /sbin/chkconfig --add git-daemon
465 %service git-daemon restart "git-daemon"
466
467 %preun daemon-standalone
468 if [ "$1" = "0" ]; then
469         %service git-daemon stop
470         /sbin/chkconfig --del git-daemon
471 fi
472
473 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
474 %webapp_register apache %{webapp}
475
476 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
477 %webapp_unregister apache %{webapp}
478
479 %triggerin gitweb -- apache < 2.2.0, apache-base
480 %webapp_register httpd %{webapp}
481
482 %triggerun gitweb -- apache < 2.2.0, apache-base
483 %webapp_unregister httpd %{webapp}
484
485 %files
486 %defattr(644,root,root,755)
487 %doc README contrib
488 %attr(755,root,root) %{_bindir}/git
489 %attr(755,root,root) %{_bindir}/git-receive-pack
490 %attr(755,root,root) %{_bindir}/git-shell
491 %attr(755,root,root) %{_bindir}/git-upload-archive
492 %attr(755,root,root) %{_bindir}/git-upload-pack
493
494 %if %{with doc}
495 %{_mandir}/man1/git-*.1*
496 %exclude %{_mandir}/man1/git-svn.1*
497 %exclude %{_mandir}/man1/git-cvs*.1*
498 %{_mandir}/man1/git.1*
499 %{_mandir}/man5/gitattributes.5*
500 %{_mandir}/man5/githooks.5*
501 %{_mandir}/man5/gitignore.5*
502 %{_mandir}/man5/gitmodules.5*
503 %{_mandir}/man5/gitrepository-layout.5*
504 %{_mandir}/man7/gitcli.7*
505 %{_mandir}/man7/gitcore-tutorial.7*
506 %{_mandir}/man7/gitdiffcore.7*
507 %{_mandir}/man7/gitglossary.7*
508 %{_mandir}/man7/gittutorial-2.7*
509 %{_mandir}/man7/gittutorial.7*
510 %{_mandir}/man7/gitworkflows.7*
511 %endif
512
513 %dir %{_libdir}/%{name}
514 %attr(755,root,root) %{_libdir}/%{name}/*-*
515 %attr(755,root,root) %{_libdir}/%{name}/git
516
517 %exclude %{_libdir}/%{name}/git-gui
518 %exclude %{_libdir}/%{name}/git-svn
519 %exclude %{_libdir}/%{name}/git-archimport
520 %exclude %{_libdir}/%{name}/git-cvs*
521 %exclude %{_libdir}/%{name}/*email*
522
523 %{_datadir}/%{name}
524
525 %{_localstatedir}/lib/git
526
527 %if %{with doc}
528 %files doc
529 %defattr(644,root,root,755)
530 %doc Documentation/RelNotes*
531 %doc Documentation/*.html Documentation/howto Documentation/technical
532 %endif
533
534 %files daemon-inetd
535 %defattr(644,root,root,755)
536 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
537
538 %files daemon-standalone
539 %defattr(644,root,root,755)
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
541 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
542
543 %files devel
544 %defattr(644,root,root,755)
545 %{_includedir}/git-core
546 %{_libdir}/libgit.a
547 %{_libdir}/libgit_xdiff.a
548
549 %files gitk
550 %defattr(644,root,root,755)
551 %if %{with doc}
552 %{_mandir}/man1/gitk.1*
553 %endif
554 %attr(755,root,root) %{_bindir}/gitk
555 %dir %{_datadir}/gitk
556 %dir %{_datadir}/gitk/lib
557 %dir %{_datadir}/gitk/lib/msgs
558 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
559 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
560 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
561 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
562 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
563 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
564 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
565 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
566
567 %files gitweb
568 %defattr(644,root,root,755)
569 %doc gitweb/{README,INSTALL}
570 %dir %{webappdir}
571 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
572 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
573 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
574 %attr(755,root,root) %{cgibindir}/gitweb.cgi
575 %{appdir}
576
577 %files gitview
578 %defattr(644,root,root,755)
579 %doc contrib/gitview/gitview.txt
580 %attr(755,root,root) %{_bindir}/gitview
581
582 %files gui
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/%{name}/git-gui
585 %dir %{_datadir}/git-gui
586 %dir %{_datadir}/git-gui/lib
587 %dir %{_datadir}/git-gui/lib/msgs
588 %{_datadir}/git-gui/lib/git-gui.ico
589 %{_datadir}/git-gui/lib/tclIndex
590 %{_datadir}/git-gui/lib/*.js
591 %{_datadir}/git-gui/lib/*.tcl
592 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
593 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
594 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
595 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
596 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
597 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
598 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
599 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
600 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
601 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
602
603 %files svn
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/%{name}/git-svn
606 %if %{with doc}
607 %{_mandir}/man1/git-svn.1*
608 %endif
609
610 %files cvs
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/git-cvsserver
613 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
614 %if %{with doc}
615 %{_mandir}/man1/git-cvs*.1*
616 %{_mandir}/man7/gitcvs-migration.7*
617 %endif
618
619 %files arch
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
622 %if %{with doc}
623 %{_mandir}/man1/git-archimport.1*
624 %endif
625
626 %files email
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/%{name}/*email*
629 %if %{with doc}
630 %{_mandir}/man1/*email*.1*
631 %endif
632
633 %files -n bash-completion-git
634 %defattr(644,root,root,755)
635 %{_sysconfdir}/bash_completion.d/*
636
637 %files -n perl-Git
638 %defattr(644,root,root,755)
639 %{perl_vendorlib}/Git.pm
640 %{_mandir}/man3/Git.3pm*
641
642 %files -n python-Git
643 %defattr(644,root,root,755)
644 %{py_sitescriptdir}/git_remote_helpers*.egg-info
645 %dir %{py_sitescriptdir}/git_remote_helpers
646 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
647 %dir %{py_sitescriptdir}/git_remote_helpers/git
648 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
649
650 %files -n vim-syntax-gitcommit
651 %defattr(644,root,root,755)
652 %doc contrib/vim/README
653 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.068656 seconds and 3 git commands to generate.