]> git.pld-linux.org Git - packages/ghc-hinotify.git/commitdiff
- new
authorJan Palus <jan.palus@gmail.com>
Sat, 16 Mar 2013 12:32:46 +0000 (13:32 +0100)
committerJan Palus <jan.palus@gmail.com>
Sat, 16 Mar 2013 12:32:46 +0000 (13:32 +0100)
ghc-hinotify.spec [new file with mode: 0644]

diff --git a/ghc-hinotify.spec b/ghc-hinotify.spec
new file mode 100644 (file)
index 0000000..418b5bc
--- /dev/null
@@ -0,0 +1,76 @@
+%define                pkgname hinotify
+Summary:       A Haskell binding to the hinotify graphics library
+Name:          ghc-%{pkgname}
+Version:       0.3.5
+Release:       0.1
+License:       BSD
+Group:         Development/Languages
+Source0:       http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
+# Source0-md5: 9e37df64edf05ba330272d12ff47e12a
+URL:           http://hackage.haskell.org/package/hinotify/
+BuildRequires: ghc >= 6.12.3
+BuildRequires: rpmbuild(macros) >= 1.608
+%requires_eq   ghc
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# debuginfo is not useful for ghc
+%define                _enable_debug_packages  0
+
+%description
+A Haskell binding to the hinotify graphics library.
+
+%package doc
+Summary:       HTML documentation for %{pkgname}
+Summary(pl.UTF-8):     Dokumentacja w formacie HTML dla %{pkgname}
+Group:         Documentation
+
+%description doc
+HTML documentation for %{pkgname}.
+
+%description doc -l pl.UTF-8
+Dokumentacja w formacie HTML dla %{pkgname}.
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+%build
+runhaskell Setup.lhs configure -v2 \
+       --prefix=%{_prefix} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libexecdir} \
+       --docdir=%{_docdir}/%{name}-%{version}
+
+runhaskell Setup.lhs build
+runhaskell Setup.lhs haddock --executables
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
+
+runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
+
+# work around automatic haddock docs installation
+rm -rf %{name}-%{version}-doc
+cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
+
+runhaskell Setup.lhs register \
+       --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%ghc_pkg_recache
+
+%postun
+%ghc_pkg_recache
+
+%files
+%defattr(644,root,root,755)
+%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
+%{_libdir}/%{ghcdir}/%{pkgname}-%{version}
+
+%files doc
+%defattr(644,root,root,755)
+%doc %{name}-%{version}-doc/*
This page took 0.08288 seconds and 4 git commands to generate.