]> git.pld-linux.org Git - packages/ggz-server.git/blame_incremental - ggz-server.spec
- added logrotate file
[packages/ggz-server.git] / ggz-server.spec
... / ...
CommitLineData
1# TODO:
2# - remove data from /var/lib/ggzd after removal of ggz-server package
3#
4Summary: Main GGZ server
5Summary(pl.UTF-8): Główny serwer GGZ
6Name: ggz-server
7Version: 0.0.14
8Release: 2
9License: GPL v2+
10Group: Applications
11Source0: http://ftp.belnet.be/packages/ggzgamingzone/ggz/0.0.14/%{name}-%{version}.tar.gz
12# Source0-md5: 7e30eedefb69834d9f76fdf7fed646ea
13Source1: %{name}.init
14Source2: %{name}.conf
15Source3: %{name}.logrotate
16Patch0: %{name}-db4.patch
17URL: http://www.ggzgamingzone.org/
18BuildRequires: autoconf >= 2.50
19BuildRequires: automake
20BuildRequires: avahi-devel
21BuildRequires: db-devel >= 4
22BuildRequires: expat-devel >= 1.95
23BuildRequires: libggz-devel >= 0.0.14
24BuildRequires: libtool
25BuildRequires: rpmbuild(macros) >= 1.268
26Requires(post,preun): /sbin/chkconfig
27Requires: %{name}-libs = %{version}-%{release}
28Requires: rc-scripts
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define _localstatedir /var/lib
32
33%description
34This package contains the main GGZ server, some administrative
35utilities and lots of game servers.
36
37%description -l pl.UTF-8
38Ta paczka zawiera główny serwer GGZ, kilka narzędzi administracyjnych
39oraz dużo serwerów gier.
40
41%package libs
42Summary: ggz-server libraries
43Summary(pl.UTF-8): Biblioteki ggz-server
44Group: Libraries
45
46%description libs
47ggz-server libraries.
48
49%description libs -l pl.UTF-8
50Biblioteki ggz-server.
51
52%package devel
53Summary: Header files for ggz-server library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki ggz-server
55Group: Development/Libraries
56Requires: %{name}-libs = %{version}-%{release}
57Requires: libggz-devel >= 0.0.14
58
59%description devel
60Header files for ggz-server library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki ggz-server.
64
65%package static
66Summary: Static ggz-server library
67Summary(pl.UTF-8): Statyczna biblioteka ggz-server
68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static ggz-server library.
73
74%description static -l pl.UTF-8
75Statyczna biblioteka ggz-server.
76
77%prep
78%setup -q
79%patch0 -p1
80
81%build
82%{__libtoolize}
83%{__aclocal} -I m4 -I m4/ggz
84%{__autoconf}
85%{__autoheader}
86%{__automake}
87%configure \
88 --with-database=db4 \
89 --with-zeroconf=avahi \
90 --with-reconfiguration=inotify
91
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,ggzd,logrotate.d},%{_var}/{lib/ggzd,log}}
98
99%{__make} install \
100 DESTDIR=$RPM_BUILD_ROOT
101
102install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ggzd
103sed -e 's,@LIBDIR@,%{_libdir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/ggzd/ggzd.conf
104install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
105
106:> $RPM_BUILD_ROOT%{_var}/log/ggz-server.log
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post
112/sbin/chkconfig --add ggzd
113%service ggzd restart
114
115%preun
116if [ "$1" = "0" ]; then
117 %service ggzd stop
118 /sbin/chkconfig --del ggzd
119fi
120
121%post libs -p /sbin/ldconfig
122%postun libs -p /sbin/ldconfig
123
124%files
125%defattr(644,root,root,755)
126%doc AUTHORS ChangeLog NEWS README TODO ggzd/ggzd.conf.example
127%attr(755,root,root) %{_bindir}/ggzd
128%attr(755,root,root) %{_bindir}/ggzduedit
129%dir %{_libdir}/ggzd
130%attr(755,root,root) %{_libdir}/ggzd/geekgameserver
131%attr(755,root,root) %{_libdir}/ggzd/ggzd.ccheckers
132%attr(755,root,root) %{_libdir}/ggzd/ggzd.chess
133%attr(755,root,root) %{_libdir}/ggzd/ggzd.combat
134%attr(755,root,root) %{_libdir}/ggzd/ggzd.connectx
135%attr(755,root,root) %{_libdir}/ggzd/ggzd.dots
136%attr(755,root,root) %{_libdir}/ggzd/ggzd.escape
137%attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards
138%attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards.ai-random
139%attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards.ai-spades
140%attr(755,root,root) %{_libdir}/ggzd/ggzd.ggzcards.ai-suaro
141%attr(755,root,root) %{_libdir}/ggzd/ggzd.hastings
142%attr(755,root,root) %{_libdir}/ggzd/ggzd.reversi
143%attr(755,root,root) %{_libdir}/ggzd/ggzd.spades
144%attr(755,root,root) %{_libdir}/ggzd/ggzd.tictactoe
145%attr(755,root,root) %{_libdir}/ggzd/keepalivesrv
146%attr(755,root,root) %{_libdir}/ggzd/krosswater_server
147%attr(755,root,root) %{_libdir}/ggzd/muehleserv
148%attr(755,root,root) %{_libdir}/ggzd/tuxmanserv
149%attr(755,root,root) %{_libdir}/ggzd/widelands_server
150%dir %{_sysconfdir}/ggzd
151%dir %{_sysconfdir}/ggzd/games
152%{_sysconfdir}/ggzd/games/ccheckers.dsc
153%{_sysconfdir}/ggzd/games/chess.dsc
154%{_sysconfdir}/ggzd/games/combat.dsc
155%{_sysconfdir}/ggzd/games/connectx.dsc
156%{_sysconfdir}/ggzd/games/dots.dsc
157%{_sysconfdir}/ggzd/games/escape.dsc
158%{_sysconfdir}/ggzd/games/geekgame.dsc
159%{_sysconfdir}/ggzd/games/ggzcards-bridge.dsc
160%{_sysconfdir}/ggzd/games/ggzcards-fortytwo.dsc
161%{_sysconfdir}/ggzd/games/ggzcards-hearts.dsc
162%{_sysconfdir}/ggzd/games/ggzcards-lapocha.dsc
163%{_sysconfdir}/ggzd/games/ggzcards-spades.dsc
164%{_sysconfdir}/ggzd/games/ggzcards-suaro.dsc
165%{_sysconfdir}/ggzd/games/ggzcards-sueca.dsc
166%{_sysconfdir}/ggzd/games/ggzcards-whist.dsc
167%{_sysconfdir}/ggzd/games/ggzcards.dsc
168%{_sysconfdir}/ggzd/games/hastings.dsc
169%{_sysconfdir}/ggzd/games/keepalive.dsc
170%{_sysconfdir}/ggzd/games/krosswater.dsc
171%{_sysconfdir}/ggzd/games/muehle.dsc
172%{_sysconfdir}/ggzd/games/reversi.dsc
173%{_sysconfdir}/ggzd/games/spades.dsc
174%{_sysconfdir}/ggzd/games/tictactoe.dsc
175%{_sysconfdir}/ggzd/games/tuxman.dsc
176%{_sysconfdir}/ggzd/games/widelands.dsc
177%dir %{_sysconfdir}/ggzd/rooms
178%{_sysconfdir}/ggzd/rooms/ccheckers.room
179%{_sysconfdir}/ggzd/rooms/chess.room
180%{_sysconfdir}/ggzd/rooms/combat.room
181%{_sysconfdir}/ggzd/rooms/connectx.room
182%{_sysconfdir}/ggzd/rooms/dots.room
183%{_sysconfdir}/ggzd/rooms/entry.room
184%{_sysconfdir}/ggzd/rooms/escape.room
185%{_sysconfdir}/ggzd/rooms/geekgame.room
186%{_sysconfdir}/ggzd/rooms/ggzcards-bridge.room
187%{_sysconfdir}/ggzd/rooms/ggzcards-fortytwo.room
188%{_sysconfdir}/ggzd/rooms/ggzcards-hearts.room
189%{_sysconfdir}/ggzd/rooms/ggzcards-lapocha.room
190%{_sysconfdir}/ggzd/rooms/ggzcards-spades.room
191%{_sysconfdir}/ggzd/rooms/ggzcards-suaro.room
192%{_sysconfdir}/ggzd/rooms/ggzcards-sueca.room
193%{_sysconfdir}/ggzd/rooms/ggzcards-whist.room
194%{_sysconfdir}/ggzd/rooms/ggzcards.room
195%{_sysconfdir}/ggzd/rooms/hastings.room
196%{_sysconfdir}/ggzd/rooms/keepalive.room
197%{_sysconfdir}/ggzd/rooms/krosswater.room
198%{_sysconfdir}/ggzd/rooms/muehle.room
199%{_sysconfdir}/ggzd/rooms/reversi.room
200%{_sysconfdir}/ggzd/rooms/spades.room
201%{_sysconfdir}/ggzd/rooms/tictactoe.room
202%{_sysconfdir}/ggzd/rooms/tuxman.room
203%{_sysconfdir}/ggzd/rooms/widelands.room
204%attr(640,root,games) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggzd/ggzd.conf
205%{_sysconfdir}/ggzd/ggzd.motd
206%attr(754,root,root) /etc/rc.d/init.d/ggzd
207%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/ggz-server
208%dir %{_datadir}/ggz/ggzd
209%{_datadir}/ggz/ggzd/ggzcards
210%{_datadir}/ggz/ggzd/hastings1066
211%{_datadir}/ggz/ggzd/muehle
212%{_datadir}/ggz/ggzd/tuxmanserv
213%{_mandir}/man6/ggzd.6*
214%{_mandir}/man6/ggzduedit.6*
215%attr(770,root,games) %{_localstatedir}/ggzd
216%attr(660,root,games) %config(noreplace) %verify(not md5 mtime size) %{_var}/log/ggz-server.log
217
218%files libs
219%defattr(644,root,root,755)
220%attr(755,root,root) %{_libdir}/libggzdmod++.so.*.*.*
221%attr(755,root,root) %ghost %{_libdir}/libggzdmod++.so.1
222%attr(755,root,root) %{_libdir}/libggzdmod.so.*.*.*
223%attr(755,root,root) %ghost %{_libdir}/libggzdmod.so.6
224
225%files devel
226%defattr(644,root,root,755)
227%attr(755,root,root) %{_libdir}/libggzdmod++.so
228%attr(755,root,root) %{_libdir}/libggzdmod.so
229%{_libdir}/libggzdmod++.la
230%{_libdir}/libggzdmod.la
231%{_libdir}/libggzdmod++.la
232%{_libdir}/libggzdmod.la
233%{_includedir}/ggzdmod++
234%{_includedir}/ggzdmod.h
235%{_mandir}/man3/ggzdmod.h.3*
236
237%files static
238%defattr(644,root,root,755)
239%{_libdir}/libggzdmod++.a
240%{_libdir}/libggzdmod.a
This page took 0.108496 seconds and 4 git commands to generate.