]> git.pld-linux.org Git - packages/ggz-java.git/blob - ggz-java.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/ggz-java.git] / ggz-java.spec
1 #
2 # Conditional build:
3 %bcond_without  javadoc         # don't build javadoc
4 #
5 Summary:        Java core client for the GGZ Gaming Zone
6 Summary(pl.UTF-8):      Klient GGZ Gaming Zone w Javie
7 Name:           ggz-java
8 Version:        0.0.14.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Applications/Games
12 Source0:        http://mirrors.dotsrc.org/ggzgamingzone/ggz/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  df1c433df4d310cb9ee90a7091bf2cf1
14 URL:            http://www.ggzgamingzone.org/
15 BuildRequires:  ant
16 BuildRequires:  jdk >= 1.4
17 BuildRequires:  jpackage-utils
18 BuildRequires:  rpm-javaprov
19 BuildRequires:  rpmbuild(macros) >= 1.300
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The GGZ Java client is a port of the following C libraries:
25 - libggz
26 - ggz-client-libs 
27 - ggz-gtk-client (redeveloped from scratch)
28 - ggz-gtk-games/ggzcards (redeveloped from scratch)
29
30 %description -l pl.UTF-8
31 Klient GGZ w Javie to port nastÄ™pujÄ…cych bibliotek C:
32 - libggz
33 - ggz-client-libs
34 - ggz-gtk-client (utworzony od podstaw)
35 - ggz-gtk-games/ggzcards (utworzony od podstaw)
36
37 %package javadoc
38 Summary:        GGZ Java client API documentation
39 Summary(pl.UTF-8):      Dokumentacja API klienta GGZ w Javie
40 Group:          Documentation
41 Requires:       jpackage-utils
42
43 %description javadoc
44 GGZ Java client API documentation.
45
46 %description javadoc -l pl.UTF-8
47 Dokumentacja API klienta GGZ w Javie.
48
49 %prep
50 %setup -q
51
52 %build
53 export JAVA_HOME="%{java_home}"
54
55 %ant jar %{?with_javadoc:javadoc} \
56         -Dsvnant.unspec=true
57
58 # see Makefile
59 cp -p ggz-java-unspec.jar ggz-java-client.jar
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT \
66         prefix=%{_prefix}
67
68 %if %{with javadoc}
69 install -d $RPM_BUILD_ROOT%{_javadocdir}
70 cp -a javadoc $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
71 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
72 %endif
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post javadoc
78 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS ChangeLog NEWS README.GGZ README.txt TODO.txt
83 %attr(755,root,root) %{_bindir}/ggz-java
84 %dir %{_datadir}/ggz/ggz-java
85 %{_datadir}/ggz/ggz-java/ggz-java-unspec.jar
86 %{_mandir}/man6/ggz-java.6*
87
88 %if %{with javadoc}
89 %files javadoc
90 %defattr(644,root,root,755)
91 %{_javadocdir}/%{name}-%{version}
92 %ghost %{_javadocdir}/%{name}
93 %endif
This page took 0.126015 seconds and 4 git commands to generate.