]> git.pld-linux.org Git - packages/ggaoed.git/blame_incremental - ggaoed.spec
- BR: libblkid-devel, pkgconfig
[packages/ggaoed.git] / ggaoed.spec
... / ...
CommitLineData
1Summary: ggaoed - ATA over Ethernet target implementation for Linux
2Name: ggaoed
3Version: 1.1
4Release: 1
5License: GPL v2
6Group: Networking/Daemons
7Source0: http://ggaoed.googlecode.com/files/%{name}-%{version}.tar.gz
8# Source0-md5: 9d46d1b274e96547bb93bc5360a1db54
9Source1: %{name}.init
10Source2: %{name}.sysconfig
11Patch0: %{name}-build.patch
12URL: http://code.google.com/p/ggaoed/
13BuildRequires: docbook2X >= 0.8
14BuildRequires: glib2-devel >= 2.12
15BuildRequires: libaio-devel >= 0.3.107
16BuildRequires: libatomic_ops >= 1.2
17BuildRequires: libblkid-devel
18BuildRequires: pkgconfig
19Requires(post,preun): /sbin/chkconfig
20Requires: rc-scripts
21Requires: uname(release) >= 2.6.31
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25ggaoed is an AoE (ATA over Ethernet) target implementation for Linux.
26It utilizes Linux kernel AIO, memory mapped sockets and other Linux
27features to provide the best performance.
28
29%prep
30%setup -q
31%patch0 -p1
32
33%build
34%configure
35%{__make}
36
37%install
38rm -rf $RPM_BUILD_ROOT
39install -d $RPM_BUILD_ROOT%{_sharedstatedir}/ggaoed
40
41%{__make} install \
42 datarootdir=$RPM_BUILD_ROOT%{_datadir} \
43 sbindir=$RPM_BUILD_ROOT%{_sbindir} \
44 mandir=$RPM_BUILD_ROOT%{_mandir}
45
46install -D ggaoed.conf.dist $RPM_BUILD_ROOT%{_sysconfdir}/ggaoed.conf
47install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ggaoed
48install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ggaoed
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54/sbin/chkconfig --add ggaoed
55/sbin/chkconfig ggaoed off
56%service ggaoed restart
57
58%preun
59if [ "$1" = "0" ]; then
60 /sbin/chkconfig --del ggaoed
61 %service ggaoed stop
62 # nuke config cache if uninstalling
63 rm -rf %{_sharedstatedir}/ggaoed/*
64fi
65
66%files
67%defattr(644,root,root,755)
68%doc NEWS README
69%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ggaoed.conf
70%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ggaoed
71%attr(754,root,root) /etc/rc.d/init.d/ggaoed
72%attr(755,root,root) %{_sbindir}/ggaoectl
73%attr(755,root,root) %{_sbindir}/ggaoed
74%{_mandir}/man5/ggaoed.conf.5*
75%{_mandir}/man8/ggaoectl.8*
76%{_mandir}/man8/ggaoed.8*
77%dir %{_sharedstatedir}/ggaoed
This page took 0.080692 seconds and 4 git commands to generate.