]> git.pld-linux.org Git - packages/gg.git/blob - gg.spec
- outdated
[packages/gg.git] / gg.spec
1 #
2 # Conditional build:
3 #
4 # _without_gnome
5 # _without_gnome_applet
6 # _without_kde
7 # _without_wm_applet
8 # _without_sound
9
10 # This looks like overkill but some day we might have *everything* bconded :)
11 %{!?_without_gnome:%define _need_gnome  1}
12 %{!?_without_gnome:%define _need_esd   1}
13 %{!?_without_gnome_applet:%define       _need_gnome     1}
14 %{!?_without_gnome_applet:%define _nees_esd   1}
15 %{!?_without_kde:%define _need_arts     1}
16 %{!?_without_wm_applet:%define _need_esd        1}
17
18 Summary:        GNU Gadu - free talking
19 Summary(pl):    GNU Gadu - wolne gadanie
20 Name:           gg
21 Version:        1.0.0
22 Release:        1.1
23 Epoch:          5
24 License:        GPL
25 Group:          Applications/Communications
26 Source0:        ftp://ftp.slackware.pl/pub/gg/%{name}-%{version}.tar.gz
27 Source1:        %{name}.png
28 Source2:        %{name}_gnome.desktop
29 Source3:        %{name}_gnome_applet.desktop
30 Source4:        %{name}_WM_applet.desktop
31 Source5:        %{name}_KDE.desktop
32 Icon:           gg.xpm
33 URL:            http://gadu.gnu.pl
34 %{?_need_arts:BuildRequires:    arts-devel}
35 %if %{!?_without_sound:1}%{?_without_sound:0}
36 %{?_need_esd:BuildRequires:             esound-devel > 0.2.7}
37 %endif
38 %{?_need_gnome:BuildRequires:   gnome-libs-devel}
39 %{?_need_gnome:BuildRequires:   gnome-core-devel}
40 BuildRequires:  gtk+-devel > 1.2.8
41 BuildRequires:  xmms-devel
42
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/X11/GNOME
46 %define         _prefix                 /usr/X11R6
47
48 %description
49 Gadu-Gadu client released on GNU/GPL.
50
51 %description -l pl
52 Klient Gadu-Gadu na licencji GNU/GPL.
53
54 %package common
55 Summary:        GNU Gadu - free talking - common files
56 Summary(pl):    GNU Gadu - wolne gadanie - wspólne pliki
57 Group:          Applications/Communications
58 Obsoletes:      gg =< 0.2.0
59
60 %description common
61 Gadu-Gadu client released on GNU/GPL.
62
63 %description common -l pl
64 Klient Gadu-Gadu na licencji GNU/GPL.
65
66 %package X11
67 Summary:        GNU Gadu - free talking
68 Summary(pl):    GNU Gadu - wolne gadanie
69 Group:          Applications/Communications
70 PreReq:         %{name}-common = %{epoch}:%{version}
71 Provides:       gg = %{epoch}:%{version}-%{release}
72
73 %description X11
74 Gadu-Gadu client released on GNU/GPL.
75
76 %description X11 -l pl
77 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla X11.
78
79 %package gnome
80 Summary:        GNU Gadu - free talking - GNOME version
81 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla GNOME
82 Group:          Applications/Communications
83 PreReq:         %{name}-common = %{epoch}:%{version}
84 Provides:       gg = %{epoch}:%{version}-%{release}
85
86 %description gnome
87 Gadu-Gadu client released on GNU/GPL. GNOME version
88
89 %description gnome -l pl
90 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla GNOME.
91
92 %package gnome-applet
93 Summary:        GNU Gadu - free talking - GNOME dockable version
94 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla GNOME
95 Group:          Applications/Communications
96 PreReq:         %{name}-common = %{epoch}:%{version}
97 Provides:       gg = %{epoch}:%{version}-%{release}
98
99 %description gnome-applet
100 Gadu-Gadu client released on GNU/GPL. GNOME dockable version
101
102 %description gnome-applet -l pl
103 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla gnome.
104
105 %package wm-applet
106 Summary:        GNU Gadu - free talking - WindowMaker dockable version
107 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla WindowMaker'a
108 Group:          Applications/Communications
109 PreReq:         %{name}-common = %{epoch}:%{version}
110 Provides:       gg = %{epoch}:%{version}-%{release}
111
112 %description wm-applet
113 Gadu-Gadu client released on GNU/GPL. WindowMaker dockable version
114
115 %description wm-applet -l pl
116 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla
117 WindowMaker'a.
118
119 %package kde
120 Summary:        GNU Gadu - free talking - KDE version
121 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla KDE
122 Group:          Applications/Communications
123 PreReq:         %{name}-common = %{epoch}:%{version}
124 Provides:       gg = %{epoch}:%{version}-%{release}
125
126 %description kde
127 Gadu-Gadu client released on GNU/GPL. KDE version
128
129 %description kde -l pl
130 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla KDE.
131
132 %prep
133 %setup -q 
134
135 %build
136 LDFLAGS=" -L%{_libdir} %{rpmldflags}"
137
138 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
139 %configure \
140         %{?_without_sound:--disable-esd} \
141         --enable-gnome \
142         --enable-panel \
143         --enable-xmms
144 %{__make}
145 mv -f src/gg src/gg_applet
146 %{__make} clean
147 %endif
148
149 %if %{!?_without_gnome:1}%{?_without_gnome:0}
150 %configure \
151         %{?_without_sound:--disable-esd} \
152         --enable-gnome \
153         --enable-xmms
154 %{__make}
155 mv -f src/gg src/gg_gnome
156 %{__make} clean
157 %endif
158
159 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
160 %configure \
161         %{?_without_sound:--disable-esd} \
162         --enable-dockapp \
163         --enable-xmms
164 %{__make}
165 mv -f src/gg src/gg_wm
166 %{__make} clean
167 %endif
168
169 %if %{!?_without_kde:1}%{?_without_kde:0}
170 %configure \
171         --enable-docklet \
172         %{!?_without_sound:--enable-arts} \
173         --disable-esd \
174         --enable-xmms
175 %{__make}
176 mv -f src/gg src/gg_kde
177 %{__make} clean
178 %endif
179
180 %configure %{?_without_sound:--disable-esd} --enable-xmms
181 %{__make}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Communications,%{_pixmapsdir},%{_datadir}/applets/Network/}
186
187 %{__make} install DESTDIR=$RPM_BUILD_ROOT
188 %{!?_without_gnome_applet:install src/gg_applet $RPM_BUILD_ROOT%{_bindir}}
189 %{!?_without_gnome:install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}}
190 %{!?_without_wm_applet:install src/gg_wm $RPM_BUILD_ROOT%{_bindir}}
191 %{!?_without_kde:install src/gg_kde $RPM_BUILD_ROOT%{_bindir}}
192
193 sed -e 's/xpm$/png/' src/GnuGadu.desktop \
194         > $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu.desktop
195 sed -e 's/xpm$/png/' -e 's/Exec=gg/Exec=gg_applet\ --activate-goad-server=gg/' \
196         src/GnuGadu.desktop > $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu.desktop
197
198 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
199 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_gnome.desktop
200 install %{SOURCE3} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_gnome_applet.desktop
201 install %{SOURCE4} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_WM_applet.desktop
202 install %{SOURCE5} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_KDE.desktop
203
204 install -d $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
205 install src/GnuGadu.gnorba $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %files common
211 %defattr(644,root,root,755)
212 %doc README ChangeLog TODO
213 %{_datadir}/gg
214 %{_pixmapsdir}/*
215
216 %files X11
217 %defattr(644,root,root,755)
218 %{_applnkdir}/Network/Communications/GnuGadu.desktop
219 %attr(755,root,root) %{_bindir}/gg
220
221 %if %{!?_without_gnome:1}%{?_without_gnome:0}
222 %files gnome
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_bindir}/gg_gnome
225 %{_applnkdir}/Network/Communications/GnuGadu_gnome.desktop
226 %endif
227
228 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
229 %files gnome-applet
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/gg_applet
232 %{_datadir}/applets/Network/GnuGadu_gnome_applet.desktop
233 %{_sysconfdir}/CORBA/servers/GnuGadu.gnorba
234 %endif
235
236 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
237 %files wm-applet
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_bindir}/gg_wm
240 %{_datadir}/applets/Network/GnuGadu_WM_applet.desktop
241 %endif
242
243 %if %{!?_without_kde:1}%{?_without_kde:0}
244 %files kde
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/gg_kde
247 %{_applnkdir}/Network/Communications/GnuGadu_KDE.desktop
248 %endif
This page took 0.10421 seconds and 3 git commands to generate.