]> git.pld-linux.org Git - packages/gg.git/blob - gg.spec
- freedesktop compatibility
[packages/gg.git] / gg.spec
1 # Conditional build:
2 #
3 # _without_gnome        - don't build with GNOME
4 # _without_gnome_applet - don't build GNOME applet
5 # _without_kde          - don't build KDE applet
6 # _without_wm_applet    - don't build WM applet
7 # _without_sound        - disable sound support
8
9 # This looks like overkill but some day we might have *everything* bconded :)
10 %{!?_without_gnome:%define _need_gnome  1}
11 %{!?_without_gnome:%define _need_esd   1}
12 %{!?_without_gnome_applet:%define       _need_gnome     1}
13 %{!?_without_gnome_applet:%define _nees_esd   1}
14 %{!?_without_kde:%define _need_arts     1}
15 %{!?_without_wm_applet:%define _need_esd        1}
16
17 Summary:        GNU Gadu - free talking
18 Summary(pl):    GNU Gadu - wolne gadanie
19 Name:           gg
20 Version:        1.0.0
21 Release:        3
22 Epoch:          5
23 License:        GPL
24 Group:          Applications/Communications
25 Source0:        http://dl.sf.net/ggadu/%{name}-%{version}.tar.gz
26 # Source0-md5:  7b32d4c866ef59dfe22373a83b1a9a2a
27 Source1:        %{name}.png
28 Source2:        %{name}_gnome.desktop
29 Source3:        %{name}_WM_applet.desktop
30 Source4:        %{name}_KDE.desktop
31 Patch0:         http://piorun.ds.pg.gda.pl/~blues/patches/gg-debian_fixes.patch
32 Icon:           gg.xpm
33 URL:            http://gadu.gnu.pl/
34 %{?_need_arts:BuildRequires:    arts-devel}
35 %if %{!?_without_sound:1}%{?_without_sound:0}
36 %{?_need_esd:BuildRequires:             esound-devel > 0.2.7}
37 %endif
38 %{?_need_gnome:BuildRequires:   gnome-libs-devel}
39 %{?_need_gnome:BuildRequires:   gnome-core-devel}
40 BuildRequires:  gtk+-devel > 1.2.8
41 BuildRequires:  xmms-devel
42
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/X11/GNOME
46 %define         _prefix                 /usr/X11R6
47
48 %description
49 Gadu-Gadu client released on GNU/GPL.
50
51 %description -l pl
52 Klient Gadu-Gadu na licencji GNU/GPL.
53
54 %package common
55 Summary:        GNU Gadu - free talking - common files
56 Summary(pl):    GNU Gadu - wolne gadanie - wspólne pliki
57 Group:          Applications/Communications
58 Obsoletes:      gg =< 0.2.0
59
60 %description common
61 Gadu-Gadu client released on GNU/GPL.
62
63 %description common -l pl
64 Klient Gadu-Gadu na licencji GNU/GPL.
65
66 %package X11
67 Summary:        GNU Gadu - free talking
68 Summary(pl):    GNU Gadu - wolne gadanie
69 Group:          Applications/Communications
70 PreReq:         %{name}-common = %{epoch}:%{version}
71 Provides:       gg = %{epoch}:%{version}-%{release}
72
73 %description X11
74 Gadu-Gadu client released on GNU/GPL.
75
76 %description X11 -l pl
77 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla X11.
78
79 %package gnome
80 Summary:        GNU Gadu - free talking - GNOME version
81 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla GNOME
82 Group:          Applications/Communications
83 PreReq:         %{name}-common = %{epoch}:%{version}
84 Provides:       gg = %{epoch}:%{version}-%{release}
85
86 %description gnome
87 Gadu-Gadu client released on GNU/GPL. GNOME version
88
89 %description gnome -l pl
90 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla GNOME.
91
92 %package gnome-applet
93 Summary:        GNU Gadu - free talking - GNOME dockable version
94 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla GNOME
95 Group:          Applications/Communications
96 PreReq:         %{name}-common = %{epoch}:%{version}
97 Provides:       gg = %{epoch}:%{version}-%{release}
98
99 %description gnome-applet
100 Gadu-Gadu client released on GNU/GPL. GNOME dockable version
101
102 %description gnome-applet -l pl
103 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla GNOME.
104
105 %package wm-applet
106 Summary:        GNU Gadu - free talking - WindowMaker dockable version
107 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla WindowMaker'a
108 Group:          Applications/Communications
109 PreReq:         %{name}-common = %{epoch}:%{version}
110 Provides:       gg = %{epoch}:%{version}-%{release}
111
112 %description wm-applet
113 Gadu-Gadu client released on GNU/GPL. WindowMaker dockable version
114
115 %description wm-applet -l pl
116 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla
117 WindowMaker'a.
118
119 %package kde
120 Summary:        GNU Gadu - free talking - KDE version
121 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla KDE
122 Group:          Applications/Communications
123 PreReq:         %{name}-common = %{epoch}:%{version}
124 Provides:       gg = %{epoch}:%{version}-%{release}
125
126 %description kde
127 Gadu-Gadu client released on GNU/GPL. KDE version
128
129 %description kde -l pl
130 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla KDE.
131
132 %prep
133 %setup -q
134 %patch0 -p1
135
136 %build
137 LDFLAGS=" -L%{_libdir} %{rpmldflags}"
138
139 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
140 %configure \
141         %{?_without_sound:--disable-esd} \
142         --enable-gnome \
143         --enable-panel \
144         --enable-xmms
145 %{__make}
146 mv -f src/gg src/gg_applet
147 %{__make} clean
148 %endif
149
150 %if %{!?_without_gnome:1}%{?_without_gnome:0}
151 %configure \
152         %{?_without_sound:--disable-esd} \
153         --enable-gnome \
154         --enable-xmms
155 %{__make}
156 mv -f src/gg src/gg_gnome
157 %{__make} clean
158 %endif
159
160 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
161 %configure \
162         %{?_without_sound:--disable-esd} \
163         --enable-dockapp \
164         --enable-xmms
165 %{__make}
166 mv -f src/gg src/gg_wm
167 %{__make} clean
168 %endif
169
170 %if %{!?_without_kde:1}%{?_without_kde:0}
171 %configure \
172         --enable-docklet \
173         %{!?_without_sound:--enable-arts} \
174         --disable-esd \
175         --enable-xmms
176 %{__make}
177 mv -f src/gg src/gg_kde
178 %{__make} clean
179 %endif
180
181 %configure %{?_without_sound:--disable-esd} --enable-xmms
182 %{__make}
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Communications,%{_datadir}/applets/Network} \
187         $RPM_BUILD_ROOT{%{_sysconfdir}/CORBA/servers,%{_pixmapsdir}}
188
189 %{__make} install \
190         DESTDIR=$RPM_BUILD_ROOT
191
192 %{!?_without_gnome_applet:install src/gg_applet $RPM_BUILD_ROOT%{_bindir}}
193 %{!?_without_gnome:install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}}
194 %{!?_without_wm_applet:install src/gg_wm $RPM_BUILD_ROOT%{_bindir}}
195 %{!?_without_kde:install src/gg_kde $RPM_BUILD_ROOT%{_bindir}}
196
197 sed -e 's/xpm$/png/' src/GnuGadu.desktop \
198         > $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu.desktop
199 sed -e 's/xpm$/png/' -e 's/Exec=gg/Exec=gg_applet\ --activate-goad-server=gg/' \
200         src/GnuGadu.desktop > $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu.desktop
201
202 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
203 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_gnome.desktop
204 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu_WM_applet.desktop
205 install %{SOURCE4} $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu_KDE.desktop
206 install src/GnuGadu.gnorba $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %files common
212 %defattr(644,root,root,755)
213 %doc README ChangeLog TODO
214 %{_datadir}/gg
215 %{_pixmapsdir}/*
216
217 %files X11
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_bindir}/gg
220 %{_applnkdir}/Network/Communications/GnuGadu.desktop
221
222 %if %{!?_without_gnome:1}%{?_without_gnome:0}
223 %files gnome
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_bindir}/gg_gnome
226 %{_applnkdir}/Network/Communications/GnuGadu_gnome.desktop
227 %endif
228
229 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
230 %files gnome-applet
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_bindir}/gg_applet
233 %{_datadir}/applets/Network/GnuGadu.desktop
234 %{_sysconfdir}/CORBA/servers/GnuGadu.gnorba
235 %endif
236
237 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
238 %files wm-applet
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_bindir}/gg_wm
241 %{_datadir}/applets/Network/GnuGadu_WM_applet.desktop
242 %endif
243
244 %if %{!?_without_kde:1}%{?_without_kde:0}
245 %files kde
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_bindir}/gg_kde
248 %{_applnkdir}/Network/Communications/GnuGadu_KDE.desktop
249 %endif
This page took 0.082276 seconds and 3 git commands to generate.