]> git.pld-linux.org Git - packages/gg.git/blob - gg.spec
- gnome applet desktop
[packages/gg.git] / gg.spec
1 #
2 # Conditional build:
3 #
4 # _without_gnome
5 # _without_gnome_applet
6 # _without_kde
7 # _without_wm_applet
8 # _without_sound
9
10 # This looks like overkill but some day we might have *everything* bconded :)
11 %{!?_without_gnome:%define _need_gnome  1}
12 %{!?_without_gnome:%define _need_esd   1}
13 %{!?_without_gnome_applet:%define       _need_gnome     1}
14 %{!?_without_gnome_applet:%define _nees_esd   1}
15 %{!?_without_kde:%define _need_arts     1}
16 %{!?_without_wm_applet:%define _need_esd        1}
17
18 Summary:        GNU Gadu - free talking
19 Summary(pl):    GNU Gadu - wolne gadanie
20 Name:           gg
21 Version:        1.0.0
22 Release:        1
23 Epoch:          5
24 License:        GPL
25 Group:          Applications/Communications
26 Source0:        ftp://ftp.slackware.pl/pub/gg/%{name}-%{version}.tar.gz
27 Source1:        %{name}.png
28 Icon:           gg.xpm
29 URL:            http://gadu.gnu.pl
30 %{?_need_arts:BuildRequires:    arts-devel}
31 %if %{!?_without_sound:1}%{?_without_sound:0}
32 %{?_need_esd:BuildRequires:             esound-devel > 0.2.7}
33 %endif
34 %{?_need_gnome:BuildRequires:   gnome-libs-devel}
35 %{?_need_gnome:BuildRequires:   gnome-core-devel}
36 BuildRequires:  gtk+-devel > 1.2.8
37 BuildRequires:  xmms-devel
38
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sysconfdir     /etc/X11/GNOME
42 %define         _prefix                 /usr/X11R6
43
44 %description
45 Gadu-Gadu client released on GNU/GPL.
46
47 %description -l pl
48 Klient Gadu-Gadu na licencji GNU/GPL.
49
50 %package common
51 Summary:        GNU Gadu - free talking - common files
52 Summary(pl):    GNU Gadu - wolne gadanie - wspólne pliki
53 Group:          Applications/Communications
54 Obsoletes:      gg =< 0.2.0
55
56 %description common
57 Gadu-Gadu client released on GNU/GPL.
58
59 %description common -l pl
60 Klient Gadu-Gadu na licencji GNU/GPL.
61
62 %package X11
63 Summary:        GNU Gadu - free talking
64 Summary(pl):    GNU Gadu - wolne gadanie
65 Group:          Applications/Communications
66 PreReq:         %{name}-common = %{epoch}:%{version}
67 Provides:       gg = %{epoch}:%{version}-%{release}
68
69 %description X11
70 Gadu-Gadu client released on GNU/GPL.
71
72 %description X11 -l pl
73 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla X11.
74
75 %package gnome
76 Summary:        GNU Gadu - free talking - GNOME version
77 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla GNOME
78 Group:          Applications/Communications
79 PreReq:         %{name}-common = %{epoch}:%{version}
80 Provides:       gg = %{epoch}:%{version}-%{release}
81
82 %description gnome
83 Gadu-Gadu client released on GNU/GPL. GNOME version
84
85 %description gnome -l pl
86 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla GNOME.
87
88 %package gnome-applet
89 Summary:        GNU Gadu - free talking - GNOME dockable version
90 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla GNOME
91 Group:          Applications/Communications
92 PreReq:         %{name}-common = %{epoch}:%{version}
93 Provides:       gg = %{epoch}:%{version}-%{release}
94
95 %description gnome-applet
96 Gadu-Gadu client released on GNU/GPL. GNOME dockable version
97
98 %description gnome-applet -l pl
99 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla gnome.
100
101 %package wm-applet
102 Summary:        GNU Gadu - free talking - WindowMaker dockable version
103 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla WindowMaker'a
104 Group:          Applications/Communications
105 PreReq:         %{name}-common = %{epoch}:%{version}
106 Provides:       gg = %{epoch}:%{version}-%{release}
107
108 %description wm-applet
109 Gadu-Gadu client released on GNU/GPL. WindowMaker dockable version
110
111 %description wm-applet -l pl
112 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla
113 WindowMaker'a.
114
115 %package kde
116 Summary:        GNU Gadu - free talking - KDE version
117 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla KDE
118 Group:          Applications/Communications
119 PreReq:         %{name}-common = %{epoch}:%{version}
120 Provides:       gg = %{epoch}:%{version}-%{release}
121
122 %description kde
123 Gadu-Gadu client released on GNU/GPL. KDE version
124
125 %description kde -l pl
126 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla KDE.
127
128 %prep
129 %setup -q 
130
131 %build
132 LDFLAGS=" -L%{_libdir} %{rpmldflags}"
133
134 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
135 %configure \
136         %{?_without_sound:--disable-esd} \
137         --enable-gnome \
138         --enable-panel \
139         --enable-xmms
140 %{__make}
141 mv -f src/gg src/gg_applet
142 %{__make} clean
143 %endif
144
145 %if %{!?_without_gnome:1}%{?_without_gnome:0}
146 %configure \
147         %{?_without_sound:--disable-esd} \
148         --enable-gnome \
149         --enable-xmms
150 %{__make}
151 mv -f src/gg src/gg_gnome
152 %{__make} clean
153 %endif
154
155 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
156 %configure \
157         %{?_without_sound:--disable-esd} \
158         --enable-dockapp \
159         --enable-xmms
160 %{__make}
161 mv -f src/gg src/gg_wm
162 %{__make} clean
163 %endif
164
165 %if %{!?_without_kde:1}%{?_without_kde:0}
166 %configure \
167         --enable-docklet \
168         %{!?_without_sound:--enable-arts} \
169         --disable-esd \
170         --enable-xmms
171 %{__make}
172 mv -f src/gg src/gg_kde
173 %{__make} clean
174 %endif
175
176 %configure %{?_without_sound:--disable-esd} --enable-xmms
177 %{__make}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Communications,%{_pixmapsdir},%{_datadir}/applets/Network/}
182
183 %{__make} install DESTDIR=$RPM_BUILD_ROOT
184 %{!?_without_gnome_applet:install src/gg_applet $RPM_BUILD_ROOT%{_bindir}}
185 %{!?_without_gnome:install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}}
186 %{!?_without_wm_applet:install src/gg_wm $RPM_BUILD_ROOT%{_bindir}}
187 %{!?_without_kde:install src/gg_kde $RPM_BUILD_ROOT%{_bindir}}
188
189 sed -e 's/xpm$/png/' src/GnuGadu.desktop \
190         > $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu.desktop
191 sed -e 's/xpm$/png/' -e 's/Exec=gg/Exec=gg_applet\ --activate-goad-server=gg/' \
192         src/GnuGadu.desktop > $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu.desktop
193
194 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
195
196 install -d $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
197 install src/GnuGadu.gnorba $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post gnome
203 if [ ! -e /usr/X11R6/bin/gg ]; then
204         ln -sf /usr/X11R6/bin/gg_gnome /usr/X11R6/bin/gg
205 fi
206
207 %post gnome-applet
208 if [ ! -e /usr/X11R6/bin/gg ]; then
209         ln -sf /usr/X11R6/bin/gg_applet /usr/X11R6/bin/gg
210 fi
211
212 %post wm-applet
213 if [ ! -e /usr/X11R6/bin/gg ]; then
214         ln -sf /usr/X11R6/bin/gg_wm /usr/X11R6/bin/gg
215 fi
216
217 %post kde
218 if [ ! -e /usr/X11R6/bin/gg ]; then
219         ln -sf /usr/X11R6/bin/gg_kde /usr/X11R6/bin/gg
220 fi
221
222 %postun
223 if [ -L /usr/X11R6/bin/gg ]; then
224         rm -f /usr/X11R6/bin/gg
225 fi
226
227 %files common
228 %defattr(644,root,root,755)
229 %doc README ChangeLog TODO
230 %{_datadir}/gg
231 %{_pixmapsdir}/*
232
233 %files X11
234 %defattr(644,root,root,755)
235 %{_applnkdir}/Network/Communications/GnuGadu.desktop
236 %attr(755,root,root) %{_bindir}/gg
237
238 %if %{!?_without_gnome:1}%{?_without_gnome:0}
239 %files gnome
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_bindir}/gg_gnome
242 %{_applnkdir}/Network/Communications/GnuGadu.desktop
243 %endif
244
245 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
246 %files gnome-applet
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_bindir}/gg_applet
249 %{_datadir}/applets/Network/GnuGadu.desktop
250 %{_sysconfdir}/CORBA/servers/GnuGadu.gnorba
251 %endif
252
253 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
254 %files wm-applet
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/gg_wm
257 %{_datadir}/applets/Network/GnuGadu.desktop
258 %endif
259
260 %if %{!?_without_kde:1}%{?_without_kde:0}
261 %files kde
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{_bindir}/gg_kde
264 %{_applnkdir}/Network/Communications/GnuGadu.desktop
265 %endif
This page took 0.113259 seconds and 3 git commands to generate.