]> git.pld-linux.org Git - packages/gg.git/blob - gg.spec
- upgrade to daily 20020612 snapshot for compatibility with ekg
[packages/gg.git] / gg.spec
1 #
2 # Conditional build:
3 #
4 # _without_gnome
5 # _without_gnome_applet
6 # _without_kde
7 # _without_wm_applet
8 # _without_sound
9
10 %define snapshot 20020612
11
12 # This looks like overkill but some day we might have *everything* bconded :)
13 %{!?_without_gnome:             %define _need_gnome     1}
14 %{!?_without_gnome:         %define _need_esd   1}
15 %{!?_without_gnome_applet:      %define _need_gnome     1}
16 %{!?_without_gnome_applet:  %define _nees_esd   1}
17 %{!?_without_kde:                       %define _need_arts      1}
18 %{!?_without_wm_applet:         %define _need_esd       1}
19
20
21 Summary:        GNU Gadu - free talking
22 Summary(pl):    GNU Gadu - wolne gadanie
23 Name:           gg
24 Version:        0.2.3
25 Release:        0.1pre%{snapshot}
26 Epoch:          4
27 License:        GPL
28 Group:          Applications/Communications
29 Source0:        ftp://ftp.slackware.pl/gg/snapshots/%{name}-%{snapshot}.tar.gz
30 Source1:        %{name}.png
31 Patch0:         %{name}-ac_fix.patch
32 Icon:           gg.xpm
33 URL:            http://netkrab.slackware.pl/gg/
34 BuildRequires:                                  gtk+-devel > 1.2.8
35 %{?_need_gnome:BuildRequires:   gnome-libs-devel}
36 %{?_need_gnome:BuildRequires:   gnome-core-devel}
37 %if %{!?_without_sound:1}%{?_without_sound:0}
38 %{?_need_arts:BuildRequires:    arts-devel}
39 %{?_need_esd:BuildRequires:             esound-devel > 0.2.7}
40 %endif
41
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _prefix         /usr/X11R6
45 %define         _mandir         %{_prefix}/man
46 %define         _sysconfdir     /etc/X11/GNOME
47
48 %description
49 Gadu-Gadu client released on GNU/GPL.
50
51 %description -l pl
52 Klient Gadu-Gadu na licencji GNU/GPL.
53
54 %package common
55 Summary:        GNU Gadu - free talking - common files
56 Summary(pl):    GNU Gadu - wolne gadanie - wspólne pliki
57 Group:          Applications/Communications
58 Obsoletes:      gg =< 0.2.0
59
60 %description common
61 Gadu-Gadu client released on GNU/GPL.
62
63 %description common -l pl
64 Klient Gadu-Gadu na licencji GNU/GPL.
65
66 %package X11
67 Summary:        GNU Gadu - free talking
68 Summary(pl):    GNU Gadu - wolne gadanie
69 Group:          Applications/Communications
70 PreReq:         %{name}-common = %{epoch}:%{version}
71 Provides:       gg = %{epoch}:%{version}-%{release}
72
73 %description X11
74 Gadu-Gadu client released on GNU/GPL.
75
76 %description X11 -l pl
77 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla X11.
78
79 %package gnome
80 Summary:        GNU Gadu - free talking - GNOME version
81 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla GNOME
82 Group:          Applications/Communications
83 PreReq:         %{name}-common = %{epoch}:%{version}
84 Provides:       gg = %{epoch}:%{version}-%{release}
85
86 %description gnome
87 Gadu-Gadu client released on GNU/GPL. GNOME version
88
89 %description gnome -l pl
90 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla GNOME.
91
92 %package gnome-applet
93 Summary:        GNU Gadu - free talking - GNOME dockable version
94 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla GNOME
95 Group:          Applications/Communications
96 PreReq:         %{name}-common = %{epoch}:%{version}
97 Provides:       gg = %{epoch}:%{version}-%{release}
98
99 %description gnome-applet
100 Gadu-Gadu client released on GNU/GPL. GNOME dockable version
101
102 %description gnome-applet -l pl
103 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla gnome.
104
105 %package wm-applet
106 Summary:        GNU Gadu - free talking - WindowMaker dockable version.
107 Summary(pl):    GNU Gadu - wolne gadanie - wersja dokowalna dla WindowMaker'a.
108 Group:          Applications/Communications
109 PreReq:         %{name}-common = %{epoch}:%{version}
110 Provides:       gg = %{epoch}:%{version}-%{release}
111
112 %description wm-applet
113 Gadu-Gadu client released on GNU/GPL. WindowMaker dockable version
114
115 %description wm-applet -l pl
116 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dokowalna dla
117 WindowMaker'a.
118
119 %package kde
120 Summary:        GNU Gadu - free talking - KDE version.
121 Summary(pl):    GNU Gadu - wolne gadanie - wersja dla KDE.
122 Group:          Applications/Communications
123 PreReq:         %{name}-common = %{epoch}:%{version}
124 Provides:       gg = %{epoch}:%{version}-%{release}
125
126 %description kde
127 Gadu-Gadu client released on GNU/GPL. KDE version
128
129 %description kde -l pl
130 Klient Gadu-Gadu na licencji GNU/GPL. Wersja dla KDE.
131
132 %prep
133 %setup -q -n %{name}-%{snapshot}
134 %patch0 -p0
135
136 %build
137 LDFLAGS=" -L%{_libdir} %{rpmldflags}"
138
139 aclocal -I macros
140 autoconf
141 automake -a -c -f
142
143 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
144 %configure \
145         %{?_without_sound:--disable-esd} \
146         --enable-gnome \
147         --enable-panel
148 %{__make}
149 mv -f src/gg src/gg_applet
150 %{__make} clean
151 %endif
152
153 %if %{!?_without_gnome:1}%{?_without_gnome:0}
154 %configure \
155         %{?_without_sound:--disable-esd} \
156         --enable-gnome
157 %{__make}
158 mv -f src/gg src/gg_gnome
159 %{__make} clean
160 %endif
161
162 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
163 %configure \
164         %{?_without_sound:--disable-esd} \
165         --enable-dockapp
166 %{__make}
167 mv -f src/gg src/gg_wm
168 %{__make} clean
169 %endif
170
171 %if %{!?_without_kde:1}%{?_without_kde:0}
172 %configure \
173         --enable-docklet \
174         %{!?_without_sound:--enable-arts} \
175         --disable-esd
176 %{__make}
177 mv -f src/gg src/gg_kde
178 %{__make} clean
179 %endif
180
181 %configure %{?_without_sound:--disable-esd}
182 %{__make}
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186 install -d $RPM_BUILD_ROOT{%{_applnkdir}/Network/Communications,%{_pixmapsdir},%{_datadir}/applets/Network/}
187
188 %{__make} install DESTDIR=$RPM_BUILD_ROOT
189 %{!?_without_gnome_applet:install src/gg_applet $RPM_BUILD_ROOT%{_bindir}}
190 %{!?_without_gnome:install src/gg_gnome $RPM_BUILD_ROOT%{_bindir}}
191 %{!?_without_wm_applet:install src/gg_wm $RPM_BUILD_ROOT%{_bindir}}
192 %{!?_without_kde:install src/gg_kde $RPM_BUILD_ROOT%{_bindir}}
193
194 sed -e 's/xpm$/png/' src/GnuGadu.desktop \
195         > $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications/GnuGadu.desktop
196 sed -e 's/xpm$/png/' -e 's/Exec=gg/Exec=gg_applet\ --activate-goad-server=gg/' \
197         src/GnuGadu.desktop > $RPM_BUILD_ROOT%{_datadir}/applets/Network/GnuGadu.desktop
198
199 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
200
201 gzip -9nf README ChangeLog TODO
202 install -d $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
203 install src/GnuGadu.gnorba $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers/
204
205 %clean
206 rm -rf $RPM_BUILD_ROOT
207
208 %post gnome
209 if [ ! -e /usr/X11R6/bin/gg ]; then
210         ln -sf /usr/X11R6/bin/gg_gnome /usr/X11R6/bin/gg
211 fi
212
213 %post gnome-applet
214 if [ ! -e /usr/X11R6/bin/gg ]; then
215         ln -sf /usr/X11R6/bin/gg_applet /usr/X11R6/bin/gg
216 fi
217
218 %post wm-applet
219 if [ ! -e /usr/X11R6/bin/gg ]; then
220         ln -sf /usr/X11R6/bin/gg_wm /usr/X11R6/bin/gg
221 fi
222
223 %post kde
224 if [ ! -e /usr/X11R6/bin/gg ]; then
225         ln -sf /usr/X11R6/bin/gg_kde /usr/X11R6/bin/gg
226 fi
227
228 %postun
229 if [ -L /usr/X11R6/bin/gg ]; then
230         rm -f /usr/X11R6/bin/gg
231 fi
232
233 %files common
234 %defattr(644,root,root,755)
235 %doc *.gz
236 %{_datadir}/gg
237 %{_pixmapsdir}/*
238
239 %files X11
240 %defattr(644,root,root,755)
241 %{_applnkdir}/Network/Communications/GnuGadu.desktop
242 %attr(755,root,root) %{_bindir}/gg
243
244 %if %{!?_without_gnome:1}%{?_without_gnome:0}
245 %files gnome
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_bindir}/gg_gnome
248 %{_applnkdir}/Network/Communications/GnuGadu.desktop
249 %endif
250
251 %if %{!?_without_gnome_applet:1}%{?_without_gnome_applet:0}
252 %files gnome-applet
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_bindir}/gg_applet
255 %attr(755,root,root) %{_datadir}/applets/Network/GnuGadu.desktop
256 %attr(755,root,root) %{_sysconfdir}/CORBA/servers/GnuGadu.gnorba
257 %endif
258
259 %if %{!?_without_wm_applet:1}%{?_without_wm_applet:0}
260 %files wm-applet
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_bindir}/gg_wm
263 %attr(755,root,root) %{_datadir}/applets/Network/GnuGadu.desktop
264 %endif
265
266 %if %{!?_without_kde:1}%{?_without_kde:0}
267 %files kde
268 %defattr(644,root,root,755)
269 %attr(755,root,root) %{_bindir}/gg_kde
270 %attr(755,root,root) %{_datadir}/applets/Network/GnuGadu.desktop
271 %endif
This page took 0.084533 seconds and 3 git commands to generate.