]> git.pld-linux.org Git - packages/gfs.git/blob - gfs.spec
- BR: perl-base (used by configure)
[packages/gfs.git] / gfs.spec
1 Summary:        Shared-disk cluster file system
2 Summary(pl):    Klastrowy system plików na wspó³dzielonym dysku
3 Name:           gfs
4 Version:        6.1
5 %define bver    pre21
6 Release:        0.%{bver}.1
7 License:        GPL v2
8 Group:          Applications/System
9 Source0:        http://people.redhat.com/cfeist/cluster/tgz/%{name}-%{version}-%{bver}.tar.gz
10 # Source0-md5:  0b623c83354884e9da498e09130a3214
11 # from gfs-kernel CVS
12 Source1:        gfs_ondisk.h
13 # NoSource1-md5: 772e1801249bff0478b844924c0fdc20 (rev. 1.7; doesn't compile with 1.8)
14 Source2:        gfs_ioctl.h
15 # NoSource2-md5: fad0a58f6f39499661704f0d5af3a8c0 (rev. 1.10)
16 # from gfs-kernel/harness CVS
17 Source3:        lm_interface.h
18 # NoSource3-md5: 5b000a3b33af218e1b6b8a7d96b7e356 (rev. 1.7)
19 URL:            http://sources.redhat.com/cluster/gfs/
20 BuildRequires:  iddev
21 BuildRequires:  perl-base
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sbindir        /sbin
25
26 %description
27 GFS (Global File System) is a cluster file system. It allows a cluster
28 of computers to simultaneously use a block device that is shared
29 between them (with FC, iSCSI, NBD, etc...). GFS reads and writes to
30 the block device like a local filesystem, but also uses a lock module
31 to allow the computers coordinate their I/O so filesystem consistency
32 is maintained. One of the nifty features of GFS is perfect consistency
33 -- changes made to the filesystem on one machine show up immediately
34 on all other machines in the cluster.
35
36 %description -l pl
37 GFS (Global File System) to klastrowy system plików. Pozwala klastrowi
38 komputerów na jednoczesne korzystanie z urz±dzenia blokowego
39 dzielonego miêdzy nimi (poprzez FC, iSCSI, NBD itp.). GFS odczytuje i
40 zapisuje urz±dzenie blokowe jak lokalny system plików, ale u¿ywa
41 dodatkowo modu³u blokuj±cego, aby umo¿liwiæ komputerom koordynowanie
42 ich operacji I/O w celu zachowania spójno¶ci systemu plików. Jedn± z
43 szykownych mo¿liwo¶ci GFS-a jest idealna spójno¶æ - zmiany wykonane w
44 systemie plików na jednej maszynie natychmiast pokazuj± siê na
45 wszystkich innych maszynach w klastrze.
46
47 %prep
48 %setup -q -n %{name}-%{version}-%{bver}
49
50 install -d include/linux
51 cp %{SOURCE1} %{SOURCE2} %{SOURCE3} include/linux
52
53 %{__perl} -pi -e 's/-Wall/%{rpmcflags} -Wall/' make/defines.mk.input
54 %{__perl} -pi -e 's/-O2 //' gfs_{mkfs,quota,tool}/Makefile
55
56 %build
57 ./configure \
58         --incdir=%{_includedir} \
59         --libdir=%{_libdir} \
60         --mandir=%{_mandir} \
61         --prefix=%{_prefix} \
62         --sbindir=%{_sbindir}
63 %{__make} \
64         CC="%{__cc}"
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_sbindir}/*
78 #%attr(754,root,root) /etc/rc.d/init.d/gfs
79 %{_mandir}/man?/*
This page took 0.076752 seconds and 3 git commands to generate.