]> git.pld-linux.org Git - packages/gflags.git/blame - gflags.spec
- release 4 (by relup.sh)
[packages/gflags.git] / gflags.spec
CommitLineData
6c0e1c4c
JB
1Summary: A commandline flags library that allows for distributed flags
2Summary(pl.UTF-8): Biblioteka flag linii poleceń pozwalająca na rozproszone flagi
3Name: gflags
6998cb4c 4Version: 2.1.1
98cbd926 5Release: 4
6c0e1c4c
JB
6License: BSD
7Group: Libraries
6998cb4c
JB
8Source0: https://github.com/schuhschuh/gflags/archive/v%{version}/%{name}-%{version}.tar.gz
9# Source0-md5: 18acc0ae270672a70a86b33ebbe9761b
10Source1: libgflags.pc
11Source2: libgflags_nothreads.pc
12Patch0: %{name}-libversion.patch
13Patch1: %{name}-nothreads.patch
73e51ce7 14URL: http://code.google.com/p/gflags/
6998cb4c 15BuildRequires: cmake >= 2.8.4
6c0e1c4c
JB
16BuildRequires: libstdc++-devel
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20gflags is Google's commandline flags library. It differs from other
21libraries, such as getopt(), in that flag definitions can be scattered
22around the source code, and not just listed in one place such as
23main().
24
25%description -l pl.UTF-8
26gflags to biblioteka flag linii poleceń stworzona przez Google. Różni
27się od innych bibliotek, takich jak getopt(), tym, że definicje flag
28mogą być rozproszone po kodzie źródłowym, a nie wypisane tylko w
29jednym miejscu, takim jak main().
30
31%package devel
32Summary: Header files for gflags library
33Summary(pl.UTF-8): Pliki nagłówkowe biblioteki gflags
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: libstdc++-devel
37
38%description devel
39Header files for gflags library.
40
41%description devel -l pl.UTF-8
42Pliki nagłówkowe biblioteki gflags.
43
44%package static
45Summary: Static gflags library
46Summary(pl.UTF-8): Statyczna biblioteka gflags
47Group: Development/Libraries
48Requires: %{name}-devel = %{version}-%{release}
49
50%description static
51Static gflags library.
52
53%description static -l pl.UTF-8
54Statyczna biblioteka gflags.
55
56%prep
57%setup -q
6998cb4c
JB
58%patch0 -p1
59%patch1 -p1
6c0e1c4c 60
2385e74b
JR
61%{__sed} -i \
62 -e 's|LIBRARY_INSTALL_DIR lib|LIBRARY_INSTALL_DIR %{_lib}|g' \
63 -e 's|CONFIG_INSTALL_DIR lib/cmake|CONFIG_INSTALL_DIR %{_lib}/cmake|g' \
64 CMakeLists.txt
65
6c0e1c4c 66%build
6998cb4c
JB
67install -d build
68cd build
69%cmake .. \
70 -DBUILD_STATIC_LIBS=ON
6c0e1c4c
JB
71%{__make}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
6998cb4c 76%{__make} -C build install \
6c0e1c4c
JB
77 DESTDIR=$RPM_BUILD_ROOT
78
6998cb4c
JB
79# .pc files used to be provided before gflags 2.1; reintroduce them
80install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
81for f in %{SOURCE1} %{SOURCE2} ; do
82 sed -e "s|@prefix@|%{_prefix}|;s|@libdir@|%{_libdir}|" "$f" \
83 >$RPM_BUILD_ROOT%{_pkgconfigdir}/$(basename $f)
84done
6c0e1c4c
JB
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
91
92%files
93%defattr(644,root,root,755)
6998cb4c 94%doc AUTHORS.txt COPYING.txt ChangeLog.txt NEWS.txt README.txt
6c0e1c4c
JB
95%attr(755,root,root) %{_bindir}/gflags_completions.sh
96%attr(755,root,root) %{_libdir}/libgflags.so.*.*.*
72920e50 97%attr(755,root,root) %ghost %{_libdir}/libgflags.so.2
6c0e1c4c 98%attr(755,root,root) %{_libdir}/libgflags_nothreads.so.*.*.*
72920e50 99%attr(755,root,root) %ghost %{_libdir}/libgflags_nothreads.so.2
6c0e1c4c
JB
100
101%files devel
102%defattr(644,root,root,755)
103%doc doc/{gflags.html,designstyle.css}
104%attr(755,root,root) %{_libdir}/libgflags.so
105%attr(755,root,root) %{_libdir}/libgflags_nothreads.so
106%{_includedir}/gflags
107%{_pkgconfigdir}/libgflags.pc
108%{_pkgconfigdir}/libgflags_nothreads.pc
6998cb4c 109%{_libdir}/cmake/gflags
6c0e1c4c
JB
110
111%files static
112%defattr(644,root,root,755)
113%{_libdir}/libgflags.a
114%{_libdir}/libgflags_nothreads.a
This page took 1.044789 seconds and 4 git commands to generate.