]> git.pld-linux.org Git - packages/gettext.git/blobdiff - gettext.spec
- release 10
[packages/gettext.git] / gettext.spec
index bcf3e3aabf32597be09a62ca00241bd97e3d4208..7777724636d041cd93cd751021b875e768285ef1 100644 (file)
@@ -1,14 +1,19 @@
+# TODO
+# - unpackaged:
+#   /usr/share/emacs/site-lisp/po-compat.el
+#   /usr/share/emacs/site-lisp/po-compat.elc
+#   /usr/share/emacs/site-lisp/po-mode.el
+#   /usr/share/emacs/site-lisp/po-mode.elc
+#   /usr/share/emacs/site-lisp/start-po.el
+#   /usr/share/emacs/site-lisp/start-po.elc
 #
 # Conditional build:
 %bcond_without asprintf        # without libasprintf C++ library
-%bcond_without xemacs          # without po-mode for xemacs
+%bcond_with            xemacs          # without po-mode for xemacs
 %bcond_without gcj             # with Java support by gcj (preferred over javac)
-%bcond_with    javac           # with Java support by some javac
+%bcond_with            javac           # with Java support by some javac
 %bcond_without dotnet          # without .NET support
 %bcond_with    bootstrap       # use system GLib and libcroco
-#
-
-%{?with_dotnet:%include        /usr/lib/rpm/macros.mono}
 
 %ifnarch %{ix86} %{x8664} arm hppa ppc s390 s390x
 %undefine with_dotnet
@@ -18,7 +23,7 @@
 %undefine with_dotnet
 %endif
 
-%undefine with_xemacs
+%{?with_dotnet:%include        /usr/lib/rpm/macros.mono}
 
 %define build_java     %{?with_gcj:1}%{!?with_gcj:%{?with_javac:1}%{!?with_javac:0}}
 Summary:       Utilties for program national language support
@@ -33,10 +38,10 @@ Summary(tr.UTF-8):  Desteği için kitaplık ve araçlar
 Summary(uk.UTF-8):     Бібліотеки та утиліти для підтримки національних мов
 Name:          gettext
 Version:       0.17
-Release:       2
+Release:       10
 License:       LGPL v2+ (libintl), GPL v3+ (tools)
 Group:         Development/Tools
-Source0:       ftp://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
+Source0:       http://ftp.gnu.org/gnu/gettext/%{name}-%{version}.tar.gz
 # Source0-md5: 58a2bc6d39c0ba57823034d55d65d606
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-killkillkill.patch
@@ -44,19 +49,27 @@ Patch2:             %{name}-pl.po-update.patch
 Patch3:                %{name}-no_docs.patch
 Patch4:                %{name}-libintl_by_gcj.patch
 Patch5:                %{name}-removed_macros.patch
+Patch6:                %{name}-creat_mode.patch
+Patch7:                %{name}-cvs.patch
+Patch8:                %{name}-m4.patch
 URL:           http://www.gnu.org/software/gettext/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.10
+BuildRequires: cvs-gnu-client
 %{?with_gcj:BuildRequires:     gcj >= 3.0}
 %{!?with_bootstrap:BuildRequires:      glib2-devel >= 2.0}
-%{?with_javac:BuildRequires:   jdk >= 1.1}
+%if %{with javac}
+BuildRequires: jdk >= 1.1
+BuildRequires: jar
+%endif
 %{!?with_bootstrap:BuildRequires:      libcroco-devel >= 0.6.1}
-%if "%(%{__cc} -dumpversion | grep -q '^4.[2-9]' ; echo $?)" == "0"
+%if "%(echo %{cc_version} | grep -q '^4.[2-9]'; echo $?)" == "0"
 BuildRequires: libgomp-devel
 %endif
 %{?with_asprintf:BuildRequires:        libstdc++-devel}
 BuildRequires: libtool >= 1:1.4.2-9
 %{?with_dotnet:BuildRequires:  mono-csharp}
+BuildRequires: rpmbuild(macros) >= 1.453
 BuildRequires: texinfo
 %{?with_xemacs:BuildRequires:  xemacs}
 Obsoletes:     gettext-base
@@ -271,7 +284,6 @@ Summary(pl.UTF-8):  Zamiennik gettextize
 License:       GPL v3+
 Group:         Development/Tools
 Requires:      %{name}-devel >= 0.10.35
-Requires:      cvs-client
 
 %description autopoint
 The `autopoint' program copies standard gettext infrastructure files
@@ -309,8 +321,25 @@ GNU gettext dla C#.
 #%patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 %build
+# make autopoint to use tar.gz archives instead of cvs repository
+install -d archive-cvs/{prepare,archive}
+tar xzf gettext-tools/misc/archive.tar.gz -C archive-cvs/prepare
+cvs -d$(pwd)/archive-cvs/prepare/archive init
+cd archive-cvs/archive
+cvs -Q -d$(pwd)/../prepare/archive -q co .
+for rev in $(cvs status -v | grep '(revision:' | awk ' { print $1 } ' | sort -u); do
+       cvs -Q up -d -r $rev
+       cd ..
+       tar czf archive-${rev}.tar.gz archive --exclude=CVS
+       cd archive
+done
+cd ../..
+
 %{__libtoolize}
 cd autoconf-lib-link
 %{__aclocal} -I m4 -I ../m4
@@ -371,7 +400,12 @@ mv -f $RPM_BUILD_ROOT%{_bindir}/{,n}gettext $RPM_BUILD_ROOT/bin
 install gettext-tools/gnulib-lib/.libs/libgettextlib.a \
        gettext-tools/src/.libs/libgettextsrc.a $RPM_BUILD_ROOT%{_libdir}
 
+install archive-cvs/archive-*.tar.gz $RPM_BUILD_ROOT%{_datadir}/gettext
+rm $RPM_BUILD_ROOT%{_datadir}/gettext/archive.tar.gz
+
 rm -r $RPM_BUILD_ROOT%{_docdir}/gettext
+rm -r $RPM_BUILD_ROOT%{_docdir}/libasprintf
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
 %find_lang %{name}-runtime
 %find_lang %{name}-tools
@@ -416,6 +450,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgettext*.la
 # libgettextpo is for other programs, not used by gettext tools themselves
 %attr(755,root,root) %{_libdir}/libgettextpo.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgettextpo.so.0
 %attr(755,root,root) %{_libdir}/preloadable_libintl.so
 %attr(755,root,root) %{_libdir}/gettext/hostname
 %attr(755,root,root) %{_libdir}/gettext/project-id
@@ -464,6 +499,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc gettext-runtime/libasprintf/{AUTHORS,ChangeLog,README}
 %attr(755,root,root) %{_libdir}/libasprintf.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libasprintf.so.0
 
 %files -n libasprintf-devel
 %defattr(644,root,root,755)
@@ -500,7 +536,7 @@ rm -rf $RPM_BUILD_ROOT
 %files autopoint
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/autopoint
-%{_datadir}/gettext/archive.tar.gz
+%{_datadir}/gettext/archive*.tar.gz
 %{_mandir}/man1/autopoint.1*
 
 %if %{with dotnet}
This page took 0.130165 seconds and 4 git commands to generate.