]> git.pld-linux.org Git - packages/geos.git/blobdiff - geos.spec
- updated to 3.8.3 (last version with swig bindings)
[packages/geos.git] / geos.spec
index be5d3d3e6b0c52e4742d74ef747c9dd10b72e875..0a60a7b833340875452edd4316fc5e4700263150 100644 (file)
--- a/geos.spec
+++ b/geos.spec
@@ -1,22 +1,29 @@
+#
+# Conditional build:
+%bcond_without ruby    # ruby binding
+
 Summary:       Geometry Engine - Open Source
 Summary(pl.UTF-8):     GEOS - silnik geometryczny z otwartymi źródłami
 Name:          geos
-Version:       2.2.3
-Release:       2
-License:       LGPL
+Version:       3.8.3
+Release:       1
+License:       LGPL v2.1
 Group:         Libraries
-Source0:       http://geos.refractions.net/%{name}-%{version}.tar.bz2
-# Source0-md5: 440be2b11fd3d711e950a47ea6f1b424
-Patch0:                %{name}-swig.patch
-URL:           http://geos.refractions.net/
+Source0:       http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
+# Source0-md5: 57e4bde34a4f8aabed096e06a2002c4d
+Patch0:                rubydir.patch
+Patch1:                %{name}-x32.patch
+URL:           https://trac.osgeo.org/geos/
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake
-BuildRequires: libstdc++-devel
-BuildRequires: python >= 1:2.5
-BuildRequires: python-devel >= 1:2.5
+BuildRequires: libstdc++-devel >= 6:4.7
+BuildRequires: python
+BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
-BuildRequires: ruby-devel
+BuildRequires: rpmbuild(macros) >= 1.519
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: swig-python >= 1.3.29
-BuildRequires: swig-ruby >= 1.3.29
+%{?with_ruby:BuildRequires:    swig-ruby >= 1.3.40-3}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,16 +37,16 @@ as well as specific JTS topology functions such as IsValid().
 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
-JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
-wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
-także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
+JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
+"Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
+specyficzne dla JTS funkcje topologiczne takie jak IsValid().
 
 %package devel
 Summary:       Header files for GEOS library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GEOS
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libstdc++-devel
+Requires:      libstdc++-devel >= 6:4.7
 
 %description devel
 Header files for GEOS library.
@@ -86,36 +93,29 @@ Wiązania języka Ruby do biblioteki GEOS.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-cp -f /usr/share/automake/config.* .
-%configure
+%{__aclocal} -I macros
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       --enable-python \
+       %{?with_ruby:--enable-ruby}
+
 %{__make} \
        pkglibdir=%{_libdir}
 
-cd swig/python
-swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
-python setup.py build
-
-cd ../ruby
-swig -c++ -ruby -autorename -o geos_wrap.cxx ../geos.i
-%{__cxx} %{rpmcxxflags} -I../../source/headers -I%{ruby_archdir} -c geos_wrap.cxx
-%{__cxx} -shared -o geos.so geos_wrap.o -lruby -L../../source/geom/.libs -lgeos
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
-       pkglibdir=%{_libdir}
-
-cd swig
-install -D ruby/geos.so $RPM_BUILD_ROOT%{ruby_archdir}/geos.so
+       pythondir=%{py_sitescriptdir}
 
-cd python
-python setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
 
 %py_postclean
 
@@ -127,9 +127,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
+%doc AUTHORS NEWS README.md
+%attr(755,root,root) %{_libdir}/libgeos-%{version}.so
 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
 
 %files devel
 %defattr(644,root,root,755)
@@ -149,10 +150,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n python-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/_geos.so
-%{py_sitedir}/geos.py[co]
-%{py_sitedir}/PyGEOS-*.egg-info
+%dir %{py_sitedir}/geos
+%attr(755,root,root) %{py_sitedir}/geos/_geos.so
+%{py_sitescriptdir}/geos
+%{py_sitescriptdir}/geos.pth
 
+%if %{with ruby}
 %files -n ruby-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_archdir}/geos.so
+%attr(755,root,root) %{ruby_vendorarchdir}/geos.so
+%endif
This page took 0.057715 seconds and 4 git commands to generate.