]> git.pld-linux.org Git - packages/geos.git/blobdiff - geos.spec
- updated to 3.8.3 (last version with swig bindings)
[packages/geos.git] / geos.spec
index 3373da4aca8747a01c5e551521cd5090a11bc61e..0a60a7b833340875452edd4316fc5e4700263150 100644 (file)
--- a/geos.spec
+++ b/geos.spec
@@ -1,23 +1,22 @@
 #
 # Conditional build:
-%bcond_without php     # PHP binding
 %bcond_without ruby    # ruby binding
-#
+
 Summary:       Geometry Engine - Open Source
 Summary(pl.UTF-8):     GEOS - silnik geometryczny z otwartymi źródłami
 Name:          geos
-Version:       3.3.5
+Version:       3.8.3
 Release:       1
 License:       LGPL v2.1
 Group:         Libraries
 Source0:       http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
-# Source0-md5: 2ba61afb7fe2c5ddf642d82d7b16e75b
-Patch0:                %{name}-ruby1.9.patch
-URL:           http://trac.osgeo.org/geos/
-BuildRequires: autoconf >= 2.52
+# Source0-md5: 57e4bde34a4f8aabed096e06a2002c4d
+Patch0:                rubydir.patch
+Patch1:                %{name}-x32.patch
+URL:           https://trac.osgeo.org/geos/
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake
-BuildRequires: libstdc++-devel
-%{?with_php:BuildRequires:     php-devel}
+BuildRequires: libstdc++-devel >= 6:4.7
 BuildRequires: python
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
@@ -38,16 +37,16 @@ as well as specific JTS topology functions such as IsValid().
 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
-JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
-wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
-także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
+JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych wg
+"Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a także
+specyficzne dla JTS funkcje topologiczne takie jak IsValid().
 
 %package devel
 Summary:       Header files for GEOS library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GEOS
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      libstdc++-devel
+Requires:      libstdc++-devel >= 6:4.7
 
 %description devel
 Header files for GEOS library.
@@ -67,19 +66,6 @@ Static GEOS library.
 %description static -l pl.UTF-8
 Statyczna biblioteka GEOS.
 
-%package -n php-geos
-Summary:       PHP bindings for Geometry Engine - Open Source
-Summary(pl.UTF-8):     Wiązania PHP do biblioteki GEOS
-Group:         Development/Languages/PHP
-Requires:      %{name} = %{version}-%{release}
-%{?requires_php_extension}
-
-%description -n php-geos
-PHP bindings for Geometry Engine - Open Source.
-
-%description -n php-geos -l pl.UTF-8
-Wiązania PHP do biblioteki GEOS.
-
 %package -n python-geos
 Summary:       Python bindings for Geometry Engine - Open Source
 Summary(pl.UTF-8):     Wiązania Pythona do biblioteki GEOS
@@ -107,6 +93,7 @@ Wiązania języka Ruby do biblioteki GEOS.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__aclocal} -I macros
@@ -114,29 +101,20 @@ Wiązania języka Ruby do biblioteki GEOS.
 %{__autoheader}
 %{__automake}
 %configure \
-       %{?with_php:--enable-php} \
        --enable-python \
        %{?with_ruby:--enable-ruby}
 
 %{__make} \
        pkglibdir=%{_libdir}
 
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-%if %{with php}
-install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
-; Enable geos extension module
-extension=geos.so
-EOF
-%endif
+       DESTDIR=$RPM_BUILD_ROOT \
+       pythondir=%{py_sitescriptdir}
 
-%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
+%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
 
 %py_postclean
@@ -149,8 +127,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/libgeos-*.so
+%doc AUTHORS NEWS README.md
+%attr(755,root,root) %{_libdir}/libgeos-%{version}.so
 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
 
@@ -170,14 +148,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgeos.a
 %{_libdir}/libgeos_c.a
 
-%if %{with php}
-%files -n php-geos
-%defattr(644,root,root,755)
-%doc php/{README,TODO}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
-%attr(755,root,root) %{php_extensiondir}/geos.so
-%endif
-
 %files -n python-geos
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/geos
@@ -188,5 +158,5 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ruby}
 %files -n ruby-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_sitearchdir}/geos.so
+%attr(755,root,root) %{ruby_vendorarchdir}/geos.so
 %endif
This page took 0.032146 seconds and 4 git commands to generate.