]> git.pld-linux.org Git - packages/geos.git/blobdiff - geos.spec
- ruby 2.0 rebuld
[packages/geos.git] / geos.spec
index 89351d864f1f7bc06539eebb540a5607c475d1b7..70cf67de0befc2e1764ab92d0c77cf4330d82bbb 100644 (file)
--- a/geos.spec
+++ b/geos.spec
@@ -1,29 +1,31 @@
-# TODO
-# - unpackaged:    /usr/bin/XMLTester
 #
 # Conditional build:
+%bcond_without php     # PHP binding
 %bcond_without ruby    # ruby binding
-#
+
 Summary:       Geometry Engine - Open Source
 Summary(pl.UTF-8):     GEOS - silnik geometryczny z otwartymi źródłami
 Name:          geos
-Version:       3.0.0
-Release:       2
+Version:       3.4.2
+Release:       5
 License:       LGPL v2.1
 Group:         Libraries
-Source0:       http://geos.refractions.net/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: 3f7940abee9fec69a9787878cd3ae771
-Patch0:                %{name}-gcc43.patch
-URL:           http://geos.refractions.net/
+Source0:       http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
+# Source0-md5: fc5df2d926eb7e67f988a43a92683bae
+Patch0:                %{name}-ruby1.9.patch
+Patch1:                rubydir.patch
+URL:           http://trac.osgeo.org/geos/
+BuildRequires: autoconf >= 2.52
 BuildRequires: automake
 BuildRequires: libstdc++-devel
+%{?with_php:BuildRequires:     %{php_name}-devel}
 BuildRequires: python
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: rpmbuild(macros) >= 1.519
 %{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: swig-python >= 1.3.29
-%{?with_ruby:BuildRequires:    swig-ruby >= 1.3.29}
+%{?with_ruby:BuildRequires:    swig-ruby >= 1.3.40-3}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -66,6 +68,19 @@ Static GEOS library.
 %description static -l pl.UTF-8
 Statyczna biblioteka GEOS.
 
+%package -n %{php_name}-geos
+Summary:       PHP bindings for Geometry Engine - Open Source
+Summary(pl.UTF-8):     Wiązania PHP do biblioteki GEOS
+Group:         Development/Languages/PHP
+Requires:      %{name} = %{version}-%{release}
+%{?requires_php_extension}
+
+%description -n %{php_name}-geos
+PHP bindings for Geometry Engine - Open Source.
+
+%description -n %{php_name}-geos -l pl.UTF-8
+Wiązania PHP do biblioteki GEOS.
+
 %package -n python-geos
 Summary:       Python bindings for Geometry Engine - Open Source
 Summary(pl.UTF-8):     Wiązania Pythona do biblioteki GEOS
@@ -93,10 +108,15 @@ Wiązania języka Ruby do biblioteki GEOS.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
-cp -f /usr/share/automake/config.* .
+%{__aclocal} -I macros
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
+       %{?with_php:--enable-php} \
        --enable-python \
        %{?with_ruby:--enable-ruby}
 
@@ -110,8 +130,16 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
-rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
+%if %{with php}
+install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
+; Enable geos extension module
+extension=geos.so
+EOF
+%endif
+
+%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_vendorarchdir}/*.{la,a}}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
 
 %py_postclean
 
@@ -124,7 +152,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/libgeos-3.0.0.so
+%attr(755,root,root) %{_libdir}/libgeos-*.so
 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
 
@@ -144,6 +172,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libgeos.a
 %{_libdir}/libgeos_c.a
 
+%if %{with php}
+%files -n %{php_name}-geos
+%defattr(644,root,root,755)
+%doc php/{README,TODO}
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
+%attr(755,root,root) %{php_extensiondir}/geos.so
+%endif
+
 %files -n python-geos
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/geos
@@ -154,5 +190,5 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ruby}
 %files -n ruby-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_sitearchdir}/geos.so
+%attr(755,root,root) %{ruby_vendorarchdir}/geos.so
 %endif
This page took 0.071308 seconds and 4 git commands to generate.