]> git.pld-linux.org Git - packages/geos.git/blobdiff - geos.spec
- unpackaged file
[packages/geos.git] / geos.spec
index a1ffb3da66e89f675d9b1f5e1e4f3418d76a268a..154fa0abc5aacb53bec8d8a3e3143e4f4fd9cd95 100644 (file)
--- a/geos.spec
+++ b/geos.spec
@@ -1,22 +1,28 @@
+# TODO
+# - unpackaged:    /usr/bin/XMLTester
+#
+# Conditional build:
+%bcond_without ruby    # ruby binding
+#
 Summary:       Geometry Engine - Open Source
-Summary(pl):   GEOS - silnik geometryczny z otwartymi ¼ród³ami
+Summary(pl.UTF-8):     GEOS - silnik geometryczny z otwartymi źródłami
 Name:          geos
-Version:       2.2.3
+Version:       3.0.0
 Release:       1
-License:       LGPL
+License:       LGPL v2.1
 Group:         Libraries
-Source0:       http://geos.refractions.net/%{name}-%{version}.tar.bz2
-# Source0-md5: 440be2b11fd3d711e950a47ea6f1b424
-Patch0:                %{name}-swig.patch
+Source0:       http://geos.refractions.net/downloads/%{name}-%{version}.tar.bz2
+# Source0-md5: 3f7940abee9fec69a9787878cd3ae771
 URL:           http://geos.refractions.net/
 BuildRequires: automake
 BuildRequires: libstdc++-devel
 BuildRequires: python
 BuildRequires: python-devel
 BuildRequires: rpm-pythonprov
-BuildRequires: ruby-devel
+BuildRequires: rpmbuild(macros) >= 1.219
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: swig-python >= 1.3.29
-BuildRequires: swig-ruby >= 1.3.29
+%{?with_ruby:BuildRequires:    swig-ruby >= 1.3.29}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -26,17 +32,17 @@ functionality of JTS in C++. This includes all the OpenGIS "Simple
 Features for SQL" spatial predicate functions and spatial operators,
 as well as specific JTS topology functions such as IsValid().
 
-%description -l pl
+%description -l pl.UTF-8
 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
-otwartymi ¼ród³ami) to port C++ biblioteki Java Topology Suite (JTS).
-Celem biblioteki jako takiej jest implementacja pe³nej funkcjonalno¶ci
-JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
+otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
+Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
+JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
-tak¿e specyficzne dla JTS funkcje topologiczne takie jak IsValid().
+także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
 
 %package devel
 Summary:       Header files for GEOS library
-Summary(pl):   Pliki nag³ówkowe biblioteki GEOS
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki GEOS
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
@@ -44,78 +50,66 @@ Requires:   libstdc++-devel
 %description devel
 Header files for GEOS library.
 
-%description devel -l pl
-Pliki nag³ówkowe biblioteki GEOS.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki GEOS.
 
 %package static
 Summary:       Static GEOS library
-Summary(pl):   Statyczna biblioteka GEOS
+Summary(pl.UTF-8):     Statyczna biblioteka GEOS
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static GEOS library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna biblioteka GEOS.
 
 %package -n python-geos
 Summary:       Python bindings for Geometry Engine - Open Source
-Summary(pl):   Wi±zania Pythona do biblioteki GEOS
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki GEOS
 Group:         Development/Languages/Python
 Requires:      %{name} = %{version}-%{release}
 
 %description -n python-geos
 Python bindings for Geometry Engine - Open Source.
 
-%description -n python-geos -l pl
-Wi±zania Pythona do biblioteki GEOS.
+%description -n python-geos -l pl.UTF-8
+Wiązania Pythona do biblioteki GEOS.
 
 %package -n ruby-geos
 Summary:       Ruby bindings for Geometry Engine - Open Source
-Summary(pl):   Wi±zania jêzyka Ruby do biblioteki GEOS
+Summary(pl.UTF-8):     Wiązania języka Ruby do biblioteki GEOS
 Group:         Development/Languages/Python
 Requires:      %{name} = %{version}-%{release}
 
 %description -n ruby-geos
 Ruby bindings for Geometry Engine - Open Source.
 
-%description -n ruby-geos -l pl
-Wi±zania jêzyka Ruby do biblioteki GEOS.
+%description -n ruby-geos -l pl.UTF-8
+Wiązania języka Ruby do biblioteki GEOS.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 cp -f /usr/share/automake/config.* .
-%configure
+%configure \
+       --enable-python \
+       %{?with_ruby:--enable-ruby}
+
 %{__make} \
        pkglibdir=%{_libdir}
 
-cd swig/python
-swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
-python setup.py build
-
-cd ../ruby
-swig -c++ -ruby -autorename -o geos_wrap.cxx ../geos.i
-%{__cxx} %{rpmcxxflags} -I../../source/headers -I%{ruby_archdir} -c geos_wrap.cxx
-%{__cxx} -shared -o geos.so geos_wrap.o -lruby -L../../source/geom/.libs -lgeos
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       pkglibdir=%{_libdir}
-
-cd swig
-install -D ruby/geos.so $RPM_BUILD_ROOT%{ruby_archdir}/geos.so
+       DESTDIR=$RPM_BUILD_ROOT
 
-cd python
-python setup.py install \
-       --optimize=2 \
-       --root=$RPM_BUILD_ROOT
+%{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
+rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
 
 %py_postclean
 
@@ -128,8 +122,9 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/libgeos.so.*.*.*
+%attr(755,root,root) %{_libdir}/libgeos-3.0.0.so
 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
 
 %files devel
 %defattr(644,root,root,755)
@@ -149,10 +144,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n python-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/_geos.so
-%{py_sitedir}/geos.py[co]
-%{py_sitedir}/PyGEOS-*.egg-info
+%dir %{py_sitedir}/geos
+%attr(755,root,root) %{py_sitedir}/geos/_geos.so
+%{py_sitescriptdir}/geos
+%{py_sitescriptdir}/geos.pth
 
+%if %{with ruby}
 %files -n ruby-geos
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_archdir}/geos.so
+%attr(755,root,root) %{ruby_sitearchdir}/geos.so
+%endif
This page took 0.030264 seconds and 4 git commands to generate.