]> git.pld-linux.org Git - packages/geos.git/blob - geos.spec
6d6030df37fadaa793d7f3e224f31132efcc0f1f
[packages/geos.git] / geos.spec
1 #
2 # Conditional build:
3 %bcond_without  ruby    # ruby binding
4 #
5 Summary:        Geometry Engine - Open Source
6 Summary(pl.UTF-8):      GEOS - silnik geometryczny z otwartymi źródłami
7 Name:           geos
8 Version:        3.0.0
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://geos.refractions.net/downloads/%{name}-%{version}.tar.bz2
13 # Source0-md5:  3f7940abee9fec69a9787878cd3ae771
14 URL:            http://geos.refractions.net/
15 BuildRequires:  automake
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  python
18 BuildRequires:  python-devel
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.219
21 %{?with_ruby:BuildRequires:     ruby-devel}
22 BuildRequires:  swig-python >= 1.3.29
23 %{?with_ruby:BuildRequires:     swig-ruby >= 1.3.29}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 GEOS (Geometry Engine - Open Source) is a C++ port of the Java
28 Topology Suite (JTS). As such, it aims to contain the complete
29 functionality of JTS in C++. This includes all the OpenGIS "Simple
30 Features for SQL" spatial predicate functions and spatial operators,
31 as well as specific JTS topology functions such as IsValid().
32
33 %description -l pl.UTF-8
34 GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
35 otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
36 Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
37 JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
38 wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
39 także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
40
41 %package devel
42 Summary:        Header files for GEOS library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GEOS
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libstdc++-devel
47
48 %description devel
49 Header files for GEOS library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki GEOS.
53
54 %package static
55 Summary:        Static GEOS library
56 Summary(pl.UTF-8):      Statyczna biblioteka GEOS
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static GEOS library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka GEOS.
65
66 %package -n python-geos
67 Summary:        Python bindings for Geometry Engine - Open Source
68 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GEOS
69 Group:          Development/Languages/Python
70 Requires:       %{name} = %{version}-%{release}
71
72 %description -n python-geos
73 Python bindings for Geometry Engine - Open Source.
74
75 %description -n python-geos -l pl.UTF-8
76 Wiązania Pythona do biblioteki GEOS.
77
78 %package -n ruby-geos
79 Summary:        Ruby bindings for Geometry Engine - Open Source
80 Summary(pl.UTF-8):      Wiązania języka Ruby do biblioteki GEOS
81 Group:          Development/Languages/Python
82 Requires:       %{name} = %{version}-%{release}
83
84 %description -n ruby-geos
85 Ruby bindings for Geometry Engine - Open Source.
86
87 %description -n ruby-geos -l pl.UTF-8
88 Wiązania języka Ruby do biblioteki GEOS.
89
90 %prep
91 %setup -q
92
93 %build
94 cp -f /usr/share/automake/config.* .
95 %configure \
96         --enable-python \
97         %{?with_ruby:--enable-ruby}
98
99 %{__make} \
100         pkglibdir=%{_libdir}
101
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
110 rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
111
112 %py_postclean
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog NEWS README TODO
123 %attr(755,root,root) %{_libdir}/libgeos-3.0.0.so
124 %attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/geos-config
130 %attr(755,root,root) %{_libdir}/libgeos.so
131 %attr(755,root,root) %{_libdir}/libgeos_c.so
132 %{_libdir}/libgeos.la
133 %{_libdir}/libgeos_c.la
134 %{_includedir}/geos
135 %{_includedir}/geos.h
136 %{_includedir}/geos_c.h
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libgeos.a
141 %{_libdir}/libgeos_c.a
142
143 %files -n python-geos
144 %defattr(644,root,root,755)
145 %dir %{py_sitedir}/geos
146 %attr(755,root,root) %{py_sitedir}/geos/_geos.so
147 %{py_sitescriptdir}/geos
148 %{py_sitescriptdir}/geos.pth
149
150 %if %{with ruby}
151 %files -n ruby-geos
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{ruby_sitearchdir}/geos.so
154 %endif
This page took 0.40603 seconds and 2 git commands to generate.