]> git.pld-linux.org Git - packages/geos.git/blame_incremental - geos.spec
- updated to 3.3.6
[packages/geos.git] / geos.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without php # PHP binding
4%bcond_without ruby # ruby binding
5#
6Summary: Geometry Engine - Open Source
7Summary(pl.UTF-8): GEOS - silnik geometryczny z otwartymi źródłami
8Name: geos
9Version: 3.3.6
10Release: 1
11License: LGPL v2.1
12Group: Libraries
13Source0: http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
14# Source0-md5: 6fadfb941541875f4976f75fb0bbc800
15Patch0: %{name}-ruby1.9.patch
16URL: http://trac.osgeo.org/geos/
17BuildRequires: autoconf >= 2.52
18BuildRequires: automake
19BuildRequires: libstdc++-devel
20%{?with_php:BuildRequires: php-devel}
21BuildRequires: python
22BuildRequires: python-devel
23BuildRequires: rpm-pythonprov
24BuildRequires: rpmbuild(macros) >= 1.519
25%{?with_ruby:BuildRequires: ruby-devel}
26BuildRequires: swig-python >= 1.3.29
27%{?with_ruby:BuildRequires: swig-ruby >= 1.3.40-3}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31GEOS (Geometry Engine - Open Source) is a C++ port of the Java
32Topology Suite (JTS). As such, it aims to contain the complete
33functionality of JTS in C++. This includes all the OpenGIS "Simple
34Features for SQL" spatial predicate functions and spatial operators,
35as well as specific JTS topology functions such as IsValid().
36
37%description -l pl.UTF-8
38GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
39otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
40Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
41JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
42wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
43także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
44
45%package devel
46Summary: Header files for GEOS library
47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GEOS
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: libstdc++-devel
51
52%description devel
53Header files for GEOS library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe biblioteki GEOS.
57
58%package static
59Summary: Static GEOS library
60Summary(pl.UTF-8): Statyczna biblioteka GEOS
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static GEOS library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka GEOS.
69
70%package -n php-geos
71Summary: PHP bindings for Geometry Engine - Open Source
72Summary(pl.UTF-8): Wiązania PHP do biblioteki GEOS
73Group: Development/Languages/PHP
74Requires: %{name} = %{version}-%{release}
75%{?requires_php_extension}
76
77%description -n php-geos
78PHP bindings for Geometry Engine - Open Source.
79
80%description -n php-geos -l pl.UTF-8
81Wiązania PHP do biblioteki GEOS.
82
83%package -n python-geos
84Summary: Python bindings for Geometry Engine - Open Source
85Summary(pl.UTF-8): Wiązania Pythona do biblioteki GEOS
86Group: Development/Languages/Python
87Requires: %{name} = %{version}-%{release}
88
89%description -n python-geos
90Python bindings for Geometry Engine - Open Source.
91
92%description -n python-geos -l pl.UTF-8
93Wiązania Pythona do biblioteki GEOS.
94
95%package -n ruby-geos
96Summary: Ruby bindings for Geometry Engine - Open Source
97Summary(pl.UTF-8): Wiązania języka Ruby do biblioteki GEOS
98Group: Development/Languages/Python
99Requires: %{name} = %{version}-%{release}
100
101%description -n ruby-geos
102Ruby bindings for Geometry Engine - Open Source.
103
104%description -n ruby-geos -l pl.UTF-8
105Wiązania języka Ruby do biblioteki GEOS.
106
107%prep
108%setup -q
109%patch0 -p1
110
111%build
112%{__aclocal} -I macros
113%{__autoconf}
114%{__autoheader}
115%{__automake}
116%configure \
117 %{?with_php:--enable-php} \
118 --enable-python \
119 %{?with_ruby:--enable-ruby}
120
121%{__make} \
122 pkglibdir=%{_libdir}
123
124
125%install
126rm -rf $RPM_BUILD_ROOT
127
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
130
131%if %{with php}
132install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
133cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/geos.ini
134; Enable geos extension module
135extension=geos.so
136EOF
137%endif
138
139%{?with_ruby:%{__rm} $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
140%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
141
142%py_postclean
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
150%files
151%defattr(644,root,root,755)
152%doc AUTHORS ChangeLog NEWS README TODO
153%attr(755,root,root) %{_libdir}/libgeos-*.so
154%attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
155%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
156
157%files devel
158%defattr(644,root,root,755)
159%attr(755,root,root) %{_bindir}/geos-config
160%attr(755,root,root) %{_libdir}/libgeos.so
161%attr(755,root,root) %{_libdir}/libgeos_c.so
162%{_libdir}/libgeos.la
163%{_libdir}/libgeos_c.la
164%{_includedir}/geos
165%{_includedir}/geos.h
166%{_includedir}/geos_c.h
167
168%files static
169%defattr(644,root,root,755)
170%{_libdir}/libgeos.a
171%{_libdir}/libgeos_c.a
172
173%if %{with php}
174%files -n php-geos
175%defattr(644,root,root,755)
176%doc php/{README,TODO}
177%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/geos.ini
178%attr(755,root,root) %{php_extensiondir}/geos.so
179%endif
180
181%files -n python-geos
182%defattr(644,root,root,755)
183%dir %{py_sitedir}/geos
184%attr(755,root,root) %{py_sitedir}/geos/_geos.so
185%{py_sitescriptdir}/geos
186%{py_sitescriptdir}/geos.pth
187
188%if %{with ruby}
189%files -n ruby-geos
190%defattr(644,root,root,755)
191%attr(755,root,root) %{ruby_sitearchdir}/geos.so
192%endif
This page took 0.038387 seconds and 4 git commands to generate.