]> git.pld-linux.org Git - packages/geos.git/blame_incremental - geos.spec
- ac version
[packages/geos.git] / geos.spec
... / ...
CommitLineData
1# TODO
2# - unpackaged: /usr/bin/XMLTester
3#
4# Conditional build:
5%bcond_without ruby # ruby binding
6#
7Summary: Geometry Engine - Open Source
8Summary(pl.UTF-8): GEOS - silnik geometryczny z otwartymi źródłami
9Name: geos
10Version: 3.2.2
11Release: 2
12License: LGPL v2.1
13Group: Libraries
14Source0: http://download.osgeo.org/geos/%{name}-%{version}.tar.bz2
15# Source0-md5: c5d264acac22fe7720f85dadc1fc17c6
16Patch0: %{name}-ruby1.9.patch
17URL: http://trac.osgeo.org/geos/
18BuildRequires: autoconf >= 2.52
19BuildRequires: automake
20BuildRequires: libstdc++-devel
21BuildRequires: python
22BuildRequires: python-devel
23BuildRequires: rpm-pythonprov
24BuildRequires: rpmbuild(macros) >= 1.219
25%{?with_ruby:BuildRequires: ruby-devel}
26BuildRequires: swig-python >= 1.3.29
27%{?with_ruby:BuildRequires: swig-ruby >= 1.3.40-3}
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31GEOS (Geometry Engine - Open Source) is a C++ port of the Java
32Topology Suite (JTS). As such, it aims to contain the complete
33functionality of JTS in C++. This includes all the OpenGIS "Simple
34Features for SQL" spatial predicate functions and spatial operators,
35as well as specific JTS topology functions such as IsValid().
36
37%description -l pl.UTF-8
38GEOS (Geometry Engine - Open Source, czyli silnik geometryczny z
39otwartymi źródłami) to port C++ biblioteki Java Topology Suite (JTS).
40Celem biblioteki jako takiej jest implementacja pełnej funkcjonalności
41JTS w C++. Obejmuje to wszystkie funkcje predykatów przestrzennych
42wg "Simple Features for SQL" OpenGIS oraz operatory przestrzenne, a
43także specyficzne dla JTS funkcje topologiczne takie jak IsValid().
44
45%package devel
46Summary: Header files for GEOS library
47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki GEOS
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: libstdc++-devel
51
52%description devel
53Header files for GEOS library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe biblioteki GEOS.
57
58%package static
59Summary: Static GEOS library
60Summary(pl.UTF-8): Statyczna biblioteka GEOS
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static GEOS library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka GEOS.
69
70%package -n python-geos
71Summary: Python bindings for Geometry Engine - Open Source
72Summary(pl.UTF-8): Wiązania Pythona do biblioteki GEOS
73Group: Development/Languages/Python
74Requires: %{name} = %{version}-%{release}
75
76%description -n python-geos
77Python bindings for Geometry Engine - Open Source.
78
79%description -n python-geos -l pl.UTF-8
80Wiązania Pythona do biblioteki GEOS.
81
82%package -n ruby-geos
83Summary: Ruby bindings for Geometry Engine - Open Source
84Summary(pl.UTF-8): Wiązania języka Ruby do biblioteki GEOS
85Group: Development/Languages/Python
86Requires: %{name} = %{version}-%{release}
87
88%description -n ruby-geos
89Ruby bindings for Geometry Engine - Open Source.
90
91%description -n ruby-geos -l pl.UTF-8
92Wiązania języka Ruby do biblioteki GEOS.
93
94%prep
95%setup -q
96%patch0 -p1
97
98%build
99%{__aclocal} -I macros
100%{__autoconf}
101%{__autoheader}
102%{__automake}
103%configure \
104 --enable-python \
105 %{?with_ruby:--enable-ruby}
106
107%{__make} \
108 pkglibdir=%{_libdir}
109
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
117%{?with_ruby:rm -f $RPM_BUILD_ROOT%{ruby_sitearchdir}/*.{la,a}}
118rm -f $RPM_BUILD_ROOT%{py_sitedir}/geos/*.{la,a}
119
120%py_postclean
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post -p /sbin/ldconfig
126%postun -p /sbin/ldconfig
127
128%files
129%defattr(644,root,root,755)
130%doc AUTHORS ChangeLog NEWS README TODO
131%attr(755,root,root) %{_libdir}/libgeos-*.so
132%attr(755,root,root) %{_libdir}/libgeos_c.so.*.*.*
133%attr(755,root,root) %ghost %{_libdir}/libgeos_c.so.1
134
135%files devel
136%defattr(644,root,root,755)
137%attr(755,root,root) %{_bindir}/geos-config
138%attr(755,root,root) %{_libdir}/libgeos.so
139%attr(755,root,root) %{_libdir}/libgeos_c.so
140%{_libdir}/libgeos.la
141%{_libdir}/libgeos_c.la
142%{_includedir}/geos
143%{_includedir}/geos.h
144%{_includedir}/geos_c.h
145
146%files static
147%defattr(644,root,root,755)
148%{_libdir}/libgeos.a
149%{_libdir}/libgeos_c.a
150
151%files -n python-geos
152%defattr(644,root,root,755)
153%dir %{py_sitedir}/geos
154%attr(755,root,root) %{py_sitedir}/geos/_geos.so
155%{py_sitescriptdir}/geos
156%{py_sitescriptdir}/geos.pth
157
158%if %{with ruby}
159%files -n ruby-geos
160%defattr(644,root,root,755)
161%attr(755,root,root) %{ruby_sitearchdir}/geos.so
162%endif
This page took 0.043489 seconds and 4 git commands to generate.