]> git.pld-linux.org Git - packages/gentoo.git/blob - gentoo.spec
2be9f7544286c0032c244cb2188d165515370432
[packages/gentoo.git] / gentoo.spec
1 Summary:        gentoo is a Gtk+ file manager for Linux.
2 Summary(pl):    gentoo jest opartym na Gtk+ zarz±dc± plików pod Linuxa.
3 Name:           gentoo
4 Version:        0.11.6
5 Release:        1
6 Copyright:      GPL
7 Group:          X11/Utilities
8 Group(pl):      X11/Narzêdzia
9 URL:            http://www.obsession.se/gentoo
10 Source0:        ftp://ftp.obsession.se/gentoo/%{name}-%{version}.tar.gz
11 Source1:        gentoo.wmconfig
12 Patch0:         gentoo-makefile.patch
13 Patch1:         gentoo-config.patch
14 BuildPrereq:    gtk+-devel >= 1.2.0
15 BuildPrereq:    glib-devel >= 1.2.0
16 BuildPrereq:    XFree86-devel
17 Requires:       file
18 BuildRoot:      /tmp/%{name}-%{version}-root
19
20 %define _prefix         /usr/X11R6
21
22 %description
23 gentoo is a file manager for Linux written from scratch in pure C. It
24 uses the GTK+ toolkit for all of its interface needs. gentoo provides
25 100%% GUI configurability; no need to edit config files by hand and re-
26 start the program. gentoo supports identifying the type of various
27 files (using extension, regular expressions, and/or the 'file' command),
28 and can display files of different types with different colors and icons.
29         gentoo borrows some of its look and feel from the classic Amiga
30 file manager "Directory OPUS"(TM) (written by Jonathan Potter).
31
32 %description -l pl
33 gentoo jest zarz±dc± plików dla Linuxa napisanym 'od zera' w czystym C.
34 U¿ywa zestawu narzêdzi GTK+ do zaspokojenia wszystkich potrzeb zwi±zanych
35 z interfejsem. gentoo zapewnia 100%-ow± konfigurowalno¶æ graficznego 
36 interfejsu; nie ma potrzeby rêcznego edytowania plików konfiguracyjnch
37 i ponownego uruchamiania programu. gentoo dostarcza identyfikacjê typów
38 ró¿nych plików (u¿ywaj±c rozszerzenia, wyra¿eñ regularnych i/lub polecenia
39 'file') oraz potrafi wy¶wietlaæ pliki ró¿nego typu w ró¿nych kolorach
40 i z ró¿nymi ikonami. gentoo zapo¿ycza trochê ze swojego wygl±du od 
41 klasycznego zarz±dcy plików Amigi -- "Directory OPUS"(TM) (napisanego
42 przez Jonathana Pottera).
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p0
48
49 %build
50
51 CFLAGS="$RPM_OPT_FLAGS" \
52 make
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1} \
58         $RPM_BUILD_ROOT{%{_datadir}/%{name}/icons,/etc/X11/wmconfig}
59
60 install -s %{name} $RPM_BUILD_ROOT%{_bindir}
61 install gentoorc-example $RPM_BUILD_ROOT%{_datadir}/%{name}/gentoorc
62 install icons/* $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
63 install docs/%{name}.1x $RPM_BUILD_ROOT%{_mandir}/man1
64 install %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/wmconfig/%{name}
65
66 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
67         BUGS FIXES-0.11 FIXES-0.9 README README.gtkrc
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc {BUGS,FIXES-0.11,FIXES-0.9,README,README.gtkrc}.gz
75 %doc docs %{name}gtkrc-example %{name}rc-example
76
77 %attr(755,root,root) %{_bindir}/%{name}
78 %{_datadir}/%{name}
79 %{_mandir}/man1/*
80
81 /etc/X11/wmconfig/%{name}
82
83 %changelog
84 - added gentoo.desktop instead of wmconfig file,
85 - minor fixes.
86 - updated to 0.11.6,
87 - added using more rpm macros,
88 - package is now FHS 2.0 compliant.
89
90 * Mon Apr 26 1999 Piotr Czerwiñski <pius@pld.org.pl>
91   [0.11.5-2]
92 - fixed some options in gentoo config file (gentoo-config.patch).
93
94 * Mon Apr 26 1999 Piotr Czerwiñski <pius@pld.org.pl>
95 - updated to 0.11.5,
96 - added pl translation,
97 - changed install prefix to /usr/X11R6,
98 - changed gentoo's files path to /usr/X11R6/share/gentoo 
99   (new gentoo-makefile.patch),
100 - fixed passing $RPM_OPT_FLAGS during compile,
101 - modified %install and %files section,
102 - added gzipping documentation and man pages,
103 - added full %defattr and %attr description,
104 - added some BuildPrereqs and Requires,
105 - added wmconfig file,
106 - recompiled on rpm 3,
107 - minor changes.
108
109 * Tue Apr  6 1999 Ryan Weaver <ryanw@infohwy.com>
110   [gentoo-0.11.4-1]
111 - 0.11.4
112 - Statusbar now shows the amount of free space for the filesystem
113   the current pane's directory is in. Note that the call that makes
114   this possible (statfs(2) on Linux, statvfs(2) on e.g. Solaris and
115   Irix) seems to be somewhat unstandardized. There might be trouble.
116 - Fixed a problem with nesting modal dialogs. Noticable when e.g.
117   Rename caused an overwrite confirmation to occur.
118 - Fixed a related dialog problem; now, if you close the Rename
119   dialog with the Overwrite confirm window still open, nothing evil
120   will happen.
121 - Did numerous clean-ups in the main "gentoo.h" header file, moving
122   many type definitions into separate C files, thus reducing coupling.
123 - Removed a useless dialog (the "child_dialog" module).
124 - Discovered what I suppose is a compiler bug in gcc 2.8.1; when
125   compiling gentoo with optimization level 2 (-O2), a supposedly
126   harmless statement in the dialog module will cause a segfault...
127 - When you write a path, the keyboard events no longer trigger
128   commands. This is better. Reported by J. Hanson <johan@tiq.com>.
129 - Added a freeze/thaw pair to the textviewer used for command output
130   capturing, resulting in way better performance and no flickering.
131 - Removed the (nonfunctional) "Print" button from the text viewer,
132   slightly changing the button layout in the process.
133 - Slowed down the animation of the busy indicator (used by the
134   Information and GetSize commands) a bit. It made me nervous. :)
135 - The hex text viewing (used by ViewHex & ViewTextOrHex) code was
136   *very* memory-inefficient (it always loaded the entire file, but
137   only looked at 16 bytes at a time). Now it reads 16 bytes at a
138   time, thus using constant buffer space (and running slower).
139 - ViewTextOrHex now correctly reports the error if it fails to
140   open a file for reading. Er, ViewText & ViewHex don't (yet).
141 - Designed and implemented a system for keeping track of each
142   command's individual configuration options. The options them-
143   selves have been around for quite a while, but they haven't been
144   configurable (without editing source, that is). Now they appear
145   on the "Command Options" page in the configuration window, and
146   are loaded and saved along with the rest of the config. Neat.
147     Please read "docs/scratch/command_options.txt" to learn what
148   different options do.
149
150 * Tue Mar 30 1999 Ryan Weaver <ryanw@infohwy.com>
151   [gentoo-0.11.3-1]
152 - Damn! That command sequence selection dialog just didn't work.
153   Typical, since I spent about 3 hrs banging on it before releasing
154   0.11.2. Perhaps I should have tested it. Reported by J. Minnberg.
155 - Eh, seems I broke the main "gentoo.h" include file, too. Fixed.
156 - Fixed a minor error (typo) in the cmdgrab module.
157
158 - package is FHS 2.0 compliant,
159 - spec file rewritten for PLD use,
160 - based on spec written by Ryan Weaver <ryanw@infohwy.com>.
This page took 0.027693 seconds and 2 git commands to generate.